19:00:30 <shadower> #startmeeting Tuskar
19:00:31 <openstack> Meeting started Tue Sep 10 19:00:30 2013 UTC and is due to finish in 60 minutes.  The chair is shadower. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:34 <openstack> The meeting name has been set to 'tuskar'
19:00:45 <shadower> hello everyone!
19:00:47 <lifeless> o/
19:00:49 <rpodolyaka> hello!
19:00:50 <lsmola_> hello
19:00:52 <marios> hey
19:00:53 <jistr> hi :)
19:00:54 <tzumainn> hiya
19:00:55 <ifarkas> hi
19:01:04 <jcoufal> _o/
19:01:10 <matty_dubs> \o/
19:01:17 <jcoufal> this is our first time :)
19:01:26 <lsmola_> lol
19:01:27 <shadower> I don't expect us to go through everything on the agenda -- just want to get a sense of timing
19:01:47 <shadower> Agenda:
19:02:21 <shadower> * Documentation
19:02:21 <shadower> * Simplify development setup
19:02:21 <shadower> * Tests
19:02:21 <shadower> * Releases & Milestones
19:02:21 <shadower> * TripleO (Deployment) session slots on the Summit
19:02:23 <shadower> * Open discussion
19:02:36 <shadower> #topic Documentation
19:02:58 <shadower> so docs are in a pretty bad shape
19:03:10 <shadower> here's a minimum of what I think we need:
19:03:19 <shadower> - project goal
19:03:19 <shadower> - resource classes
19:03:19 <shadower> - our vs. tripleo responsibilities
19:03:19 <shadower> - roadmap
19:03:19 <shadower> - arch overview
19:03:22 <shadower> - have a wiki page on OpenStack
19:03:38 <shadower> the current project description is kind of wishy-washy
19:03:51 <matty_dubs> +1, especially to arch overview and us vs. tripleo
19:03:52 <jcoufal> id' add also racks concept
19:03:59 <jcoufal> which is pretty crucial
19:04:06 <shadower> jcoufal: good point
19:04:23 <tzumainn> maybe a glossary would make sense - resource classes, racks, flavors, etc
19:04:29 <marios> shadower: taking that to its logical conclusion, we really need a good description of all concepts
19:04:35 <marios> tzumainn: what you said
19:04:36 <tzumainn> because tuskar flavors != nova flavors exactly, right?
19:04:40 <shadower> marios: yup
19:04:45 <jcoufal> tzumainn: +1 glossary and keeping constant names ;)
19:04:57 <lifeless> if tuskar flavors are not nova flavors, then -really- recommend renaming them.
19:05:02 <shadower> #info have a glossary pages
19:05:09 <lifeless> because 'flavor' is very well understood in OpenStack
19:05:17 <marios> lifeless: well, they *are* going to be flavors ... once provisioned
19:05:23 <shadower> yup
19:05:41 <shadower> anyone wants to tackle a particular topic?
19:05:43 <stevebaker> flavor templates?
19:05:43 <marios> lifeless: kind of like 'definitions of flavors' except we haven't passed them to nova
19:06:03 <shadower> stevebaker: not a bad idea
19:06:09 <jcoufal> tzumainn: they are sort of templates for later registration of flavors in nova when provisioning node, not?
19:06:10 <marios> stevebaker: sure, that or something like that could work
19:06:19 <shadower> protoflavours
19:06:25 <marios> boo
19:06:27 <jcoufal> oh no
19:06:29 <shadower> haha
19:06:29 <marios> :)
19:06:30 <noslzzp> ;)
19:06:30 <jcoufal> :))
19:06:33 <tzumainn> lol
19:06:34 <lsmola_> hehe
19:06:49 <tzumainn> I think this highlights the importance of this glossary, though - we all need to agree on terminology
19:06:54 <jcoufal> so let's say constant naming for all concepts
19:06:57 <shadower> yeah
19:07:00 <shadower> okay, I think it's better if people pick a topic and write it up rather than one person doing all the writing
19:07:04 <jcoufal> I'll start separate thread in ML for that
19:07:14 <jcoufal> (naming)
19:07:21 <shadower> #action jcoufal to kick off a glossary ML thread
19:07:27 <marios> jcoufal: am thinking an etherpad may lend itself better to renaming stuff/descriptions
19:07:30 <matty_dubs> shadower: Lacking a more competent volunteer, I'll try to tackle the architecture overview
19:07:31 <jcoufal> shadower: roger that!
19:07:40 <shadower> thx
19:07:42 <matty_dubs> (may need help0
19:07:43 <tzumainn> shadower, one sec - we want the glossary to have a consistent layout, right?
19:07:46 <jcoufal> marios: it will, just I need to resend link then :)
19:07:59 <shadower> tzumainn: what do you mean?
19:08:02 <tzumainn> so it may make sense to create one first and send it out with the initial ML
19:08:07 <martyntaylor> matty_dubs: I will help you out on that
19:08:25 <shadower> #action martyntaylor and matty_dubs to write up the Tuskar architecture
19:08:25 <tzumainn> shadower, title, overview, links to api, I dunno - each section should be structured the same way
19:08:47 <shadower> tzumainn: we can polish it up later I reckon, let's get something usable up there first
19:08:52 <tzumainn> shadower, okay
19:09:00 <jcoufal> agree, just get some content first
19:09:09 <shadower> cool
19:09:09 <jcoufal> we can polish stuff in time
19:09:13 <shadower> any more takers?
19:09:22 <tzumainn> it's just - if we were to do parallel coding, we'd want everyone to have similar coding style, right?  this would be the same
19:09:26 <marios> shadower: sure put me down for docs tasks wherever needed
19:09:33 <jcoufal> tzumainn: no coding for now
19:09:35 <shadower> I'm happy to take up whatever remains
19:09:36 <marios> shadower: (could probably help with arch)
19:09:40 <matty_dubs> tzumainn: I don't disagree, but we can probably tackle that offline.
19:10:04 <jcoufal> tzumainn: oh, you mean coding style guide?
19:10:06 <tzumainn> matty_dubs, okay - I'm just afraid five people will pick five different topics and come up with five completely different ways of formatting the entries
19:10:13 <jcoufal> not for docs, but in general for the project?
19:10:24 <shadower> marios: how about you have a look at describing where we differ from tripleo?
19:10:28 <tzumainn> jcoufal, no, I meant for the glossary - I remember you mentioned that there'd be separate pages
19:10:30 <shadower> I'll help of course
19:10:36 <marios> jcoufal: i think tzumainn is saying that the "description document"  of each item in the glossary has to be the same
19:10:42 <tzumainn> so each paget should just be formatted the same
19:10:49 <tzumainn> ah, marios said it better than I did : )
19:10:53 <jcoufal> I wouldn't worry that much
19:10:58 <jcoufal> somebody can send some basic outline
19:11:09 <tzumainn> could you send one with the mail you'll send out on the mailing list?
19:11:10 <jcoufal> but it shouldn't block us dealing with coding now
19:11:12 <marios> jcoufal: tzumainn: but i believe the general consensus is right, as in we need to actually agree on the descriptions first and we can work out the format
19:11:15 <marios> shadower: sure
19:11:19 <shadower> marios: thx
19:11:25 <jistr> also, i wonder if we have proper docs on how to get tuskar running? i don't mean dev env now, i mean more like wiring Tuskar to the rest of openstack and setting it up for actual use
19:11:37 <shadower> #action marios to write up how tuskar differs from tripleo
19:11:48 <shadower> jistr: good point
19:11:59 <jcoufal> tzumainn: I can take some stab on docs outline
19:12:04 <shadower> jistr: wanna volunteer? :-)
19:12:06 <jcoufal> not sure if it will be very useful though :)
19:12:07 <pblaho> jistr: +1
19:12:11 <rpodolyaka> jistr: +1, but something like TripleO's devtest guide would be very helpful too
19:12:18 <jistr> shadower: i'm wokring on RDO now with jayg
19:12:27 <shadower> okay
19:12:28 <jistr> shadower: not sure when that will be over
19:12:36 <lifeless> so having tripleo-image-elements to install tuskar would be perhaps even better than docs.
19:12:39 <marios> shadower: what's the time frame on these action items? if any
19:12:48 <lifeless> Since that would let the seed cloud bring tuskar up
19:12:51 <jcoufal> rpodolyaka: would you like to help with initial tuskar setup doc?
19:12:57 <shadower> lifeless: next point on the agenda :-)
19:12:59 <shadower> I agree
19:12:59 <lifeless> and you wouldn't need to do manual steps :>
19:12:59 <jcoufal> you went through the process lately
19:13:03 <lifeless> hah, ok :)
19:13:07 <shadower> np
19:13:11 <rpodolyaka> jcoufal: yes, sure
19:13:15 <ifarkas> shadower, I can do the tuskar setup doc
19:13:17 <jcoufal> shadower: ^
19:13:30 <shadower> #shadower write up the project goal docs
19:13:36 <shadower> #action shadower write up the project goal docs
19:13:54 <shadower> #action ifarkas write up production setup docs
19:14:01 <shadower> anything else re: documentation?
19:14:08 <jcoufal> ifarkas: great you can share it with rdopieralski
19:14:22 <ifarkas> jcoufal, rdopieralski, great!
19:14:25 <shadower> #link https://wiki.openstack.org/wiki/Tuskar
19:14:30 <shadower> we have a wiki page ^
19:14:38 <shadower> let's make sure everything links from there
19:14:49 <noslzzp> \o/
19:15:08 <marios> we have tzumainn's mouse to thank for that :)
19:15:14 <shadower> #topic Simplify development setup
19:15:21 <pblaho> I am just thinking about some documentation inline... and generating it.... some openstack projects does that... using CI gate jobs....
19:15:33 <shadower> pblaho: once we have the content, why not
19:15:35 <pblaho> but that is probably tied to releasing some packaged stuff
19:15:38 <shadower> I'd start there first tho
19:15:43 <jcoufal> shadower: are we going tu fork devstack somehow?
19:15:49 <pblaho> shadower: good point
19:15:59 <shadower> jcoufal: so devstack integration would be one thing
19:16:03 <shadower> wouldnt' want to fork it
19:16:16 <jcoufal> or integration, yeah, sounds better
19:16:19 <shadower> but as lifeless mentioned: we colud integrate tuskar with tripelo image elemns
19:16:20 <jcoufal> that's what I meant
19:16:26 <shadower> tripleo image elements even
19:16:46 <shadower> lifeless: I'm not sure how exactly that works: can the users pick what parts to include and what not?
19:16:56 <lifeless> shadower: of course :)
19:17:03 <shadower> lifeless: perfect
19:17:14 <shadower> lifeless: any docs/source you could point us to?
19:17:17 <lifeless> shadower: if you haven't, you should give devtest.md from tripleo-incubator a spin
19:17:24 <shadower> cheers
19:17:25 <lifeless> shadower: that will give you a feel for the tooling
19:17:47 <lifeless> shadower: then diskimage-builder/README.md and tripleo-image-elements/README.md for the entry point docs
19:18:03 <shadower> awesome, thanks
19:18:08 <shadower> #action shadower to look at integrating tuskar with tripleo
19:18:37 <shadower> this would allow us to install tuskar whilst deploying tripleo -- which the tuskar users need to do anyway
19:18:43 <shadower> everyone fine with that idea?
19:18:47 <marios> shadower: it would be great if we can actually use that for the seed/master controller for demo
19:18:58 <lsmola_> shadower, yes
19:19:07 <shadower> yea
19:19:31 <shadower> #topic Tests
19:19:42 <jcoufal> sounds good
19:20:04 * shadower will have to learn to give longer timeout before switching topics
19:20:15 <jcoufal> np, my bad, was getting cup of tea
19:20:17 <jcoufal> sorry
19:20:22 <shadower> np
19:20:47 <shadower> so tuskar (api) and python-tuskarclient have been using jenkins' CI for a while now
19:20:53 <shadower> we need to do the same for the UI
19:21:03 <shadower> it's all mostly setup but the django 1.4 tests are failing
19:21:08 <lsmola_> yes, it is very needed
19:21:18 <shadower> anyone againts us leaving 1.4 behind for now?
19:21:32 <shadower> we can add it as soon as anyone says they need it I reckon
19:21:43 <lsmola_> shadower, nope, we should test the same as the rest of openstack
19:21:47 <jcoufal> shadower: you know what is the django version support in horizon?
19:21:55 <ifarkas> shadower, how long Horizon will support 1.4?
19:22:06 <matty_dubs> Yeah, I'd rather have incomplete tests that pass than tests that are commented out and not run because they're incomplete.
19:22:07 <shadower> Horizon has 1.4 and 1.5, but e.g. Savanna has just 1.5 iirc
19:22:21 <shadower> matty_dubs: not tests, just disabled the environment for now
19:22:34 <pblaho> last time I checked tuskar-ui tests they were not really easy to run.... it would be fine if running "tox" is all you have to do
19:22:41 <matty_dubs> Oh, I see.
19:22:43 <shadower> pblaho: tox is all you need now
19:22:59 <matty_dubs> From tuskar-ui? I've been running tests from horizon.
19:23:06 <jistr> we left behind some tests on tuskar api initially too i think. it's perfectly fine from my point of view. any CI whatsoever helps *a lot*, you can add the rest later
19:23:07 <jcoufal> shadower: I'd say that set up anything as soon as possible, for levaing django 1.4 I'd better be close to what horizon does
19:23:15 <shadower> matty_dubs: you can do that from tuskar ui now
19:23:46 <matty_dubs> jcoufal++ -- start with something now, and if we want 1.4 we can add it later
19:24:00 <lsmola_> jcoufal +1
19:24:08 <shadower> everyone else fine with that for now? We *can* add the 1.4 tests later
19:24:09 <jistr> jcoufal, matty_dubs: yeah
19:24:20 <pblaho> start any CI now +++
19:24:28 <tzumainn> +1
19:24:37 <rpodolyaka> +1
19:24:45 <shadower> #action shadower to enable tuskar-ui CI
19:25:04 <shadower> #agreed we will drop the django 1.4 tests for now
19:25:18 <shadower> anything else on testing?
19:26:03 <shadower> moving swiftly on
19:26:13 <shadower> #topic TripleO (Deployment) session slots on the Summit
19:26:27 <shadower> The TripleO project has 5 session slots assigned to the summit. They're willing to share one with Tuskar if we come up with something and it gets accepted.
19:26:49 <matty_dubs> Nice!
19:26:55 <shadower> (tuskar isn't elligible for slots on its own because we're not an official/incubated project)
19:26:58 <jcoufal> Oh, nice
19:27:06 <shadower> some background: https://wiki.openstack.org/wiki/Summit
19:27:15 <shadower> the sessions proposed so far: http://summit.openstack.org/
19:27:19 <jcoufal> Many thanks to triple-o guys
19:27:25 <shadower> indeed
19:27:54 <shadower> these are design sessions. No talk with slides, more like disc9ussingh the direction etc.
19:28:25 <shadower> so if you've got ideas, feel free to propose them at the sessions page (or let me do it) under tripleo
19:28:45 <shadower> that's no guarantee they'll be picked but if we don't propose anything, we won't have a slot there at all ;-)
19:29:12 <lifeless> Potentially more than one; we're both focused on deployment, we need to assess the overall set of things that need discussing and then triage down to just 5 :)
19:29:22 <shadower> ++
19:29:24 <shadower> lifeless: is there a deadline for the session proposals?
19:29:30 <jcoufal> yeah, usually the latest 'hot' stuff and good place for getting all people to the same page
19:29:35 <jcoufal> so it is close to the smmit
19:29:37 <jcoufal> the deadline
19:30:00 <jcoufal> what I've heard about week or 14 days before the summit itself
19:30:15 <lifeless> yeah
19:30:19 <shadower> cool
19:30:37 <jcoufal> but
19:30:45 <jcoufal> some stuff might be accepted earlier
19:30:48 <jcoufal> so they are taking slots
19:30:52 <jcoufal> so the sooner the better
19:31:33 <shadower> lifeless: are the deployment slots under you guys' control or will someone else pick it up?
19:32:59 <shadower> nm, we can sort that later
19:33:01 <jcoufal> shadower: I think PTL's are choosing the topics, but not very sure
19:33:11 <shadower> thx
19:33:22 <shadower> next point on teh agenda
19:33:33 <shadower> #topic Releases & Milestones
19:33:33 <lifeless> shadower: it is all me
19:33:43 <lifeless> shadower: as "OpenStack Deployment PTL"
19:34:08 <shadower> lifeless: yup. So if you do want to give us a tighter deadline, let us know
19:34:55 <shadower> regarding milestones I think we want to align ourselves with the OpenStack ones: icehouse-{1, 2, 3, rc1, ...}
19:34:59 <shadower> thoughts?
19:35:00 <lifeless> shadower: the one all projects are using is fine I think
19:35:11 <shadower> lifeless: okay, thanks
19:35:19 <lsmola_> shadower, agree
19:35:22 <jcoufal> shadower: the sooner we synchronize with openstack ones the better I would say
19:35:29 <jistr> +1
19:35:30 <jcoufal> so for me it looks fine
19:35:41 <matty_dubs> What does that imply for deadlines for us?
19:35:44 <matty_dubs> i.e., any soon?
19:35:51 <shadower> #agreed we will use the same milestones as openstack
19:36:10 <shadower> matty_dubs: I'll have a look and write it up
19:36:12 <lsmola_> matty_dubs, you have just missed one :-)
19:36:22 <shadower> lsmola_: you talking h3?
19:36:24 <matty_dubs> lsmola_: What else is new? ;)
19:36:30 <jcoufal> matty_dubs: I would say more targeted planning against these milestones
19:36:48 <lsmola_> shadower, yes h3 is gone
19:37:00 <jcoufal> currently we already have some basic plans, but we might slightly try to align with openstack milestones (deadlines)
19:37:02 <shadower> lsmola_: yea, I was thinking more like start with the i-series
19:37:07 <lsmola_> matty_dubs, :-)
19:37:27 <lsmola_> shadower, yes
19:37:31 <shadower> #action shadower create the icehouse series and the appropriate milestones in launchpad
19:37:40 <marios> shadower: that would make sense given we're currently planning towards hk
19:37:48 <shadower> ya
19:38:35 <lsmola_> shadower, I am already working on some new ceilometer blueprints, but all can go in after I1 starts
19:38:51 <shadower> cool
19:39:16 <jcoufal> shadower: "1
19:39:19 <jcoufal> +1
19:39:28 <lsmola_> +2
19:39:30 <shadower> now afaik openstack doesn't have any releases in between the big stable ones every 6 months
19:39:47 <shadower> do we want to have at least a semi stable release that we're confident works
19:39:50 <shadower> for folks to try out?
19:39:59 <matty_dubs> I think that's worthwhile.
19:40:01 <lsmola_> yes
19:40:05 <matty_dubs> It probably doesn't have to be super-formal.
19:40:07 <tzumainn> +1
19:40:11 <pblaho> yes...
19:40:22 <lsmola_> shadower, we should be able to finish crutial blueprints
19:40:34 <stevebaker> stable branches get maintenance releases
19:40:38 <jcoufal> shadower: hmm, what timeframe are you thinking of?
19:40:45 <pblaho> and setup jobs for CI to release package when ready...
19:41:00 <shadower> jcoufal: not sure, after hk perhaps? we ought to have a working snapshot for the demo then
19:41:21 <marios> shadower: yeah, though will need some rework after the demo ;)
19:41:24 <jcoufal> shadower: something what was on the demo might be released as 'alpha' or whatever version
19:41:31 <shadower> stevebaker: right
19:41:37 <jcoufal> but nobody will be still able to do the setup from scratch
19:41:46 <stevebaker> once tuskar is integrated with tripleo, the need for a stable release might be reduced
19:42:18 <shadower> stevebaker: hmm why would that be?
19:42:27 * shadower is probably missing something here
19:42:58 <stevebaker> because you'll launch a tripleo seed cloud and it will be there ready to use
19:43:38 <stevebaker> and with CI, there will be a good chance that it works ;)
19:43:49 <shadower> fair point
19:44:02 <shadower> okay, so I'd lean towards getting that done
19:44:19 <stevebaker> maintaining a stable branch can be quite a burden, so you might want to delay that for as long as possible
19:44:27 <shadower> yea
19:44:55 <shadower> stevebaker: I thought more like "we know this tarball works, you can try it out"
19:45:09 <shadower> not doing any proper stable maintenance for now
19:45:46 <stevebaker> hopefully you can say that for at least some of the milestone releases
19:46:00 <shadower> yea
19:46:07 <shadower> okay, I'll have a look at the t-i-e integration and we'll revisit the releases ofter that
19:46:18 <jcoufal> shadower:
19:46:21 <jcoufal> ok
19:46:42 <matty_dubs> t-i-e?
19:46:49 <shadower> matty_dubs: tripleo image elements
19:46:50 <marios> tripleo image elements
19:46:56 <matty_dubs> Thanks :)
19:47:16 <marios> matty_dubs: lifeless through that one at us yesterday ;)
19:47:24 <shadower> yup
19:47:36 <shadower> #agreed we'll revisit releases after we've integrated with tripleo
19:47:47 <shadower> #topic Open discussion
19:47:52 <shadower> 13 minutes
19:48:01 <jcoufal> now we can say whatever we want? :)
19:48:03 <shadower> anything else you want to get off your chest?
19:48:08 <shadower> jcoufal: pretty much
19:48:09 <marios> oh dear
19:48:10 <shadower> be civil tho
19:48:10 <jcoufal> just kidding :)
19:48:28 <lsmola_> hehe
19:48:38 <matty_dubs> Thanks to shadower and martyntaylor both for running for PTL!
19:48:56 <jcoufal> yup and congratulations to shadower btw :)
19:49:01 <shadower> cheers
19:49:12 <shadower> still can't decide if it's congrats or condolences I need
19:49:22 <lsmola_> hehe
19:49:31 <jcoufal> I think the meeting was handled perfectly
19:49:38 <shadower> thanks
19:49:39 <lsmola_> agreed
19:49:46 <shadower> ready to end it?
19:49:48 <marios> shadower: indeed good job mate
19:49:54 <shadower> cheers
19:49:59 <jcoufal> no other business here
19:50:04 <matty_dubs> Thanks lifeless for joining us at the crack of dawn, too.
19:50:06 <shadower> #endmeeting