19:00:13 <jcoufal> #startmeeting Tuskar
19:00:14 <openstack> Meeting started Tue Sep 17 19:00:13 2013 UTC and is due to finish in 60 minutes.  The chair is jcoufal. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:17 <openstack> The meeting name has been set to 'tuskar'
19:00:25 <jcoufal> Hey everbyody
19:00:29 <lsmola_> hello
19:00:32 <marios> hi
19:00:34 <ifarkas> hi
19:00:34 <jtomasek> hi
19:00:37 <lblanchard> hi all
19:00:39 <julim> hi
19:00:51 <tzumainn> heya
19:00:57 <jcoufal> Today I am going to substitute shadower, who couldn't make it, hopefully he gets better soon
19:00:59 <pblaho> hi
19:01:06 <jistr> hi :)
19:01:20 <jcoufal> #topic Agenda
19:01:27 <jcoufal> just very briefly
19:01:39 <jcoufal> we are going to review previous actions
19:01:49 <jcoufal> then we are going to discuss and vote for glossary
19:02:00 <jcoufal> and in the end the will be some space for open discussion
19:02:16 <jcoufal> #topic Review Actions
19:02:40 <jcoufal> Anybody who was given action last time, feel free to give some updates how it is going
19:03:32 <jcoufal> From my side, I started etherpad with gathering name proposals, posted that to the mailing list.
19:03:38 <marios> jcoufal: my action was to write up about how tuskar & OOO fit (or "how tuskar is different from OOO") - I got carried away with sprint start and didn't get to it. Can we put action item for next week and I will get onto it tomorrow, before other things take over again - my apologies
19:04:00 <jcoufal> Lately there were no more updates on names so we are going to wrap it up today
19:04:29 <marios> (jcoufal etherpad @ https://etherpad.openstack.org/tuskar-naming )
19:04:36 <noslzzp> marios, what form was the write to take?
19:04:42 <jcoufal> #action marios to move his stuff to this week (tuskar & OOO fit)
19:04:42 <ifarkas> jcoufal, I am working on the production setup guide. I need to figure out a bunch of stuff. I am setting up tripleo + tuskar on my laptop
19:04:50 <noslzzp> s/write/write up/
19:04:55 <marios> noslzzp: well, wasn't specified. I am guessing a paragraph or two to be used #somewhere
19:05:09 <marios> noslzzp: (TBD)
19:05:15 <pblaho> marios, noslzzp : project wiki?
19:05:18 <noslzzp> marios: ok.. I'll send you something I'm working on that may help.
19:05:24 <marios> noslzzp: thats great thanks
19:06:01 <marios> jcoufal: thanks mate
19:06:18 <jcoufal> np at all
19:06:44 <jcoufal> any other updates?
19:07:03 <jcoufal> looking at the list, it looks that shadower asigned most of the actions to himself :)
19:07:25 <lsmola_> :-)
19:07:28 <jcoufal> will see if sends any e-mail with updates how it is going
19:07:29 <marios> (action items from last week @ http://eavesdrop.openstack.org/meetings/tuskar/2013/tuskar.2013-09-10-19.00.html )
19:08:09 <jcoufal> next topic then
19:08:18 <jcoufal> #topic Glossary
19:08:42 <jcoufal> so based on the etherpad document, we are going to vote actually on names and see what we can get from there
19:08:46 <jcoufal> #link https://etherpad.openstack.org/tuskar-naming
19:09:26 <jcoufal> the voting will happen that I explain quickly what we are talking about, start voting and then each memebr with preference votes like '#vote option'
19:09:40 <jcoufal> in the end we are going to do a summary and end voting for that one question
19:09:56 <jcoufal> if interested: http://ci.openstack.org/irc.html#meetbot (commands)
19:10:10 <jcoufal> so firstly we have Resource Classes
19:10:33 <jcoufal> it looks like w don't want to change the name, but in order to keep it in record, I'll oficial make the voting happen
19:10:37 <jcoufal> we can practice here :)
19:10:43 <noslzzp> sure.. :)
19:10:50 <jcoufal> #startvote How should we name 'Resource Classes'? Resource Classes, Other
19:10:51 <openstack> Begin voting on: How should we name 'Resource Classes'? Valid vote options are Resource, Classes, Other.
19:10:52 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:10:58 <jcoufal> #vote Resource Classes
19:10:58 <openstack> jcoufal: Resource Classes is not a valid option. Valid options are Resource, Classes, Other.
19:11:12 <jcoufal> oh gosh you see, here is the challenge
19:11:16 <noslzzp> Res_Class maybe?
19:11:17 <lblanchard> heh
19:11:18 <marios> jcoufal: might want to start it again
19:11:23 <jcoufal> yes
19:11:27 <jcoufal> #endvoting
19:11:32 <noslzzp> that was quick.
19:11:38 <lblanchard> lol
19:11:43 <marios> jcoufal: good idea to practice
19:11:56 <jistr> jcoufal: endvote
19:11:57 <jcoufal> #endvote
19:11:58 <openstack> Voted on "How should we name 'Resource Classes'?" Results are
19:12:00 <jcoufal> yes
19:12:02 <jcoufal> so
19:12:04 <jcoufal> #startvote How should we name 'Resource Classes'? Resource_Classes, Other
19:12:05 <openstack> Begin voting on: How should we name 'Resource Classes'? Valid vote options are Resource_Classes, Other.
19:12:06 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:12:11 <jcoufal> #vote Resource_Classes
19:12:14 <marios> #vote Resource_classes
19:12:15 <jomara> #vote Resource_Classes
19:12:18 <jistr> #vote Resource_Classes
19:12:24 <noslzzp> #vote Classes_Resource
19:12:25 <ifarkas> #vote Resource_classes
19:12:25 <pblaho> #vote Resource_Classes
19:12:25 <openstack> noslzzp: Classes_Resource is not a valid option. Valid options are Resource_Classes, Other.
19:12:25 <lblanchard> #vote Resource_Classes
19:12:27 <julim> #vote Resource_Classes
19:12:29 <jtomasek> #vote Resource_Classes
19:12:36 <lsmola_> #vote Resource_Classes
19:12:37 <noslzzp> #vote Resource_Classes
19:12:41 <tzumainn> #vote Resource_Classes
19:12:46 <jcoufal> any more?
19:12:52 <marios> noslzzp: testing the edge cases there? :)
19:12:52 <jcoufal> #showvote
19:12:52 <openstack> Resource_Classes (12): julim, ifarkas, pblaho, tzumainn, marios, jtomasek, lblanchard, jomara, noslzzp, jistr, lsmola_, jcoufal
19:12:58 <jcoufal> #endvote
19:12:59 <openstack> Voted on "How should we name 'Resource Classes'?" Results are
19:12:59 <noslzzp> marios: indeed. :)
19:13:00 <openstack> Resource_Classes (12): julim, ifarkas, pblaho, tzumainn, marios, jtomasek, lblanchard, jomara, noslzzp, jistr, lsmola_, jcoufal
19:13:02 <pblaho> hmm... underscore is just for voting bot?
19:13:12 <jcoufal> pblaho: yes
19:13:22 <jcoufal> space is considered like another option
19:13:32 <pblaho> jcoufal: thanks
19:13:33 <marios> jcoufal: (you could have set 'ResourceClasses'
19:13:44 <jcoufal> which is better for you guys?
19:13:50 <noslzzp> doesn't matter.
19:13:51 <jcoufal> cammel case or _?
19:13:52 <jistr> doesn't matter at all
19:13:56 <jcoufal> fine
19:14:02 <jcoufal> now we have class types
19:14:15 <noslzzp> apparently the voting is case InSensitiVE anyway..
19:14:17 <jcoufal> ethepred line 9
19:14:33 <ifarkas> we should vote on the camel case vs _ thing :-)
19:14:38 <jistr> nooo
19:14:42 <marios> boo
19:14:44 <lblanchard> hahaha
19:14:51 <noslzzp> rock the vote!
19:14:54 <jcoufal> #startvote How should we name class which contains main management node (undercloud) and nodes with overcloud services (except resource services)? Control_Class, Core_Service_Class, Service_Class, Controller_Class, Complement_Class, Core_Class, Other
19:14:55 <openstack> Begin voting on: How should we name class which contains main management node (undercloud) and nodes with overcloud services (except resource services)? Valid vote options are Control_Class, Core_Service_Class, Service_Class, Controller_Class, Complement_Class, Core_Class, Other.
19:14:56 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:15:16 <noslzzp> #vote controller_class
19:15:16 <jomara> #vote Controller_Class
19:15:18 <pblaho> #vote Controller_Class
19:15:24 <lblanchard> #vote Controller_Class
19:15:29 <jtomasek> #vote Controller_Class
19:15:30 <julim> #vote Controller_Class
19:15:30 <lsmola_> #vote Control_Class
19:15:30 <jistr> #vote controller_class
19:15:33 * noslzzp is a trend setting..
19:15:40 <jcoufal> #vote controller_class
19:15:40 <marios> #vote Control_Class
19:15:49 <ifarkas> #vote Controller_Class
19:16:05 <jomara> noslzzp: public ballot, we have to vote with you or matty dubs will punch us
19:16:08 <jcoufal> anybody else?
19:16:14 <jistr> noslzzp: no way, it was me who suggested that name :P
19:16:23 * jistr takes back the credit :D
19:16:28 <jcoufal> #endvote
19:16:29 <openstack> Voted on "How should we name class which contains main management node (undercloud) and nodes with overcloud services (except resource services)?" Results are
19:16:30 <openstack> Controller_Class (9): julim, ifarkas, pblaho, jtomasek, lblanchard, jomara, noslzzp, jistr, jcoufal
19:16:32 <openstack> Control_Class (2): marios, lsmola_
19:16:59 <jcoufal> just to make it official we have compute end storage classes, so these might be very quick
19:17:04 <jcoufal> *and
19:17:09 <lblanchard> so now it's a race to see who can get in their vote first!
19:17:12 <noslzzp> "fun with meetbot"..
19:17:15 <pblaho> (imagine politicians voting through IRC)
19:17:26 <jcoufal> #startvote How should we name 'Compute Class'? Compute_Class, Compute_Resource_Class, Other
19:17:27 <openstack> Begin voting on: How should we name 'Compute Class'? Valid vote options are Compute_Class, Compute_Resource_Class, Other.
19:17:28 <noslzzp> #vote compute_class
19:17:29 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:17:30 <lsmola_> hehe
19:17:31 <noslzzp> doh!
19:17:32 <noslzzp> #vote compute_class
19:17:36 <marios> #vote compute_class
19:17:38 <matty_dubs> #vote compute_class
19:17:38 <julim> #vote Compute_Class
19:17:40 <jomara> #vote compute_class
19:17:41 <jcoufal> #vote compute_class
19:17:41 <tzumainn> #vote compute_class
19:17:43 <lblanchard> #vote compute_class
19:17:46 <pblaho> #vote compute_class
19:17:46 <jistr> #vote compute_class
19:17:50 <lsmola_> #vote compute_class
19:17:53 <ifarkas> #vote Compute_Class
19:17:53 <matty_dubs> Is Gabelstaplerfahrer not on the table?
19:17:59 <lblanchard> matty_dubs: hahaha
19:18:01 <noslzzp> lol
19:18:02 <pblaho> matty_dubs: other?
19:18:03 <marios> #vote Gabelstaplerfahrer
19:18:03 <jtomasek> #vote Compute_Class
19:18:04 <jcoufal> sorry matt
19:18:04 <openstack> marios: Gabelstaplerfahrer is not a valid option. Valid options are Compute_Class, Compute_Resource_Class, Other.
19:18:08 <ifarkas> #vote Gabelstaplerfahrer
19:18:08 <lblanchard> matty_dubs: you should have added it to the etherpad :)
19:18:08 <openstack> ifarkas: Gabelstaplerfahrer is not a valid option. Valid options are Compute_Class, Compute_Resource_Class, Other.
19:18:09 <matty_dubs> :'(
19:18:10 <jcoufal> haha
19:18:12 <noslzzp> lol
19:18:18 <jcoufal> #endvote
19:18:19 <openstack> Voted on "How should we name 'Compute Class'?" Results are
19:18:20 <openstack> Compute_Class (13): julim, ifarkas, pblaho, marios, jtomasek, lblanchard, jomara, noslzzp, matty_dubs, tzumainn, lsmola_, jcoufal, jistr
19:18:24 <noslzzp> write ins not allowed..
19:18:26 <jcoufal> #startvote How should we name 'Object Storage Class'? Object_Storage_Class, Object_Storage_Resource_Class, Other
19:18:26 <openstack> Begin voting on: How should we name 'Object Storage Class'? Valid vote options are Object_Storage_Class, Object_Storage_Resource_Class, Other.
19:18:27 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:18:38 <marios> #vote Object_Storage_Class
19:18:38 <jistr> #vote object_storage_class
19:18:39 <pblaho> #vote Object_Storage_Class
19:18:39 <noslzzp> #vote object_storage
19:18:39 <openstack> noslzzp: object_storage is not a valid option. Valid options are Object_Storage_Class, Object_Storage_Resource_Class, Other.
19:18:39 <matty_dubs> #vote object_storage_class
19:18:41 <julim> #vote Object_Storage_Class
19:18:44 <jtomasek> #vote Object_Storage_Class
19:18:45 <ifarkas> #vote Object_Storage_Class
19:18:46 <jcoufal> #vote object_storage_class
19:18:49 <tzumainn> #vote object_storage_class
19:18:50 <noslzzp> #vote object_storage_class
19:18:50 <lblanchard> #vote Object_Storage_Class
19:18:50 <jomara> #vote object_storage_class
19:18:59 <lsmola_> #vote object_storage_class
19:19:05 <noslzzp> lemmings!!
19:19:07 <jcoufal> #endvote
19:19:08 <openstack> Voted on "How should we name 'Object Storage Class'?" Results are
19:19:09 <openstack> Object_Storage_Class (13): julim, ifarkas, pblaho, marios, jtomasek, lblanchard, tzumainn, jomara, noslzzp, matty_dubs, jistr, lsmola_, jcoufal
19:19:16 <jcoufal> #startvote How should we name 'Block Storage Class'? Block_Storage_Class, Block_Storage_Resource_Class, Other
19:19:17 <openstack> Begin voting on: How should we name 'Block Storage Class'? Valid vote options are Block_Storage_Class, Block_Storage_Resource_Class, Other.
19:19:18 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:19:18 <marios> #vote Block_Storage_Class
19:19:25 <noslzzp> #vote block_storage_class
19:19:27 <jcoufal> #vote block_storage_class
19:19:27 <lblanchard> #vote block_storage_class
19:19:29 <jistr> #vote block_storage_class
19:19:29 <matty_dubs> #vote block_storage_class
19:19:30 <jtomasek> #vote Block_Storage_Class
19:19:31 <tzumainn> #vote block_storage_class
19:19:35 <ifarkas> #vote Block_Storage_Class
19:19:37 <julim> #vote Block_storage_Class
19:19:38 <lsmola_> #vote block_storage_class
19:19:38 <pblaho> #vote block_storage_class
19:19:40 * matty_dubs tempted to go against grain just so votes aren't unanimous
19:19:59 <noslzzp> won't work Matty.. i tried.
19:20:04 <jcoufal> #endvote
19:20:05 <openstack> Voted on "How should we name 'Block Storage Class'?" Results are
19:20:06 <openstack> Block_Storage_Class (12): julim, ifarkas, pblaho, marios, jtomasek, lblanchard, tzumainn, noslzzp, matty_dubs, jistr, lsmola_, jcoufal
19:20:09 <jcoufal> so these were pretty fast
19:20:16 <jcoufal> we are getting into troubles slowly
19:20:19 <jcoufal> flavors
19:20:21 <pblaho> and pretty unisono
19:20:34 <jcoufal> all the rationals are given in the etherpad from line 43
19:20:35 <jomara> matty_dubs: i stood out by abstaining!
19:20:44 <jcoufal> let's the fight begin
19:21:01 <jcoufal> #startvote How should we name 'Flavors' in Tuskar? Flavors, Flavor_Templates, Flavor_Definitions, Instance_Types, Instance_Configurations, Configuration_Templates, Configuration_Profiles, Other
19:21:02 <openstack> Begin voting on: How should we name 'Flavors' in Tuskar? Valid vote options are Flavors, Flavor_Templates, Flavor_Definitions, Instance_Types, Instance_Configurations, Configuration_Templates, Configuration_Profiles, Other.
19:21:03 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:21:07 <jistr> #vote flavors
19:21:08 <jtomasek> #vote flavors
19:21:11 <pblaho> #vote Flavor_Definitions
19:21:13 <ifarkas> #vote Flavor_Templates
19:21:14 <jcoufal> #vote flavor_definitions
19:21:21 <matty_dubs> #vote flavor_definitions
19:21:22 <marios> #vote flavors
19:21:31 <matty_dubs> I think the problem with flavors is that there's ALREADY a flavors concept in OpenStack
19:21:37 <pblaho> this will be interesting....
19:21:40 <marios> matty_dubs: but these are one and the same
19:21:41 <lsmola_> #vote flavors
19:21:44 <matty_dubs> And ours aren't identical to them
19:21:45 <tzumainn> #vote flavors
19:21:45 <noslzzp> #vote instance_family
19:21:45 <openstack> noslzzp: instance_family is not a valid option. Valid options are Flavors, Flavor_Templates, Flavor_Definitions, Instance_Types, Instance_Configurations, Configuration_Templates, Configuration_Profiles, Other.
19:21:48 <jistr> matty_dubs: yeah but we *don't* introduce a new concept
19:21:49 <noslzzp> :)
19:21:51 <marios> matty_dubs: yes they are
19:21:52 <julim> #vote Other
19:21:54 <jomara> #vote flavors
19:21:57 <noslzzp> #vote Other
19:22:00 <lsmola_> matty_dubs, they should be identicl
19:22:01 <pblaho> marios: yeah... and we have a link between them and our flavors
19:22:03 <lblanchard> #vote Other
19:22:29 <jcoufal> anybody else any preference?
19:22:34 * ifarkas wondering what are the Other suggestions?
19:22:35 <pblaho> marios: sorry.. it was for matty_dubs ... you know, "ma TAB"
19:22:42 <marios> pblaho: ;)
19:22:47 <jcoufal> ifarkas: none, we need to work harder if that's the case :)
19:22:51 <jcoufal> #showvote
19:22:52 <openstack> Flavors (6): marios, jtomasek, tzumainn, jomara, lsmola_, jistr
19:22:54 <openstack> Other (3): julim, noslzzp, lblanchard
19:22:55 <openstack> Flavor_Templates (1): ifarkas
19:22:56 <openstack> Flavor_Definitions (3): matty_dubs, jcoufal, pblaho
19:23:07 <matty_dubs> So if I create a Flavor in Nova
19:23:12 <matty_dubs> Does it show up in our app as a Flavor?
19:23:16 <jcoufal> it looks for flavors then
19:23:22 <matty_dubs> And vice versa?
19:23:39 <lsmola_> matty_dubs, it should
19:23:40 <jcoufal> does anybody want to change vote or rationalize his voting?
19:23:40 <marios> matty_dubs: by the same reasoning, if you launch an instance in openstack nova, independently of tuskar, it may not show up in the dashboard (at least not presently)
19:23:55 <ifarkas> #vote Flavor_Definitions
19:24:05 <ifarkas> I don't want to be alone...
19:24:35 <jcoufal> any suggestions from people voting for others?
19:24:40 <lblanchard> Instance Profile?
19:24:44 <pblaho> in the future we should focus more on campaing before voting :-)
19:24:59 <jistr> instance pool family frost flavor?
19:24:59 <lsmola_> matty_dubs, otherwise it doesn`t have 1to1 mapping
19:25:00 <julim> In the vBlock world, it's typically called a Service Profile
19:25:19 <jcoufal> ok, let's move forward
19:25:20 <jcoufal> #endvote
19:25:21 <openstack> Voted on "How should we name 'Flavors' in Tuskar?" Results are
19:25:22 <openstack> Flavors (6): marios, jtomasek, tzumainn, jomara, lsmola_, jistr
19:25:23 <openstack> Other (3): julim, noslzzp, lblanchard
19:25:23 <lsmola_> jistr, lol
19:25:25 <openstack> Flavor_Definitions (4): ifarkas, matty_dubs, jcoufal, pblaho
19:25:38 <jcoufal> quick one about nodes in general
19:25:46 <jcoufal> #startvote How should we name general physical machines, which are part of the racks? Nodes, Hosts, Other
19:25:47 <openstack> Begin voting on: How should we name general physical machines, which are part of the racks? Valid vote options are Nodes, Hosts, Other.
19:25:48 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:25:58 <jcoufal> #vote nodes
19:25:58 <jomara> #vote hosts
19:26:01 <ifarkas> #vote Nodes
19:26:05 <pblaho> #vote nodes
19:26:06 <matty_dubs> #vote nodes
19:26:06 <jtomasek> #vote Nodes
19:26:10 <jistr> #vote nodes
19:26:11 <noslzzp> #vote nodes
19:26:12 <marios> #vote hosts
19:26:16 <lblanchard> #vote Nodes
19:26:16 <julim> #vote Nodes
19:26:17 <jomara> rage against the machine
19:26:24 <tzumainn> #vote nodes
19:26:29 <jomara> rage against the (host) machine
19:26:37 <matty_dubs> FWIW I liked hosts too, but I don't see a reason to change
19:26:40 <jcoufal> anybody else?
19:26:41 <marios> seems to be that everywhere else in OS they are called 'hosts' - but it would definitely be easier to keep nodes right now
19:26:43 <lsmola_> matty_dubs, though to work correctly, it should be set only from undercloud, so there were a thought to forbid to set them in overcloud :-)
19:26:50 <lsmola_> #vote nodes
19:26:58 <jcoufal> 3, 2, 1
19:27:02 <jcoufal> #endvote
19:27:02 <openstack> Voted on "How should we name general physical machines, which are part of the racks?" Results are
19:27:03 <openstack> Nodes (11): julim, ifarkas, pblaho, jtomasek, lblanchard, tzumainn, noslzzp, matty_dubs, jistr, lsmola_, jcoufal
19:27:04 <openstack> Hosts (2): marios, jomara
19:27:13 <jcoufal> And now we are getting to racks
19:27:20 <noslzzp> weeee!
19:27:23 <ifarkas> #vote Racks
19:27:26 <tzumainn> jcoufal, should we allow some campaigning before the actual vote?
19:27:28 <jcoufal> #startvote How should we name 'Rack' in general (no specific purpose of the rack)? Rack, Chassis, Logical_Rack, Enclosure, Other
19:27:29 <openstack> Begin voting on: How should we name 'Rack' in general (no specific purpose of the rack)? Valid vote options are Rack, Chassis, Logical_Rack, Enclosure, Other.
19:27:30 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:27:36 <pblaho> #vote racks
19:27:36 <openstack> pblaho: racks is not a valid option. Valid options are Rack, Chassis, Logical_Rack, Enclosure, Other.
19:27:38 <marios> #vote rack
19:27:40 <jtomasek> #vote rack
19:27:40 <jcoufal> you can do the campaign druing voting
19:27:42 <pblaho> #vote rack
19:27:45 <jcoufal> tzumainn: ^
19:27:48 <ifarkas> #vote Rack
19:27:50 <jomara> #vote rack
19:27:50 <matty_dubs> Chassis doesn't mean the same thing in racks, though. A server chassis is the enclosure on one server.
19:27:52 <lblanchard> #vote Rack
19:27:53 <matty_dubs> #vote Rack
19:27:54 <jcoufal> people can change their votes, last one is counted
19:27:55 <julim> #vote rack
19:27:56 <tzumainn> #vote rack
19:27:59 <jistr> #vote rack
19:28:04 <pblaho> jcoufal: ok.... be conservative, stay with Rack :-)
19:28:05 <matty_dubs> At least in normal terminology
19:28:05 <noslzzp> #vote rack
19:28:15 <jcoufal> #vote rack
19:28:18 <lsmola_> #vote other
19:28:40 <jcoufal> anybody else?
19:28:43 <matty_dubs> #playsong Tyga - Rack City
19:28:56 <jcoufal> not working matty_dubs
19:28:59 <jcoufal> #endvote
19:29:00 <openstack> Voted on "How should we name 'Rack' in general (no specific purpose of the rack)?" Results are
19:29:01 <openstack> Other (1): lsmola_
19:29:02 <openstack> Rack (12): julim, ifarkas, pblaho, marios, jtomasek, lblanchard, jomara, noslzzp, matty_dubs, tzumainn, jcoufal, jistr
19:29:04 <pblaho> "Only with Rack we can have working Tuskar for everyone"
19:29:18 <lblanchard> matty_dubs: why is that song so catchy?
19:29:26 <noslzzp> now on to the good stuff..
19:29:27 <jcoufal> one for make it official
19:29:30 <jcoufal> #startvote How should we name rack which is part of Controller Class? Controller_Rack, Other
19:29:31 <openstack> Begin voting on: How should we name rack which is part of Controller Class? Valid vote options are Controller_Rack, Other.
19:29:32 <matty_dubs> lblanchard: I don't get it. I assume it's not actually about data centers.
19:29:33 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:29:46 <jcoufal> #vote controller_rack
19:29:49 <ifarkas> #vote Controller_rack
19:29:53 <tzumainn> #vote controller_rack
19:29:55 <jistr> #vote controller_rack
19:29:55 <jomara> #vote controller_rack
19:29:57 <noslzzp> #vote controller_rack
19:29:57 <lblanchard> matty_dubs: lol…yes, I think "Chassis City" would be different
19:30:01 <pblaho> #vote controller_rack
19:30:09 <lblanchard> #vote controller_rack
19:30:11 <jtomasek> #vote controller_rack
19:30:13 <julim> #vote Controller_Rack
19:30:17 * matty_dubs abstains
19:30:22 <marios> i dont get this
19:30:27 <pblaho> I think this will be not used in code or api.... but in discussions and probably docs...
19:30:28 <lsmola_> #vote controller_rack
19:30:31 <marios> #vote other
19:30:46 <jistr> pblaho: yeah i think so too
19:30:51 <lblanchard> pblaho: agreed
19:30:55 <lsmola_> #vote other
19:31:15 <jcoufal> pbaexactly
19:31:22 <jcoufal> no code, more discussion wise
19:31:23 <lsmola_> I dont like it anynmore :-)
19:31:29 <jcoufal> #endvote
19:31:30 <openstack> Voted on "How should we name rack which is part of Controller Class?" Results are
19:31:31 <openstack> Controller_Rack (10): julim, ifarkas, pblaho, jtomasek, lblanchard, jomara, noslzzp, tzumainn, jcoufal, jistr
19:31:32 <openstack> Other (2): marios, lsmola_
19:31:43 <jcoufal> now we are going to nodes with specific purposes
19:31:54 <jcoufal> #startvote How should we name main management node, which is containing undercloud and is part of controller rack? Undercloud_Management_Node, Primary_Management_Node, Core_Management_Node, Other
19:31:54 <openstack> Begin voting on: How should we name main management node, which is containing undercloud and is part of controller rack? Valid vote options are Undercloud_Management_Node, Primary_Management_Node, Core_Management_Node, Other.
19:31:55 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:32:05 <noslzzp> The Diebold code embedded in my IRC client changed my vote!
19:32:08 <ifarkas> #vote Undercloud_Management_Node,
19:32:09 <openstack> ifarkas: Undercloud_Management_Node, is not a valid option. Valid options are Undercloud_Management_Node, Primary_Management_Node, Core_Management_Node, Other.
19:32:14 <matty_dubs> noslzzp: LOL
19:32:15 <pblaho> #vote undercloud_management_node
19:32:19 <marios> #vote undercloud_management_node
19:32:21 <ifarkas> #vote Undercloud_Management_Node
19:32:28 <matty_dubs> #vote Undercloud_Management_Node
19:32:28 <lsmola_> #vote undercloud_management_node
19:32:29 <julim> #vote Primary_Management_Node
19:32:30 <jtomasek> #vote Undercloud_Management_Node
19:32:33 * matty_dubs votes for least-bad
19:32:43 <noslzzp> #vote other
19:32:45 <lblanchard> #vote Primary_Management_Node
19:32:47 <jcoufal> #vote primary_management_node
19:32:58 <noslzzp> #vote primary_management_node
19:33:12 <pblaho> wow... we are losing buzzwords :-)
19:33:12 <jcoufal> #showvote
19:33:12 <openstack> Primary_Management_Node (4): noslzzp, julim, lblanchard, jcoufal
19:33:13 <openstack> Undercloud_Management_Node (6): ifarkas, pblaho, marios, jtomasek, matty_dubs, lsmola_
19:33:17 <jistr> #vote primary_management_node
19:33:27 <jtomasek> #vote primary_management_node
19:33:28 <noslzzp> Undercloud is too technical..
19:33:30 <jcoufal> anybody wants to change mind? or do campaign?
19:33:30 <jistr> nice
19:33:35 <jistr> jtomasek: tie vote!
19:33:36 <noslzzp> Change your vote please.. :)
19:33:40 <pblaho> #showvote
19:33:41 <openstack> Primary_Management_Node (6): julim, jtomasek, lblanchard, noslzzp, jistr, jcoufal
19:33:42 <openstack> Undercloud_Management_Node (5): ifarkas, pblaho, marios, matty_dubs, lsmola_
19:33:43 <lblanchard> Undercloud is confusingggg :(
19:33:49 <matty_dubs> We already expose 'undercloud' to user though
19:33:49 <noslzzp> Indeed!
19:33:54 <julim> No end user will get undercloud vs. overcloud
19:33:55 <matty_dubs> It has a clear meaning, unlike 'primary'
19:33:57 <noslzzp> Follow slzzp and Liz on this one..
19:34:01 <lblanchard> matty_dubs: we do?
19:34:01 <noslzzp> less typing!
19:34:19 <lsmola_> matty_dubs, agreed
19:34:22 <pblaho> maybe hw management node>
19:34:24 <pblaho> ?
19:34:25 <jtomasek> this is tough decision
19:34:26 <matty_dubs> lblanchard: Oh, maybe not UX wise. But 'primary' means that there's a secondary/backup
19:34:33 <lsmola_> do we have secondary management node?
19:34:34 <matty_dubs> Err, means _to me_
19:34:42 <noslzzp> This is a control plane problem.. so primary management node makes sense in that context.
19:34:43 <pblaho> matty_dubs: +1
19:34:50 <jistr> matty_dubs: hmm yeah that's a good point
19:34:51 <matty_dubs> "This is my primary management node, and this is my hot spare, the secondary management node"
19:34:51 <lblanchard> matty_dubs: but if people use cloud to butt it will be "Underbutt" :(
19:34:58 <noslzzp> the under/over stuff is only meaningful for g33ks.
19:35:06 <matty_dubs> lblanchard: LOL, best argument ever
19:35:16 <jcoufal> noslzzp: that's true
19:35:25 <jcoufal> so last chance to change your minds
19:35:33 <lsmola_> #vote UnderbuttManagementNode
19:35:34 <openstack> lsmola_: UnderbuttManagementNode is not a valid option. Valid options are Undercloud_Management_Node, Primary_Management_Node, Core_Management_Node, Other.
19:35:36 <marios> i'd probably go with core over primary though
19:35:38 <pblaho> noslzzp: yeah.. but I don't see how primary tell me that it would be managing what?
19:35:43 <jomara> noslzzp: how many nongeeks will be in our docs
19:35:47 <ifarkas> noslzzp, or anyone who is familiar with tripleo glossary
19:35:52 <jcoufal> ok, ending voting
19:35:54 <jcoufal> 3, 2, 1
19:35:56 <noslzzp> everyone who deploys OpenStack..
19:36:03 <jcoufal> #endvote
19:36:04 <openstack> Voted on "How should we name main management node, which is containing undercloud and is part of controller rack?" Results are
19:36:06 <openstack> Primary_Management_Node (6): julim, jtomasek, lblanchard, noslzzp, jistr, jcoufal
19:36:07 <openstack> Undercloud_Management_Node (5): ifarkas, pblaho, marios, matty_dubs, lsmola_
19:36:10 <jomara> they arent geeks>?
19:36:11 <matty_dubs> Noooo
19:36:19 <noslzzp> The are *customers*. :)
19:36:22 <jcoufal> interesting one
19:36:23 <noslzzp> s/The/They/
19:36:26 <matty_dubs> noslzzp: Not upstream :-P
19:36:34 * jistr wonders if this is a good candidate for a revote next week :D
19:36:46 <marios> jistr: lol
19:36:52 <jcoufal> I think so
19:36:57 <noslzzp> No, the hanging chads have been counted.  It's over.
19:36:57 <jomara> i would put this up for revote
19:37:00 <jcoufal> each very close voting might get one more chance
19:37:07 <noslzzp> Accept your fate.
19:37:08 <marios> jomara: SECOND!
19:37:10 <jomara> primary doesnt really make sense, but if nobody knows what an 'undercloud' is
19:37:14 <jomara> then that doesnt make sense either
19:37:22 <pblaho> jomara: +
19:37:35 <noslzzp> Maybe we need some more options?
19:37:36 <jcoufal> #action revote Undercloud Management Node
19:37:39 <jomara> yeah
19:37:43 <marios> lets wait until noslzzp is pto and revote then
19:37:43 <noslzzp> does just "management node" work?
19:37:47 <jomara> haha
19:37:49 <jistr> jcoufal: +1 thanks
19:37:50 <jcoufal> feel free to update etherpad until next week
19:37:50 <noslzzp> marios: lol
19:37:54 <jomara> Club Mate Management Node
19:37:57 <matty_dubs> Well let's brainstorm some better options offline and revote at the next meeting?
19:38:03 <ifarkas> tertiary management node?
19:38:09 <noslzzp> oh dear.
19:38:10 <jcoufal> #startvote How should we name all other nodes which are part of the controller rack? Service_Nodes, Controller_Nodes, Nodes, Other
19:38:10 <openstack> Begin voting on: How should we name all other nodes which are part of the controller rack? Valid vote options are Service_Nodes, Controller_Nodes, Nodes, Other.
19:38:11 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:38:11 <lblanchard> Management Management Node? :)
19:38:11 <lsmola_> hehe
19:38:32 <jcoufal> this one is about talking in discussions mostly
19:38:34 <marios> #vote controller_nodes
19:38:36 <lsmola_> Meta management node
19:38:37 <lblanchard> #vote Controller_Nodes
19:38:39 <noslzzp> The "Management Node that says Bad Mother.. r On It"
19:38:40 <jtomasek> #vote controller_nodes
19:38:42 <jcoufal> I don't think it will appear in the code
19:38:44 <jistr> #vote controller_nodes
19:38:46 <matty_dubs> Didn't we already have Controller Nodes somewhere else?
19:38:47 <marios> jcoufal: right, i was just about to ask for clarification - this is just how 'we talk about them' right?
19:38:52 <pblaho> #vote controller_nodes
19:38:56 <jcoufal> #vote Controller_Nodes
19:38:59 <pblaho> marios: we have controller class
19:39:04 <tzumainn> #vote controller_nodes
19:39:05 <lblanchard> noslzzp: BAMF Management Node!!!
19:39:06 <jcoufal> marios: yeah
19:39:09 <jistr> marios: and controller rack :)
19:39:12 <ifarkas> #vote Controller_Nodes
19:39:18 <pblaho> marios: or racks?
19:39:24 <jistr> pblaho: both :)
19:39:24 <julim> #vote Other
19:39:31 <lsmola_> #vote controller_nodes
19:39:37 <jomara> #vote controller_nodes
19:39:39 <noslzzp> #vote controller_nodes
19:39:53 <lsmola_> #vote node
19:39:54 <jcoufal> more?
19:39:54 <openstack> lsmola_: node is not a valid option. Valid options are Service_Nodes, Controller_Nodes, Nodes, Other.
19:39:58 <lsmola_> #vote nodes
19:40:05 <marios> pblaho: yeah the controller rack i didn't understand either ... but the controller class.. we already talk about that.. like the "compute class" or the "storage class " etc etc. so i think its the same. just for reference, so everyone agrees what we are talking about
19:40:19 <jcoufal> #endvote
19:40:20 <openstack> Voted on "How should we name all other nodes which are part of the controller rack?" Results are
19:40:21 <openstack> Nodes (1): lsmola_
19:40:22 <jcoufal> marios: yes
19:40:23 <openstack> Other (1): julim
19:40:24 <openstack> Controller_Nodes (9): pblaho, marios, jtomasek, lblanchard, tzumainn, jomara, noslzzp, jistr, jcoufal
19:40:42 <jcoufal> smae think mainly for discussions are other racks
19:40:44 <pblaho> marios: yeah... controller node is a shortcut for node in controller class
19:40:48 <jcoufal> #startvote How should we name rack which is providing compute or storage resources? Resource_Rack, Other
19:40:49 <openstack> Begin voting on: How should we name rack which is providing compute or storage resources? Valid vote options are Resource_Rack, Other.
19:40:50 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:40:54 <marios> pblaho: right, thats what i understood
19:41:07 <marios> pblaho: so we have very clear way of discussing the various nodes/racks/classes
19:41:09 <matty_dubs> #vote Other
19:41:13 <noslzzp> #vote resource_rack
19:41:20 <marios> #Resource_Rack
19:41:23 <jistr> #vote resource_rack
19:41:24 <marios> err
19:41:26 <lblanchard> hrmmm
19:41:28 <matty_dubs> For non-technical reasons, I really hate 'Resource Rack'
19:41:28 <julim> #vote Resource_Rack
19:41:29 <marios> #vote Resource_Rack
19:41:35 <pblaho> compute or storage means non controller?
19:41:35 <ifarkas> #vote Other
19:41:39 <jcoufal> pblaho: yes
19:41:41 <lsmola_> #vote Other
19:41:43 <jcoufal> #vote other
19:41:46 <lblanchard> why not split this between Compute_Rack and Object_Storage_Rack
19:41:49 <marios> matty_dubs: i guess the rational is 'resource' vs 'service'
19:41:50 <jistr> pblaho: yeah that's how i understand it
19:41:50 <lblanchard> #vote other
19:41:51 <pblaho> #vote other
19:41:51 <matty_dubs> I don't actually have a better suggestion though :-\
19:42:05 <jomara> #vote resource_rack
19:42:06 <jistr> lblanchard: yeah they will actually be split
19:42:10 <jomara> i dont mind resource rack?
19:42:11 <pblaho> I do not like Resource Rack... resource is used in classes... confucing
19:42:16 <pblaho> *cnofusing
19:42:18 <matty_dubs> pblaho++
19:42:23 <pblaho> **you know
19:42:28 <noslzzp> suggestions?
19:42:29 <lsmola_> #vote for not having that many terms, it should be simpler
19:42:30 <openstack> lsmola_: for not having that many terms, it should be simpler is not a valid option. Valid options are Resource_Rack, Other.
19:42:30 <jistr> lblanchard: but we wanted a joint naming for all non-controller racks
19:42:42 <jcoufal> lsmola_: we need to reference it somehow
19:42:43 <lblanchard> jistr: ah...
19:42:48 <jcoufal> the whole propblematic is complex
19:43:01 <julim> what's wrong with calling it a non-controller rack?
19:43:13 <jcoufal> #showvote
19:43:14 <openstack> Other (6): ifarkas, pblaho, lblanchard, matty_dubs, lsmola_, jcoufal
19:43:15 <openstack> Resource_Rack (5): marios, julim, noslzzp, jistr, jomara
19:43:16 <jistr> julim: yeah i'm thinking this right now too
19:43:16 <lsmola_> control class rack ?
19:43:20 <jistr> #vote other
19:43:24 <jistr> because
19:43:27 <noslzzp> push to next week?
19:43:33 <jcoufal> yes
19:43:34 <marios> noslzzp: +1
19:43:34 <lsmola_> resource class rack?
19:43:38 <jcoufal> more suggestions and next week
19:43:39 <matty_dubs> Given that 'Other' is winning, I might propose that we take this offline and brianstorm here
19:43:42 <jcoufal> #endvote
19:43:43 <jomara> yeah +1
19:43:43 <openstack> Voted on "How should we name rack which is providing compute or storage resources?" Results are
19:43:44 <openstack> Other (7): ifarkas, pblaho, lblanchard, matty_dubs, jistr, lsmola_, jcoufal
19:43:45 <openstack> Resource_Rack (4): marios, julim, noslzzp, jomara
19:43:51 <matty_dubs> Or maybe brainstorm. Brian might not like being stormed.
19:43:53 <jcoufal> #action revote Resource Racks
19:44:04 <tzumainn> I have to admit that this would be easier for me if there was a document showing how all these pieces fit together
19:44:21 <matty_dubs> tzumainn++
19:44:21 <tzumainn> I kinda see it, but it's a bit fuzzy
19:44:39 <matty_dubs> Martyn and I said we'd tackle that at the last meeting, but haven't (at least I haven't) made progress yet :(
19:44:40 <jcoufal> #startvote How should we name node which is a management node in 'resource' rack (but not the primary management node)? Leaf_Management_Node, Management_Node, Hypervisor, Host, Undercloud_Worker, Other
19:44:41 <openstack> Begin voting on: How should we name node which is a management node in 'resource' rack (but not the primary management node)? Valid vote options are Leaf_Management_Node, Management_Node, Hypervisor, Host, Undercloud_Worker, Other.
19:44:42 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:44:43 <pblaho> I would suggest to name racks after resource class it is in
19:45:00 <matty_dubs> Please oh God not 'Hypervisor'
19:45:08 <jomara> #vote management_node
19:45:08 <julim> #vote Leaf_Management_Node
19:45:11 <jistr> matty_dubs: +1
19:45:14 <lblanchard> depends on what we decide for the primary management node...
19:45:16 <matty_dubs> It's the only thing in the rack that ISN'T a hypervisor
19:45:17 <marios> #vote management_node
19:45:18 <pblaho> #vote management_node
19:45:18 <jcoufal> #vote management_node
19:45:18 <jtomasek> #vote management_node
19:45:21 <lblanchard> #vote management_node
19:45:23 <matty_dubs> #vote Leaf_Management_Node
19:45:26 <marios> matty_dubs: haha
19:45:28 <jistr> #vote leaf_management_node
19:45:28 <ifarkas> #vote management_node
19:45:40 <ifarkas> #vote leaf_management_node
19:45:41 <marios> matty_dubs: domain_0_node
19:45:47 <jistr> management_node will be confusing
19:45:48 <lsmola_> #vote hypervisor
19:45:49 <matty_dubs> #vote Management_Node
19:45:50 <jtomasek> #vote leaf_management_node
19:45:54 <noslzzp> shouldn't this vote be held in concurrence with the other management node vote?
19:45:59 <jistr> i think people will refer to primary mgmt node that way too
19:46:13 <pblaho> #vote leaf_management_node
19:46:13 <jcoufal> #showvote
19:46:14 <openstack> Hypervisor (1): lsmola_
19:46:15 <openstack> Leaf_Management_Node (5): julim, ifarkas, pblaho, jtomasek, jistr
19:46:16 <matty_dubs> Oh, is this the opposite of the 'primary' thing?
19:46:17 <openstack> Management_Node (5): marios, lblanchard, jomara, matty_dubs, jcoufal
19:46:19 * pblaho revoted
19:46:22 <matty_dubs> #slap lsmola_
19:46:28 <tzumainn> lol
19:46:29 <noslzzp> matty_dubs: related, yes..
19:46:30 <lsmola_> matty_dubs, ouch
19:46:33 <matty_dubs> ;)
19:46:37 <lsmola_> matty_dubs, freeedom
19:46:39 <jcoufal> #endvote
19:46:40 <openstack> Voted on "How should we name node which is a management node in 'resource' rack (but not the primary management node)?" Results are
19:46:41 <openstack> Hypervisor (1): lsmola_
19:46:43 <openstack> Leaf_Management_Node (5): julim, ifarkas, pblaho, jtomasek, jistr
19:46:44 <openstack> Management_Node (5): marios, lblanchard, jomara, matty_dubs, jcoufal
19:46:48 <pblaho> 5-5?
19:46:49 <jistr> lol lsmola_
19:46:52 <jcoufal> #action revote Leaf Management Node
19:46:59 <matty_dubs> Oh man, I was on the fence. I even changed my vote and could see myself rechanging
19:47:00 <jcoufal> last 2 votes
19:47:00 <lsmola_> btw. leaf doesn have leaves
19:47:02 <matty_dubs> Agree on the revote
19:47:07 <marios> god please no more votes
19:47:11 <marios> (today)
19:47:13 <noslzzp> i'm dizzy.
19:47:13 <matty_dubs> At a later date I mean
19:47:20 <pblaho> yeah, but that node manages other leaves
19:47:27 <jcoufal> #startvote How should we name all other nodes which are part of 'resource' rack providing 'resource' service (compute or storage)? Resource_Nodes, Nodes, Instances, Other
19:47:27 <openstack> Begin voting on: How should we name all other nodes which are part of 'resource' rack providing 'resource' service (compute or storage)? Valid vote options are Resource_Nodes, Nodes, Instances, Other.
19:47:28 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:47:30 <matty_dubs> Trunk?
19:47:32 <matty_dubs> Branch?
19:47:39 <marios> matty_dubs: splinter
19:47:46 <ifarkas> #vote Other
19:47:48 <jistr> #vote other
19:47:54 <pblaho> #vote other
19:47:55 <jcoufal> I guess it depends on the 'resource' racks
19:47:59 <matty_dubs> Wait, what is this question
19:48:04 * pblaho suggests leaf node
19:48:07 <julim> #vote Other
19:48:07 <lsmola_> #vote nodes
19:48:08 <matty_dubs> Everything in a resource rack?
19:48:10 <lblanchard> #vote Other
19:48:17 <jcoufal> matty_dubs: yeah
19:48:21 * jistr suggests non-controller node -- silly but precise
19:48:22 <jcoufal> except management node
19:48:23 <matty_dubs> #vote Nodes
19:48:25 <pblaho> matty_dubs: except that management node
19:48:26 <marios> #vote resource_nodes
19:48:29 <jcoufal> #other
19:48:31 <matty_dubs> Oh, yeah, good point
19:48:32 <lsmola_> #vote resources
19:48:33 <openstack> lsmola_: resources is not a valid option. Valid options are Resource_Nodes, Nodes, Instances, Other.
19:48:38 * marios not sure how much of this will actually ever be used in conversation
19:48:50 <jcoufal> marios: we used this quite a lot
19:48:52 <jcoufal> really
19:48:58 <jtomasek> #vote resource_nodes
19:49:10 <jistr> and it really depends how we name the "non-controller rack" or "resource rack" that we postponed
19:49:10 <jcoufal> any other votes?
19:49:16 <jcoufal> #showvote
19:49:17 <openstack> Nodes (2): matty_dubs, lsmola_
19:49:18 <openstack> Other (5): julim, lblanchard, ifarkas, jistr, pblaho
19:49:19 <openstack> Resource_Nodes (2): marios, jtomasek
19:49:21 <lblanchard> jistr: agreed :)
19:49:27 <matty_dubs> Another where 'other' wins
19:49:29 <jcoufal> #endvote
19:49:30 <openstack> Voted on "How should we name all other nodes which are part of 'resource' rack providing 'resource' service (compute or storage)?" Results are
19:49:31 <openstack> Nodes (2): matty_dubs, lsmola_
19:49:32 <openstack> Other (5): julim, lblanchard, ifarkas, jistr, pblaho
19:49:34 <openstack> Resource_Nodes (2): marios, jtomasek
19:49:37 <jcoufal> #action revote Resource Nodes
19:49:38 <pblaho> is there anyone who will be making some kind of image - diagram - of all these racks/nodes?
19:49:46 <noslzzp> I did.
19:49:50 <jcoufal> last one is about images
19:49:57 <jcoufal> which we are going to provison on nodes
19:49:59 <matty_dubs> noslzzp: Can you re-send that to us?
19:50:06 <matty_dubs> #vote lolcats
19:50:06 <jcoufal> #startvote How should we name images which are going to be provisioned on nodes? Images, Overcloud_Images, Other
19:50:07 <openstack> Begin voting on: How should we name images which are going to be provisioned on nodes? Valid vote options are Images, Overcloud_Images, Other.
19:50:08 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
19:50:15 <julim> #vote Images
19:50:15 <lsmola_> #vote overcloud_images
19:50:16 <tzumainn> #vote images
19:50:16 <noslzzp> matty_dubs: sure..
19:50:25 <jcoufal> #vote images
19:50:26 <lblanchard> #vote images
19:50:30 <ifarkas> #vote Images
19:50:30 <matty_dubs> #vote images
19:50:33 <marios> #vote images
19:50:35 <pblaho> #vote images
19:50:36 <jtomasek> #vote images
19:50:38 <jistr> so are we talking api/code now?
19:50:39 <noslzzp> #vote images
19:50:40 <jistr> or docs?
19:50:43 <lsmola_> Ilike overcloud and undercloud
19:50:49 <jcoufal> any more?
19:50:53 <jistr> jcooley:
19:50:57 <jistr> jcoufal: me
19:51:02 <jistr> sorry for noise
19:51:05 <jcoufal> jistr: right
19:51:07 <jcoufal> :)
19:51:13 <jistr> can someone answer my question?
19:51:14 <jcoufal> jistr: both
19:51:19 <jomara> #vote images
19:51:20 <jistr> ok
19:51:25 <jistr> #vote overcloud_images
19:51:33 <jcoufal> api as well as ui as well as discussions
19:51:44 <jcoufal> #endvote
19:51:45 <openstack> Voted on "How should we name images which are going to be provisioned on nodes?" Results are
19:51:46 <openstack> Images (11): julim, ifarkas, pblaho, marios, jtomasek, lblanchard, tzumainn, noslzzp, matty_dubs, jomara, jcoufal
19:51:48 <openstack> Overcloud_Images (2): jistr, lsmola_
19:51:49 <matty_dubs> The more we vote, the more I think I want the flexibility for us to change all of these down the road
19:51:54 <jcoufal> ok this was voting
19:51:58 <jcoufal> pretty crazy experience :)
19:52:04 <matty_dubs> Since we are voting on terms without knowing too much about what we're doing
19:52:07 <matty_dubs> (at least I am)
19:52:08 <jcoufal> we have bunch of them to revote next week
19:52:12 <jcoufal> and I will call it last chance
19:52:15 <lsmola_> matty_dubs, +10
19:52:21 <jistr> matty_dubs: yeah, at least some of them are pretty foggy
19:52:23 <jcoufal> so feel free to update etherpad and think through them
19:52:25 <tzumainn> jcoufal, can I suggest that we try and do the following for next week - create an architecture document using these terms
19:52:29 <pblaho> matty_dubs: it will be on wiki, etherpad or somewhere... not in stone
19:52:30 <tzumainn> so that we can see how they fit
19:52:37 <tzumainn> and that might help people make up their minds?
19:52:44 <marios> jcoufal: good job mate
19:52:45 <jcoufal> tzumainn: if it helps, yes
19:52:52 <matty_dubs> Well can we keep the door open to individual revotes later down the road if we all come to hate some of these names?
19:52:55 <jcoufal> is there anybody who want to take care about arch doc?
19:52:59 <pblaho> jcoufal, tzumainn : it will help a lot
19:53:14 <matty_dubs> I'm happy to help.
19:53:14 <lblanchard> jcoufal: nice job running the votes! I agree we should have time to think through this more and revote on certain ones next week.
19:53:19 <tzumainn> matty_dubs, I think "down the road" is dangerous, because it means we're pushing off potential decisions for the future
19:53:36 <tzumainn> I'm happy to help as well, I just don't think I'm qualified to do it : )
19:53:39 <matty_dubs> tzumainn: I'm saying we should run with these names, but not consider them completely immutable
19:53:41 <noslzzp> draft diagrams sent..
19:53:45 <matty_dubs> noslzzp: Thanks!
19:53:49 <pblaho> noslzzp: cool
19:53:50 <jcoufal> #action create matty_dubs architecture doc using names and send it to the ML
19:53:56 <marios> tzumainn: matty_dubs: especialy the ones that impact the code... if we are having to rehaul names of stuff in the code, i'd rather now than later (well, actually i'd rather not at all..)
19:53:57 <jcoufal> #topic Open Discussion
19:54:01 <jistr> matty_dubs: i think so. It would be unpleasant after some GA release, but up to that point i hope we're quite free.
19:54:07 <jcoufal> last 5 minutes for any other business
19:54:33 <jistr> mexican wave! \o\ |o| /o/
19:54:34 <jcoufal> I would like to start etherpad with all possible states for racks/nodes
19:54:41 <matty_dubs> Yeah. I just want to make sure we don't say "Well we voted on them" and never allow us to change anything ever.
19:54:43 <marios> matty_dubs: feel free to ping me for that arch doc/diagram
19:54:57 <jcoufal> fairly soon, so we can discuss there all combinations
19:55:03 <matty_dubs> marios: Meaning ping you to ask questions, or ping you to get it?
19:55:11 * marios hides
19:55:14 <tzumainn> lol
19:55:17 * matty_dubs just dense
19:55:26 <jcoufal> #action jcoufal start etherpad wtih possible rack/node states
19:55:40 <marios> matty_dubs: :) either
19:55:49 <tzumainn> should we also put our tentative glossary on the wiki?  it's easier for people to read in a cleaned up form, I think
19:55:57 <matty_dubs> tzumainn++
19:56:14 <jcoufal> tzumainn: you wanna take stab on that?
19:56:15 * pblaho looks for "tantative" in dictionary
19:56:23 <noslzzp> thanks jcoufal..
19:56:30 <noslzzp> off to another meeting..
19:56:37 <marios> lets revote now
19:56:37 <tzumainn> jcoufal, sure!
19:56:41 <jcoufal> noslzzp: thanks have a great day
19:56:50 * noslzzp has left the room and you feel a great sense of loss..
19:56:53 <jtomasek> just info: mrunge is working on blueprint that should simplify creating plugins for horizon, I'll discuss this more with him tomorrow... https://blueprints.launchpad.net/horizon/+spec/plugin-architecture
19:56:58 <jcoufal> #action tzumainn create tentative glossary on wiki
19:57:10 <jtomasek> tuskar is a nice way to test it
19:57:19 <jcoufal> jtomasek: that's nice
19:57:38 <jcoufal> any other business?
19:57:41 <pblaho> jtomasek: wow... but I would suggest to complete tuskar-ui CI task....
19:58:11 <jcoufal> ok, thanks everybody for this meeting, it was very productive
19:58:15 <jcoufal> #endmeeting