19:04:52 <ShillaSaebi> #startmeeting UC
19:04:52 <openstack> Meeting started Mon Jan 18 19:04:52 2016 UTC and is due to finish in 60 minutes.  The chair is ShillaSaebi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:04:55 <openstack> The meeting name has been set to 'uc'
19:05:37 <ShillaSaebi> hi everyone
19:05:43 <ShillaSaebi> can we do a roll call?
19:05:57 <shamail> here.
19:06:03 <rolandchan> I'm here
19:06:04 <HeidiJoy> Heidi Joy Tretheway here from the foundation.
19:06:33 <ShillaSaebi> alright
19:06:59 <lsell> I'm here as well :)
19:07:06 <ShillaSaebi> Hello all
19:07:21 <ShillaSaebi> ok lets go ahead and get started
19:07:44 <ShillaSaebi> #topic UC meeting schedule
19:08:12 <ShillaSaebi> There is a proposal to switch to the UC meetings to biweekly (from monthly) & have alternating times with 1 being APAC friendly
19:08:39 <ShillaSaebi> A doodle was sent out for this but I am not sure if anything was finalized
19:08:49 <ShillaSaebi> rolandchan can you provide any updates on that?
19:09:16 <rolandchan> We had a clear leader on which time was acceptable. I think 1pm Wednesdays Australian time
19:09:35 <rolandchan> I can add that to the wiki pagea
19:09:49 <shamail> Thanks, I'll update the eavesdrop setting.
19:10:08 <ShillaSaebi> awesome that would be gerat
19:10:09 <rolandchan> And obviously I'm happy run that meeting as needed.
19:10:10 <shamail> I'll also update the link to past meetings since we use "UC" as meeting title.
19:10:10 <ShillaSaebi> great*
19:10:34 <rolandchan> I'll send an email to the list to confirm the time and schedule
19:11:08 <rolandchan> That's about it.
19:11:13 <ShillaSaebi> #action rolandchan to add 1pm Wed Australian time to wiki page for meetings
19:11:30 <ShillaSaebi> #action shamail to update link to past meetings
19:11:39 <ShillaSaebi> cool thanks
19:12:16 <ShillaSaebi> #topic Next steps for Survey analysis (cuts against NP score)
19:14:25 <ShillaSaebi> i dont have much information on this particular topic
19:14:48 <ShillaSaebi> can anyone fill in for this topic
19:15:56 <rolandchan> I found the results that were potentially significant interesting (the types of packages that were not perceived well)
19:16:26 <HeidiJoy> I worked with the data scientist to do additional analysis based on the committee's request last month. Provided content to the committee.
19:17:20 <rolandchan> I'm not sure we can dig into the next level of detail without causing some issues around confidentiality
19:19:26 <HeidiJoy> I think the main things we learned were (a) the v2 numbers were not originally analyzed in a consistent manner to the v3 numbers, so when we went back to apply consistent standards to both, the NPS variances were much smaller.
19:20:03 <HeidiJoy> (b) We found that when we applied various filters, there were not substantial variations in NPS, excepting the vendor note Roland mentioned.
19:21:27 <ShillaSaebi> ok
19:22:16 <ShillaSaebi> and we discussed a survey wg as well right?
19:23:07 <HeidiJoy> Yes, we hope to have a Survey WG to take some of the burden off the UC for things like comment analysis.
19:24:18 <ShillaSaebi> awesome
19:25:27 <ShillaSaebi> cool so do we need to assign any action items for getting the survey WG together?
19:25:34 <ShillaSaebi> how soon do we want to have this group formed?
19:26:11 <lsell> We would want to have this group formed mid-to-late February
19:26:20 <lsell> Because the majority of analysis will happen in March
19:26:44 <lsell> Perhaps we should throw it out on the mailing list again? We haven't gotten may people raise their hands to date :)
19:27:10 <rockyg> Definitely out to the ML again.
19:27:20 <ShillaSaebi> ok
19:27:52 <shamail> Is this group A) NDA only B) Non-vendor only C) Some other requirement for participation?
19:28:46 <ShillaSaebi> NDA should probably be required
19:28:53 <shamail> +1
19:29:05 <lsell> yes confidentiality agreement, but i don't think vendors excluded for this working group
19:29:18 <ShillaSaebi> yes i agree
19:29:25 <shamail> Thanks ShillaSaebi and lsell... I'll look out for info on the ML and volunteer at that time.
19:29:32 <ShillaSaebi> cool
19:29:46 <ShillaSaebi> so how large will the group be
19:29:48 <ShillaSaebi> does it matter
19:30:22 <ShillaSaebi> or volunteers who sign the NDA agreement will be part of the group?
19:31:45 <HeidiJoy> I think the group can be manageable at 6 or fewer.
19:32:00 <ShillaSaebi> ok so lets do a call for volunteers and start the process
19:32:06 <shamail> I was thinking 10 but 6 is good too..
19:32:06 <HeidiJoy> Thank you!
19:32:07 <ShillaSaebi> maybe add a sign up area on our wiki
19:32:20 <shamail> Small is good to start with... lots of fast iteration needed in the beginning
19:32:40 <ShillaSaebi> #action ShillaSaebi to send an email to the user ml to look for survey WG
19:32:40 <HeidiJoy> If we have more than 6 volunteers, I'd be happy to see that. The key is having people who follow through on their promises (e.g. to return comments in a timely manner)
19:33:00 <ShillaSaebi> agreed
19:33:03 <shamail> HeidiJoy: +1
19:33:22 <ShillaSaebi> alright awesome anything else on this topic?
19:33:25 <shamail> I'll look out for the wiki update and jump on the opportunity :-)
19:33:42 <ShillaSaebi> thanks shamail
19:34:21 <ShillaSaebi> alright moving on to the next topic
19:34:33 <ShillaSaebi> #topic review UC survey items for discussion
19:34:46 <HeidiJoy> I have 3 questions for the group:
19:34:49 <ShillaSaebi> HeidiJoy I will let you run with this topic
19:34:57 <ShillaSaebi> sure
19:35:10 <HeidiJoy> Thank you! First question, regarding the User Roles: Recommendation: What are the ways you work with OpenStack? Existing options: (57%) Cloud operator or sys-admin, (33%) OpenStack upstream developer, (32%) App developer-deployer, (21%) Other. Recommend adding categories: "Cloud architect," "Consultant/Training" and "Sales/Marketing" to better quantify the "other" responses. At a minimum, definitely add "cloud architect" a
19:36:47 <rolandchan> All three additional responses would probably get some activity
19:36:56 <shamail> agreed
19:37:08 <shamail> I like the proposal to add "Cloud Architect" and "Sales"... since it opens a new role for presenters/content to target.
19:37:09 <lsell> would we want sales/marketing to respond to the survey?
19:37:17 <rockyg> HeidiJoy, have you seen Pieter's personae?
19:37:24 <shamail> I think they probably already are but doing it as "other"
19:37:32 <ShillaSaebi> yeah probably
19:37:38 <shamail> having the category would let us get better insight as to their view
19:37:42 <ShillaSaebi> i'm not opposed to adding those categories
19:37:47 <ShillaSaebi> it's more targeted and that's good
19:38:13 <rockyg> ++
19:38:33 <shamail> Should app developer/deployer be one role?
19:38:36 <rockyg> you also might  consider "user" as an option.
19:38:40 <HeidiJoy> I chose the 3 additional based on the highest number of responses in the "other" open field.
19:39:02 <shamail> App developer and app deployer could be the same but can also be different people.
19:39:31 <shamail> Not sure though if breaking them out would provide additional insight or not...
19:40:25 <HeidiJoy> @Rockyg I'm open to using other categories, but my main driver is being able to quantify answers rather than wade through a pile of "other" responses..
19:41:10 <HeidiJoy> We had ~400 "app developer/deployer" responses to the last survey and I'd be generally opposed to breaking them out because it would break our survey logic that surfaces the app dev section of the survey.
19:41:31 <rockyg> So, with public clouds, and some other self-service clouds, there can be lots of people who think they are just users because they choose what the need from the catalog, and run with it.
19:42:10 <rockyg> Not a big area for OpenStack so far, but growing...
19:42:39 <shamail> Thanks for the response HeidiJoy
19:42:56 <HeidiJoy> Second question, regarding industry: last survey 64% of users reported being in the IT industry. HT Recommendation: create an additional defined-answer question set (multiple choice, with an "other" option) for their specific IT industry segment. The IT dropdown options could be some of the following: Web hosting/services, cloud hosting/support, public cloud, software vendor, data center/storage, professional services, tra
19:43:28 <HeidiJoy> system admin & integration, OpenStack distribution, networking equipment & software, mobile, IT services, infrastructure/ IaaS, security, data visualization/analytics. I would request one volunteer to nail down this list, then we'd email to the UC for approval by 1/20.
19:44:42 <rockyg> don't forget scientific!
19:46:32 <rolandchan> I can't hit that date unfortunately but otherwise would like to do that
19:46:37 <shamail> That's a good starting list... I can help with that HeidiJoy.
19:46:46 <shamail> Can you put it into an etherpad or email?
19:46:54 <HeidiJoy> Will do, and thank you!
19:46:56 <rockyg> ++
19:47:00 <shamail> Thanks
19:47:23 <HeidiJoy> OK, then, on to Q3: Recommend the committee review/revise the answer options for "Which new/emerging technologies are you interested in using or seeing interated with OpenStack?" Current answers are: Containers, NFV, PaaS, IoT. Suggested additional answer could include those on page 14 of the report, such as DBaaS, Bare metal, SDN, VPC
19:49:27 <rockyg> microservices...
19:49:49 <rolandchan> The list could get rather long :)
19:49:59 <rockyg> oh yeah ;)
19:50:16 <ShillaSaebi> HeidiJoy do we have "other" listed currently with a fill out field for additional info?
19:50:41 <HeidiJoy> Yes - that's where I got the suggestions for other items.
19:50:52 <ShillaSaebi> oh cool ok
19:51:09 <ShillaSaebi> the list could definitely get long
19:51:10 <HeidiJoy> Here are the items survey-takers proposed as "other": • ARM-based virtualization • Bare metal • CI systems • Cloud federation • DBaaS (Trove) • Desktop as a service • Integrated HA / improved VM migration • Real-time data processing & Apache Zeppelin • SDN (OpenDaylight) • Standard/proprietary APIs • VPC • Windows Nano-Server
19:51:59 <HeidiJoy> I'm hoping the UC can decide on (1) should we pull anything from our existing list? e.g. Are containers no longer emerging, but a mature technology?
19:52:08 <HeidiJoy> (2) Should we add anything to the list?
19:52:11 <shamail> I think this list should be reduced and other should be used to capture the bulk of the data.  I would suggest high-level trends such as NFV, PaaS, Container Orchestration, DC Resource Pooling, etc.
19:52:41 <shamail> The other technologies are generally enablers or part of a bigger solution related to the higher-level desired end-state
19:52:45 <rockyg> how about we add "Baby Birthing" and see if anyone selects it?
19:52:52 <rolandchan> I don't think there is anything on the list we would regard as not emerging.
19:52:58 <HeidiJoy> Agree, I am not recommending we would include all of the things on this list. I would hope the UC would direct me to add one or two things from that list to the existing question set.
19:52:59 <shamail> agreed rolandchan
19:53:16 <HeidiJoy> OK, thanks for answering Q1 Roland.
19:53:25 <shamail> I do think that some are identifying larger trends/direction while others would be used in multiple trends/directoins (as a part of the stack)
19:53:35 <rockyg> The improved "x" is probably not needed.  It should be covered in other parts.
19:54:00 <HeidiJoy> +1 ^
19:54:56 <shamail> PaaS, Cloud Federation, Microservice Architectures, NFV, and Specialized Computing would be my suggestions
19:55:18 <ShillaSaebi> that makes sense
19:55:37 <ShillaSaebi> im good with that. Do we want to run this by Jonathan and Subbu as well?
19:55:43 <shamail> Specialized computing is referring to GPU, NIBS, etc.
19:55:43 <rockyg> You could use things like SDN and others as examples under the bigger trends (SDN under NFV)
19:55:49 <shamail> NUMA sorry
19:56:50 <HeidiJoy> One last Q before time is up:    	  	31H2016 Timeline  21H2016 Survey Changes  42015 Deployment  		    Q4: We ask people to define what stage their deployment is in (production, QA/testing, POC). Additionally, we asked for a specific project, whether that was in use in production, testing, or merely "interested." Question to the UC: Should we discontinue the practice of defining a deployment stage on a per-project basis? I
19:57:18 <HeidiJoy> Sorry, my cut/paste malfunctioned...
19:57:28 <HeidiJoy> Q4: We ask people to define what stage their deployment is in (production, QA/testing, POC). Additionally, we asked for a specific project, whether that was in use in production, testing, or merely "interested." Question to the UC: Should we discontinue the practice of defining a deployment stage on a per-project basis? I
19:57:36 <HeidiJoy> If yes, the result would be that users are asked if they are "using" a project, but will not be asked to define whether that project is in full production or just in testing phase.
19:57:36 <rockyg> Interested might be better as Investigating
19:58:17 <shamail> I like the per-project phase, especially since it can help feed that data into the project navigator
19:58:25 <rockyg> ++
19:58:28 <shamail> I think people consideration adoption would be interested in that data.
19:58:29 <rolandchan> I think the per project status is interesting if its being used.
19:58:41 <shamail> considering*
19:58:43 <HeidiJoy> It caused us an alarming amount of headaches in data processing and survey logic, FWIW.
19:58:45 <shamail> I'm off my IRC game today.
19:58:59 <ShillaSaebi> just a quick time check - we have a minute
19:59:33 <shamail> Example: https://www.openstack.org/software/releases/liberty/components/cinder
19:59:44 <shamail> The "adoption" percentage only factors in production users
20:00:01 <shamail> Without the classification of production this might show a different result...
20:00:16 <shamail> Should we first see the impact of this change on the project navigator using a few sample projects before deciding?
20:00:27 <ShillaSaebi> we can do that
20:00:31 <ShillaSaebi> we are at time t
20:00:39 <HeidiJoy> Thanks all for your feedback!
20:00:42 <ShillaSaebi> anyway we can take this conversation to an email thread
20:00:46 <shamail> +1
20:00:49 <HeidiJoy> +1
20:01:10 <ShillaSaebi> alright lets move it to a thread and continue there
20:01:10 <rockyg> +1
20:01:15 <ShillaSaebi> thanks everyoen for joining!
20:01:23 <ShillaSaebi> #endmeeting