19:00:11 <jproulx> #startmeeting uc
19:00:12 <openstack> Meeting started Mon Mar 14 19:00:11 2016 UTC and is due to finish in 60 minutes. The chair is jproulx. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:16 <openstack> The meeting name has been set to 'uc'
19:00:23 <shamail> hi!
19:00:39 <jproulx> Oh someone's here :)
19:00:43 <pfreund> Hello :)
19:00:47 <shamail> Agenda (#link https://wiki.openstack.org/wiki/Governance/Foundation/UserCommittee)
19:01:02 <rlpple> Hello!
19:01:04 <shamail> Yep, wouldn’t miss it.
19:01:37 <jproulx> Shilla and Edgar are both traveling this week but we've got some interesting topics on the link shamail posted
19:02:03 <jproulx> #topic Next steps for Survey analysis
19:02:43 <jproulx> anyone have an update on current Survey status?
19:03:26 <shamail> I don’t… I was unable to participate in the analysis phase but will definitely join for the report review process.
19:03:31 <jproulx> I must confess I've not kept up as I should on this one.
19:04:00 <shamail> Should I see if Heidi Joy is available to join?
19:04:48 <shamail> I just asked if she can join
19:04:59 <shamail> She is coming on now
19:05:05 <shamail> she should be able to help us out with this topic
19:05:12 <jproulx> Thanks
19:05:39 <shamail> I think we got a better response rate this time but I am uncertain
19:07:01 <shamail> jproulx: do you want to change topics until she can joins us?
19:07:09 <shamail> Maybe we can come back to this one
19:07:17 <jproulx> OK
19:07:27 <jproulx> #topic Operators recognition next steps
19:08:03 <jproulx> this generated quite the mailing list thread.
19:08:05 <pfreund> I might be at the origin of the recent discussion :) one of the "multiple request"
19:08:54 <pfreund> I'm very interested in changing things
19:09:35 <shamail> If I recall properly, the three main topics that were heavily discussed were the name of the program, metrics used to identify eligibility, and passes?
19:09:42 <shamail> Is that right?
19:09:57 <jproulx> I think those are the high points
19:09:59 <maishsk> Good evening all
19:10:07 <shamail> Hi HeidiJoy and maishsk
19:10:27 <HeidiJoy> Hello!
19:10:52 <pfreund> I think passes are a consequence of the recognition, not the initial subject (in threads)
19:10:59 <jproulx> on the shor term side eligibility and badge recognision
19:11:14 <shamail> good point pfallenop
19:11:21 <shamail> pfreund*
19:11:22 <maishsk> pfreund: I agree
19:12:01 <maishsk> I think it is time that Operators are recognised as equal contributors to OpenStack
19:12:03 <pfreund> When I wrote the mail about passes I was buying them, that's why I wrote the initial mail, but the problem is deeper
19:12:32 <maishsk> the same as anyone else submitting patches
19:12:32 <pfreund> And there was two types of recognition, ops AND community helpers
19:12:59 <shamail> yes, ops + working groups + user group leaders
19:13:03 <maishsk> The problems is the current governance does not allow for that
19:13:28 <maishsk> I was thinking of proposing a patch to governance to change that
19:13:41 <shamail> How does governance not allow for that currently?
19:14:03 <shamail> It’s not explicit but is there a barrier to recognizing these contributions in the governance today?
19:14:13 <maishsk> Very much so
19:14:49 <maishsk> the only to get acknowledged as a ‘contributor’ to OpenStack is to submit a patch - for one of the official OpenStack projects
19:15:00 <maishsk> that gives you ATC for a period of 365 days
19:15:13 <maishsk> only an ATC is eligible for a summit pass
19:15:24 <maishsk> (which in my opinion is the less important part)
19:15:29 <shamail> Agreed, but I think this is partially the fact that governance only recognizes TC based projects today
19:15:36 <pfreund> vote is also important
19:15:38 <jproulx> Passes aren't actually in governance only ATC (AFAIK)
19:15:49 <maishsk> But the real problem is that only ATC can vote for the TC
19:15:49 <shamail> UC governed projects currently do not have anything in their charter equivilant to ATC
19:16:12 <jproulx> I think that's what needs to be changed
19:16:26 <jproulx> defining the constituancy of the UC
19:16:29 <shamail> ATC is a participant in a TC governed project, we need the equivilent for UC governed projects and we should be able to address these items in that charter
19:16:36 <shamail> agreed jproulx
19:16:50 <pfreund> +1
19:17:18 <maishsk> shamail: and allow the equivalent the same voting rights for the TC as well
19:17:24 <maishsk> http://lists.openstack.org/pipermail/openstack-operators/2016-March/009796.html
19:17:27 <jproulx> once we have a defined constiuency we can have proper voting and recognition
19:17:28 <maishsk> That was my proposal
19:17:52 <shamail> So is a good next step for someone from UC to define the charter/constituancy in the official governance repo and submit the review to UC/ops ML?
19:18:37 <maishsk> So what is that constituancy?
19:18:57 <maishsk> And how is that measured?
19:19:04 <shamail> maishsk: I agree with the concept but i’ll play devils advocate for a second… The results of those votes directly impact the ATC/TC governed projects… We don’t necessarily work on the core development teams so could our votes potentially alter results that the teams working on the projects would’ve wanted?
19:19:25 <maishsk> And why is that a bad thing?
19:19:33 <shamail> e.g. What is the implications of non-project contributors selecting a PTL
19:19:42 <maishsk> PTL - stays PTL
19:19:51 <shamail> It’s not a bad thing but do we have enough visibility to vote accurately?
19:20:04 <maishsk> that I completely agree - if you contribute code to a project then you should choose the PTL
19:20:10 <shamail> got it
19:20:11 <maishsk> I am talking about the TC elections
19:20:15 <shamail> which votes were you thinking about?
19:20:19 <maishsk> and only TC elections
19:20:22 <shamail> Ah, yes! I totally agree with that
19:20:34 <shamail> TC elections have broader implications and impact outside of projects
19:20:43 <maishsk> shamail: +1000
19:21:23 <maishsk> Going back to constituancy - and how that is measured…
19:21:36 <shamail> The current criteria is that only ATCs can vote… so we would need a multi-step solution… 1) define our equivilent designation 2) update TC election criteria to include this new designation
19:22:07 <rlpple> Question
19:22:14 <maishsk> For code contributions to OPs projects - the same as an ATC - you receive recognition for 365 days
19:23:00 <rlpple> not "only ATC's can vote" but Code contributors to the OP's projects that are ATC
19:23:08 <rlpple> correct?
19:23:47 <maishsk> The problem is those who are not contributing code (Working groups, Meetups etc. basically everything that was mentioned in the thread ) http://lists.openstack.org/pipermail/openstack-operators/2016-March/009735.html
19:24:15 <pfreund> I think we should think about how we can contribute without submitting code. If I give an important feedback about a bug, trying hard to reproduce it, and give important logs to a developper, I don't actually submit code.
19:24:29 <pfreund> maishsk: indeed
19:24:31 <maishsk> rlpple: I dont understand the question
19:24:38 <rlpple> Check out how the Security Team does it
19:25:03 <shamail> Security is ATC eligible
19:25:04 <rlpple> they use attendance of tmeetings or contributation or comments
19:25:13 <shamail> anything in projects.yaml can obtain ATC
19:25:15 <shamail> #link https://github.com/openstack/governance/blob/master/reference/projects.yaml
19:25:15 <rlpple> for their elections
19:25:48 <rlpple> ignore my question you answered
19:26:04 <shamail> Thanks rlpple, glad I could help.
19:26:13 <maishsk> they are an official Openstack Project - therefore contributions are considered ATC
19:26:22 <maishsk> @rlpple
19:26:50 <shamail> maishsk: I agree… the second group is harding to define criteria for
19:27:11 <shamail> harder*
19:27:32 <rlpple> Rolls are kept
19:27:33 <shamail> When we say “meetups” are we referring to leads or anyone who presents?
19:27:34 <rlpple> right
19:27:38 <shamail> they are
19:27:46 <rlpple> set a critera of X over period of time
19:27:50 <maishsk> So lets take the things peice by peice
19:27:53 <shamail> The best way to handle this would be with a mechanism similar to extra-ATC
19:28:17 <shamail> give working group leads and opensatck ambassadors the ability to add extra-<whatever we name our designation)
19:28:24 <shamail> OpenStack*
19:28:26 <pfreund> For meetups, and more generally Community helpers, I don't understand why we don't use ambassadors.
19:28:42 <pfreund> they should no every user group in their zone
19:28:48 <shamail> Yep
19:28:54 <pfreund> sorry they should "know"
19:29:37 <pfreund> I think it would be easy to detect fake user groups, It will not happen
19:29:43 <shamail> Make all repos under https://github.com/openstack/governance/blob/master/reference/user-committee-repos.yaml elgible for designation and give working group leads/ambassadors the ability to add the “extra-ATC” equivilent for UC
19:29:59 <shamail> jproulx: any thoughts on next steps?
19:30:08 <maishsk> Working groups - people participate in meetings - there is a roll call - define a minimum quota of participation - and those receive recognition
19:30:29 <rlpple> +1
19:30:30 <jproulx> As much as I think we already have too many working groups, I'm going to suggest we spawn another do try and define what we think this set of criteria (beyond git) should be and how we can automate collecting it....
19:30:35 <maishsk> That should be a no-brainer - just define a threshold
19:30:38 <shamail> maishsk: Wouldn’t it be easier to just let working group leads name who is eligible from their team?
19:30:49 <rlpple> no
19:31:09 <rlpple> Setting a criteria avoids the possiblilyt of missing someone
19:31:12 <shamail> why not? I help lead a working group and could probably name of the top off my head who has been active
19:31:20 <rlpple> or including only your friends
19:31:32 <shamail> That’s not any different from extra-ATC today
19:31:36 <maishsk> rlpple: I agree - it is all about transparency
19:31:44 <rlpple> that is the word
19:31:56 <shamail> It would be transparent since it would be logged (who got recognition)
19:32:07 <shamail> we could include a “reason” field too
19:32:10 <shamail> if that helps
19:32:15 <pfreund> Maybe amabassadors should be able to give any number of recognition, but it should be public.
19:32:28 <shamail> In my working group, for example, I know that there are people who contirbute but don’t review our repo
19:32:42 <rlpple> Also by setting criteria is makes the decison making process simplere for the leads
19:32:44 <shamail> jproulx: +1, this topic is deep enough to warrant one
19:32:46 <jproulx> I prefer methods where human intervention is the exception rateh than the rule
19:32:54 <maishsk> Ambassadors - was a one time thing - was it not - nothing has been done since the first designates
19:33:11 <shamail> jproulx: +1, this would be after we exhaust quantative criteria
19:33:13 <pfreund> We should trust our ambassadors. If not, there is a problem.
19:33:28 <jproulx> if humans are fiilling in asmall numbe rof gaps the automation can catch it's much better than trying to manually list everyown
19:33:29 <shamail> maishsk: it was a one time thing but they have been active
19:33:42 <shamail> maishsk: the only thing that hasn’t happened again is inducting new ambassadors
19:34:20 <jproulx> so we're more than 50% through
19:34:29 <shamail> jproulx: Maybe we should ask working groups to use IRC (even if it is just for roll-calls) to have a centralized attendance system
19:34:43 <jproulx> who wants to take point on a working group to hash out a cohesive proposal
19:34:44 <shamail> anyways, +1 to wokring team to explore this stuff further
19:34:57 <shamail> I’ll participate…
19:35:00 <jproulx> shamail: +1 for irc rollcall
19:35:26 <maishsk> I would be happy to jump in
19:35:26 <pfreund> I don't understand, for meetup groups ? Use IRC ?
19:35:32 <shamail> No, working groups
19:35:40 <pfreund> ok
19:35:42 <shamail> this doesn’t solve for user groups… that would still need to be discussed
19:36:00 <pfreund> I'm in
19:36:03 <shamail> Anyone willing to take point on the WG?
19:36:20 <jproulx> link https://wiki.openstack.org/wiki/Procedure_for_Creating_a_New_Working_Group
19:36:24 <shamail> If not, I can kick start it
19:36:31 <shamail> and then we can transition as needed
19:36:43 * maishsk reads the link quickly…
19:37:08 <jproulx> mostly what it needs is a wiki presence so people can see it and irc meeting scheduling
19:37:11 <shamail> jproulx: Please assign me the action
19:37:15 <shamail> i’ll start it up
19:37:28 <pfreund> I'll be part of the discussions
19:37:50 <jproulx> #action shamail to setup basic structure for Ops Recognition Workingroup (or similar name?)
19:37:57 <maishsk> shamail: I will be happy to support - and if need be you can transition it over to me
19:38:10 <shamail> That’ll be great maishsk, I’m used to the process of WG creation
19:38:11 <maishsk> I just have to get up to speed with the technicalities
19:38:14 <shamail> but would be glad to transition it
19:38:31 <shamail> Sounds like we got a plan here
19:38:47 <pfreund> Ops and Community are two separated subjects
19:38:59 <shamail> pfreund: +1
19:39:00 <pfreund> with two different solutions
19:39:13 <maishsk> Where do the working groups fall under - Ops / Community ?
19:39:18 <shamail> We’ll just call it something like “non-ATC Recognition” for now
19:39:24 <jproulx> +1
19:39:25 <pfreund> +1
19:39:32 <rlpple> +1
19:40:00 <shamail> ping HeidiJoy
19:40:04 <jproulx> ready for next topic?
19:40:07 <shamail> Should we try to revisit the survey if she is here?
19:40:13 <maishsk> I was toying with calling us OOPs (Openstack OPs)
19:40:15 <maishsk> :)
19:40:20 <shamail> lol
19:40:27 <jproulx> #topic Next steps for Survey analysis
19:41:12 <shamail> Hi HeidiJoy!
19:41:20 <HeidiJoy> We've wrapped survey analysis from the team and the next step will be writing/reviewing the report.
19:41:57 <jproulx> HeidiJoy anything you need now or is next step report review after there's something to review?
19:42:00 <shamail> Do we need more volunteers for that phase and when do we foresee starting it?
19:42:00 <HeidiJoy> The two things to expect coming soon are the data output from the data scientist (next couple of days) and the first draft of the report (end of the week)
19:42:31 <HeidiJoy> I don't think we need more volunteers. We have a nice contributing group at this point.
19:42:44 <shamail> awesome
19:42:54 <HeidiJoy> Also, we've got the data much more dialed in this round than last time. Far fewer rounds of revisions, thankfully.
19:42:55 <jproulx> that is good to hear!
19:43:22 <shamail> What ever happened with the NPS discussion?
19:43:37 <shamail> Did we do anything different this time around?
19:43:53 <jproulx> #info coming soon are the data output from the data scientist (next couple of days) and the first draft of the report (end of the week), don't think we need more volunteers. We have a nice contributing group at this point. (HeidiJoy)
19:43:55 <HeidiJoy> ^^We learned that the NPS for 2015-01 was calculated wrong and as a result it looked like the score went down substantially.
19:44:11 <shamail> Doh.
19:44:42 <maishsk> +1 Doh
19:44:50 <HeidiJoy> I've had the data scientist recalculate every answer set (she didn't do 2015-01 initially, it was another firm), and we're looking at NPS in several ways, including by individual, by company, and by deployments only.
19:45:07 <jproulx> did 2015-01 get recalculated correcty or are we just looking forward?
19:45:21 <jproulx> oh what you jus tsaid...
19:45:44 <HeidiJoy> The result is we'll be able to report clear apples-to-apples (yes, jproulx, we're recalculating from the raw data) and my first look at this suggests a nice positive trend.
19:45:59 <maishsk> That is really good to hear!
19:46:17 <shamail> maishsk: +1
19:46:34 <HeidiJoy> I think we'll still see a small spike in the 2015-01 data because it was such a small sample size relative to the others.
19:46:42 <jproulx> So sounds like we're on solid footing and happily moving forward survey wise, many thanks!
19:46:51 <HeidiJoy> (Meaning, the 2015-01 NPS will be slightly higher)
19:47:16 <HeidiJoy> Yes, we're on schedule! And I'm quite happy to see the results... one thing I want to point out that's subtle but VERY cool...
19:48:36 <HeidiJoy> Only 36% of the people who answered 2016-01 also answered 2015-02. That means we are looking at a substantially different survey response population. And yet, the answers don't change much from survey to survey. Same use of projects, tools, etc. That suggests that we've gotten a sufficient cross-section of the OpenStack community that we can legitimately extrapolate from the data.
19:49:07 <HeidiJoy> Also, 1,111 different organizations participated in this 2016-01 survey. A wonderful turnout.
19:49:16 <shamail> That is interesting and exciting.
19:49:20 <rlpple> +1
19:49:22 <jproulx> that is very cool (both points)
19:49:44 <HeidiJoy> I'm always happy to answer your questions, but that's all from me for now. :-)
19:50:03 <jproulx> Thanks Heidijoy
19:50:22 <shamail> Thanks
19:50:25 <jproulx> we have 10min to go and one huge topic
19:50:37 <jproulx> #topic where we want to take the UC and what we can change
19:50:49 <jproulx> This is the ever present question
19:50:53 <shamail> agreed
19:51:06 <jproulx> my 10sec answer is I'd like to se our constituency defined
19:51:07 <shamail> So one thing I’d like to bring up is something that was discussed almost a year ago..
19:51:29 <jproulx> & have that constituency start votring for a larger memmbership
19:51:41 <shamail> Originally, the UC was 3 members (from non-vendor companies) to keep it neutral and, more importantly, keep the survey data confidential
19:52:19 <shamail> It was discussed that if the survey WG could be created (with NDAs) that the UC itself could then open up to additional members and wouldn’t necessarily need the non-vendor requirement
19:52:30 <shamail> that was the portion that was most essential to protect
19:52:46 <shamail> jproulx: +1, that is definitely a big need going forward
19:52:48 <maishsk> I appoligise but I have to drop
19:52:57 <shamail> See you maishsk
19:53:08 <jproulx> thanks maishsk.
19:53:13 <shamail> My question is whether the UC would be open to expanding (outside of survey activities) to share workload?
19:53:35 <HeidiJoy> From a User Survey perspective, I'd like to see a few more UC members, noting that they have a critical role to play in providing feedback at key benchmarks in the process. Either way (whether a UC member or a member of the comment analysis team), we require a confidentiality agreement and no one gets access to user names/emails in conjunction with their comments/deployments. The two are always separated.
19:53:59 <shamail> +1
19:54:41 <jproulx> For my part sounds like the current reviewer process for the Survey is in good shape and can take non-UC reviewers under same NDA?
19:54:50 <shamail> I am interested in staffing up activities like working group governance and other community topics (e.g. the non-ATC stuff we just discussed) etc
19:54:52 <HeidiJoy> Correct.
19:54:59 <shamail> It can, and there are non-UC reviwers
19:55:12 <jproulx> If that's the case the only impediment I see to expanding the UC is the issue of constiruency and voting for new members
19:55:31 <shamail> jproulx: +1
19:55:43 <jproulx> as currently written if we expand the UC voting is open to all foundation members
19:55:50 <shamail> That would be outside of the non-ATC recoginition WG and something the UC itself would need to work on
19:56:30 <shamail> At one point, the idea of having 12-13 UC members (similar to TC) was floated
19:56:56 <jproulx> It's beyond the scope of non-ATC recoginition but I think that could eb an important foundation to work from
19:56:57 <pfreund> How many people are actively working in UC ?
19:57:05 <shamail> but the voting process (and eligibility) would need to be defined
19:58:07 <pfreund> I mean, like you all right now ?
19:58:17 <jproulx> I think the important question to consider is "should we expand the UC soon (with full foundation membership voting) or later with a more defined 'atc-like' constituency?"
19:58:30 <shamail> ohhh, chicken and egg. :P
19:58:55 <shamail> JK, I think defining ATC-like constittuency is the next step
19:58:59 <shamail> pfreund: officially, the UC consists of 3 members… but a lot more people are involved in the activities
19:59:17 <jproulx> shamail types much faster than I do...
19:59:27 <shamail> sorry :\
19:59:36 <jproulx> not please type away :)
19:59:51 <jproulx> OK 30sec any burning needs ?
20:00:01 <pfreund> ATC-like constittuency +1
20:00:02 <shamail> I think they can be worked on in parallel… the UC can discuss how the new structure would look and put a placeholder on the consituency being the voters
20:00:18 <shamail> the other team can define the ATC-like designation and it will plug in once its ready
20:00:29 <shamail> the elections cant happen until both, but both can be worked on in paralle
20:00:54 <jproulx> Other than constituency I think the only question is a number isn't it?
20:00:55 <pfreund> What is the next step for ATC-like WG ?
20:01:08 <shamail> number and charter (would does UC utlimately govern)
20:01:20 <jproulx> charter...yes
20:01:21 <shamail> I will be creating the WG pfreund and sending out emails on the ML
20:01:27 <pfreund> ok
20:01:30 <shamail> I’m just kicking it off
20:01:49 <shamail> We are over time
20:02:01 <jproulx> OK I'm going to call it
20:02:06 <jproulx> Thanks all.
20:02:09 <shamail> sounds good. great meeting!
20:02:10 <rlpple> l8r
20:02:11 <pfreund> thanks
20:02:15 <jproulx> #endmeeting