19:02:15 <emagana> #startmeeting UC
19:02:16 <openstack> Meeting started Mon Dec  5 19:02:15 2016 UTC and is due to finish in 60 minutes.  The chair is emagana. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:19 <openstack> The meeting name has been set to 'uc'
19:02:43 <emagana> We have a good agenda and tomorrow is an important day for this community
19:02:49 <docaedo> o/
19:03:04 <emagana> Agenda: #link https://wiki.openstack.org/wiki/Governance/Foundation/UserCommittee
19:03:17 <emagana> #topic Review proposed bylaws changes
19:03:29 <Rockyg> o/
19:03:31 <emagana> #link https://docs.google.com/document/d/1QmLOeseAkjBWM_TXsUeKBErNaSHnuZp81II0T71ARfo/edit?usp=sharing
19:03:50 <emagana> Hello docaedo mrhillsman CarolBarrett jproulx Rockyg
19:04:25 <emagana> So, we have been working with this document for many many weeks, the question is. Are we good with it? Does it reflect what we want?
19:05:11 <docaedo> It's been looking good to me - I saw one little bit of feedback come in this morning and it seems good - but can't imagine there's much of anything left to tweak at this point
19:06:02 <maishsk> good evening
19:06:18 <emagana> the only last minute feedback I have received was from Tim Bell on the elections period but I was a misunderstanding and it's has been cleared off.
19:06:22 <emagana> Hi maishsk
19:06:29 <mrhillsman> great
19:06:39 <emagana> I have not received anything else.
19:06:46 <jproulx> I think it's in a good place.
19:07:19 <emagana> I am really hoping this can be approved and finally we can move to the election process and the new UC members will start forming the agenda.
19:07:21 <maishsk> jproulx: +1
19:07:58 <emagana> BTW. The expected election in Feb time frame will be for only 2 seats in the UC (at least any of the current members wants to step down)
19:08:52 <CarolBarrett> emangana: From reading the doc, it looks like there will only be WGs within the UC and not Teams too. Right?
19:08:52 <emagana> During August/Sep we will have another election for the 3 seats that are allocated now (Shilla, jproulx and emagana)
19:09:42 <emagana> CarolBarrett: In the bylaws we will leave it open to the UC to decide and that can be change in the Charter
19:09:43 <maishsk> So are we now moving the work into the review for submission?
19:10:03 <emagana> Right now in the UC Charter we have both, WG and Teams.
19:10:22 <emagana> maishsk: Yes. Well, I want that at least somebody has an objection.
19:10:27 <mrhillsman> we are only focusing on the bylaws right now right?
19:10:47 <emagana> BTW. Thank you so much for your help on the UC Charter maishsk I added most of your suggestions and it looks way better
19:10:50 <CarolBarrett> emagana: Then I think you should update 4.14 (c) to include Teams and define the difference
19:11:33 <emagana> If we do that CarolBarrett. We will need to have a very clear definition of WG vs Teams
19:11:39 <maishsk> I had a about https://review.openstack.org/#/c/404318/5/reference/charter.rst@25
19:11:47 <emagana> Think about WG as a generic name for people to work together.
19:11:56 <emagana> We can internally name them whatever we want
19:12:06 <maishsk> Do we really need to mention termination - specifically?
19:12:22 <emagana> Does that make sense CarolBarrett?
19:12:30 <emagana> Let me check your suggestion maishsk
19:12:31 <CarolBarrett> Personally, I don't see why we need 2 different types of groups - but it seems in the other UC discussions that other people do and there is a desire to have both.
19:12:46 <CarolBarrett> If that's going to be the direction, then I think clear definitions of them are good.
19:13:34 <emagana> I understand but we can have that definition in the charter instead of in the bylaws. The suggestion from the BoD and the Layer is that we should be more generic in the bylaws instead of very specific.
19:13:44 <emagana> in the charter we can be more specific
19:13:50 <mrhillsman> +1
19:13:51 <emagana> because changing charter is up to UC
19:14:04 <emagana> and changing bylaws, well you can see how painful it is
19:14:06 <maishsk> Also I made some other suggestions regarding the stating explicity that only two members will be elected this cycle (for 1 year) with the 3 current members continuing for another 6 months - and the cycle would continue.
19:14:38 <emagana> maishsk: It was recommended to define how a UC member will terminate its relation or position.
19:14:43 <CarolBarrett> emagana: yes, changing bylaws is painful.
19:14:51 <docaedo> I also agree, distinction and definition of WG vs. Team would be best in charter, where it's easier to adjust
19:15:11 <docaedo> also doesn't seem like it would have a tremendous impact on the work - more like window dressing
19:15:25 <emagana> maishsk: What was exactly your suggestion maishsk for the election cycles?
19:15:26 <CarolBarrett> In the election section, I see where it talks about elections every 6 months, after the initial election, but not that only half of the UC is elected in each 6 month election. Is that still the plan?
19:15:42 <emagana> I do agree docaedo
19:15:52 <CarolBarrett> maishsk: +1
19:15:57 <maishsk> Initial committee
19:15:58 <maishsk> ============
19:15:59 <maishsk> The current UC will serve as UC until the elections in Spring 2017. At that point, the current three UC members who still had 6 months to serve get a 6-month seat, and an election is run to determine the other two members. Candidates ranking 1st and 2nd would get one-year seats. Fall 2017 elections should see the normal renewal of 3 seats.
19:16:00 <emagana> CarolBarrett: Yes, that is the plan
19:16:01 <jproulx> CarolBarrett: that is the plan
19:16:02 <Rockyg> well, if we want to describe them in charter, should we use a more generic, inclusive term for the groups/teams in the byloaws?
19:16:36 <mrhillsman> +1 Rockyg
19:17:27 <CarolBarrett> emagana, jproulx: Is that called out in the election section?
19:17:36 <emagana> Rockyg: We received feedback from the BoD that Working Groups are generic enough without making them exclusive to UC, we have WG that do not belong to UC
19:17:56 <emagana> CarolBarrett and maishsk: I am getting a bit lost here.
19:18:30 <Rockyg> emagana, I was thinking more along the lines of teams vs working groups, but if wgs include teams, then ok
19:18:38 <emagana> Rockyg: Yes!
19:18:56 <maishsk> emagana: there are number of suggestions that I dont think made it into the review
19:19:33 <emagana> maishsk: Correct, I made a call on what could be added and what could not but I am not perfect, this is why we are here.
19:19:43 <emagana> Anyway, it seems that we are talking about charter.
19:19:45 <jproulx> CarolBarrett:  maybe we could be more explicit but a term of 1yr with elections every 6month results in the partial reelection cycle we want
19:19:55 <emagana> Let's move the topic to UC charter then, ok?
19:19:56 <maishsk> ;)
19:20:02 <maishsk> works for me
19:20:19 <emagana> #topic Proposed charter changes (to match proposed bylaws)
19:20:25 <emagana> #link https://review.openstack.org/#/c/404318/
19:20:37 <CarolBarrett> emagana, jproulx: The TC charter says: The TC is composed of 13 directly-elected members. It is partially renewed using elections every 6 months.
19:20:40 <emagana> Before we discuss about it.
19:21:39 <emagana> The idea behind this patch is to provide support to the by-law changes and we can modify it whenever we feel that we need it. Obviously, the less we touch it the better
19:21:47 <emagana> OK, now let's get into the feedback.
19:22:20 <emagana> Basically, it seems that you want to add a section about the initial committee, correct?
19:22:46 <maishsk> emagana: correct
19:23:03 <emagana> and you are proposing:
19:23:04 <emagana> The current UC will serve as UC until the elections in Spring 2017. At that point, the current three UC members who still had 6 months to serve get a 6-month seat, and an election is run to determine the other two members. Candidates ranking 1st and 2nd would get one-year seats. Fall 2017 elections should see the normal renewal of 3 seats.
19:23:18 <shamail> o/
19:23:25 <emagana> hi shamail
19:23:42 <shamail> hi emagana, sorry for being late.
19:23:47 <CarolBarrett> emagana: +1
19:23:52 <maishsk> I think that filling vacated seats - should also be mentioned
19:24:02 <jproulx> CarolBarrett would you like to add that phrasing from TC charter in that paragraph as well?
19:24:38 <emagana> who is in favor of adding the Initial committee section?
19:24:47 <jproulx> +1
19:24:50 <emagana> I am actually!
19:24:52 <maishsk> So the question is - if by stating specifically 5 members - is that limiting the charter in the future?
19:24:53 <emagana> +1
19:24:53 <shamail> +1
19:24:55 <maishsk> +!
19:24:57 <maishsk> +1
19:25:05 <emagana> maishsk: Yes and No.
19:25:32 <emagana> The idea is that UC by feedback of the community will decide when extend the number of seat from 5 to something else
19:25:43 <emagana> is totally under the power of the UC
19:25:47 <jproulx> So in the charter I think we do say howmany specificly, then teh UC can ammend the chardter  later so long as it doesn't conflict with the 5 minimum specification in the by-laws
19:25:49 <emagana> No BoD needed for that
19:25:56 <Rockyg> +1
19:26:05 <emagana> jproulx: yes!
19:26:18 <shamail> The charter is a UC governed document right?  We are hoping to change by-laws only once and then change count (if needed) at the UC’s discretion to make changes to charter
19:26:20 <jproulx> yeah what emagana said
19:26:31 <emagana> Ok. Good number of people wants the Inital Committee section, I will add it to the commit today.
19:26:47 <maishsk> so then +1 on CarolBarrett ’s addition
19:26:49 <emagana> #action emagana add the "initial committee" section in the gerrit review
19:27:06 <emagana> You are so quick for me..
19:27:13 <emagana> OK, CarolBarrett addition was?
19:27:21 <CarolBarrett> jproulx: I think the way emagana wrote it would be fine
19:27:37 <shamail> emagana: On line 19, do we want to state any sort of timeframe for the first election?  It doesn’t have to be a date but maybe a deadline?
19:28:01 <maishsk> “The TC charter says: The TC is composed of 13 directly-elected members. It is partially renewed using elections every 6 months.”
19:28:04 <shamail> or change it from “first election” to just “UC elections"
19:28:31 <maishsk> Are we missing a section about elections?
19:28:44 <shamail> whoa.
19:28:48 <emagana> I see your point shamail
19:29:06 <emagana> I will fix that inital election, I think we should be more generic.
19:29:19 <maishsk> I took this from the TC charter
19:29:24 <Rockyg> shamail, yeah, nasty split
19:29:36 <emagana> LOL
19:29:43 <maishsk> Election for UC seats
19:29:44 <maishsk> ===============
19:29:45 <maishsk> The allotted number of UC seats are partially renewed every 6 months using staggered elections: the minority number of seats are renewed every (Northern hemisphere) Spring, and the majority number of seats are renewed every Fall. Seats are valid for one-year terms. For this election we’ll use a single-winner election system. The election is held no later than 3 weeks prior to each OpenStack Summit, with elections held open for no less than four
19:29:45 <maishsk> business days.
19:29:48 <shamail> sounds good… +1 this document should not have any time-bound items since its a charter/living document… we should refer to everything as if it was established
19:30:08 <CarolBarrett> +2
19:31:01 <Rockyg> And relative for time so that a date slip can be handled as an exception rather than a charter change
19:31:49 <emagana> Who is in favor of adding the "Election for UC seats" section as described by maishsk
19:32:04 * maishsk will be back in 2 minutes
19:32:05 <emagana> BTW. I would like to rename it to "UC Election"
19:32:05 <maishsk> +1
19:32:13 <Rockyg> +1
19:32:31 <shamail> emagana: +1 to maishsk’s description
19:32:40 <jproulx> +1
19:32:43 <shamail> and to the title chhange you suggested
19:32:50 <jproulx> +1
19:32:57 <emagana> Yes, I will also +1 that addition!
19:33:04 <emagana> any -1 or -2?
19:33:12 <emagana> speak now or.. you know the rest
19:33:35 <shamail> I have a small nit on line 41, that one should have the automated script and also state “<currently manually calculated for non-IRC WGs>"
19:33:45 <maishsk> The titles are not etched in stone - so feel free to rename - I think the content is what counts
19:33:48 <emagana> could you add that directly in gerrit shamail
19:33:50 <emagana> ?
19:33:51 <shamail> sure
19:34:08 <emagana> ok.. let's go for it.
19:34:21 <emagana> #action shamail to add suggestion in gerrit
19:34:38 <docaedo> (late, but +1 for "UC Election" section)
19:34:41 <emagana> #action emagana to include "UC Election" in gerrit review for Uc charter
19:34:56 <emagana> awesome feedback folks!
19:35:13 <emagana> What else in the UC Charter?
19:35:34 <emagana> BTW. Anything minor or simple, just go directly and add your review in gerrit.
19:35:57 <maishsk> The last one was
19:36:02 <emagana> #action All should provide your +1 to the charter, that will help for tomorrow's decision on the bylaws
19:36:21 <maishsk> Filling Vacated UC Seats
19:36:44 <maishsk> Again taken from the TC charter.
19:36:59 <maishsk> If a seat on the UC is vacated before the end of the term for which the member was elected, the UC will select a replacement to serve out the remainder of the term. The mechanism for selecting the replacement depends on when the seat is vacated relative to the beginning of the candidacy period for the next scheduled UC election. Selected candidates must meet all other constraints for membership in the UC.
19:37:00 <maishsk> If the vacancy opens less than four weeks before the candidacy period for the next scheduled UC election begins, and the seat vacated would have been contested in the upcoming election anyway, then the seat will remain open until the election and filled by the normal election process.
19:37:01 <maishsk> If the vacancy opens less than four weeks before the candidacy period for the next scheduled UC election begins and the seat would not have been contested in the upcoming election, the candidates who do not win seats in the election will be consulted in the order they appear in the results until a candidate who is capable of serving agrees to serve out the partial term.
19:37:02 <maishsk> If the vacancy opens with more than four weeks until the candidacy period for the next scheduled UC election begins, regardless of whether the vacated seat would have been contested in the next election, the candidates who did not win seats in the most recent previous UC election will be consulted in the order they appear in the results until a candidate who is capable of serving agrees to serve out the partial term.
19:37:21 <shamail> emagana: When will you be able to incorporate these new changes/suggestions?  I will go ahead and check the status tonight and +1
19:37:35 <emagana> shamail: I will work on them right after this meeting.
19:37:45 <shamail> awesome
19:38:05 <jproulx> maishsk: +1 for copy paste of TC stuff as written
19:38:22 <shamail> maishsk: +1
19:38:26 <emagana> maishsk: That part was intentionally left out. Let me give you my reasons. It just a bit complicated to do replacements
19:38:30 <Rockyg> +1
19:38:34 <mrhillsman> bah, lost all my interwebs :(
19:38:41 <shamail> welcome back mrhillsman
19:38:49 <emagana> I rather wait for the next election (no more that 6 months)
19:39:08 <emagana> that making an internal process to select somebody!
19:39:40 <emagana> As UC Team we will learn from our internal process and adjust as needed.
19:40:08 <maishsk> The only problem with that - is that it could cripple any decisions (if they are not agreed by all UC members)
19:40:39 <jproulx> 6 months is a long time to be down one person on a body of 5, also having an even number of people complicates things
19:40:39 <Rockyg> The team *is* starting out pretty small....
19:40:50 <emagana> maishsk: Let me be optimistc and trust that UC members will behave and always agree  :-)
19:41:09 <docaedo> I agree on waiting for next election to replace
19:41:09 <mrhillsman> hehe
19:41:12 <maishsk> That is something we can be optimistic about
19:41:38 <docaedo> way better than trying to come up with a process (and if the UC is down a seat, things will keep on functioning)
19:41:52 <maishsk> but we also need to be realistic - anything that does not have a majority vote - does not pass
19:42:08 <jproulx> I don't take a strong position either way, but the actual process layed out in all those words isn't very complex, just go down the list from the last election until someone says yes
19:42:09 <emagana> So far, Shilla, Jon and I have been working very nicely and we were appointed not elected. I will assume that elected members will be even more participative.
19:42:19 <maishsk> emagana: why would you rather wait?
19:42:34 <maishsk> jproulx: +1
19:42:48 <emagana> because I dont want as a current UC member to have to "SELECT" someone
19:43:13 <jproulx> well that's why the process is there it's not really a choice
19:43:13 <emagana> ahhh jproulx that is a bit different
19:43:28 <shamail> There is also the section already stating what to do when a disagreement happens... worst case is that could be invoked if needed although generally I see UC staying functional on its own even if down a member
19:43:54 <Rockyg> emagana, take a look at what is happening in the projects right now...lots of core resignations because of job reassignments.  What if the UC goes down 2 members?
19:44:16 <mrhillsman> i would think it should stay functional and there is currently a process to resolve splits right?
19:44:37 <emagana> Yes, it should but I can see both points.
19:44:45 <maishsk> mrhillsman: splits mean - the motion does not pass - by default
19:44:57 <maishsk> there must be a majority
19:45:13 <maishsk> (and rightfully so)
19:45:16 <emagana> I just do not want to give the power of the UC to select randomly someone but if we follow line by line the replacement process, we should be fine.
19:45:28 <maishsk> emagana: it is not random
19:45:59 <emagana> maishsk: Yes, I see that.
19:46:04 <maishsk> If the vacancy opens less than four weeks before the candidacy period for the next scheduled UC election begins and the seat would not have been contested in the upcoming election, the candidates who do not win seats in the election will be consulted in the order they **appear in the results** until a candidate who is capable of serving agrees to serve out the partial term.
19:46:49 <emagana> ok, checking on time and based on the discussion. I want to know who is in favor or adding "Filling Vacated UC Seats" section.
19:46:51 * jproulx becomes more strongly in favor of that language
19:47:00 <mrhillsman> in favor
19:47:02 <emagana> +1 I am with the proper language
19:47:12 <shamail> +1
19:47:14 <emagana> aviosing to have to SELECT random people  ;-)
19:47:14 <Rockyg> +1
19:47:17 <mrhillsman> +1
19:47:20 <emagana> avioding*
19:47:25 <mrhillsman> :)
19:47:46 <Rockyg> one day, emagana will learn how to spell...
19:47:47 <jproulx> also if we loose someone and go below 5 we've violating the By laws yes?
19:47:49 <docaedo> +1
19:47:57 <emagana> anyone not in favor!
19:48:03 * jproulx will never learn to spell
19:48:07 <maishsk> +1
19:48:07 <emagana> I know Rockyg everyday is worse!
19:48:08 <emagana> LOL
19:48:37 <emagana> ok.. done..
19:48:40 <emagana> #action emagana add a section in gerrit UC charter for "Filling Vacated UC Seats"
19:48:49 <emagana> You folks are giving me a lot of work!!!!!
19:48:56 <mrhillsman> you love it
19:48:57 <shamail> Lol
19:49:16 <emagana> Anything else on UC Charter?
19:49:22 <maishsk> emagana: let me know if I can assist in any - I posted most of tha language in the review
19:49:38 <jproulx> we talked about changing "at least 5" to "5" yes?
19:49:46 <emagana> It should be very easy, just copy & paste  :-)  Thanks maishsk for the offer.
19:49:51 <maishsk> :)
19:50:03 <emagana> jproulx: Not exactly but I saw your comment in gerrit and I was planning to change it
19:50:28 <jproulx> that's all I've got then
19:50:36 <emagana> ok. next topic.
19:50:49 <emagana> #topic Open Discussion
19:51:15 <emagana> I want to bring something and it is basically a kind request
19:51:44 <emagana> The BoD election for Individual Directors is open. I encourage you all to participate.
19:51:57 <emagana> If anyone needs a nomination please reach out.
19:52:00 <shamail> Nicely done on the bylaw changes and UC charter emagana, jproulx, and Shilla!
19:52:07 <mrhillsman> +1
19:52:46 <maishsk> +1
19:52:49 <docaedo> definitely participate - there are some good candidates this round too!
19:52:49 <emagana> Most importantly, support our fellow UC members in their election process. I know so far shamail and emagana will participate. But again, I want to invite everybody to give it a try!
19:53:13 <Rockyg> Still on the fence
19:53:22 <shamail> +1, glad to nominate as well
19:53:24 <emagana> Thanks shamail! Great team effort, including you all!
19:53:33 <CarolBarrett> +1
19:53:41 <emagana> Rockyg: Just let us know!
19:53:42 <jproulx> Rockyg if you hop the fence I'll be happy to nominate..
19:54:11 <emagana> That's all from me. Anyone else?
19:54:11 <mrhillsman> if you do decide to run, send me an email as well and i will be glad to +1 you :)
19:54:14 <Rockyg> Thanks all...
19:54:24 <emagana> Rockyg rocks!
19:54:30 <mrhillsman> mrhillsman@gmail if you do not know :)
19:54:59 <emagana> mrhillsman: everybody knows you buddy  ;-)
19:55:07 <Rockyg> mrhillsman, yah, got that one ;-)
19:55:19 <emagana> well.. I am going to start a new patch for the Uc charter.
19:55:23 <mrhillsman> \o/
19:55:30 <shamail> Sounds good, see y'all later!
19:55:38 <emagana> Thank you all for attending. I am so happy to see you all around.
19:55:41 <emagana> ciao ciao!
19:55:44 <mrhillsman> l8rs
19:55:48 <maishsk> Thanks emagana and all for making the UC a more influencial body int he OpenStack Community
19:55:52 <maishsk> l8r
19:55:53 <jproulx> thanks all!
19:55:57 <docaedo> thanks!
19:56:21 <emagana> maishsk: It has been a team effort... Jon and Shilla and You All are the real thing!
19:56:25 <emagana> #endmeeting