19:01:11 <emagana> #startmeeting uc
19:01:12 <openstack> Meeting started Mon Feb 13 19:01:11 2017 UTC and is due to finish in 60 minutes. The chair is emagana. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:16 <openstack> The meeting name has been set to 'uc'
19:01:45 <emagana> I would like to start the meeting by asking how many people we have around. Please, say hi!
19:01:51 <leong> hi!
19:02:16 <ekhugen_> hi!
19:02:31 <emagana> I sent the reminder last minute today. So, it is my fault but I everything it could go wrong in our deployments just happened last weekend.
19:02:47 <mrhillsman> hi
19:02:53 <mrhillsman> hi!
19:02:53 <shamail> hi everyone
19:03:34 <maishsk> o/
19:03:37 <maishsk> Hello all
19:04:14 <emagana> Hello all!
19:04:51 <emagana> #topic UC-Election
19:05:37 <emagana> Ok, emails are out
19:06:01 <emagana> I was wondering if we have concerns or anything that we should discuss about our first election
19:06:20 <shamail> How many AUCs do we have at this point?
19:06:49 <shamail> Did we manage to account for the newer WGs?
19:06:56 <emagana> God one! I do not have the number on hand but I think it was around 350ish
19:07:05 <shamail> Thanks!
19:07:07 <emagana> good*
19:07:10 <leong> are those AUC over the past 6 moths?
19:07:21 <emagana> correct
19:07:22 <shamail> Sounds good, it was around 260 in Barcelona
19:08:47 <shamail> No concerns, thanks for making it happen so quickly and a thanks to the election committee as well for their hard work!
19:08:57 <emagana> so the numbers are what we should be expecting, UC still needs to review the AUC members for LCOO.
19:09:05 <docaedo> o/
19:09:14 <mrhillsman> No concerns with me either.
19:09:28 <shamail> emagana: +1, the organization vs individual voters has to be hashed out.
19:09:33 <emagana> @action emagana and uc review that LCOO membership is correct
19:09:38 <shamail> I agree with Jeremy that AUCs should be individuals
19:09:57 <leong> +1 AUC should be individuals
19:10:02 <ekhugen_> shamail +1
19:10:02 <mrhillsman> +1
19:10:24 <emagana> my only concern is this one: We should provide AUC based on: WG membership AND active work.
19:11:00 <mrhillsman> -1 on the wg membership
19:11:02 <emagana> For instance, I can have a WG and just showing up to an IRC meeting should NOT grant me AUC status. Otherwise, everybody could end up being an AUC
19:11:22 <emagana> mrhillsman: This is why I said both not just membership.
19:11:27 <shamail> emagana: +1, the current criteria emphasized activity (and how we can define the metrics to show it)
19:11:56 <maishsk> agreed - participation was a key element
19:12:01 <shamail> Agree, the current critiera is show up to meetings + log over 25 lines in 4 meetings or 100 in 1.
19:12:15 <leong> participation and contribution is key
19:12:47 <shamail> I see the issue with LCOO though since their activity is not in systems that we leverage.
19:12:47 <emagana> the hard part is to measure the "activiness"
19:12:51 <docaedo> that's pretty tricky measurement, many meetings take place over phone or google hangouts, and some of the WGs never use IRC as far as I understand
19:12:53 <leong> but there might be "gray area" on the definition of "participation"
19:13:19 <shamail> I wonder if the current "Non IRC WG" method could work for them? (WG chair submits list based on etherpad attendance/participation)
19:13:23 <emagana> Anyway, this is a challenge that we need to solve.
19:13:57 <ekhugen_> for non IRC WGs, is it possible that they do a lot over email?
19:14:02 <docaedo> +1 to WG chairs determining participation at least - they know who is actually contributing, etc.
19:14:11 <ekhugen_> I know WOO doesn't do IRC meetings, but we do have a listserv
19:14:29 <shamail> ekhugen_: not normally, for example Enterprise WG does a lot in etherpads but ML is fairly idle.
19:14:31 <docaedo> ekhugen_: if that were the case one would hope the email conversation happens on the user-committee mailing list (rather than a bespoke one of their own)
19:15:10 <emagana> In my mind, I would like to potentially remove the WG relationship. So, if you are part of a WG and you provide contribution they should be part of any of the other AUC criteria. So, the membership and active participation is redundant at that time.
19:15:11 <leong> maybe that can be a topic of discussion at Forum on "AUC criteria"
19:15:17 <shamail> ekhugen_: for AUC in the past, we asked Megan to help collect a list of active WOO members... need a longer term solution though eventually. Agree with emagana, needs a solution eventually.
19:15:53 <ekhugen_> that's fair, I don't know why we ended up with a separate listserv there
19:16:08 <shamail> emagana: it is fairly redundant already because anyone performing activities would be considered a member anyway.
19:16:16 <mrhillsman> agree with removing the wg relationship as a criteria and possibly forum discussion on criteria
19:16:39 <shamail> ekhugen_: we did that too, we have recently shut down our MLs and standardized on User Committee ML.
19:16:49 <shamail> +1 to forum discussion
19:16:52 <jamemcc> Hi - I'm sorry I'm late - Herer to asnwer any questions and help represent LCOO
19:17:07 <emagana> Thanks for joining jamemcc
19:17:14 <leong> hi jamemcc
19:17:16 <docaedo> +1 on AUC criteria being important topic at the forum
19:17:45 <emagana> We were just discussion how we can be sure we have AUC membership properly given
19:18:37 <emagana> #action During the forum UC will discuss AUC assignment based on WG membership. (I know it sounds a bit confusing)
19:18:58 <emagana> but should we wait until the forum or we should start in the ML?
19:19:08 <maishsk> +1 for starting on the ML
19:19:09 <docaedo> emagana: definitely start on the mailing list IMO
19:19:10 <jamemcc> Yeh - thanks, important to LCOO
19:19:18 <emagana> maybe we need a good AUC list for the Forum, so we will have the problem again in two months
19:19:21 <mrhillsman> ML can feed into forum if not completed
19:19:26 <mrhillsman> at least get the thoughts churning
19:19:32 <jamemcc> I'd like to bring some of my thoughts into the ML
19:19:39 <emagana> @action emagana and uc start the discussion on ML.
19:20:05 <shamail> emagana: please use #action
19:20:49 <emagana> jamemcc: you missed a previous action item but I will review today LCOO AUC membership. I want to be sure that we are all happy about it. I have been traveling and I could not respond your last email.
19:21:05 <emagana> arrgghhhh thanks shamail
19:21:13 <emagana> #action emagana and uc start the discussion on ML.
19:21:37 <emagana> Ok. Are we good with how the election is going on so far?
19:21:42 <shamail> +1
19:21:50 <jamemcc> THanks - appreciate it - I'm caught up in the whole meeting
19:21:54 <emagana> Anyone, what to brings a point on this topic?
19:21:59 <docaedo> I am - got my CIVS and voted this morning ;)
19:22:31 <emagana> Yes, I also voted already! It felt good to be honest. I was looking for this from the first day I became UC
19:22:41 <maishsk> :)
19:22:53 <emagana> ok.. moving on.
19:23:00 <emagana> #topic PTG activities from UC members
19:23:48 <emagana> Just wanted to have some time to discuss anything related to PTG. As you know the PTG is focus on the development side but I know some AUC folks will be there and wanted to meet.
19:23:59 <emagana> Anything that is worth to discuss here?
19:25:05 <emagana> I will take that silence as: "No, we are all good and we want to end this meeting soon" .. ok! point taken
19:25:09 <maishsk> :)
19:25:12 <mrhillsman> lol
19:25:15 <emagana> #Boston Planning
19:25:23 <emagana> #topic Boston Planning
19:25:34 <shamail> lol emagana
19:25:54 <emagana> I assume that all WGs have requested time via the CFS already.
19:26:01 <jamemcc> Yes
19:26:13 <docaedo> app dev enablement has
19:26:26 <emagana> I really like that this time we were able to allocate sessions for WG and UC in general without affecting our three chances to submit a CFS topic.
19:26:27 <shamail> PWG has as well
19:26:34 <emagana> That was great!
19:26:37 <shamail> emagana: +1
19:26:37 <leong> Same for EWG
19:26:46 <jamemcc> I can speak for LCOO, Telco/NFV and Massive Scalable
19:27:12 <emagana> awesome! jamemcc docaedo shamail leong
19:27:45 <emagana> I also noticed Logging WG had a last minute request. Not sure if that was granted but I could help if needed
19:28:04 <emagana> Please, provide an update as soon as you know about the schedule for the Boston event.
19:28:04 <mrhillsman> yeah, we have an effort to revive that hopefully
19:28:21 <mrhillsman> and i believe rocky would like to see the same
19:28:31 <emagana> mrhillsman: Great. I know Rocky is very positive about it.
19:28:33 <shamail> mrhillsman: is OsOps going to request space in Boston?
19:28:48 <emagana> mrhillsman: I hope they did!
19:28:51 <shamail> OSOps*
19:29:03 <mrhillsman> not as of right now, we still need to understand the direction
19:29:13 <jamemcc> We asked for a Birds of the Feather for LCOO as well since new and seems so much enthusiasm (my spin)
19:29:18 <mrhillsman> wanted to get your thoughts on that emagana via email (you mentioned something previously)
19:29:41 <emagana> mrhillsman: sounds good. We can always have a un-conference session.
19:29:53 <shamail> mrhillsman and emagana: would it be easier to request it for now and cancel if not needed (versus trying to get a room later on)?
19:30:01 <mrhillsman> agreed shamail
19:30:04 <shamail> Or too late already?
19:30:07 <mrhillsman> ^
19:30:10 <emagana> maybe too late.
19:30:15 <mrhillsman> ok
19:30:20 <jamemcc> Seems to me there may be a place for 2 sessions in this pattern for many WG. The main one for us is supposed to be more of the face to face and get business already known done.
19:30:21 <shamail> Unconf it is!
19:30:29 <mrhillsman> :)
19:30:38 <emagana> Go for it and try it. If not possible we can talk directly with the Foundation members to see what we can do.
19:30:48 <jamemcc> BoF session would be more of the let anyone talk about anything session
19:31:16 <emagana> Obviously, I do not want to give the impression that we can just avoid the process and guarantee space. No, I do not want to give that impression.
19:31:24 <shamail> jamemcc: +1 that is a good approach because if you do one session then most of it will be spent on answering questions for new attendees
19:31:59 <emagana> let's move on.
19:32:06 <emagana> #topic WGs Updates
19:32:25 <shamail> emagana: we had a topic on forum planning from PWG on agenda as well.
19:32:30 <leong> Product WG is making a proposal to help facilitate the Boston Forum
19:32:46 <leong> here a link to the slide decks
19:32:55 <emagana> I want to make this a regular topic. Just to have the opportunity for WGs chairs to share anything that they want on the working activities for their respective WGs
19:32:56 <leong> #PWG Proposal for Forum: https://docs.google.com/presentation/d/1jTlO4UdNjc5cOKboeCNhLDEdttazWWlDgNxxulUrPNg/edit#slide=id.g1c401aad5d_0_142
19:33:40 <leong> emagana: shall we discuss the PWG proposal?
19:33:54 <emagana> Let's start with shamail, is there something to discuss here or just FYI?
19:33:57 <leong> shamail and I are here to dscuss :-)
19:34:10 <jamemcc> @emagana Agreed that that's somethign we do each UC and that in general each WG chair should be attending here of possible to interact.
19:34:25 <jamemcc> I think that this weekt hough the time is better spent on PWG proposal
19:34:38 <shamail> There is something to discuss. Leong has a proposal which we would like to share and see if the UC would be willing to pursue it.
19:35:06 <leong> please find the above link to that proposal.. generally can focus on last slide
19:35:25 <leong> #link Proposal for Forum: https://docs.google.com/presentation/d/1jTlO4UdNjc5cOKboeCNhLDEdttazWWlDgNxxulUrPNg/edit#slide=id.g1c401aad5d_0_142
19:35:55 <emagana> I will need time for reading the slides. You probably sent them before over ML but I have not got time to go over them.
19:36:09 <leong> PWG is proposing if we can help to do some pre-forum planning as well as post-forum analysis
19:36:10 <emagana> Did you have any initial feedback from the rest of the UC members?
19:36:12 <maishsk> So I like the idea of providing a template
19:36:15 <shamail> emagana: Before we dive in. How do you want to proceed? WG updates first or change topic?
19:36:25 <leong> i haven't receive anything from UC members
19:36:39 <emagana> shamail: Let's change topic.
19:36:48 <shamail> Thanks
19:36:53 <shamail> emagana: we haven't proposed it yet because we wanted permission from UC first to facilitate
19:36:54 <emagana> #topic PWG proposal review
19:37:13 <leong> +1 shamail
19:37:16 <emagana> shamail: Have you sent the proposal to UC already?
19:37:27 <emagana> only UC is what I meant?
19:37:51 <leong> it was brought up in previous UC meeting..
19:38:04 <emagana> Ok, this is what I missed.
19:38:19 <shamail> emagana: Leong and I have not yet since it depends on the PWG's role being a horizontal one inside the UC WG structure. We have talked about this before but we have not done anything yet that would actually formalize this (this would be the first activity in that scope)
19:38:51 <shamail> leong: want to run through it first and then we can discuss?
19:38:59 <emagana> shamail: Could you clarify this: PWG's role being a horizontal one inside the UC WG structure
19:39:00 <leong> yup.. our plan is to discuss with UC first before formaizing it
19:39:17 <emagana> leong: that's the right approach
19:39:42 <shamail> emagana: yes, horizontal as in a WG that can help aggregate and work with other WGs (we have called this "the funnel" in the past)
19:40:03 <shamail> Essentially what slide 1 shows
19:40:50 <jamemcc> +1 on the need for a team to faciliate the funnel
19:41:01 <emagana> shamail: OK. I think makes sense to start contacting directly Jon and Shilla but I also think that we should wait until the end of the election to get the 5 UC members to comment on it.
19:41:12 <maishsk> shamail: Can you explain a bit more about the benefit of having the PWG acting as a funnel?
19:41:26 <leong> that might be a good point: emagana
19:41:36 <shamail> PWG = Partner with UC to help our WGs document and progress user stories. Unlike other working groups, we don't try to generate stories on our own from a market/user perspective but we help WGs that are representing user needs document them and build an action plan.
19:41:54 <jamemcc> Alternative is for the UC to come up with some other sub-team - but why would we when the PWG is volunteering and appropriately interested
19:43:06 <shamail> some user stories are generated from our team but our goal would be to get and track more stories from Enterprise, LCOO, Telco, Scientific, Logging, etc. and help document, build a plan, and execute. PWG is more of a group of SMEs on Product management best practices.
19:43:43 <shamail> maishsk: does that address your question?
19:43:44 <mrhillsman> i think pwg is an excellent piece of the puzzle
19:43:50 <leong> this can also help to facilitate activities across WGs if following the User Story workflow
19:43:57 <mrhillsman> ^
19:44:00 <shamail> leong: +1
19:44:01 <emagana> shamail and leong what about if you prepare an email to UC explaining the proposal and requesting time to discuss it.
19:44:12 <shamail> emagana: +1 we can do that
19:44:15 <emagana> I do not want to talk in behalf of the entire UC on this area.
19:44:17 <maishsk> shamail: sounds like a nice plan - and I also agree with emagana - that we wait to hear until after the elections to get full buy in from the whole entire UC
19:44:21 <leong> sure emagana
19:44:22 <emagana> it is just me..
19:44:25 <maishsk> we should*
19:45:04 <leong> i will work with Shamail and prepare an email for that.. maybe sent out after the end of UC election?
19:45:05 <shamail> Okay so...
19:45:10 <maishsk> (and emagana thought we wanted to get this meeting over and done with…) : )
19:45:11 <emagana> #action shamail leong send a request for feedback on the PWG proposal to UC members after the election in order to include the new two members.
19:45:14 <shamail> leong: will send an email to UC with summary
19:45:24 <leong> +1 shamail
19:45:27 <shamail> We will also be glad to answer questions from anyone else :)
19:45:41 <shamail> We can decide on proposal after UC = 5
19:45:48 <leong> nice
19:45:54 <emagana> maishsk: I have two guys talking next to me about our OpenStack issues. I thought I could get time back.. lol
19:46:02 <shamail> lol
19:46:32 <shamail> emagana: solve all issues by upgrading to Ocata xD
19:46:42 <emagana> some days I feel I should not be in Ops
19:46:44 <emagana> LOL
19:46:47 <mrhillsman> :)
19:47:17 <shamail> Sorry for the distraction, thanks for giving leong and I a path forward.
19:47:18 <emagana> shamail: The worse part is that the issues are not OpenStack ones, are related to the whole INF and OPS ecosystem around it.
19:47:28 <shamail> That's really common
19:47:31 <emagana> ok... next topic.. ok?
19:47:38 <mrhillsman> yep
19:47:42 <leong> +1
19:47:52 <emagana> #topic WGs Updates
19:48:10 <emagana> As I said before. I want to make this topic a regular one.
19:48:18 <shamail> emagana: +1
19:48:24 <jamemcc> +1
19:48:51 <emagana> Space for WG chairs to share their progress and potential impediments. Not a force one but will be nice to have all WGs sharing.
19:48:53 <shamail> emagana: could we add something to the wiki where chairs can update the status each week? This will allow greater external visibility as well.
19:48:54 <emagana> Ok, anyone?
19:48:57 <leong> emagana +1
19:49:04 <mrhillsman> +1
19:49:04 <docaedo> I can throw out a quick off-the-cuff update for app dev enabling WG
19:49:08 <emagana> shamail: good point! +1
19:49:08 <shamail> And we could use this time in meetings to discuss specific concerns, blockers, etc
19:49:11 <docaedo> also +1 for wiki
19:49:17 <leong> should let all WG chairs aware about this regular agenda
19:49:36 <emagana> leong is giving me a lot of action items! :-)
19:50:06 <jamemcc> So as a proposal for what the WGs would come with - #1 any big changes in approach, scope so that it could be vetted and assisted by the other WGs
19:50:06 <leong> and maybe also a regular F2F WG meeting at summit
19:50:08 <emagana> #action emagana let to know via ML to all WGs chairs about the wiki updates.
19:50:09 <mrhillsman> feel free to action me something
19:50:15 <leong> lol emagana
19:50:35 <jamemcc> #2 Announcement of any new User Stories - kind of the same thing but a level down.
19:50:52 <shamail> emagana: good point leong... on that note, could we also set criteria that when you become a UC WG one of your chairs must make this meeting at least once a month? Miss two months and your WG will be marked inactive? (I know this is another topic that should wait for full UC but wanted to throw it out before I forget)
19:51:07 <jamemcc> #3 Questions/Ideas from the WG members that seem to come up to the higher level.
19:51:37 <emagana> shamail: That very hard rule should be discuss as a team in the Forum.
19:51:43 <emagana> discussed*
19:51:43 <leong> it is important to make sure all UC WG are engaged and communicated across..
19:51:50 <shamail> emagana: same as mrhillsman , feel free to assign actions.
19:51:54 <shamail> emagana: +1
19:52:22 <docaedo> shamail: I agree with discussion, but I also agree something like that should be a rule (and if I get on the committee I'm going to work to formalize a lot of how WGs operate so it's not so much the wild west ;) )
19:52:45 <emagana> let's continue this conversation in our next IRC meeting.
19:53:34 <mrhillsman> docaedo agreed i think no matter who is added should definitely have some formalization as much as possible
19:53:48 <mrhillsman> i'll be helping no matter the outcome
19:53:59 <shamail> docaedo: +1, same
19:54:23 <emagana> docaedo: I like the spirit!
19:54:43 <emagana> For sure WGs activities and process need to be formalized.
19:54:51 <emagana> but not in this meeting.
19:55:09 <leong> that will be a "2017 goal" for UC as a whole
19:55:11 <mrhillsman> yep
19:55:11 <leong> :)
19:55:14 <emagana> We are running out of time/
19:55:17 <mrhillsman> ^
19:55:43 <emagana> I want to finish the meeting now because I need to jump into other work things if you folks do not mind.
19:55:59 <mrhillsman> nothing from me
19:56:02 <docaedo> works for me, thanks emagana
19:56:07 <maishsk> emagana: thanks for running a tight ship
19:56:13 <mrhillsman> thanks emagana and everyone
19:56:13 <emagana> but feel free to continue any conversation in the #openstack-uc channel.
19:56:20 <shamail> Thanks emagana
19:56:26 <leong> thanks emagana
19:56:26 <emagana> Thank you all!
19:56:33 <emagana> In two weeks we should have our new UC members! Good luck to all the candidates!
19:56:45 <emagana> emagana out!
19:56:49 <AndyU> indeed. good luck all.
19:57:01 <emagana> #endmeeting