18:01:42 <shamail> #startmeeting uc
18:01:42 <emagana> shamail: Would you be able to moderate it today?
18:01:43 <openstack> Meeting started Mon Aug 28 18:01:42 2017 UTC and is due to finish in 60 minutes.  The chair is shamail. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:46 <shamail> sure thing
18:01:47 <openstack> The meeting name has been set to 'uc'
18:01:49 <emagana> Thanks! shamail
18:01:49 <shamail> #chair emagana
18:01:50 <openstack> Current chairs: emagana shamail
18:01:55 <shamail> #topic roll call
18:02:00 <shamail> So… who’s here?
18:02:03 <VW> o/
18:02:31 <shamail> Hi VW! Welcome to the UC (I missed the meeting where everyone else welcomed you)
18:02:35 <shamail> #chair VW
18:02:36 <openstack> Current chairs: VW emagana shamail
18:02:40 <VW> thanks, shamail
18:02:51 <shamail> hi leong
18:02:55 <leong> hi shamail
18:03:04 <shamail> Our proposed agenda for today:
18:03:07 <shamail> #link https://wiki.openstack.org/wiki/Governance/Foundation/UserCommittee#Meeting_Agenda.2FPrevious_Meeting_Logs
18:03:23 <shamail> #topic Review action items from last meeting
18:03:42 <shamail> #link http://eavesdrop.openstack.org/meetings/uc/2017/uc.2017-08-21-18.00.html
18:03:44 <Rockyg> o/
18:03:46 <shamail> Meeting notes from the last UC meeting
18:03:49 <shamail> Hi Rockyg
18:03:59 <Rockyg> hey all
18:04:06 <shamail> I only see one action item: mrhillsman include the Financial team in commit
18:04:30 <emagana> correct!
18:05:54 * shamail trying to find patch which adds Financial team
18:06:13 <VW> I think it got merged
18:06:17 <shamail> Melvin had asked us to merge https://review.openstack.org/#/c/436757/ first which has now been completed
18:06:41 <mrhillsman> apologies
18:06:42 <emagana> https://review.openstack.org/#/c/436757/3/reference/teams.yaml
18:06:48 <mrhillsman> lost power for a bit
18:06:55 <emagana> That has been merged!
18:06:59 <shamail> Sweet
18:07:03 <shamail> thanks mrhillsman and welcome
18:07:06 <shamail> #chair mrhillsman
18:07:07 <openstack> Current chairs: VW emagana mrhillsman shamail
18:07:08 <emagana> Financial group as been included
18:07:23 <shamail> Safe to move on?
18:07:35 <VW> I think so
18:07:40 <shamail> #topic Discuss current state of UC
18:07:50 <shamail> Sub-topic 1: wiki updates
18:07:59 <shamail> Anyone leading this effort?
18:08:02 <mrhillsman> i meant to add more to that list
18:08:12 <Rockyg> Hope you're weathering the storm ok, mrhillsman
18:08:16 <shamail> mrhillsman: Feel free to do so now
18:08:20 <mrhillsman> i am, thx
18:08:55 <shamail> Are these things that are in-flight mrhillsman or do you want to discuss the state of various items that we need to address?
18:08:59 <mrhillsman> regarding wiki updates, wanted to be sure the info there is relevant still
18:09:35 <mrhillsman> and are we generally satisfied with the structure, not that it is bad, but any suggestions to improve, etc
18:09:35 <shamail> mrhillsman: I think most of the information is relevant *however* we should start removing content that has been merged into our repo
18:09:46 <shamail> This way the information has a single source of truth
18:09:49 <emagana> shamail: +1
18:09:52 <mrhillsman> ok, and point folks to the governance page?
18:09:54 <rlpple> +1
18:09:58 <shamail> The WG/teams info and even structure doesn’t need to be there anymore
18:10:02 <shamail> mrhillsman: +1
18:10:06 <mrhillsman> ok cool
18:10:14 <shamail> Do you want to take this?
18:10:19 <rlpple> mrhillsman +1
18:10:19 <mrhillsman> sure thing
18:10:31 <shamail> #action mrhillsman will update the UC wiki and remove redunant information that is now available on our governance page
18:10:51 <mrhillsman> another thing, we should think about which groups should be WGs/Teams based on our requirements doc
18:11:02 <shamail> mrhillsman: +1
18:11:11 <VW> agreed.
18:11:18 <shamail> I think that UC members should review existing groups based on the established criteria
18:11:20 <mrhillsman> and reach out to them to discuss the change and work with them to make it happen
18:11:24 <mrhillsman> yep
18:11:38 <shamail> We can probably start this discussion via email and then divide contacting the WG chairs if more info is needed?
18:11:51 <mrhillsman> sounds good
18:12:06 <shamail> Anyone want to own starting the email thread?
18:12:27 <mrhillsman> just a general announcement, based on requirements put forth, we will start discussing with groups/teams current status and needed changes
18:13:15 <shamail> mrhillsman: +1
18:13:20 <mrhillsman> emagana?
18:13:33 <emagana> +1
18:13:36 <mrhillsman> since you are the chair, personally i think it makes sense for you to communicate it
18:13:46 <emagana> sounds good..
18:13:48 <VW> so, is the request going to be to make sure all existing groups/teams go back and fufill all the steps for new ones
18:13:58 <emagana> I will take that action item
18:14:32 <shamail> thanks
18:14:44 <mrhillsman> i think that is main part of it VW and based on that maybe a team will be a wg and vice versa
18:14:57 <shamail> #action emagana will send an email to UC ML letting them know that we will start discussing with groups/teams current status and needed changes
18:15:02 <VW> got it
18:15:22 <shamail> I would like to add an item to the state of UC list...
18:15:34 <VW> I'll try to jump on the request (as a chair) quickly when it comes out to help encourage others
18:15:34 <mrhillsman> awesome, did not want to be alone in this hehe
18:15:42 <shamail> What is our role with SIGs? Is that defined or it isn’t a UC concern? Just want to wrap my head around our obligation on that front
18:16:11 <shamail> I don’t have an answer, just the question :P
18:16:15 <mrhillsman> good question
18:16:35 <emagana> what is the traction around SIG?
18:17:04 <mrhillsman> discussions have been that some wgs/teams may still exist even after there are "official" sigs
18:17:26 <mrhillsman> and i did want to add that as well in terms of discussing with working groups / teams but did not want to rock the boat too much
18:17:50 <mrhillsman> we should discuss definitely
18:18:01 <shamail> #link http://lists.openstack.org/pipermail/openstack-sigs/
18:18:04 <mrhillsman> emagana good traction on the dev side thus far
18:18:04 <leong> isn't SIG suppose to be collaboratively driven/owned by both TC and UC?
18:18:09 <shamail> SIG ML to gauge activity
18:18:16 <emagana> ok
18:18:33 <mrhillsman> thierry has reached out to some to move to a SIG and some have obliged
18:18:34 <shamail> thread of particular interest
18:18:36 <shamail> #link http://lists.openstack.org/pipermail/openstack-sigs/2017-August/000035.html
18:19:08 <mrhillsman> i wanted to suggest we identify wgs/teams that could be a sig instead
18:19:18 <VW> I still need to understand it all, but I'm very much opposed to dual oversight
18:19:26 <shamail> mrhillsman: +1 but is “What is a SIG” written down anywhere yet?
18:19:35 <VW> exactly ^
18:20:00 <mrhillsman> #link https://wiki.openstack.org/wiki/OpenStack_SIGs
18:20:05 <mrhillsman> this is the current working space
18:20:17 <rlpple> shamail +1 mrhillsmand ty
18:20:28 <mrhillsman> i will get a what is a SIG formal writeup done
18:21:05 <shamail> “OpenStack SIGs are teams within the community where we collaborate to bring unified discussions for all community members who share a common interest. As examples SIGs can be but are not limited to being a first stage in the development of new projects, feature requests, standards adoption, policy implementation, adjacent community work, and just general discussion(s).” is very broad and it would be hard to decide which WGs/Teams to convert
18:21:05 <shamail> based on it.
18:21:11 <mrhillsman> myself and thierry wanted to start socializing and put it out there to try to get it moving organically
18:21:11 <rlpple> will this replace current mailing lists?
18:21:30 <shamail> I am wondering if we  would be better served by documenting what a SIG isn’t since the definition of IS is broad
18:21:52 <shamail> thanks mrhillsman
18:22:02 <mrhillsman> makes sense shamail
18:22:07 <shamail> rlpple: I don’t think it will… mrhillsman said that there might be a need for continued WGs
18:22:19 <shamail> rlpple: SIG has its own ML and WGs/Teams use the User Committee ML
18:22:56 <mrhillsman> there are no hard rules right now and that is more/less the issue per se and the reason there has not been a formal announcement/requirement
18:23:02 <rlpple> trying to understand how it avoids duplication will read more.
18:23:05 <rlpple> ty
18:23:10 <shamail> Thanks mrhillsman, how does this sound: Let’s wait to see the formal writeup and, once it’s in place, use that as criteria to evaluate WG/Team charters
18:23:30 <mrhillsman> the hope is that by sydney we can have more solid examples via those who said they would like to move to a SIG
18:24:02 <mrhillsman> and be able to better communicate what is/is not one and have a good on/off-boarding process identified
18:24:16 <shamail> #info UC will discuss which WGs/Teams might be better served as SIGs after there is a formal definition of SIG in place.
18:24:19 <mrhillsman> feedback/help is definitely welcome
18:24:40 <shamail> mrhillsman: please share the writeup so that we know where to give feedback when it’s available :)
18:24:50 <mrhillsman> sure thing
18:24:52 <shamail> thanks
18:25:00 <shamail> Anything else to add to the “current state of UC” topics?
18:25:16 <mrhillsman> oh
18:25:32 <emagana> all good so far
18:25:36 <mrhillsman> so wanted to see if we could provide also a 'current state' presentation during the joint meeting
18:25:58 <shamail> mrhillsman: +1, first elected UC and all that
18:26:23 <mrhillsman> along with the next topic or a foreshadow hehe of the next topic during the joint meeting (maybe next by sydney and state by ptg)
18:26:28 <mrhillsman> yep
18:26:45 <shamail> +1 from me, emagana and VW… thoughts?
18:27:09 <emagana> mrhillsman: Yes, it is expected
18:27:27 <emagana> I think Alan always give us 5 minutes to talk about the latests from UC
18:27:47 <emagana> we should cover the election, and the WGs/Teams/SIG summary
18:27:54 <shamail> #action UC will request to present a “current state of UC” overview at the Joint TC+UC+Board meeting
18:28:20 <emagana> I want to bring a topic to the board meeting, its about assigning a full time employee from the Foundation to be part of the UC
18:28:45 <shamail> Tell me more emagana… why is that needed?
18:28:51 <emagana> For instance, the TC has Thierry and some times even Mike was part of that
18:28:51 <mrhillsman> i wanted to see us move the uc to be more influential
18:28:56 <VW> I'm good with the plan on the UC update.  I still have questions around the SIGs, though
18:29:04 <VW> and yeah, emagana - elaborate
18:29:10 <VW> ah - good point
18:29:18 <mrhillsman> and think we not only need to provide general update, but what we need moving forward
18:29:21 <VW> re: the TC having staff
18:29:27 <mrhillsman> very similar to what you are stating emagana
18:29:30 <emagana> Their job is to make the TC successful. For the UC we need something similar in my opinion.
18:29:35 <Rockyg> ++ mrhillsman
18:29:38 <mrhillsman> very good place/thing to identify
18:29:55 <mrhillsman> and would like these types of things to be part of that presentation at ptg
18:30:03 <mrhillsman> or sydney joint meeting
18:30:28 <emagana> we all have the UC as a partial job, we have our companies role and responsabilities.
18:30:34 <mrhillsman> but not sure if part of this topic or next more or less
18:30:39 <shamail> emagana: Do we have enough work to warrant a FTE from the foundation? I understand the influence aspect but I am also trying to understand whether it could be justified
18:31:17 <shamail> We are 5 people who (part-time) are working with 11-13 WGs/Teams
18:31:21 <emagana> If you think about wiki, repo, communication and planing for: user survey, forum, ops meet-up, etc
18:31:26 <emagana> we have a lot in our plate
18:31:28 <shamail> On the TC side, you have 60+ repos under governance
18:31:48 <emagana> beides, we need more communication for WGs/Teams and SIGs
18:32:24 <VW> How much is the TC involved in PTG planning, etc
18:32:37 <emagana> Maybe that person could not be just 100% for UC but helping us to keep moving and provide us support whenever we need it.
18:32:49 <shamail> Devil’s Advocate: We have Anne helping us with the User Survey, Forum Committee (UC+TC+OpenStack Foundation) for the Forum, and Ops Meetup used to be Foundation led and they let the community lead it… would having a FTE be working backwards to make the foundation a dependency for these activities again?
18:32:57 <VW> I would argue, that UC should have a large hand in guiding the forum structure
18:33:12 <emagana> and it does VM
18:33:24 <emagana> shamail and mrhillsman were totally involved in the last one
18:33:28 <VW> awesome
18:33:39 <shamail> emagana: +1 on having a partially dedicated foundation member
18:33:51 <VW> I'm just curious if there is a parallel need around staff involvement because o fthat
18:33:55 <emagana> anyhow.. it is just an idea
18:33:57 <shamail> The dedicated full-time foundation member is what I was finding harder to justify
18:34:22 <mrhillsman> i think it makes sense but am not able to articulate all the "reasons" right now
18:34:30 <shamail> We can make the case and see if it sticks :)
18:34:45 <emagana> shamail: I do understand it.. maybe not full-time but partially
18:35:19 <shamail> Any other sub-topics before we move on?
18:35:29 <mrhillsman> i prefer we fight for full-time, justify it, i know we have at least one advocate at the board level, and probably staff too, and if we get a part-time fine hehe
18:35:53 <shamail> +1
18:35:59 <shamail> #topic Discuss goals for this cycle (8/2017-2/2017)
18:36:13 <shamail> I have one that I know of off-hand…
18:36:37 <shamail> Complete our re-work of the AUC system to allow self-service additions/removals by WG/Team chairs
18:36:48 <shamail> We started this but I don’t know if we can make it as "done"
18:37:01 <VW> +1 on that shamail
18:37:27 <Rockyg> mrhillsman, ++ need a full time tech organizer to ensure that tthe SIGs thaat are UC started get devs on board.
18:37:39 <Rockyg> Proj mgr/evangelist for US needs
18:37:43 <shamail> Do others agree as well? I can make it as an action (so we remember the goal)
18:38:06 <mrhillsman> agree with that shamail +1
18:38:15 <shamail> #action Complete our re-work of the AUC system to allow self-service additions/removals by WG/Team chairs
18:38:51 <emagana> +1
18:38:57 <shamail> Another goal: Review existing WG/Team for official status based on the newly published UC WG/Team Requirements
18:39:08 <rlpple> have to drop for another meeting.  will read notes.
18:39:17 <shamail> By the end of the cycle, we should be able to say that all WG/Teams are official (or not)
18:39:38 <mrhillsman> i put that one on our agenda as well, and it came/comes from reviewing - https://docs.google.com/document/d/1yD8TfqUik2dt5xo_jMVHMl7tw9oIJnEndLK8YqEToyo - in part and watching a video from the initial folks who put together the UC
18:39:58 <shamail> #link https://docs.google.com/document/d/1yD8TfqUik2dt5xo_jMVHMl7tw9oIJnEndLK8YqEToyo/edit#heading=h.n75incdeemsm
18:40:02 <Rockyg> need a plan in there for moribund WG/Teams that might still be foundational
18:40:07 <mrhillsman> thx shamail, sorry
18:40:20 <shamail> Are we good with adding “Review existing WG/Team for official status based on the newly published UC WG/Team Requirements”?
18:40:21 <mrhillsman> thought it would be good for us to start thinking about goals going forward
18:40:25 <mrhillsman> +1
18:40:46 <shamail> Good addition to the agenda mrhillsman
18:41:08 <shamail> Rockyg: +1
18:41:24 <shamail> Just because we don’t have a WG/team doesn’t mean it isn’t need it and the UC can/should surface these gaps
18:41:38 <shamail> needed*
18:41:46 <mrhillsman> +1
18:41:53 <Rockyg> or if one goes dormant.  How to kickstart. whether to...
18:42:00 <mrhillsman> to both yours and Rockyg's
18:42:15 <shamail> #action Review existing WG/Team for official status based on the newly published UC WG/Team Requirements (and identify coverage gaps after the official list is compiled)
18:42:50 <shamail> Anyone else want to propose a goal? I can go on and on. :)
18:43:05 <mrhillsman> i will work to think about more as i figured you all would have better insight to get some started
18:43:19 <mrhillsman> especially you and emagana
18:43:43 <emagana> :-0
18:43:51 <mrhillsman> will also reach out to some of our regular friendly participants for some feedback we can solidify
18:44:14 <mrhillsman> hehe, i just need a few days to let my brain coalesce all the things
18:44:18 <shamail> How about working to build closer ties with other AUC? We focus a lot on WGs/Teams but we haven’t done as much to learn about how we can help local user group organizers, knowledge contributors, etc
18:44:29 <mrhillsman> yes
18:44:33 <mrhillsman> +1000
18:44:37 <mrhillsman> oh yeah, on that note
18:44:37 <shamail> lol
18:45:06 <Rockyg> ++
18:45:06 <mrhillsman> would like to ask the foundation to provide more opps for UC visibility
18:45:13 <shamail> mrhillsman: +1
18:45:31 <mrhillsman> one thing i noticed at china days and other openstack days, thierry usually presents what the TC is/is not
18:45:43 <mrhillsman> and that speaks in part to emagana's point as well
18:45:50 <shamail> Granted I could probably do more on my end but I often think about sitting idle as a resource when there are local events near me
18:46:07 <shamail> I think we have to advertise that UC is a thing more often
18:46:16 <mrhillsman> yep
18:46:30 <emagana> indeed!
18:46:32 <VW> agreed
18:46:40 <emagana> we can't attend all OpenStack events all over the world
18:46:47 <emagana> having someone from the foundation will help a lot
18:46:52 <mrhillsman> ;)
18:47:08 <Rockyg> ++
18:47:18 <shamail> #action UC will work to build closer ties with other AUCs (such as local user group organizers, knowledge contributors)
18:47:25 <shamail> emagana: +1 :)
18:48:08 <shamail> Anything else to add for 2H 2017 goals?
18:48:20 * mrhillsman needs to buy a new mini-notepad to write down things so he does not forget
18:48:46 <shamail> you’re just looking for an excuse to buy a new mini-notepad… notepad on the phone works just fine
18:48:52 <mrhillsman> hehe
18:49:02 <mrhillsman> very true sir, very true
18:49:16 <mrhillsman> nothing more from me
18:49:18 <Rockyg> mrhillsman, you can pick some up when you visit Santa clara
18:49:24 <mrhillsman> ++
18:49:54 <shamail> Do we want to tackle making the UC meetings multi-region in this cycle? I am curious as to whether we think there is demand… last time we tried it, it didn’t work out
18:50:03 <emagana> need to leave early folks.. Thanks for driving the meeting!
18:50:07 <shamail> cya emagana
18:50:17 <mrhillsman> l8r emagana
18:50:26 <mrhillsman> i think we can get that done this cycle shamail
18:50:36 <VW> do we have many APAC wg chairs, etc, shamail
18:51:05 <mrhillsman> i know we have the recent financial team, public cloud has apac chairs iirc, and i believe lcoo does as well
18:51:08 <shamail> I think the new financial team has APAC chairs
18:51:12 <mrhillsman> i know jamemcc was pushing for it
18:51:22 <shamail> and yeah, the others mrhillsman mentioned
18:51:28 <VW> ah yes
18:51:33 <VW> I'm certainly open to it
18:51:47 <VW> we can always try, and if it doesn't work go back to same time weekly
18:51:57 <shamail> #action Establish a solution for multi-region (or alternating schedule) UC meetings to become more accessible in other timezones
18:52:05 <mrhillsman> ++
18:52:12 <shamail> VW: +1
18:52:45 <shamail> This is a good starting list… anyone have anything to add for now? We can always add later as well
18:53:05 <shamail> We should however firm up our goals by end of September so that we have enough time/focus for the remainder of the cycle
18:53:40 <shamail> going once
18:53:47 <shamail> …twice
18:53:50 <VW> agreed.  I think we should probably start the n+1 cycle goals after SYD too.  Once we see how the second round of Forum sessions goes and are mid way through the current cycle goals
18:53:59 <shamail> VW: +1
18:54:23 <VW> otherwise, I'm sold (
18:54:33 <shamail> #action UC will continue to discuss goals with the objective of committing for this cycle by end of Sept.
18:54:41 <shamail> #topic Open Discussion
18:54:58 <shamail> Nada from me
18:55:07 <mrhillsman> ^
18:55:25 <jamemcc> Hi - Ive Got 1
18:55:25 <VW> I'm good
18:55:29 <shamail> Hi jamemcc
18:55:30 <mrhillsman> gotta run, l8r everyone, thx for joining, thx shamail for running meeting
18:55:39 <VW> what is it jamemcc
18:55:44 <shamail> YW, see ya mrhillsman
18:55:47 <mrhillsman> will catch the logs
18:55:51 <jamemcc> Should we/could we try for another session of Cross WG Status
18:56:06 <jamemcc> Seems all it would take is scheduling it
18:56:14 <shamail> I think that is a good idea
18:56:44 <jamemcc> We had somewhat agreed on on Late Wed night/Early Thursday morning - which is when we had the first one
18:56:48 <jamemcc> I propose next week
18:56:49 <shamail> Same time zone or could we do one in US friendly time?
18:56:59 <shamail> since the last was APAC
18:57:04 <VW> I'd be good with late Wed night
18:57:05 <jamemcc> We got 3 for that meeting and I will make it 4
18:57:12 <VW> as both a UC member and a WG chair
18:57:19 <jamemcc> Good
18:57:20 <jamemcc> 5
18:57:22 <shamail> cool
18:57:52 <jamemcc> Can one of you take action item to reply or otherwise communicate - same as Edgar did for the first session?
18:57:55 <shamail> Is next week good or would September be better (post PTG) so WGs/Teams can factor those discussions into the cross WG/team sync?
18:58:32 <Rockyg> next week is Labor day
18:58:43 <jamemcc> ;Yeah - ok to move out a couple weeks
18:58:48 <shamail> good point Rockyg
18:58:50 <shamail> VW: would you be okay with taking this communication?
18:59:07 <VW> sure
18:59:11 <shamail> thanks
18:59:16 <shamail> #action VW will send communication regarding the next cross WG/team meeting
18:59:30 <shamail> We are at time, thank you everyone!
18:59:45 <shamail> #endmeeting