14:00:38 <mrhillsman> #startmeeting uc
14:00:39 <openstack> Meeting started Mon Jan 29 14:00:38 2018 UTC and is due to finish in 60 minutes.  The chair is mrhillsman. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:42 <openstack> The meeting name has been set to 'uc'
14:00:57 <shamail_> Hi everyone
14:00:58 <mrhillsman> #chair VW zioproto shamail_
14:00:59 <openstack> Current chairs: VW mrhillsman shamail_ zioproto
14:01:06 <aprice> hello!
14:01:10 <mrhillsman> #topic RollCall
14:01:11 <VW> hola
14:01:15 <VW> o/
14:01:26 <aprice> o/
14:01:29 <mrhillsman> good morning/evening/afternoon great people
14:01:43 <shamail_> o/
14:02:20 <mrhillsman> any others here for uc meeting?
14:02:50 <mrhillsman> will give it a few minutes
14:03:11 <mrhillsman> agenda is here #link https://wiki.openstack.org/wiki/Governance/Foundation/UserCommittee
14:03:23 <mrhillsman> please modify should there be anything missing
14:05:47 <mrhillsman> alright
14:05:58 <mrhillsman> #topic Update on election process
14:06:05 <VW> yeah - was about to say it looked like no one had additions
14:06:16 <VW> so we have election officials - yay!
14:06:24 <VW> but we need to get the call for candidates out today
14:06:37 <mrhillsman> ++
14:06:49 <mrhillsman> We also need to approve #link https://review.openstack.org/#/c/538311/
14:07:27 <mrhillsman> Unfortunately if anyone was waiting to see the update via the usual SUCCESS job link, infra is not storing success jobs for now
14:07:53 <VW> reviewing patch now
14:08:44 <jamesmcarthur> Hi o/
14:08:46 <mrhillsman> ty sir
14:08:51 <VW> hey jamesmcarthur
14:08:53 <mrhillsman> hey jimmy
14:09:09 <mrhillsman> is there anything we need to resolve re election?
14:09:33 <jamesmcarthur> I’m working on the full list of the electorate
14:09:40 <jamesmcarthur> Hope to have put by EOD
14:09:48 <mrhillsman> awesome
14:09:54 <jamesmcarthur> I’ve never run he actual election
14:10:09 <jamesmcarthur> So I’m hoping someone else can provide some guidance on that front :)
14:10:45 <mrhillsman> no worries, we have general notes from Tom #link https://docs.google.com/document/d/1nBNGel9aNVgPG0wBYZA36gfGzZedLPpO3YJy-EdWY2E/edit
14:11:17 <mrhillsman> and some re the auc technical details #link https://docs.google.com/document/d/1djJSA8reYSsNETpCRRhoFUTrnLiTDPW2r36ccqZZzSw/edit
14:12:08 <mrhillsman> plus i believe shilla and tim are officials are familiar, and edgar as well
14:12:31 <jamesmcarthur> Got it
14:13:30 <mrhillsman> if you do run across anything you think should be documented, feel free to add to #link https://docs.google.com/document/d/1LLk_v3KAM_3cJGaYJyU3k2L9w1geP4ccv2cL3CtLOhc/edit
14:14:02 <mrhillsman> we hope to take as much from this election and give it a permanent home for posterity
14:14:10 <mrhillsman> anything else on the election peeps?
14:14:24 <Shamail> mrhillsman: +1, it should become a wiki page eventually
14:14:39 <mrhillsman> ++
14:14:54 <mrhillsman> #chair Shamail
14:14:55 <openstack> Current chairs: Shamail VW mrhillsman shamail_ zioproto
14:15:25 <mrhillsman> moving on
14:15:36 <mrhillsman> #topic Ops midcycle update
14:16:27 <VW> wait - did we task someone with getting a note out for nominations/candidates?
14:16:50 <VW> once the page is updated, of course
14:17:06 <mrhillsman> #topic Update on election process
14:17:06 <Shamail> VW: I think that is one of the function of the election officials, right?
14:17:57 <mrhillsman> not 100% sure, i do not remember who did the last time :(
14:18:19 <jamesmcarthur> We can dig back through the digest
14:18:48 <mrhillsman> yep, looking
14:19:26 <Shamail> mrhillsman: I’ve seen Tony send them out for TC elections before... if it wasn’t an election official last time then I would recommend it be one this time. This gives people a clear path on who to communicate with.
14:20:08 <VW> seems reasonable
14:20:10 <mrhillsman> ++
14:20:22 <mrhillsman> VW you want to reach out to Shilla and Tim?
14:20:34 <VW> yeah - I will ping them
14:20:52 <mrhillsman> it was actually Shilla last time
14:20:53 <mrhillsman> http://lists.openstack.org/pipermail/openstack-operators/2017-January/012530.html
14:21:15 <VW> PS - I may be lacking all the right permissions for the UC project in code review.  Let's look at that after the meeting mrhillsman
14:21:34 <mrhillsman> sure thing
14:21:45 <mrhillsman> anything else on election?
14:21:52 <Shamail> Same here (unless it only has +1 options).... I do see workflow -1/+1 as well.
14:22:05 <openstackgerrit> Merged openstack/governance-uc master: Add election officials  https://review.openstack.org/538311
14:22:59 <VW> nm - guess I had enough permissions ^
14:23:01 <VW> :)
14:23:14 <mrhillsman> hrm...yeah, that is interesting, i do not see +2
14:23:29 <VW> OK - I can reach out to Tim and Shilla
14:23:40 <VW> with the slight change in process
14:24:27 <VW> an no, no other election stuff here
14:24:31 <mrhillsman> #action VW to reach out to Tim and Shilla to send nomination/candidacy announcement
14:24:42 <mrhillsman> ok cool
14:24:47 <mrhillsman> Shamail ?
14:24:58 <mrhillsman> jamesmcarthur:
14:25:00 <Shamail> Nothing from me either
14:25:14 <mrhillsman> good deal
14:25:25 <mrhillsman> #topic Ops midcycle update
14:25:33 <jamesmcarthur> I’m good
14:25:43 <zioproto> hello
14:25:53 <Shamail> Hi zioproto
14:25:57 <mrhillsman> unfortunately i missed last couple meetings but things appeared to be in order, zioproto or VW probably have a better bead on this one
14:25:59 <mrhillsman> hey zioproto
14:26:18 <VW> yes - things look good for Tokyo
14:26:23 <VW> no host for the August meeting yet
14:26:37 <VW> Bloomberg may be willing again, but not confirmed
14:26:44 <mrhillsman> last note was getting the attendee list and discounts for sponsors
14:27:00 <jamesmcarthur> Have y’all considered tying the next meetup into an OpenStack Day?
14:27:02 <mrhillsman> did amrith from verizon drop back in?
14:27:23 <VW> I don't know
14:27:38 <VW> but I do recall hearing/seeing something about them being out as a sponsor
14:27:45 <mrhillsman> jamesmcarthur i do not recall when it was last brought up
14:27:48 <VW> I think
14:28:37 <mrhillsman> i think however it was discussed previously to do so after the next one since some folks, bloomberg verizon etc, had ok'd hosting
14:28:53 <jamesmcarthur> Got it.
14:28:55 <mrhillsman> but, may be good time to circle back around to that tomorrow
14:29:01 <VW> yeah
14:29:07 <VW> I'll be in the meeting tomorrow
14:29:11 <mrhillsman> since no host has been decided and tokyo seems to be in the books
14:29:19 <mrhillsman> ++
14:29:34 <VW> that seemed to be the general thoughts when I caught up with them at the tail end of last week's meeting
14:29:41 <mrhillsman> the list of attendees has been curated and discount codes provided
14:30:05 <mrhillsman> i should be there as well :)
14:30:19 <VW> at the meetup? Nice!
14:30:21 <mrhillsman> that 8am
14:30:25 <VW> oh
14:30:27 <VW> yeah
14:30:38 <mrhillsman> nah, not going to make tokyo :(
14:30:48 <mrhillsman> i bought a ticket in support though
14:31:11 <mrhillsman> anything more on this topic?
14:31:49 <Shamail> Not on my side
14:32:24 <VW> nope - good here
14:32:32 <mrhillsman> cool
14:32:41 <mrhillsman> #topic UC planning session at PTG
14:33:14 <mrhillsman> we have a doc for that hehe #link https://docs.google.com/document/d/19DhGbvO-WfQKG5MJEUqQ2xfVBFZYjOR8H7JvfQNHUA0/edit
14:33:28 <VW> yes - and I have not done good at adding to it
14:33:31 <Shamail> I haven’t heard back from the Travel Support Program yet. I’ll let all of you know once I find out anything from that end.
14:33:33 <VW> I need to work on that
14:33:55 <mrhillsman> awesome, hope that you can make it Shamail
14:34:11 <Shamail> I’ll add topics to the document later this week regardless of if I can make it or not.
14:34:24 <mrhillsman> wonderful
14:34:53 <mrhillsman> we should probably consider some options for remote too
14:35:05 <Shamail> mrhillsman: +1
14:35:10 <zioproto> For sure I will not be in person at the PTG. But I am available via Zoom
14:35:10 <mrhillsman> leong will probably not be able to make it for instance but wanted to participate
14:35:22 <mrhillsman> awesome zioproto
14:35:31 <VW> we should.  It's looking positive that I can make it but waiting on final confirmation
14:35:34 <mrhillsman> i will take things to facilitate that
14:35:58 <Shamail> Reviewing the existing items on the list... have we made any contact with the Ambassadors yet? Do we know if will be present at PTG?
14:36:18 <mrhillsman> i know i have not
14:36:37 <mrhillsman> Sonia is probably best person to reach out to
14:36:50 <Shamail> I can take that item...
14:37:03 <Shamail> Sonia at OpenStack dot org?
14:37:08 <mrhillsman> sec
14:37:09 <aprice> shamail: for ambassador outreach, can you please email me?
14:37:17 <Shamail> Absolutely aprice!
14:37:38 <mrhillsman> thx aprice!
14:37:46 <aprice> that is Sonia's email address, so please keep her cc'd, but I think that other folks on our team are going to be taking on that role
14:37:47 <aprice> no
14:37:51 <aprice> np!*
14:37:58 <Shamail> I can provide a summary of what we are trying to accomplish, ask if any will be at PTG, and invite them to a UC meeting.
14:38:00 <zioproto> is there a mailing list to get in touch with all the ambassadors ?
14:38:10 <mrhillsman> i was hoping you or jamesmcarthur would answer cause i was not sure she was still handling that
14:38:14 <aprice> perfect
14:38:30 <mrhillsman> zioproto i was told before openstack ML
14:38:56 <Shamail> #action Shamail will email aprice to connect with Ambassadors ahead of PTG
14:38:56 <aprice> they primarily use the community ML
14:38:59 <mrhillsman> aprice got it thugh :)
14:39:38 <mrhillsman> this is where zoom again can be good
14:39:59 <Shamail> mrhillsman: +1
14:40:15 <Shamail> or robots with screens on them, either one.
14:40:17 <mrhillsman> not sure how many will be at the ptg, but also Shamail maybe we could try to find a day/time best for as many ambassadors as possible
14:40:19 <Shamail> :-)
14:40:19 <mrhillsman> hehe
14:41:14 <Shamail> mrhillsman: agreed... we can find out. I think regardless of PTG that we should invite them to our weekly meeting (as often as they can make it) to increase collaboration between UC & Ambassadors
14:41:18 <mrhillsman> probably having us all talk is a high priority and something we should do more frequently going forward?
14:41:21 <mrhillsman> ++
14:41:32 <mrhillsman> we on the same page ;)
14:41:38 <Shamail> Yep yep
14:42:09 <mrhillsman> so i think we can all just take the action to update that document 'tween now and next meeting
14:42:17 <Shamail> Sounds good
14:42:20 <mrhillsman> anything else on this topic?
14:42:29 <Shamail> No. Thanks.
14:42:32 <VW> none here
14:42:37 <zioproto> none here
14:42:47 <mrhillsman> #info all uc members update #link https://docs.google.com/document/d/19DhGbvO-WfQKG5MJEUqQ2xfVBFZYjOR8H7JvfQNHUA0/edit for next meeting
14:42:54 <mrhillsman> cool
14:43:00 <mrhillsman> #topic Open Discussion
14:43:15 <mrhillsman> so we have ~17 minutes, anything we need to touch on?
14:43:25 <Shamail> I’m good.
14:43:31 <VW> me too
14:43:35 <mrhillsman> if not, we can get a few minutes back
14:43:41 <zioproto> Should we
14:43:45 <zioproto> gather user feedback
14:43:51 <zioproto> on the new Release Cycle discussion
14:43:52 <zioproto> ??
14:43:59 <zioproto> I think at the PTG that will be an hot topic
14:44:10 <zioproto> and we dont really have a "what users want"
14:44:13 <zioproto> right ?
14:44:17 <mrhillsman> ++
14:44:25 <Shamail> zioproto: ++
14:44:47 <zioproto> Should we agree on a common statement, of what users community wants ?
14:45:01 <zioproto> could be enough to make a summary of the long emails threads that were out there
14:45:08 <jamesmcarthur_> I think we need to present something that shows a breadth of users.
14:45:10 <mrhillsman> so that thread was pretty long, was actually 2 of them hehe
14:45:19 <jamesmcarthur_> Yes, those threads were insane.
14:45:22 <mrhillsman> maybe we should start another hehe
14:45:36 <VW> agree with jamesmcarthur_ - I don't think there is one common statement
14:45:45 <mrhillsman> yeah
14:46:00 <zioproto> The problem is that there two topics that get always mixed. Release cycle, and upgrade skipping releases
14:46:06 <mrhillsman> there were suggestions from one extreme to the other
14:46:32 <jamesmcarthur_> Right. We've had a couple of users that are working off of master saying they see no reason to change the cycle. So that's the thing that the TC is clinging to.
14:46:43 <VW> imo it's because we talk about the wrong thing.  We focus on release cycle, upgrade skips etc - when the thing people are worked about is the pain of upgrade
14:46:49 <jamesmcarthur_> But users that are working off of master are not indicative of a larger sample set.
14:46:50 <VW> fix that and a lot of this becomes moot
14:47:00 <mrhillsman> maybe we should start with a problem statement and get feedback on just that
14:47:06 <jamesmcarthur_> VW +1
14:47:16 <zioproto> I think the all point here, is making Openstack able for Operations consume
14:47:30 <mrhillsman> without going directly to implementation which is where stuff gets convoluted
14:48:02 <Shamail> It would be great if we could summarize the user feedback (not one view but the various views offered) and highlight some trade offs to stir conversation
14:48:15 <mrhillsman> what i remember about the threads is a constant "what are we trying to solve for exactly, what is the actual issue users have"
14:48:29 <zioproto> the problem statement is that is difficult to consume Openstack for the industry. In sydney the person from AT&T made a presentation about this.
14:48:35 <zioproto> I dont remeber his name
14:48:44 <zioproto> he explained why the delivery of openstack is slow
14:48:46 <mrhillsman> was it the keynote?
14:48:50 <zioproto> no no
14:48:56 <zioproto> at the Monday board meeting
14:49:37 <mrhillsman> ah ok
14:50:19 <zioproto> https://wiki.openstack.org/wiki/Governance/Foundation/5Nov2017BoardMeeting
14:50:24 <mrhillsman> so what do we want to do here? what is the next step
14:51:07 <mrhillsman> Chris and Kandan?
14:51:13 <VW> let's add an agenda item for next week.  Sounds like we at least need to get agreement within the UC on how e can productively steer the process
14:51:20 <mrhillsman> ++
14:51:26 <Shamail_> VW: ++
14:51:34 <jamesmcarthur_> Can we target a set of operators from different industry size and type to see if we can get specific feedback around release cycles and upgrades?
14:51:34 * VW edits wikis
14:51:38 <jamesmcarthur_> A mini-survey?
14:51:47 <VW> I think we can jamesmcarthur_
14:51:49 <mrhillsman> sounds good to me jamesmcarthur_
14:52:39 <mrhillsman> #info can we target a set of operators from different industry size and type to see if we can get specific feedback around release cycles and upgrades?
14:52:40 <zioproto> mini survey looks like the right thing to do
14:52:46 <Shamail_> Last time PWG had a discussion on this topic about 2 years ago... there was a big difference not based on just organization size but cloud type as well
14:53:12 <mrhillsman> ++
14:53:15 <Shamail_> Public operators were much more comfortable with more frequent releases while end user operators didn’t want to go through change control that often
14:54:05 <Shamail_> +1 for mini survey
14:54:10 <zioproto> the problem is the EOF of the releases that happens very soon now
14:54:17 <mrhillsman> so it sounds like we want to get just enough but not too much info via the survey
14:54:41 <Shamail_> The survey should give data points for discussion and not an outcome/decision
14:54:52 <zioproto> but if from the survery it comes out that we need more devs for the stable releases, how we actually get those resources ?
14:55:08 <zioproto> this part of the solution of the problem is still not clear to me
14:55:33 <mrhillsman> Seems we have quite a bit of information already on this #link https://docs.google.com/document/d/1wu_tKwogCvirDV3kd4YkWa4bWb_UMT4j4llle6j5MRg/edit
14:55:34 <zioproto> we can identify the problem. but if the TC does not have resources to solve it... I dont see how the problem will be really fixed
14:55:45 <VW> because we are jumping to a solution - i.e. "we need a stable release for x years"
14:55:50 <VW> figure out the problem first
14:55:52 <mrhillsman> We can use the doc there to start capturing thoughts/info in prep for the mini-survey?
14:55:59 <jamesmcarthur_> VW ++
14:56:04 <Shamail_> VW: ++
14:56:10 <VW> get a list of the 5 or 6 things that make upgrades painful for a wide range of operators
14:56:15 <mrhillsman> exactly
14:56:33 <VW> then use the survey to have folks "vote" on the consolidated list
14:57:11 <VW> "here are 28 painful issues with upgrades. You have 5 dollars to spend on fixing them.  You can spend all 5 on one or 1 on 5 or something in between.  Ready - go!"
14:57:16 <VW> something like that
14:57:19 <mrhillsman> i think we could help with moving the needle by helping get those 5 or 6 things, and provide a plan of action and call to duty to completion
14:57:35 <VW> yes sir
14:57:46 <mrhillsman> so it is not so much a TC thing but a UC thing
14:58:03 <mrhillsman> and maybe we can push for resources that way
14:58:25 <VW> Ok - I added it to next week's agenda
14:58:28 <mrhillsman> so we have a couple minutes
14:58:35 <zioproto> Thanks for the meeting ! :)
14:58:41 <mrhillsman> we have the doc and updated agenda
14:58:58 <mrhillsman> any other pressing items please update agenda :)
14:59:09 <mrhillsman> thx everyone for making it
14:59:18 <mrhillsman> #endmeeting