16:01:13 <VW> #startmeeting uc
16:01:13 <openstack> Meeting started Wed Feb 28 16:01:13 2018 UTC and is due to finish in 60 minutes.  The chair is VW. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:16 <openstack> The meeting name has been set to 'uc'
16:01:32 <leong> o/
16:01:43 <VW> #chair zioproto spotz leong mrhillsman
16:01:44 <openstack> Current chairs: VW leong mrhillsman spotz zioproto
16:01:54 <aprice> o/
16:02:06 <spotz> \o/
16:02:06 <zioproto> welcome to the UC spotz :)
16:02:10 <VW> fyi - mrhillsman and I are in a room where another conversation is going on, so he may be focused on that
16:02:13 <spotz> thanks zioproto:)
16:02:20 <VW> yes - first off, congrats to leong and spotz
16:02:31 <leong> multitasking... mrhillsman
16:02:37 <leong> thanks VW
16:02:43 <spotz> Thanks VW:)
16:02:51 <zioproto> welcome leong :)
16:02:56 <VW> we'll do more of the formal welcomes, chair elections, etc on Monday
16:03:22 <VW> but we did want to catch the whole team up on conversations to date
16:03:43 <leong> VW: what's the agenda today?
16:03:57 <VW> my thought was we could walk through https://etherpad.openstack.org/p/UC-Rocky-PTG
16:04:03 <VW> at a high level of course
16:04:25 <VW> part of why we set up the meeting was to have a place holder if we needed any votes
16:04:33 <VW> doesn't look like we'll need that
16:04:53 <VW> but we'd love to pass on some key items coming out of the strategic planning sessions
16:05:00 <VW> which reminds me...
16:05:17 <VW> #topic Review UC PTG discussions
16:05:48 <leong> i did read through the etherpad.. looks good to me from a high-level perspective
16:05:56 <VW> cool
16:05:57 <mrhillsman> sorry i'm here :)
16:06:54 <leong> just a few nits when comes into detailed discussion
16:07:12 <VW> so, I think one of the key summary items is that the UC needs to start channeling output from Ops and end users in to more tangible items in the dev process
16:07:37 <VW> for example - can we help get topics at the Ops Mid-cycle translated into forum submissions at the next summit
16:07:38 <leong> i assume that we also need to review UC 2018 Goals in alignment with Boards' strategic focus areas
16:07:55 <VW> yes
16:08:20 <VW> but there seems to be general agreement that the user space across all the SFA's is probably largely shared
16:08:32 <spotz> Can OPs submit for forum sessions and if so do they know?
16:08:33 <VW> so the UC as it is today probably needs to play a role across them all
16:08:39 <VW> They can
16:08:41 <VW> some do
16:09:03 <VW> our hope is that we can help make it all more obvious and successful
16:09:33 <VW> our realistic goals are looking to getting feedback from mid-cycles, OS days and regional meetups into Berlin as forum sessions
16:09:36 <leong> spotz: VW: need to clarify with Foundation staff on how to structure the Ops and Forum session
16:09:51 <spotz> Might be a good superuser article, A hey OPs did you know... and that could be one item
16:10:00 <VW> not sure I follow, leong
16:10:14 <leong> it used to have a Ops "summit" alongside with the normal summit
16:10:25 <VW> ah yes - words are hard :)
16:10:31 <VW> let me try and explain a bit
16:10:39 <aprice> Jimmy is unable to join the meeting today, but I will pass along any notes from the meeting
16:10:49 <VW> thanks aprice
16:10:52 <spotz> Thanks aprice
16:10:57 <VW> and it is being recorded
16:11:09 <leong> let's put that an AR to follow up and clarify with Jimmy (they have been doing a great job!)
16:11:47 <VW> anyway, beginning in Atlanta, we started having sessions co-located with the design summit for Operators
16:12:08 <VW> however, the design summit, itself, changed to the forum in Boston
16:12:25 <leong> VW: do you want to take that AR to follow up with Jimmy? :)
16:12:43 <leong> or i can shoot an email now..:)
16:12:45 <VW> sure - not sure what I'm following up on
16:13:05 <aprice> yeah, im happy to follow up as well, but am confused about the action item
16:13:11 <spotz> Criteria for submitting to the forum I think?
16:13:41 <VW> ah - let me finish the brief history lesson and I think it will make more sense :)
16:14:28 <VW> back in the design summit days, the primary summit sessions were very much about HOW things would be implemented in software.  The conversations in the room were very blueprint and code focused
16:14:55 <VW> it was often hard to feel useful if you were an operator in the room that hadn't been involved in all the dev team work to that point
16:15:31 <VW> with the shift to the Forum model, the focus on the sessions is now more about WHAT the software should do - high level feature/function conversations that aren't too deep in the code
16:15:55 <VW> they should attract both dev and ops looking to discuss these items
16:16:13 <VW> the "HOW" bit now takes place at the PTG
16:16:41 <VW> anyway, to leong's point, it's really more that the old design summits and Ops sessions merged (or got replaced) by the new forum sessions
16:17:05 <VW> there isn't a lot of risk of us driving submissions by Ops/Users colliding with other things
16:17:37 <VW> does that make a little more sense?
16:18:50 <zioproto> the all story you described makes sense to me
16:18:52 <spotz> VW I think it's more of a communication issue of what can be submitted for the Forum and when
16:18:58 <zioproto> it is a perfect summary of the current situation
16:20:07 <VW> spotz: https://wiki.openstack.org/wiki/Forum
16:20:15 <spotz> At least from the OSA side of things we're following what you've described and the few others I've seen prepping for Forums have as well
16:20:44 <VW> what we are trying to do is leverage Ops/user gatherings for the "Brainstorming" portion
16:21:11 <leong> my assumption is that: anyone including ops can propose forum sessions. Today Forum sessions is focus around 3 areas: project-specific, cross-project, and strategic.
16:21:21 <leong> and it is still more "dev-centric"
16:21:31 <VW> and turning common issues, pain, concerns into forum submissions for fixes, features, functions
16:21:37 <leong> i think there should have an area which is more "ops-centric"
16:21:48 <VW> not really
16:21:51 <spotz> leong I think that's a result of OPs not submitting things which goes back to us helping to drive it
16:22:03 <VW> we aren't looking to make ops/distinctions here
16:22:04 <zioproto> spotz: +1
16:22:15 <VW> we are looking to take the concerns of the users and turn them in to change/action
16:22:26 <VW> yeah - +1 spotz
16:22:46 <leong> that's what i am trying to say.. more forum sessions are driven by dev
16:22:53 <VW> ah - yes
16:22:56 <VW> got ya
16:23:32 <VW> cool - so we all are in general agreement that anything we can do as a body to help get more session driven by Ops input, the better things will be
16:23:34 <leong> we need a focus where users can express their needs/requirements and get these into the development priority
16:23:38 <VW> plenty of details to figure out :)
16:23:44 <leong> VW: +1
16:23:51 <spotz> VW +1
16:24:13 <zioproto> VW: +1
16:24:17 <VW> so, leong - that's where we want to really focus things like the mid-cycle and gatherings at the OS days and regional meetups
16:24:28 <VW> these are places where OPs/Users are already gathering
16:24:35 <leong> VW: +1
16:24:42 <VW> and to date, the discussions there don't turn into much tangible action
16:24:57 <zioproto> VW: I would say that we tried to group in the same geo location PTG and Ops Mid-Cycle but Ops community refused the idea
16:25:08 <leong> we have been trying to collect those data from mid-cycle / os days or meetups.. but haven't been very effective
16:25:23 <spotz> zioproto: What was the reason?
16:25:26 <VW> agreed leong
16:25:57 <leong> mrhillsman and I were driving the "etherpad digging and summarized action items"
16:26:05 <mrhillsman> personally i believe the process was too heavy
16:26:19 <mrhillsman> we discussed very simple process during sessions
16:26:29 <VW> let's be careful.  co-locating the Ops-midcycle isn't the way to really push what I am describing above
16:26:40 <zioproto> spotz: Ops felt their importance would be smaller merging their event into the PTG. Ops mid-cycle is a 2 days event. PTG is a full week. Putting the events together in the same place and the same week sounded scary to ops. They were afraid to be overwhelmed by the PTG
16:26:47 <VW> there may be reasons to co-locate in the future for budget/facility reasons
16:27:12 <VW> BUT the forum sessions are the discussions where Ops and Dev in the same room provides the most value
16:27:15 <leong> for information: #link etherpad double-hashtag result: https://github.com/openstack/development-proposals/tree/master/forum/201705-bos
16:27:56 <leong> VW: +1... co-locating is not  a solution
16:28:15 <VW> but it still might need to happen, but we'll table that discussion for now :D
16:28:25 <mrhillsman> ++
16:28:44 <VW> we actually decided to do a little pilot test with the Tokyo meeting next week
16:28:49 <VW> we have two simple goals
16:29:07 <VW> 1.  can we get a list of 3 or 4 key issues that are common to most of the attendess
16:29:12 <spotz> Ok so we've got promoting OPs to submit forum sessions as an action everyone can agree on:)
16:29:41 <VW> the hope is that we, as the UC, can circulate that back to the regional meetups and such to get more feedback and channel to forum sessions by Berlin
16:29:55 * leong unfortunately i won't be attending Tokyo Ops midcycle
16:30:36 <VW> 2.  Since there are some specific tracks in Tokyo (NFV for example), we are going see if we "might" be able to get 1 or 2 direct forum submissions out of the conversations there
16:30:41 <VW> #2 is a long shot
16:31:06 <VW> but if the UC can show that kind of success, it would be a huge win
16:31:18 <VW> none of us will be there leong
16:31:32 <VW> but anne from the foundation is here and will be attending Tokyo
16:31:58 <VW> jamesmcarthur, aprice, mrhillsman and myself have been working with her to try and do some of what I just described
16:31:59 <spotz> VW if we can get the top 1-4 pain points, could the UC submit and drive the coversation?
16:32:09 <leong> VW: i agree with the goal... the challenge is 'how' and 'who' to drive the 3-4 key issues (assuming that not all UC has the relevant domain knowledge in every issues)
16:32:14 <VW> yes, spotz - exactly
16:32:29 <VW> well, leong - that ties in to another part of the etherpad
16:32:46 <VW> better use of regional ambassadors, regional meetups, etc
16:33:15 <VW> We should get that top 4 things in their hands and get input from the users we may not hear from as often
16:33:28 <leong> scratching the etherpad contents is a pain especially if you are not "in that" discussion
16:33:42 <VW> agreed
16:34:08 <VW> but if we can make the ambassadors or meetup leaders more active in the process...
16:34:28 <aprice> we are also hoping that the organizers are going to send a summary as well so that digging through the etherpads are not as much of a pain
16:34:30 <VW> maybe they can translate the conversations into some specifics for us
16:34:34 <aprice> Anne is going to try and help them do that
16:34:45 <aprice> (ops meetup organizers)
16:34:53 <VW> or OpenStack Days organizers
16:35:00 <VW> or meetup organziers
16:35:01 <VW> etc
16:35:16 <aprice> ++
16:35:34 <spotz> I'll try to hit the next Austin meetup, the last one I went to wasn't very OpenStack related
16:35:42 <VW> that's fair
16:35:54 <VW> but what if we had that top 4 list for you to float and get feedback ;)
16:36:09 <leong> aprice: VW: +1 i think we should *kind of* put some guidelines in place and encourage coordinator/organizer to send a summary *with action items*
16:36:26 <leong> when is the next Austin meetup?
16:36:58 <VW> but yes - you guys are totally getting it
16:37:28 <VW> and leong your question is exactly why we want to "test" some of the process with Tokyo
16:37:56 <leong> VW: cool... let;s get that going and sync up with shintaro
16:38:34 <VW> yeah - since he and Chris were online yesterday for the normal Ops Meetup team meeting, we did a preliminary dump of these ideas on them
16:38:40 <VW> they were open to it
16:38:54 <VW> and Anne will help drive things there
16:39:10 <VW> there's a chance we got it all wrong, but we will just iterate on the process based on how things go
16:39:25 <spotz> leong In the next week or 2 I think
16:39:47 <leong> spotz: ok... got it.. you mean to regional meetup... i thought you refer to ops-midcycle :-)
16:40:04 <spotz> leong: Oh no though it would be nice if there was one there:)
16:40:26 <VW> #action spotz confirm next Austin regional meetup date
16:40:45 <spotz> VM MArch 8:)
16:41:04 <VW> #action VW add iterating on feedback loop via Austin meetup to agenda
16:41:37 <VW> we'll try and revisit that on Monday, spotz
16:42:31 <VW> so, the last big thing I wanted to touch on from the PTG etherpad is we may be looking at further defining/expanding the AUC designation
16:44:05 <VW> jamesmcarthur, aprice, lsell, mrhillsman and myself don't know exactly what that looks like yet, but we discussed the need to make improvements
16:44:32 <VW> that's likely to be a recurring topic in our regular meetings
16:45:50 <leong> AUC needs to be reviewed and updated per cycle and published
16:46:01 <VW> right
16:46:15 <VW> we need to figure out to better catch ALL the right folks
16:46:20 <aprice> ++
16:46:25 <VW> and do so as programmatically as possible
16:46:36 <spotz> ++
16:46:44 <zioproto> sounds good
16:47:04 <VW> so tl;dr - the work here has been good, and the UC has a pretty full plate for the next year
16:47:18 <VW> but the foundation is all about helping us be successful in all of the stuff above
16:47:48 <leong> also on how SIG to be included in AUC
16:48:01 <zioproto> again, it looks like enough stuff to justify a Foundation person working in the UC, like there are already Foundation persons in the TC. This was also proposed in the past.
16:48:20 <VW> so that is where jamesmcarthur comes in
16:48:21 <aprice> jamesmcarthur from the Foundation is going to be working very closely with the UC
16:48:27 <VW> the UC isn't the only thing he does
16:48:30 <zioproto> great news ! :) thanks
16:48:35 <VW> but he has been doing a lot for us
16:48:40 <VW> and will continue to
16:49:03 <zioproto> because it takes a lot of time to finalize all this things, and all of us are doing UC out of our core business
16:49:14 <VW> but, zioproto - I can attest to the fact that a lot of the discussions that are in the etherpad included many many Foundation members
16:49:33 <VW> and they are all very interested in helping us accomplish these things
16:49:46 <mrhillsman> ++
16:50:01 <zioproto> VW: yes. But there are some steps that require a single person gathering the material, polish it, and perform an action step
16:50:17 <spotz> I think SIGs and a lot of the ops/user/new folks facing groups should be included for UC. The trouble is weeding through to get the folks who are actually active
16:50:17 <VW> agreed
16:50:30 <VW> right spotz
16:50:38 <VW> we'll talk about it though
16:51:15 <VW> we spent some time on SIGs, but there is still lots of confusion and very mixed opinions about what they are, should they exist, how they should be governed, etc
16:51:17 <zioproto> I mean that we can provide input with these meetings. We can do some actions, but we cannot work 20 or 30% of our time as community managers for the UC. This is why the help from jamesmcarthur  is very welcome
16:51:21 <VW> more stuff for us to spend time on :D
16:51:46 <zioproto> I think this is the same vision also Edgar had in the past
16:52:00 <VW> true zioproto, but we should expect to have to spend some time out side of the meetings, etc working on things
16:52:05 <zioproto> to run the UC it is not enough to work on it 3 or 4 hours per week
16:52:51 <zioproto> that is why it is important to have a person that can spend more time on this actions, finalizing the things, after we provide input and material to work on
16:52:51 <VW> time check - this was supposed to be a quick update and we've gone almost an hour
16:53:11 <VW> anything else we need to discuss today?
16:53:53 <aprice> not from me
16:53:54 <leong> thanks VW
16:54:00 <zioproto> thanks VW
16:54:07 <spotz> I think we covered alot:)
16:54:16 <VW> awesome - thank you all for taking the time
16:54:21 <VW> welcome again, leong and spotz
16:54:33 <VW> will see you all on Monday at 1800 UTC!!
16:54:45 <spotz> Thanks, take care all:)
16:54:48 <leong> have a good day!
16:55:05 <VW> #endmeeting