18:02:08 <mrhillsman> #startmeeting uc
18:02:09 <openstack> Meeting started Mon Mar 19 18:02:08 2018 UTC and is due to finish in 60 minutes.  The chair is mrhillsman. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:09 <jamesmcarthur> o/
18:02:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:02:12 <openstack> The meeting name has been set to 'uc'
18:02:22 <mrhillsman> #chair VW zioproto spotz leong
18:02:23 <openstack> Warning: Nick not in channel: VW
18:02:24 <openstack> Current chairs: VW leong mrhillsman spotz zioproto
18:02:27 <mrhillsman> thx VW_
18:02:38 <mrhillsman> sorry for being so abrupt :)
18:03:06 <mrhillsman> #topic RollCall
18:03:13 <spotz> o/
18:03:29 <mrhillsman> Agenda #link https://wiki.openstack.org/wiki/Governance/Foundation/UserCommittee
18:03:30 <VW> o/ (sort of)
18:04:12 <mrhillsman> will give a minute or two more for others
18:04:38 <leong> o/
18:05:03 <aprice> o/
18:05:05 <ashferg> o/
18:05:16 <leong> i have to drop in 30 mins for another meeting.. my apoloyg.
18:05:46 <leong> sorry that i can't attend last week meeting...
18:06:13 <mrhillsman> thx leong
18:06:23 <mrhillsman> #topic User Survey Changes
18:06:54 <mrhillsman> did you have anything you wanted to cover aprice
18:07:21 <aprice> not right now - I am working on an email to you all about the changes. jamesmcarthur and I will be working through some of the changes this week
18:07:36 <mrhillsman> awesome, thx
18:07:41 <aprice> so that we can begin promoting in April - I will keep the group updated as we move forward :)
18:07:43 <aprice> one thing....
18:08:14 <aprice> at the end of the User Survey, we have PTL specific questions and lsell thought it would be a good idea to get feedback around extended maintenance adn release cycle.
18:08:35 <spotz> That would be a good ides
18:08:41 <aprice> So we will share a draft of that question with the UC before including, but wanted to give yall a heads up since that has been a big topic lately.
18:09:00 <aprice> but other than me needing to send yall info, there's nothing new to cover :)
18:09:04 <mrhillsman> cool
18:09:35 <mrhillsman> there is a TC resolution pretty close to being ratified re EM
18:09:42 <mrhillsman> will be interesting to see responses
18:09:45 <aprice> oh cool
18:10:22 <mrhillsman> #link https://review.openstack.org/#/c/548916/
18:10:31 <mrhillsman> in case anyone does not have
18:11:26 <leong> We probably should send out that link to UC-mailling list to encourage operator feedback on that gerrit
18:11:40 <mrhillsman> it has gone out at least 3 times
18:12:11 <mrhillsman> thierry once, myself twice
18:12:21 <mrhillsman> can definitely do it again though
18:12:38 <mrhillsman> especially since it looks like thierry called for a formal-vote
18:13:01 <mrhillsman> after discussion has been taking place for a couple weeks
18:13:12 <mrhillsman> anything else on the User Survey?
18:13:33 <aprice> that's all from me
18:14:27 <mrhillsman> #topic Formalize UC position on Ops Meet-ups based on PTG discussion output
18:14:43 <mrhillsman> i do not remember what this was re specifically
18:14:55 <jamesmcarthur> So...
18:15:27 <jamesmcarthur> I can probably address this. We're talking about co-locating the Ops Meetup at the PTG.. However, we need to get buy-in from the folks that manage these meetups.
18:15:42 <mrhillsman> ah ok
18:15:46 <jamesmcarthur> Anne Bertucio went as a Foundation rep and there is a lot of resistance to the idea.
18:15:52 <mrhillsman> i remember that discussion :)
18:16:09 <jamesmcarthur> A lot of it is simply a language issue - like it's called teh PTG, not the Ops/PTG meetup
18:16:33 <jamesmcarthur> I'm currently working on an email that I was going to float to mrhillsman and VW for review
18:16:42 <mrhillsman> ++
18:16:43 <spotz> PTG was always a strange name though
18:16:45 <jamesmcarthur> And I'd like to put it in front of a handful of ops to see if we can get buyin.
18:16:46 <VW> sounds good
18:17:04 <jamesmcarthur> I don't think we're quite ready to post to the operators list yet, but that would be the ultimate goal.
18:17:25 <jamesmcarthur> The only real catch here is, we need a decision pretty quickly for the September PTG. We have to have a decision by April 4.
18:17:41 <leong> wasn't there a comment that the schedule can be very squeezy if both Ops and PTG are on the same week?
18:17:43 <VW> yeah jamesmcarthur - we can definitely start socialize it with the Meetup team when you are ready
18:18:04 <jamesmcarthur> leong: yes, it was discussed. I think there is enough downtime later in the week that we can void that.
18:18:31 <jamesmcarthur> The idea would be that Ops and Devs meet in separate rooms, with only a day overlap between the two.
18:18:36 <jamesmcarthur> avoid not void
18:18:39 <mrhillsman> i think from talking with VW that keeping the days events and local meetups as primary places of general discussion, "PTG" as place to work on stuff and have space/overlap to socialize
18:18:47 <leong> i think there are always good and bad to collocate Ops and PTG , but the logistic might be tough..
18:19:12 <jamesmcarthur> leong: i think it's wroth trying in an effort to bridge the divide b/w Ops and Devs
18:19:17 <spotz> Larger numbers would reduce the overhead for both things though
18:19:19 <leong> my undestanding is the core-developers will be busy with their Project and cross-project discussion.. not sure how another Ops session can fit into their already-packed schedule within that week
18:19:28 <jamesmcarthur> sometimes just people sharing dinner and laughs goes a long way to helping build community
18:19:37 <spotz> +1
18:19:44 <aprice> ++
18:19:44 <leong> jamesmcarthur: i totally agree... i am not opposing:-)
18:19:46 <mrhillsman> in my experience i look at a thing like monitoring - i have said this more than one :) - as discussion that happens at midcycle, but no actual "work" for the ops/end-users/app-devs at large comes out of it
18:19:55 <jamesmcarthur> leong: I don't think the current Ops meetups really get any (or very very few) core developers
18:20:01 <jamesmcarthur> So this would at least put them in reach
18:20:08 <leong> i am just thinking how is that going to structure..definitely need to bridge ops and devs
18:20:23 <VW> yeah - the logistics get a little dicy
18:20:36 <VW> but the PTG could use a few more folks to help pay for it
18:20:42 <mrhillsman> ++
18:20:46 <VW> and the Ops mid-cycle could use more love from the Foundation
18:20:52 <jamesmcarthur> VW: leong: the good news here is we get the advantage of using our super smooth Events team from the Foundation :)
18:20:53 <leong> i would like to give that a try... and see how to improve that...
18:20:53 <VW> so practically speaking, this helps both issues
18:21:28 <spotz> I think it'll come down to how it's presented and what it's called
18:21:36 <VW> I was one of the folks who originally opposed, but I have come around ;)
18:21:41 <jamesmcarthur> It might be a dramatic failure, but I have a feeling, based on attending 2 PTGs, that it would be a successful event.
18:21:42 <VW> true spotz
18:21:46 <VW> words are hard
18:21:53 <jamesmcarthur> spotz: ++
18:22:01 <mrhillsman> spotz: ^
18:22:11 <jamesmcarthur> I'm currently writing an encyclopedia to send out to explain it
18:22:29 <VW> cool
18:22:38 <VW> happy to review whenever you think it's ready for that
18:22:39 <mrhillsman> from a practical perspective i know there are devs at the PTG who would love to work on ops things
18:22:55 <mrhillsman> we tend to get some excited parties after the midcycle
18:23:16 <mrhillsman> it has gone down imho from the first one i attended
18:23:33 <leong> so is that something aiming to collocate PTG/Ops in 2019? or the next PTG?
18:23:37 <spotz> I haven't made it to a PTG yet:(
18:23:49 <jamesmcarthur> leong: ideally the next PTG, but it's really up to the Ops organizers
18:23:54 <jamesmcarthur> Which kind of brings up a side point...
18:24:34 <jamesmcarthur> That IMHO, the UC should consider what its involvement is in these meetups.
18:24:57 <jamesmcarthur> Right now, they exist outside of governance. I'm not saying they must be governed, but based on all the other items we've been discussing...
18:25:17 <jamesmcarthur> it's worth considering how we structure these things, along with Ambassadors, User Group Leaders, and OpenStack Days
18:26:08 <ashferg> and we’re also planning a Forum session for all of these groups
18:26:34 <ashferg> We’re also planning to hold a 90-minute session at the Forum with User Group Leaders and Ambassadors to shape goals for the next year. I created an etherpad to collect ideas and topics for the session, so please feel free to contribute, and I’ll follow up with exact timing, because it would be great to have UC representation there.
18:27:05 <ashferg> #link https://etherpad.openstack.org/p/YVR-UG-Ambassador
18:27:22 <spotz> Thanks ashferg I'll definitely try to get there
18:27:35 <VW> "because it would be great to have UC representation there" - s/great/damn near required :)
18:27:42 <mrhillsman> ^
18:27:50 <aprice> :)
18:27:51 <ashferg> ++ :)
18:27:54 <leong> ashferg: i will try to be there if my "travel document" is approved :)
18:28:16 <aprice> VW: subtlety ya know :)
18:28:25 <mrhillsman> preface - words are hard (VW) - but essentially it is the basis of my concern - trying to be pragmatic about things
18:28:36 <VW> totally
18:28:53 <mrhillsman> boiling down to some very simple deliverables and avoid complexity
18:28:54 * leong got to drop..will check irc logs offline
18:28:59 <mrhillsman> thx leong
18:29:06 <spotz> I think it'll be another summit where the only presentation I make it to are those I'm giving or supporting from the audience:)
18:29:06 <VW> I just think the UC see has so much opportunity to create a repeatable way to get user discussion turned in to changes in software behavior
18:29:15 <mrhillsman> ^
18:29:23 <jamesmcarthur> ++
18:29:23 <mrhillsman> and additional tooling
18:29:26 <VW> and the more we commit ourselves to all of these things, the better we will be at that
18:29:51 <spotz> And there's so much stuff that can be shared between groups which probably isn't
18:29:54 <jamesmcarthur> yes!
18:30:45 <VW> yeah - spots - I gave up on summit talks in lieu of design/forum sessions a long time ago.  So much work to be done... :)
18:30:47 <mrhillsman> do/can we have any action items today?
18:30:56 <VW> sorry spotz not spots
18:30:57 <mrhillsman> same here VW
18:31:19 <spotz> hehe VW, it's ok one of the spotted wonders is asleep on my fet
18:31:26 <mrhillsman> oh, speaking of forum, we need to hound people about sessions :)
18:31:32 <VW> I think at least you and I have to be ready to quickly review and provide feedback on jamesmcarthur's encyclopedia
18:31:36 <mrhillsman> the formal tool according to the schedule should open today
18:31:43 <mrhillsman> need to checking with mike p
18:31:48 <mrhillsman> s/checking/check
18:31:54 <spotz> I emailed and got an etherpad going for the Diversity WG, I'll see about getting one going for WoO too
18:32:11 <mrhillsman> eyes and fingers are ready jamesmcarthur
18:32:49 <jamesmcarthur> ok - my editors are reviewing mrhillsman ;)
18:32:50 <spotz> Just be nice to ops, we tend to feel second class:(
18:33:41 <jamesmcarthur> spotz: yeah, we're trying hard to focus on that
18:34:50 <mrhillsman> anything else here? i think we essentially are going to wait for the output from jamesmcarthur and review then circulate and everyone understands the discussion/concern
18:35:25 <spotz> I think we're good
18:35:29 <VW> what's interesting spotz, is the foundation has been pushing for some time now to have Ops/users drive much more of the priority.  No one is really first/second class, but the reality is that we have gone from a world where "hey this is a cool project to dev on" to "hey, people use this @#$% and we should listen to what they have to say about it"
18:36:34 <mrhillsman> ++
18:36:37 <spotz> That's why I think combining is a great idea, get the people in the same room
18:37:09 <VW> yes, but we also need to make sure we honor the intent for the type of work
18:37:34 <VW> the forum is still the best place to get everyone in the same room and have them focus on WHAT the software should do
18:37:37 <mrhillsman> agreed spotz - personally i think we want to help reduce talking to working ratio
18:37:47 <mrhillsman> ++ VW
18:37:59 <VW> we need to keep some dev focused activities at the PTG (or what ever we call it) so they can focus on HOW to make the code do that
18:38:03 <mrhillsman> Forum, OpenStack Days, Local User Groups
18:38:18 <VW> but having the ops and devs in the location at the "PTG" can still reap many bennifits
18:38:18 <spotz> We just need to get the groups to submit topics!
18:38:22 <mrhillsman> "PTG" (newly named/branded) - work :)
18:38:51 <spotz> OpenStack Community Working Midcycle!
18:38:56 <mrhillsman> and we can help there too spotz
18:39:05 <spotz> Keywords added for travel approvals:)
18:39:09 <VW> mrhillsman: you can action me to go over the little bit of feedback from Tokyo to see if there is a "quick win" for submitting something to the Vancouver forum
18:39:10 <mrhillsman> last year i reached out to a lot of the local user groups
18:39:38 <VW> Berlin is still our main goal for the "new" process, but I'd love to score some quick points and advertise the heck out of it if we can
18:39:40 <mrhillsman> #action VW go over Tokyo feedback for some Forum "quick wins"/sessions
18:39:55 <VW> "hey Ops - you talked about X.  Look - we are turning that into action..."
18:40:43 <mrhillsman> i think also we may end up finding sessions we need to have use more than one slot
18:40:49 <spotz> Yeah if we can turnaround and get something in from Tokyo I think it would be a big win
18:41:21 <VW> and ashferg, it would be great if we could help set the agenda, topics for the big session you described above
18:41:23 <mrhillsman> could be worthwhile considering the format/planning of the Forum as well at some point
18:41:58 <ashferg> VW absolutely. would love y’all’s help with that
18:42:01 <mrhillsman> like wrap up sessions for x project(s) at the end in prep for "ptg" or "x event"
18:42:02 <VW> yeah - but that to me will depend on a lot on the overall plan for number of events per year - summits and ptgs - which all sounds very TBD after the fall
18:42:20 <jamesmcarthur> VW: we're definitely planning ot provide a framework for these discussions. I would consider them separate from normal forum sessions And we're also planning on doing the same sessions in Berlin.
18:42:45 <VW> totally jamesmcarthur
18:44:40 <mrhillsman> #topic Open Discussion
18:44:49 <mrhillsman> so we have 15 minutes left :)
18:44:56 <mrhillsman> open mic
18:46:07 <jamesmcarthur> I just flew in from LA and boy are my arms tired.
18:46:20 <mrhillsman> lol
18:46:35 <spotz> oh boy....
18:46:38 <mrhillsman> so on jamesmcarthur's bad joke
18:47:11 <mrhillsman> seems like we can reclaim some time?
18:47:30 <spotz> Yeah
18:47:32 <mrhillsman> #endmeeting