14:59:39 <VW_> #startmeeting uc
14:59:40 <openstack> Meeting started Mon Jul  1 14:59:39 2019 UTC and is due to finish in 60 minutes.  The chair is VW_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:44 <openstack> The meeting name has been set to 'uc'
14:59:55 <VW_> #chair studarus spotz
14:59:56 <openstack> Current chairs: VW_ spotz studarus
15:00:03 <VW_> #topic roll call
15:00:07 <VW_> o/
15:00:10 <studarus> o/
15:00:14 <aprice> o/
15:00:28 <VW_> we'll give folks a couple minutes
15:00:35 <jamesmcarthur> o/
15:01:24 <VW_> #chair belmoreira
15:01:25 <openstack> Current chairs: VW_ belmoreira spotz studarus
15:02:17 <spotz> o/
15:02:43 <VW_> alrighty let's pick up from last week
15:02:55 <VW_> #topic Role of the UC
15:03:23 <VW_> So, jamesmcarthur / aprice - one of you want to re-ask some of the questions that started us last week?
15:03:38 <aprice> sure
15:04:06 <aprice> basically, we wanted to revisit the role of the UC. This lead into a conversation where we can start with a question of "What are the goals of the UC?"
15:04:22 <aprice> then we can drill down into specific activities, but it didn't seem like there was consensus around that question last week
15:05:56 <VW_> so, looks like Belmiro and I put some thoughts in the etherpad
15:05:58 <VW_> #link https://etherpad.openstack.org/p/uc
15:06:23 <VW_> we can start there and see if there are any goals that we are missing (or if anything is on the list we don't agree with)
15:06:24 <belmoreira> my thoughts are more related to activities and the high level goals
15:06:41 <VW_> #chair josephrsandoval
15:06:43 <openstack> Current chairs: VW_ belmoreira josephrsandoval spotz studarus
15:06:52 <belmoreira> for me the s/and/than
15:07:58 <studarus> does outreach and evangelism fall under the UC? basically increasing adoption
15:08:24 <spotz> belmoreira: I don't think you're far off for the high end stuff. That's pretty much been our focus. To some degree we haven't been as in your face as the TC so we're les out there
15:09:48 <aprice> studarus: i think that increasing adoption would be a good goal and if outreach and evangelism get that done, then by all means
15:11:21 <belmoreira> aprice studarus I think that's a good point. But I don't feel that should be UC focus. In my view UC should facilitate communication between technical/users
15:11:52 <belmoreira> adoption should be an OSF goal
15:12:11 <VW_> I see a lot of that, but the relationship of the UC to Ambassadors is a space where I do think the UC plays a role in outreach/etc
15:12:34 <VW_> (have to turn on VPN for a second - might get dropped, but will come back)
15:12:53 <aprice> yeah i think that's a good point belmoreira
15:14:12 <belmoreira> as UC we always refer to users. But what's not clear to me is what a "user" should be for the UC
15:14:40 <aprice> belmoreira: i think that the way we have typically defined it is someone who is operating OpenStack
15:15:13 <belmoreira> end users usually are not aware what is the cloud platform that they are on. At least is my perception
15:15:31 <belmoreira> so for me the focus of the UC should be ops
15:15:36 <aprice> yeah i think that end users is a different community. rather, it's folks who are directly operating the infrastructure
15:16:09 <jamesmcarthur> For reference, here's the way we defined the role of the UC in February 2018 at the Dublin PTG: https://etherpad.openstack.org/p/UC-Rocky-PTG
15:16:38 <VW_> sorry - back
15:17:05 <jamesmcarthur> This document was set up as a set of guidelines for how to move the UC forward.  Very few of the agenda items ever ended up with actions associated.
15:17:37 <spotz> Yeah our users are the operators for public/private/hybrid clouds not like Rackspace customers or people in CERN with a login to do stuff
15:18:10 <jamesmcarthur> spotz: I don't think that's accurate.
15:18:31 <jamesmcarthur> People in CERN and end users of OpenStack clouds are most definitely within the definition of users.
15:18:40 <spotz> jamesmcarthur: Many of those people have no clue what they're hosted on though
15:19:28 <jamesmcarthur> But many do. And for those people looking to give feedback around OpenStack use, they would most definitely be considered a user.
15:19:48 <jamesmcarthur> They consume the APIs that are maintained by our community.
15:19:51 <josephrsandoval> User by definition is broader in scope compared to operators.
15:20:01 <jamesmcarthur> That's why we've always made a distinction b/w operators and users.
15:20:13 <VW_> and it's a fair distinction
15:20:19 <VW_> I do believe the UC represents both
15:20:41 <VW_> often, we bias to that Operators - and that's not bad as long as we view them as speaking on behalf of the end users in many cases
15:20:42 <belmoreira> cloud deployments usually have their own support. Most of my users don't have any idea about OpenStack and no interest to interact with the community. Ops bridge to the OpenStack community
15:22:41 <jamesmcarthur> I've personally been working with Mohammed on problems with OpenStack public cloud and setting up a working load balancer for a simple web environment.
15:22:56 <jamesmcarthur> This is for our setup on Vexxhost for openstack.org and our other web properties.
15:23:16 <jamesmcarthur> It's resulted in more than a dozen patches for Ansible and Octavia.
15:23:52 <jamesmcarthur> So while you're right, not everyone is clued into their environment, a lot of hosting companies use the OpenStack dashboard and people are very familiar with the environment.
15:24:02 <jamesmcarthur> And can offer valuable feedback to teh community.
15:24:12 <jamesmcarthur> Just something to consider.
15:25:54 <belmoreira> jamesmcarthur: I see that as a very particular case
15:26:10 <belmoreira> my experience is that when having issues or suggestions they contact the cloud operators. Couldn't be different because any OpenStack cloud is different. We have ~10k users. Over the years I think we didn't have any ticket opened upstream by an user.
15:27:19 <spotz> We can hope to educate users to want to be on OpenStack I just don't know if we have/should have access to them
15:28:03 <VW_> but again - this body has to be thinking both about stability/ease of operatoins (for operators) and feature/function/east of use (for end users) - whether the later comes directly or via the Ops folks themselves
15:29:19 <belmoreira> VW_ +1. For me this is ops. Because my users pain is my day work pain (support tickets, requests, ...)
15:31:04 <spotz> Agree with that
15:32:56 <belmoreira> in my view if we invest in a strong ops/developers interaction end users will benefit
15:33:17 <belmoreira> and we reduce the scope of our committee
15:37:11 <VW_> So, this is good discussion, but are we narrowing down on agreement/next steps
15:38:55 <josephrsandoval> feels like the scope is narrowing on what the user committee aspirationally should be doing.
15:42:20 <VW_> So, can we commit to updating the thoughts in the etherpad based on this conversation by next Monday?
15:44:28 <belmoreira> but having a narrow/focus scope is not bad. Having a well defined target/mission can help us to accomplish more, considering how few we are.
15:44:43 <VW_> agreed
15:46:36 <VW_> Ok - well in the spirt of time managment
15:47:22 <VW_> #action belmoreira spotz studarus VW_ josephrsandoval update etherpad with thoughts on scope/goals based on today's discussion
15:48:28 <VW_> we can also take the conversation to email, etc
15:48:40 <josephrsandoval> +1
15:48:43 <VW_> #topic Elections
15:49:11 <VW_> regardless of the outcome of all these conversations, we need to get the ball rolling on the elections
15:50:15 <VW_> the following were the dates last year:
15:50:18 <VW_> August 6 - August 17, 05:59 UTC: Open candidacy for UC positions
15:50:19 <VW_> August 20 - August 24, 11:59 UTC: UC elections (voting)
15:52:05 <VW_> We good with August 5 - 16th for candidacy and 19 - 24 for elections
15:52:09 <josephrsandoval> yes
15:52:16 <belmoreira> looks good for me
15:53:03 <VW_> cool - anyone want to volunteer to create the page for it
15:53:31 <VW_> similar to
15:53:32 <josephrsandoval> election window Aug 19-23 if we are following time cadence
15:53:40 <VW_> #link https://governance.openstack.org/uc/reference/uc-election-aug2018.html
15:53:52 <VW_> yes - sorry - typo on my part josephrsandoval
15:55:07 <spotz> Well who wants to lead the election? Easier if they make the page as well
15:57:00 <studarus> Can that be someone from the UC or does it need to be outside?
15:57:27 <VW_> someone not running should be a big driver, but we'll reach out for election officials to run the actual process
15:57:58 <studarus> I'm not running - I can create the page
15:58:22 <VW_> cool
15:58:33 <VW_> we can probably make the call for officials in a week or two
15:58:44 <VW_> #actoin studarus create page for elections
15:58:49 <VW_> #topic other business
15:58:55 <VW_> 35 seconds - go :)
15:59:50 <VW_> Thanks for playing, folks - we'll do it again next week
15:59:56 <VW_> spend some time on the etherpad
16:00:16 <VW_> #endmeeting