09:06:27 <jamespage> #startmeeting upgrade-sig
09:06:27 <openstack> Meeting started Tue May 15 09:06:27 2018 UTC and is due to finish in 60 minutes.  The chair is jamespage. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:06:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:06:30 <openstack> The meeting name has been set to 'upgrade_sig'
09:06:44 <jamespage> #topic decide on regular agenda for meeting
09:06:55 <jamespage> lujinluo: any thoughts on this?
09:07:27 <lujinluo> i had been give this a thought. Remember in PTG, we said we will start with documentations first
09:07:30 <jamespage> with the target group for this SIG, we should aim to try to facilitate comms between operators and developers
09:07:44 <jamespage> lujinluo: yeah I was trying to remember what we discussed
09:07:54 <jamespage> do you have the pad URL handy?
09:08:03 <lujinluo> one second
09:08:17 <lujinluo> https://etherpad.openstack.org/p/ffu-ptg-rocky
09:08:44 <lyarwood> \o
09:08:46 <jamespage> hey lyarwood !
09:08:52 <jamespage> https://etherpad.openstack.org/p/upgrades-sig-meeting
09:08:53 <lujinluo> he lyarwood !
09:08:54 <jamespage> for reference
09:08:57 <lujinluo> hey*
09:09:11 <jamespage> lujinluo and I where just discussing the general structure for this meeting going forwards
09:09:24 <jamespage> but dublin appears to have rrd'ed out of my brain!
09:09:59 <lyarwood> hehe yeah, so what did you have in mind?
09:10:23 <jamespage> I think we need to line up behind the objectives for the SIG
09:10:32 <jamespage> so some standing agenda items to support that would be good
09:10:46 <jamespage> I'd quite like to see a 'deployment project updates' type section
09:10:59 <lujinluo> ++
09:11:20 <jamespage> but  I think the priority is to distill the current pain points out of deployment projects and operators to drive action items into development
09:11:28 <lyarwood> yeah agreed, ops feedback?
09:11:37 <jamespage> yeah that sounds good
09:11:45 <lujinluo> yep
09:12:37 <lujinluo> in the etherpad, shall we separate knowledge sharing and deployment update?
09:12:43 <jamespage> yeah ok
09:13:04 <lujinluo> knowledge sharing is supposed to be from operators, right
09:14:28 <lujinluo> please add Kolla as well! o/
09:14:40 <jamespage> lujinluo: done
09:14:43 <lujinluo> thanks!
09:15:08 <lujinluo> for the knowledge sharing, do we wanna talk with Docs team?
09:15:26 <jamespage> lujinluo: I think knowledge sharing can  be from ops and from devs - sometimes is just that the golden nugget to unlock something has been done - but it  just needs to be drawn out of someones head!
09:15:42 <lujinluo> makes sense
09:15:52 <jamespage> lujinluo: yes but I think that would just to get setup - the Upgrades SIG should drive the documentation process.
09:16:12 <lujinluo> i am thinking about the style, wiki page does not guaranttee reviews
09:16:30 <jamespage> thats true - but it is sometimes a handy dumping ground for content
09:16:32 <lujinluo> if we can set up some branches, we only merge things with people checking on them
09:16:55 <lujinluo> yeah, we need a trade-off
09:17:06 <lujinluo> so maybe we start with wiki pages first?
09:17:34 <jamespage> yeah I think that's what we discussed in dublin - we can move to an 'upgrade-docs' repo later
09:18:04 <jamespage> lujinluo, lyarwood: does that sounds like a plan?
09:18:18 <lujinluo> sounds good to me!
09:18:29 <lyarwood> yeah that's cool
09:18:44 <lyarwood> I don't think anyone has really reviewed the FFU wiki docs provided by ops thus far however
09:18:58 <jamespage> lyarwood: link?
09:19:30 <lujinluo> https://wiki.openstack.org/wiki/Fast_forward_upgrades here you go
09:19:34 <lyarwood> https://wiki.openstack.org/wiki/Fast_forward_upgrades
09:19:36 <lyarwood> yeah
09:19:39 <jamespage> #link https://wiki.openstack.org/wiki/Fast_forward_upgrades
09:20:23 <jamespage> ok - I'll try grab some time between now and next week to take a bit of a review
09:20:33 <jamespage> maybe transform that into an Upgrades wiki
09:20:56 <lujinluo> awesome
09:21:51 <lyarwood> cool, I'll also try
09:22:29 <lujinluo> me too
09:22:34 <jamespage> great - have the slight complication of a charm release to deal with as well but #team can always backfll for me
09:22:57 <jamespage> #action lyarwood, lujinluo, jamespage: review current upgrade docs before summit session next week
09:23:08 <jamespage> speaking of which
09:23:16 <jamespage> #topic Plans for summit session next week
09:23:57 <lujinluo> ohh, Jimmy puts us as presentation. But do we want to do it like a presentation or discussion?
09:24:10 <jamespage> discussion I think
09:24:19 <lujinluo> agree
09:24:25 <jamespage> however I think there is also an upgrade war stories type session right?
09:24:37 * jamespage checks
09:24:45 <lujinluo> there were a couple of upgrade related sessions/discussions this time
09:25:01 <lujinluo> i believe there are 2 FFU specific discussiones
09:25:36 <jamespage> so I see
09:25:38 <lyarwood> well I have a presentation on Thursday
09:25:49 <lyarwood> I wasn't aware of any FFU forum sessions tbh
09:25:49 <jamespage> erik is moderating those
09:25:53 * lyarwood likely missed something
09:25:59 <jamespage> #link https://www.openstack.org/summit/vancouver-2018/summit-schedule/global-search?t=upgrades
09:26:02 <lujinluo> yeah
09:26:14 <lyarwood> ah
09:26:20 <lyarwood> yeah I missed these
09:27:27 <jamespage> ok so do we need a seperate SIG or should we just fold into those sessions?
09:28:00 <jamespage> I suspect if we'd moved on more with the formation of the SIG we'd be a bit more organised with the operator community
09:28:32 <lyarwood> yeah, as we've not made any progress since PTG I'd fold into these sessions if possible
09:28:47 <jamespage> +1
09:28:51 <lyarwood> there could be room for a standalone upgrade (N to N+1) session as well
09:29:06 <lyarwood> but there's no point in repeating things for FFU
09:30:13 <jamespage> so maybe rename our Upgrades SIG to 'Rolling Upgrades BOF'? and ask for a fishbowl setting?
09:30:30 <jamespage> and one of us should reach out to erik to coordinate things a bit more
09:30:39 <lujinluo> +1
09:30:59 <lyarwood> I didn't mean we should replace/rename the SIG, just try to bring erik in for the FFU part
09:31:18 <lyarwood> I'm stepping away from FFU after this summit anyway
09:31:29 <lyarwood> so it would be useful to have him or someone else lead/own it
09:31:41 <lujinluo> we can reach to him and aslo talk about that at the summit
09:32:00 <lujinluo> it'd be good to have an operator on board too
09:32:05 <jamespage> agreed
09:32:32 <lujinluo> lyarwood, sad to hear that you are moving away from FFU
09:32:59 <lujinluo> is it possible that you can attract/invite people who are still working on FFU in TripleO to the SIG?
09:33:10 <jamespage> lujinluo: can you go back Jimmy and get us a fishbowl session
09:33:16 <jamespage> ?
09:33:24 <jamespage> we might be to late but worth a try
09:33:28 <lujinluo> sure, i will send him an email right away.
09:33:46 <jamespage> #action lujinluo ask for fishbowl for forum session
09:34:15 <jamespage> I'll track down Erik and invite him to participate a bit more directly in the SIG
09:34:39 <jamespage> #action jamespage - invite erik m to help with SIG formation and discuss at Forum
09:34:42 <lyarwood> I'll get the TripleO folks more involved as well
09:34:47 <jamespage> lyarwood: thanks
09:34:53 <lyarwood> #action lyarwood - reach out to the TripleO upgrades squad
09:34:59 <lujinluo> thanks
09:35:11 <jamespage> does that just about cover things for today?
09:35:41 <lujinluo> i think we haven't decided on the agenda in summit, or did i miss it?
09:36:03 <jamespage> Hmm no not really
09:36:05 <jamespage> other than
09:36:09 <jamespage> SIG formation update
09:36:19 <jamespage> Fast Forward Upgrades progress
09:36:29 <jamespage> Rolling Upgrades Discussion
09:36:33 <jamespage> or something like that
09:36:43 <jamespage> I think we can do that in a Pad between now and then
09:36:52 <lujinluo> ok
09:37:13 <lujinluo> will update the pad if i come up with anything
09:37:30 <jamespage> lujinluo: do we have one already?
09:37:40 <jamespage> specifically for the forum session?
09:37:43 <lujinluo> not yet
09:37:53 <jamespage> #link https://etherpad.openstack.org/p/vancouver-forum-upgrades-sig
09:37:59 <jamespage> there we go :-)
09:38:09 <lujinluo> ;)
09:38:12 <jamespage> right then - so we need a bit of an agenda between now and next week
09:38:18 <jamespage> I'll discuss with Erik as well
09:38:24 <lujinluo> cool
09:38:31 <jamespage> I think we can probably call that a wrap
09:38:35 <jamespage> #endmeeting