19:02:18 <j^2> #startmeeting user-committee
19:02:19 <openstack> Meeting started Mon Nov 16 19:02:18 2015 UTC and is due to finish in 60 minutes. The chair is j^2. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:23 <openstack> The meeting name has been set to 'user_committee'
19:02:29 <j^2> #chair ShillaSaebi
19:02:30 <openstack> Current chairs: ShillaSaebi j^2
19:02:40 <j^2> anyone else want chair?
19:02:47 <sgordon> nahhh
19:02:56 <ShillaSaebi> maybe SubbuA and jproulx
19:03:01 <SubbuA> That sounds good. Thanks for starting.
19:03:02 <j^2> agenda link? I don't have it infront of me
19:03:09 <amitry> https://wiki.openstack.org/wiki/Governance/Foundation/UserCommittee
19:03:10 <ShillaSaebi> #link https://wiki.openstack.org/wiki/Governance/Foundation/UserCommittee
19:03:11 <SubbuA> Please go for it ShillaSaebi
19:03:13 <j^2> #chair SubbuA
19:03:14 <openstack> Current chairs: ShillaSaebi SubbuA j^2
19:03:33 <barrett> #link https://wiki.openstack.org/wiki/Governance/Foundation/UserCommittee
19:04:08 <ShillaSaebi> ok so there is an agenda posted on the wiki
19:04:14 <ShillaSaebi> lets go ahead and get started
19:04:23 <ShillaSaebi> #topic Administrivia
19:04:27 <SubbuA> This is the first ever UC meeting :) Thanks for ShillaSaebi for joining the UC. Welcome.
19:04:35 <ShillaSaebi> thanks :)
19:04:35 <barrett> +1
19:04:38 <amitry> +1
19:04:39 <SubbuA> Te agenda is at https://wiki.openstack.org/wiki/Governance/Foundation/UserCommittee
19:04:40 <simon-AS5591> +1
19:04:44 <noggin143> +1
19:04:49 <maishsk> WElcome
19:05:09 <jproulx> I'd like to propose we add discussion on Ops Midcycle meetup to agenda (time permitting)
19:05:20 <j^2> #agreed jproulx
19:05:31 <ShillaSaebi> yeah same here
19:05:36 <SubbuA> #agreed jproulx
19:05:45 <maishsk> #agreed
19:05:51 <amitry> #agreed jproulx
19:06:29 <SubbuA> Next item on the agenda is purpose, timing and advertising (?) of this meeting
19:06:44 <ShillaSaebi> does this timing work for everyone?
19:06:55 <barrett> It does for me
19:06:55 <med_> probably for anyone here.
19:07:00 <sgordon> LOL
19:07:01 <rolandchan> Only just.
19:07:05 <maishsk> good for me
19:07:09 <simon-AS5591> +1 (but beware selection bias)
19:07:15 <amitry> +1
19:07:24 <noggin143> ok from europe too
19:07:28 <jproulx> +1 (+bias)
19:07:30 <ShillaSaebi> ok thats great
19:08:02 <rolandchan> when summer time comes to an end in a few months, it'll be a 5am kickoff.
19:08:19 <j^2> rolandchan: coffee is a good friend ;)
19:08:25 <jbryce> tfifield might be one notable exception to the current attendees
19:08:36 <jbryce> on the selection bias front
19:09:01 <SubbuA> ok. We can revisit. Can we discuss the purpose?
19:09:26 <j^2> "A larger cross section of the different usecases for OpenStack"
19:09:30 <j^2> SubbuA: ^^
19:09:52 <lsell> I think overall, we want the User Committee to be a stronger, more visible body that will make a strategic impact on the community - influencing development, helping operators be successful, and better serving the needs of end users
19:09:57 <med_> Use Cases? Or actual usage?
19:10:06 <j^2> med_: good point, actual usage
19:10:14 <med_> +`
19:10:18 <med_> +1
19:10:24 <maishsk> lsell - influencing development?
19:10:50 <lsell> yes, helping to get user feedback into the development process, or even contributing directly
19:11:03 <jproulx> The initial reason for UC was to bring user concerns back to developers
19:11:16 <barrett> I'd add: Foster the collaboration of the UC Working Groups to achieve that end.
19:11:25 <lsell> +1
19:11:30 <jproulx> +1
19:11:51 <jproulx> that's how I believe we are (attempting to) implementing that goal
19:13:05 <SubbuA> Agree with lsell. I would add that the goal is to improve the continuation of a closed loop in the OpenStack ecosystem.
19:13:54 <barrett> I like the "closed loop" element
19:14:03 <j^2> The people on this committee should be represented of the people who actually run and consume openstack, our goal is to voice concerns and viable strategic changes that the consumers need or want. that's why we need to make it bigger than just 3 people
19:14:31 <maishsk> j^2: agreed
19:14:38 <j^2> :D
19:14:51 <SubbuA> Agree j^2
19:14:54 <j^2> the tl;dr: it's the USER committee
19:15:36 <SubbuA> That can be next topic on the agenda, if we choose to spend on that instead of user survey results.
19:15:57 <ShillaSaebi> +1
19:15:59 <jproulx> Shall we discuss expansion then.
19:16:02 <lsell> so as far as the meeting purpose / goals / timing... does monthly seem like the right frequency?
19:16:25 <jproulx> + monthly
19:16:28 <rolandchan> it seems a little infrequent to me, but I'm new here.
19:16:29 <jproulx> +1 that is
19:16:32 <j^2> lsell: i think so until we need more. this should be check in and anything tatical should be used via the ML
19:16:35 <barrett> lsell: depends upon how we define our deliverables, I think
19:16:46 <ShillaSaebi> @rolandchan I think the same thing but I am also new so I'm not quite sure
19:16:56 <maishsk> +1 monthly
19:17:05 <simon-AS5591> +1 monthly
19:17:16 <barrett> rolandchan: +1
19:17:17 <rolandchan> I suppose we can see what happens. if we need more, we can increase tempo easily enough.
19:17:37 <jproulx> exactly scheduling is changable
19:17:52 <j^2> and the ML isn't used at all
19:17:54 <SubbuA> sounds good. Let's stick to monthly for now.
19:17:57 <lsell> i also expect a lot of the work and more detailed discussions will get pushed into the user groups, where a lot of work is already happening :)
19:17:57 <j^2> i can't stress that enough
19:18:48 <sgordon> right
19:18:51 <jproulx> so last piece of that lien item is advertising
19:18:55 <sgordon> many of the working groups are weekly...
19:18:59 <rolandchan> wait what?
19:19:07 <rolandchan> sorry, misread
19:20:14 <barrett> does user group = working group?
19:20:27 <lsell> yes, sorry, i meant working group
19:20:44 <lsell> like product group, large deployments, etc.
19:20:48 <noggin143> user group for me is geographical, working group is topical
19:21:28 <j^2> noggin143: that's a great way to describe it
19:21:29 <SubbuA> Cool. Are we good on the frequency? Can we move to the next topic?
19:21:35 <sgordon> noggin143, +1
19:21:37 <j^2> SubbuA: i think so yes
19:21:58 <ShillaSaebi> yep
19:22:09 <amitry> +1
19:22:19 <jproulx> I thnk working groups meeting weekly (at their own decision) and User Committee coordiantion monthly seems to make sense to me, but if it 's no trequesnt enough we can be more frequent but let's start here at monthly for UC
19:22:25 <SubbuA> #topic uc-expansion
19:22:54 <jproulx> We all agree (I think) that we need more people and bandwidth
19:23:20 <jproulx> question as I see it si shoudl we formally expand with ellected members or informally expand with volunters
19:23:36 <j^2> totally, there needs to be more visiablity of this committee, as i said in tokyo, i didn't know existed till Tom mentioned it to me
19:23:57 <noggin143> +1 for volunteers... helps build a list of people who can contribute
19:24:00 <SubbuA> Can't agree more. There is quite a bit of valuable work is happening in various working groups, and IMO, it is important to make that visible under the UC umbrella.
19:24:19 <amitry> +1 volunteers
19:24:29 <jproulx> +1
19:24:43 <j^2> what's the shortest path to success? There's nothing that we have to set in stone right?
19:24:44 <lsell> notes from the user committee "meta" session in tokyo if helpful: https://etherpad.openstack.org/p/TYO-ops-user-commitee-meta-session
19:24:58 <j^2> #link https://etherpad.openstack.org/p/TYO-ops-user-commitee-meta-session
19:25:09 <SubbuA> thanks lsell - was just going to open that
19:25:45 <ShillaSaebi> ok so we talked about possibly expanding the UC and adding more members
19:25:53 <ShillaSaebi> oops sorry I didnt read above
19:26:28 <ShillaSaebi> do we want to specify how many volunteers we want to start with?
19:26:44 <jproulx> as many as will volunteer :)
19:26:52 <ShillaSaebi> that sounds great to me
19:26:58 <j^2> ShillaSaebi: i think we just open it as a "Looking for Group" type thing see who joins, then who sticks around, then they are our group
19:27:07 <kencjohnston> one point for discussion, if we open it up to volunteers you are going to get folks like me, who are corporately-aligned, representing but not explicitly acting as "users" as some of your volunteer base. Is that a concern?
19:27:23 <j^2> churn is the killer, always the killer
19:27:36 <rolandchan> kencjohnston: not if you're a user.
19:27:46 <kencjohnston> I'd love to volunteer but I'd want to make sure I'm a good/appropriate fit.
19:27:47 <jproulx> So I think this actually comes back to advertising our existence
19:28:09 <kencjohnston> OK, so I guess that is a call for being clear on who we want as volunteers
19:28:43 <j^2> should we take our first major action item is create a doc that explains what type of user we are looking for?
19:28:53 <jproulx> The only place we need to be very careful about who volunteers is with User Survey Working group, but I think that's it's own topic
19:28:54 <kencjohnston> I'm a core member of the PWG btw
19:29:01 <kencjohnston> j^2 +1
19:29:13 <SubbuA> jproulx: certainly. In addition would like to get clarity on the process.
19:29:43 <jproulx> +1
19:30:08 <SubbuA> We discussed the process at the summit, but I don't think we had a conclusive answer.
19:30:25 <noggin143> The user survey group should be VERY distinct. NDA requirements for getting good coverage.
19:30:34 <maishsk> So number of members - shoud be an odd (not even) number
19:30:40 <jproulx> +10^23
19:30:40 <j^2> yeah that is the "elected" group to the user commitee
19:30:56 <noggin143> My understanding of the bylaws is that there is no problem expanding the UC, but need to create a user survey WG with NDA.
19:31:21 <maishsk> A number of questions regarding elections thoug - if we want to go down that route ?
19:31:24 <j^2> noggin143: yep, that sounds fimilar from the meta meeting
19:31:48 <j^2> maishsk: i think we should think about that when we need to, right now we're just trying to reengage
19:31:55 <jbryce> noggin143: that’s correct. there are some constraints on the election piece though
19:32:24 <noggin143> Typical example for me would be Matt Van W who would count as a vendor (Rackspace) but major contributor to ops (e.g. Large Deployments). He should be able to start for the UC but not the survey group.
19:32:30 <jproulx> I thought we'd decided on volunteers rather than election to avoid that complication, but if we do expand by election then there are lots of issues
19:33:14 <egon> an election would tend to be a sub-set of volunteers
19:33:35 <egon> the volunteer pool would hopefully be more inclusive than an election would end up with.
19:33:42 <noggin143> Elections take a serious effort... let's find the volunteers first which also helps to build a manifesto.
19:33:50 <j^2> noggin143: totally
19:33:54 <jproulx> We have an agenda item for "formation of the User Survey Working Group" are we on that now? I feel we've wandered a bit from expantion but onto next topic on agenda...
19:34:19 <SubbuA> jproulx: yes, that's the topic (uc-expansion)
19:34:21 <maishsk> noggin143: agree
19:34:37 <SubbuA> anyone feels that there needs to be elected body?
19:34:50 <j^2> SubbuA: not for the time being
19:34:55 <rolandchan> nup
19:35:04 <maishsk> SubbuA: not yet - but could be necessary down the road
19:35:13 <barrett> nope, think volunteers is the way to go
19:35:20 <maishsk> depending on what ‘klout’ and influence the UC has / comes up with
19:35:21 <SubbuA> so, volunteers it is
19:35:32 <jproulx> +1 maishsk
19:35:52 <SubbuA> Any thoughts on the process we would use for adding volunteers?
19:36:00 <noggin143> +1 SubbuA for volunteers
19:36:40 <j^2> SubbuA: start out with the normal communication channels, or hell open an etherpad and ask people to put their email address on it, and start conversations there
19:37:01 <j^2> then eventually get everyone on the user-committee ML and start the conversations we need to have there
19:37:08 <jproulx> I think for general committee organizational work whoever shows up to these meeting or the mail list is good
19:37:34 <j^2> but the uc-ml requires admin approval, so we don't want to initally have everyone join it, it'll be a flood of work for Tom
19:37:59 <jproulx> we'd discussed not moderating joins to uc-ml
19:38:08 <SubbuA> I suggest (a) an email broadcast, followed by (b) a section on https://wiki.openstack.org/wiki/Governance/Foundation/UserCommittee with the
19:38:21 <maishsk> jproulx: I agree related to the participants on the meetings
19:38:22 <sgordon> so umm dumb question
19:38:23 <SubbuA> list of participants
19:38:27 <ShillaSaebi> I like the idea of adding the volunteers to the wiki page instead of a separate etherpad
19:38:34 <ShillaSaebi> sign up section on the wiki
19:38:40 <j^2> i hope yall see the underlying issue that i'm trying to solve here, there isnt communication between the teams and this committee has the oppertunity to be the cantolist to be that communication so i'm extremely excited to be apart of this
19:38:43 <sgordon> a lot of the WGs already either have their own list or use ops list
19:38:51 <sgordon> and im wondering if more UC comms on the ops list
19:38:59 <sgordon> might solve the visibility issue...
19:39:16 <j^2> ShillaSaebi: you don't want it on the wiki, the edits are blasted and tracked, it'll be a lot of noise
19:39:20 <sgordon> excluding of course those comms that are privileged (survey related)
19:39:25 <jproulx> I don't see value of a list of volunteers. what about when they leave? I think mailing list is enough (though not strongly opposed ot other list)
19:39:38 <rolandchan> +1
19:39:43 <j^2> jproulx: agreed, but the mailing list requires admin approval
19:40:04 <j^2> that's a barrier to entry
19:40:08 <jproulx> I think we shgould change mailing list so it doesn't require approval to subscribe
19:40:10 <lsell> admin approval is pretty easy, or we could just remove it
19:40:19 <jproulx> +1 remove it
19:40:22 <maishsk> j^2: why does it require admin approval?
19:40:35 <j^2> maishsk: no clue, but it does when i signed up for it
19:40:35 <sgordon> maishsk, historical probably
19:41:00 <j^2> lsell: yes, please lets just remove it then we can ask people to join the ML as a sign of them voluenteering to help
19:41:01 <maishsk> I don’t see any reason for keeping it then
19:41:27 <lsell> to sgordon's earlier point, i do think the ops list is where we have critical mass
19:41:41 <SubbuA> so, the consensus is to let folks join the list to volunteer as a virtual expansion of the UC
19:41:43 <lsell> the only issue is that we also want to think about end users, so the intended audience is a bit broader
19:41:44 <noggin143> historically we were worried that the list would be overloaded ... I think this is not such as concern today :-) +1 for auto subscription
19:41:50 <j^2> SubbuA: that seems accurate yes
19:42:07 <jproulx> +1 SubbuA
19:42:11 <j^2> lsell: i think we should look at endusers after we get our feet under ourselves
19:42:57 <SubbuA> We've 18 minutes more. Shall we move to the next topic?
19:43:04 <jproulx> lsell: re ops list we shoudl promote a bit there as Operators are currently the biggest set of users we suppost, but I think we envision representing Users beyond that scope as well
19:43:06 <maishsk> So who takes the action to remove the authorization for the mailing list?
19:43:07 <lsell> j^2: there is already work with the app ecosystem group to start thinking about end users, and i just don't want to send a message that the user committee only serves ops by using the ops mailing list as the point of collaboration. that was my only point...
19:43:29 <lsell> i'll take that
19:43:38 <jproulx> thx lsell
19:43:50 <med_> did you talk about Ops Meetup in Manchester yet?
19:43:53 <j^2> lsell: ah yeah, makes sense. yeah it's one of those things that could be a landmine if not worded correctly
19:43:57 * med_ sees the old subject line still
19:43:58 <maishsk> #action lsell - remove the authorization requirement for the UC mailing list
19:44:18 <SubbuA> med_: that can be the next topic. Do we want to discuss here or continue on ML?
19:44:28 <j^2> SubbuA: ML
19:44:45 <SubbuA> +1 for ML
19:45:07 <maishsk> +1 for ML as well
19:45:20 <med_> wfm
19:45:28 <noggin143> I'm fine with the ML but let's be open to significant meetups outside the US. Constraint being Product WG and PTL attendence which is beneficial.
19:46:27 <simon-AS5591> noggin143 +1
19:46:45 <jproulx> 15 min to go
19:46:47 <maishsk> Or perhaps allow for virtual participation
19:47:02 <SubbuA> noggin143 +1
19:47:08 <amitry> +1
19:47:13 <sgordon> you can still get good dev engagement at least in other locales
19:47:19 <rolandchan> maishk: Any more virtual and we won't actually do anything :(
19:47:22 <sgordon> e.g. cores if not PTLs
19:47:23 <noggin143> or non-PTL but significant member of the team
19:47:49 <noggin143> sgordon _1
19:47:50 <maishsk> rolandchan: :)
19:48:46 <SubbuA> I suggest we let that discussion continue on the ML. Any other topic for the remaining 12 minutes?
19:48:51 <jproulx> Do we ahve any Working group reports for last 12 min?
19:49:03 <rolandchan> Um... survey results analysis?
19:49:12 <jproulx> Ah yes
19:49:48 <rolandchan> Is anyone currently assigned to do analysis?
19:49:55 <maishsk> rolandchan: what kind of analysis?
19:50:05 <rolandchan> any kind would be a good start.
19:50:33 <maishsk> above and on top of what was published in the report?
19:50:45 <rolandchan> yup
19:51:22 <SubbuA> rolandchan: I don't believe there is any such track for additional analysis. lsell ?
19:51:45 <SubbuA> rolandchan: can you be more specific?
19:51:47 <jproulx> what questions would you like to see answered that weren't
19:51:57 <rolandchan> Fundamentally: why?
19:52:06 <maishsk> And for that to happen someone would actually have to have access to the raw data - which I think is not very many at the current ime
19:52:06 <rolandchan> why do the results look they way they do
19:52:19 <maishsk> time*
19:52:22 <noggin143> is this the NPS scores ?
19:52:55 <SubbuA> rolandchan: still not parsing. Can you elaborate?
19:52:56 <rolandchan> yes. what is behind that variance? What do we need to look at next survey?
19:53:45 <jproulx> What do we need to look at next survey? is a function of User Survey Working Group
19:54:07 <rolandchan> what is that working group? I couldn't find it.
19:54:27 <lsell> i think pages 10-13 in the report attempt to dig deeper into the comments and "why" factor https://www.openstack.org/assets/survey/Public-User-Survey-Report.pdf
19:54:29 <rolandchan> Tom's note on the agenda implies it would require formation. ie: it doesn't exist.
19:54:29 <SubbuA> rolandchan: till now, that working group is the UC itself.
19:54:34 <lsell> but there's certainly room for additional analysis
19:54:39 <noggin143> The worry is that there was a swing in NPS ratings.... statistical or trend ? Survey WG will only look once per 6 months
19:54:55 <SubbuA> With the expansion to volunteers, we will need to form a smaller group and have them sign NDAs
19:55:28 <rolandchan> noggin143: yes, but I'd rather not wait another 2 data points before doing analysis.
19:55:59 <noggin143> Propose initial WG those who have signed NDA or are foundation members ?
19:56:11 <j^2> 5 mins
19:56:38 <SubbuA> noggin143: +1
19:56:50 <rolandchan> noggin143: +!
19:56:53 <rolandchan> noggin143: +1
19:56:56 <amitry> +1
19:57:13 <noggin143> Clarify ... Propose initial WG from those who have signed NDA or are foundation staff members ?
19:57:15 <egon> you guys just +1ed an or statement
19:57:25 <maishsk> :)
19:57:41 <lsell> the user experience working group also expressed interest in further comment analysis - the ops question, the what do you like / want improved, and the individual feedback provided to PTLs
19:57:57 <lsell> perhaps we pull them into the survey working group, have them sign the confidentiality agreement and assist with additional comment analysis
19:58:07 <maishsk> Can I make a suggestion - since there are open issues - which we have note addressed - either we continue this on the mailing list or…
19:58:12 <rolandchan> can we at least resolve to do some analysis, and then work out the details on the ML?
19:58:16 <lsell> nps not ops
19:58:20 <maishsk> set up another meeting for two weeks from now.
19:58:43 <j^2> maishsk: i think we should do both
19:58:53 <maishsk> j^2: I concur
19:59:18 <j^2> there's a lot of information flying back and forth, and it's hard to see the threads
19:59:19 <jproulx> <1min remianing s +1 to ML
19:59:22 <med_> Opinion on the ML is consolidating around ONE ops midcycle meetup in Manchester to keep focus.
19:59:24 <barrett> +1
19:59:25 <SubbuA> I suggest we continue the discussion, and have the proposal made on the ML for a new meeting in two weeks.
19:59:43 <j^2> SubbuA: agreed
19:59:44 <SubbuA> I mean continue the discussion on ML
19:59:55 <simon-AS5591> +1
19:59:59 <jproulx> ops mailing list for Midcycle discussion uc list for survey?
20:00:22 <SubbuA> jproulx: +1
20:00:25 <simon-AS5591> jproulx +1
20:00:32 <ShillaSaebi> +1
20:00:46 <j^2> any objections to closing the meeting?
20:01:02 <ShillaSaebi> not from me
20:01:04 <j^2> thanks everyone!
20:01:06 <barrett> bye
20:01:07 <SubbuA> let's close.
20:01:08 <SubbuA> thanks
20:01:08 <simon-AS5591> bye
20:01:10 <j^2> #endmeeting