19:04:37 <ShillaSaebi> #startmeeting User Committee
19:04:38 <openstack> Meeting started Mon Dec 14 19:04:37 2015 UTC and is due to finish in 60 minutes.  The chair is ShillaSaebi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:04:41 <openstack> The meeting name has been set to 'user_committee'
19:04:43 <HeidiJoy> Thank you, I am! Looks like we have Shilla, Jonathan, Shamail and Lauren here - who else for the UC meeting?
19:04:44 <Shamail> Hi!
19:04:48 <rolandchan> Morning all.
19:04:49 <sgordon> o/
19:04:57 <jproulx> I'm rathert franticly trying to pull togatehr me notes & irc meeting cheet sheet
19:05:17 <jproulx> Subu sends his regrets
19:05:23 <HeidiJoy> I'd love a copy of that cheat sheet sometime @jproulx
19:05:29 <Shamail> jproulx: I'll be doing that for product WG and I'll share it with UC
19:05:40 <jproulx> well it's on line somewhere & I'm googling for it :)
19:06:12 <ShillaSaebi> alright
19:06:17 <ShillaSaebi> we can start with the first topic on the agenda
19:06:20 <jproulx> https://wiki.openstack.org/wiki/Meetings/ChairaMeeting
19:06:23 <jbryce> https://wiki.openstack.org/wiki/Governance/Foundation/UserCommittee
19:06:42 <HeidiJoy> Thanks!
19:06:48 <ShillaSaebi> #topic meeting schedule proposed to biweekly
19:06:50 <j^2> hey :D
19:06:50 <openstack> jproulx: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
19:07:05 <j^2> the command is #chair to add another chair
19:07:20 <ShillaSaebi> #chair jproulx
19:07:21 <openstack> Current chairs: ShillaSaebi jproulx
19:07:29 <ShillaSaebi> ok we should be good to go
19:07:46 <jproulx> #topic schedule
19:08:01 <jproulx> proposal to witch to biweekly (from monthly) & have alternating time with 1 APAC friendly
19:08:20 <jproulx> I think we're generally on board with the idea, bu thow shoudl w epick time 2
19:08:46 <Shamail> The proposal makes sense to me, easier to remember.  I would like to suggest someone taking an action item to send out a doodle to poll timing options.
19:09:04 <jbryce> rolandchan seems to be our regular apac participant so maybe let him make suggestions
19:09:43 <rolandchan> I can send a doodle. Do we have enough APAC participants? Split meeting have not worked for diversity..
19:09:43 <jproulx> if rolandchan is willing that sounds like a good idea is he here?
19:10:15 <HeidiJoy> I think the User Committee has enough business & tasks that it warrants biweekly meetings. I'm flexible on time.
19:10:16 <j^2> we'll need to make sure that the intersection of topics are recorded and destributed per meeting. i suggest notes sent out after each meeting per the ML
19:10:29 <ShillaSaebi> +1
19:10:48 <Shamail> rolandchan: +1
19:11:04 <amitry> +1
19:11:06 <j^2> we need a scribe then, that will take responsibility to make the notes and email each meeting
19:11:09 <jbryce> rolandchan: it’s a good point about participation. we could either scratch the idea or try and review after the first couple
19:11:36 <Shamail> I think it's worth trying too
19:12:25 <rolandchan> Ok. Let's see how we go. I'll send a doodle request to the list
19:12:49 <jbryce> #agreed rolandchan to send doodle request for APAC-friendly meeting time
19:13:31 <jproulx> So any other scvheduling before we move topics
19:13:32 <Shamail> Thanks rolandchan
19:14:26 <jproulx> #topic Next steps for Survey analysis
19:15:22 <jbryce> i have to run in a few minutes but i did want to chat about this one
19:15:39 <jbryce> lsell sent out an update about the nps analysis to date
19:15:50 <lsell> i was just pulling the link actually: http://lists.openstack.org/pipermail/user-committee/2015-December/000554.html
19:16:50 <jbryce> i know there’s also been discussion about how useful nps is for us to track. i actually feel like it’s very valuable to have a quantitative metric for trending
19:17:02 <rolandchan> Yep.
19:17:25 <jbryce> nps is definitely not just a brand loyalty tool as stef was sort of pigeon-holing it
19:17:42 <amitry> it is also industry recognized
19:17:58 <HeidiJoy> I'd support continued NPS surveying. I have certification from Satmetrix to administer NPS if we have questions on methodology.
19:18:19 <jproulx> That looks like a good plan to me for the NPS part & I think since we have it we should look, if it turns out not to correlate in any useful way then we can think about discuss dropping it
19:18:34 <j^2> jbryce: at the same time, nps is also extremely tenuious at best to grok. As someone who has seen huge mistakes made because of unfavorable NPS scores they really are hard to use without long term trending
19:18:34 <jbryce> but i agree the number on its own is not the whole story. we’ve actually been digging into and reaching out to the detractors to follow up on their specific circumstances
19:18:50 <rolandchan> Oh? That's great!
19:18:52 <j^2> jbryce: that's great to hear
19:19:02 <jproulx> so you have been doing interviews based on that, that was my next suggestion
19:19:03 <Shamail> I like it (especially having a quantitative value to track) but I do agree that we need to define what we are capturing (segments, deployment phase, etc.) and what will it influence for us.
19:19:27 <HeidiJoy> A big point made in certification is following up with the groups (promoters, neutrals, detractors). It can be more significant than score-tracking, especially for a small survey population.
19:19:44 <Shamail> HeidiJoy: +1
19:19:50 <jbryce> j^2: for sure, i agree. and you have to take into account the make up of your sample
19:20:02 <j^2> jbryce: :D
19:20:36 <jproulx> jbryce: has the foundation also been following up on negative responses in comments aside from NPS?
19:21:18 <HeidiJoy> I think we'd get the most out of additional analysis if we narrowed down the 54 questions asked on the user survey to a handful of questions that we could do multivariant quant analysis on. In the same way we already did analysis on user roles and company size and found no variations there.
19:21:41 <jbryce> jproulx: it depends on where the comments show up. some we follow up on and some we pass on to PTLs or others
19:22:52 <Shamail> I'd like to share that data with the Product WG as well (if it's in a sanitized form)...
19:24:34 <jproulx> HeidiJoy: I think projects used might be relevent but there's so many possible permutations idk of it would just devolve to noise
19:25:04 <sparkyco_> I think it would be interesting to see if version used correlates or shows any trending between versions
19:25:18 <jproulx> sparkyco_ +1
19:25:43 <Shamail> sparkyco_: +1
19:26:51 <HeidiJoy> That would cut ~350 responses by ~25 variables and probably be too small to give us trend data @jproulx. But we could pull ~55 detractors and simply look at which projects they identified, which would not show a trend, but would be useful with their comments as context.
19:28:53 <jproulx> HeidiJoy, sparkyco_ suggestion to cut by version seems like it may yield workable sample size
19:29:45 <HeidiJoy> I agree we can cut by version for a good size. Are there other variables we should look into?
19:30:29 <rolandchan> I don't recall the questions, but whether the respondent had any external assistance would be interesting.
19:30:48 <HeidiJoy> Note that cutting by version has a basis of ~350=deployments only. We have a total answer population of ~1400 for this survey. Would we want to cut by an answer that all respondents gave?
19:31:08 <lsell> I think we should focus on deployments
19:31:15 <lsell> So I'm fine cutting by version
19:32:51 <jproulx> HeidiJoy do you recall if there's a question that relates to external support?  I can't think of one, but you've been liveing much closer to this...
19:33:06 <Shamail> I have to drop off, will catch up on the meeting via log.  Take care.
19:34:02 <HeidiJoy> Roland, yes, we have many questions asking about which vendor is used for specific things. Which do you have in mind? Pointing to a page number in the report is especially helpful in the survey:  https://www.openstack.org/assets/survey/Public-User-Survey-Report.pdf  Page 26-33 reference vendors.
19:36:00 <jproulx> "What packages does this deployment use…?" seems relevent
19:36:26 <sgordon> sort of but even the wording of that is a bit open ended
19:36:28 <HeidiJoy> Jproulx examples are PaaS tools, hypervisors, drivers, etc
19:37:57 <HeidiJoy> 39% of deployments are using vendor distributions, 55% unmodified. So we could look at "which packages does this deployment use?"
19:38:43 <Rolandchan_> The packages question on pg 25 looks like a reasonable start to me
19:39:31 <jproulx> Yes, that's the one I was referencing
19:39:46 <HeidiJoy> So I can go back to the data scientist and cut by that question (page 25) and the question on OpenStack version (page 20) ... anything else?
19:40:19 <sgordon> similarly for "packages you've modified" - which packages
19:40:20 <HeidiJoy> I can also probably do a historical comparison to the prior survey's data.
19:40:30 <jproulx> Just a gut feeling on this but possibly network driver (pg 29)
19:40:44 <rolandchan__> I don't appear to be having much luck with the web client today :(
19:41:24 <HeidiJoy> For this question on page 25, would we want to look at all deployment responses, or only those in production, or those in production + test phase?
19:41:43 <rolandchan__> All I think.
19:41:49 <HeidiJoy> Options are production, dev/QA, and POC
19:43:32 <HeidiJoy> I have to drop off but I will be happy to engage with the data scientist for these additional questions and any more on this meeting string.
19:43:41 <rolandchan__> +1 on @jproulx gut feeling,
19:43:53 <jproulx> thanks HeidiJoy
19:45:12 <jproulx> So I think Survey stuff is covered with further discussion to mailing list, unless anyone has some final comments?
19:45:29 <rolandchan__> I'm done
19:46:03 <jproulx> #topic UC direction
19:46:22 <jproulx> I believe this was j^2 's topic:
19:46:28 <j^2> :D
19:46:29 <jproulx> discuss where we want to take the UC and what we can change
19:46:40 <j^2> that's the short of it yeah
19:47:27 <j^2> the UC has an oppertunity to help the community as a whole
19:47:38 <j^2> we need to empower ourselves to make this happen
19:47:42 <jproulx> One of the things I'm seeing is on https://wiki.openstack.org/wiki/Governance/Foundation/UserCommittee we list a numbe rof working groups and teams.
19:48:33 <jproulx> I wonder how many of the organisers of those know they're listed there :)
19:48:54 <j^2> as the UC do we have representives at each of these WGs?
19:49:23 <jproulx> I don't think so.
19:49:23 <j^2> if not, we should, and we should ask those representives to come back to the UC to report what that WG is doing/deciding
19:50:23 <j^2> unless i'm missing something, but as an openstack community member we need to help where we can, obviously people won't come to the UC so the UC needs to come to them
19:50:24 <jproulx> perhaps we should add a colum to that table on the wiki for 'UC liason'
19:50:34 <j^2> jproulx: +1 love it
19:51:12 <jproulx> then we can try and fill in that blank...
19:51:42 <lsell> +1
19:51:54 <j^2> we should ask for volunteers from this group to fill in those boxes which are most realistily close to their day to day. We are the user committee so something should fall within your skill set
19:52:25 <jproulx> #action jproulx will add a column to 'Working Groups and Teams'  table on the wiki for 'UC liason'
19:52:30 <j^2> and by our next meeting we should have liasons that we can ask to start...liasoning?
19:53:39 <jproulx> j^2 that may be optimistic, but we should at least know which need a liason and which already have active involvement
19:53:47 <rolandchan__> LOL. Liaising :)
19:54:19 <j^2> jproulx: hey sometimes a streach goal is something we need to get involvement ;)
19:55:04 <jproulx> j^2 I'm all for optimism, who wants to take that challenge?
19:55:14 <j^2> it's a challange to the group :D
19:55:21 <maishsk> sorry I am late to the party… :)
19:55:53 <jproulx> whoever liases most gets a gold star?
19:56:00 <j^2> exactly :D
19:56:15 <jproulx> works for me :)
19:56:25 <jproulx> so time check we're at 4 min to go
19:56:33 <j^2> that should definantly be put in the meeting notes, and followed up in the ML
19:56:38 <jproulx> anything we've not covered?
19:57:22 <jproulx> we've not covered who will send meeting notes to ML...any volunteers?
19:57:39 <jproulx> basically clean up irc log
19:58:32 <rolandchan__> I'll give it a shot
19:59:01 <jproulx> thanks rolandchan__
19:59:22 <jproulx> hearing no other topics I think we're at teh end
20:00:00 <jproulx> #endmeeting