15:00:57 <jasondotstar> #startmeeting vahana
15:00:59 <openstack> Meeting started Wed Jan  6 15:00:57 2016 UTC and is due to finish in 60 minutes.  The chair is jasondotstar. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:03 <openstack> The meeting name has been set to 'vahana'
15:01:07 <jasondotstar> #topic roll call
15:01:10 <Ng> .o/
15:01:10 <jasondotstar> o/
15:01:17 <jasondotstar> greetings, Ng
15:01:27 <Ng> hey :)
15:01:54 <jasondotstar> #topic Introduction
15:02:07 <jasondotstar> Again, this is a friendly remeinder that the OpenStack Vahana project
15:02:17 <jasondotstar> We're building an iOS client for OpenStack, in the form of one or more frameworks for interacting with the OS API, and *possibly* front end app
15:02:32 <jasondotstar> #link https://etherpad.openstack.org/p/openstack-mobile-ios-brainstorm
15:02:51 <jasondotstar> Interested parties are encouraged to join the #openstack-vahana IRC channel
15:03:06 <jasondotstar> hopefully, we'll get to a point where I won't have to say that :-)
15:03:18 <Ng> :)
15:03:24 <jasondotstar> #topic Action Items from Last Meeting
15:03:46 <jasondotstar> so, it's our first meeting of the new year
15:04:01 <jasondotstar> lots of ground to cover, if we're to get this truly off the ground
15:04:11 <jasondotstar> guess it's time to kick the tires and light the fires
15:04:24 <jasondotstar> with that let's see where we are today....
15:04:34 <jasondotstar> Ng to make contact with the UX team
15:04:41 <jasondotstar> anything yet?
15:05:10 <Ng> jasondotstar: I have nothing to report, christmas got completely in the way of doing anything
15:05:15 <Ng> but I will have something for next week
15:05:22 <jasondotstar> yeah, about the same here :-(
15:05:32 <jasondotstar> let's put this on the agenda again then
15:05:36 <jasondotstar> #action Ng to make contact with the UX team
15:05:55 <jasondotstar> next one:
15:05:57 <jasondotstar> jasondotstar to make contact with either the infra team or the horizon team to identify use cases
15:06:03 <jasondotstar> I did make contact
15:06:10 <jasondotstar> but there's more discussion to have
15:06:24 <jasondotstar> b/c I really need to capture the use cases in a doc somewhere
15:06:35 <jasondotstar> i mean, we've got the brainstorming etherpad
15:06:47 <jasondotstar> but is there a more 'official' place to put these atm?
15:06:57 <Ng> I don't think so
15:07:01 <jasondotstar> or just capture them there, and then xfr them to a wiki page later
15:07:28 <jasondotstar> i couldn't think of a better place (for now)....ok
15:08:00 <jasondotstar> #action jasondotstar to make progress on capturing use cases on the brainstorming etherpad
15:08:22 <jasondotstar> next up:
15:08:24 <jasondotstar> jasondotstar to chat with -infra about public cloud API testing environment(s)
15:08:47 <jasondotstar> this one needs to simply move fwd.
15:08:57 <jasondotstar> no progress on that ask yet...
15:09:34 <jasondotstar> #action jasondotstar to chat with -infra about public cloud api testing enviros. Report findings at the next mtg.
15:09:55 <Ng> I feel like we should also get a repo :)
15:10:01 <jasondotstar> ype
15:10:03 <jasondotstar> *yep
15:10:09 <jasondotstar> that's on the unassigned task list
15:10:10 <Ng> I can take an action to go and talk to infra about that
15:10:13 <jasondotstar> come up with a list of short-term MVP goals
15:10:20 <jasondotstar> is also there.
15:10:51 <jasondotstar> #action Ng to follow up with -infra about setting up a git repository for the project
15:11:23 <jasondotstar> and I think we can continue capturing the short term goals, which in my mind is basically interfacing with one module at a time
15:11:32 <Ng> +1
15:12:12 <jasondotstar> #agreed Short-term goals are to iteratively work thru interfacing swift with each OS module API
15:12:30 <jasondotstar> we can list those out if need-be
15:12:38 <jasondotstar> cool
15:12:55 <jasondotstar> any other goals we need to add for this week?
15:13:00 <jasondotstar> that's probably a plenty
15:13:04 <jasondotstar> :-)
15:13:13 <Ng> yeah I think that'll do for now
15:13:18 <jasondotstar> +1
15:13:54 <jasondotstar> ok... moving on....
15:13:59 <jasondotstar> #topic R&D
15:14:21 <jasondotstar> for me personally..... the holiday was a friggin' wash. :-/
15:14:33 <jasondotstar> so, Still catching up on my Swift-fu
15:14:57 <jasondotstar> as i said before, I got alamofire working in a playground
15:15:16 <jasondotstar> interfacing with the HP public cloud atm
15:15:20 <Ng> yeah I have a full holiday of zero R&D to report ;)
15:16:04 <jasondotstar> cool. however.... you made a pretty awesome breakthru with the start of the vahana class structure
15:16:21 <jasondotstar> #link http://pastebin.com/Fz9vcbw7
15:17:08 <jasondotstar> using OSV at the class prefix.... do you see any conflicts with that?
15:17:27 <Ng> I don't think so
15:17:30 <Ng> did you have something in mind?
15:17:38 <jasondotstar> nah.. i couldn't think of anything
15:17:55 <jasondotstar> just want to ensure we have a unique namespace i guess :-/
15:18:36 <jasondotstar> OSVIdentity (and the like) I assume isn't used anywhere else... hell Swift isn't used anywhere else for that matter
15:18:49 <Ng> yeah I don't think we're going to clash with anything
15:18:59 <jasondotstar> but i wonder if there are 3rd party libraries
15:19:07 <jasondotstar> (non-OS related)
15:19:18 <Ng> if you're worried, we could just abandon the three letter prefix thing and have VahanaBase, VahanaIdentity, etc
15:19:32 <jasondotstar> nah not really, if you're set, I'm set.
15:19:48 <jasondotstar> i like the OSV distinction
15:20:13 <Ng> :)
15:20:34 <jasondotstar> mmmmmk that's probably it for R&D
15:20:37 <jasondotstar> oh.... wait
15:20:55 <jasondotstar> local dev environment i.e. local devstack
15:22:04 <jasondotstar> wanna see if I can get that working. i have one, but i want to see if i can document how to get the whole environment setup for testing everything locally
15:22:22 <jasondotstar> I'll take that as a personal goal
15:22:41 <jasondotstar> #action jasondotstar to report on documenting a vahana/devstack local test environment
15:22:59 <Ng> yeah that's a good idea, get something we standardise on and make it easier for others :)
15:23:22 <jasondotstar> yeah, that way when ppl decide it's a worthy cause, they can jump right in.
15:24:00 <jasondotstar> any other R&D stuff? (we'll probably finish early today)
15:24:09 <Ng> yeah, one thing
15:24:17 <jasondotstar> ok
15:24:27 <Ng> I'm a little concerned about how we deal with the myriad of possible openstack configurations/setups
15:25:47 <Ng> even in the lowest level classes, OSVIdentity could easily get very complex dealing with all the possible auth setups
15:25:56 <Ng> how would we ever test them all?
15:26:02 <jasondotstar> true
15:26:15 <jasondotstar> is it possible to read in a yaml file or something
15:26:47 <jasondotstar> that way we can have the configurations outside ?
15:27:07 <Ng> perhaps, although ultimately it would be nice if we could discover stuff
15:27:16 <Ng> I'm not sure how reasonable that is though
15:27:20 <jasondotstar> indeed.
15:27:31 <Ng> and digging through python-openstackclient a bit, it's got an awful lot of architecture going on ;)
15:27:49 <jasondotstar> yikes.
15:28:02 <Ng> I sort of feel like we should just get stuck in and get something that works against devstack, before trying to build layer upon layer that can cope with everything
15:28:13 <Ng> against a stock devstack config, I mean
15:28:33 <jasondotstar> small bites
15:28:48 <Ng> yeah
15:28:49 <jasondotstar> +1
15:29:34 <jasondotstar> #agreed working towards getting deals with a stock devstack configuration is the best course of action, prior to dealing with complex configurations
15:29:50 <jasondotstar> damn typos....
15:30:06 <jasondotstar> s/getting/getting something that/
15:30:52 <jasondotstar> any actions to take on this beside looking more into the python-openstackclient (eww)
15:30:54 <jasondotstar> ?
15:31:12 <Ng> I don't think so
15:31:47 <jasondotstar> oki
15:32:11 <jasondotstar> #topic Open Discussion
15:32:32 <jasondotstar> so there's a local ios/cocoheads meetup group here in RTP
15:32:54 <jasondotstar> in the spirit of getting some helping hands, I've asked them to allow me to come to their meetup and present
15:33:02 <jasondotstar> my summit preso
15:33:09 <Ng> nice!
15:33:11 <jasondotstar> in hope to get a couple more folks
15:33:37 <jasondotstar> good group of guys/gals, so we'll see how that goes
15:34:12 <jasondotstar> other than that, that's all I've got
15:35:00 <Ng> I have nothing else
15:35:13 <jasondotstar> cool. well, until next week
15:35:15 <jasondotstar> thanks, Ng
15:35:19 <jasondotstar> Ng++
15:35:25 <jasondotstar> #endmeeting