15:01:05 <jasondotstar> #startmeeting vahana
15:01:06 <openstack> Meeting started Wed Jan 13 15:01:05 2016 UTC and is due to finish in 60 minutes.  The chair is jasondotstar. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:10 <openstack> The meeting name has been set to 'vahana'
15:01:13 <jasondotstar> #topic roll call
15:01:15 <jasondotstar> o/
15:01:16 <Ng> .o/
15:01:22 <jasondotstar> howdy Ng
15:01:28 <Ng> hey :)
15:01:36 <jasondotstar> #topic Introduction
15:02:04 <jasondotstar> Again, this is a friendly reminder that the OpenStack Vahana project
15:02:11 <jasondotstar> We're building an iOS client for OpenStack, in the form of one or more frameworks for interacting with the OS API, and *possibly* front end app
15:02:18 <jasondotstar> #link https://etherpad.openstack.org/p/openstack-mobile-ios-brainstorm
15:02:35 <jasondotstar> Interested parties are encouraged to join the #openstack-vahana IRC channel
15:03:09 <jasondotstar> ok....
15:03:11 <jasondotstar> #topic Action Items from Last Meeting
15:03:22 <jasondotstar> Ng to make contact with the UX team
15:03:36 <Ng> I have (only just) kicked off the process of that
15:03:37 <jasondotstar> this was carried over from last meeting. any movement this past week?
15:03:44 <jasondotstar> that's cool.
15:04:01 <jasondotstar> movement!
15:04:03 <jasondotstar> :-P
15:04:08 <Ng> :)
15:04:17 <jasondotstar> next:
15:04:19 <jasondotstar> jasondotstar to make progress on capturing use cases on the brainstorming etherpad
15:04:29 <jasondotstar> k so, I had to basically *remind* myself what we needed
15:04:40 <jasondotstar> and if you remember, we were going to kick off an Operators survey
15:04:57 <jasondotstar> to see if we can assess what the use cases might be
15:05:18 <jasondotstar> dhellmann agreed to 'support' me wrt being introduced to the user committee
15:05:26 <Ng> nice
15:05:34 <jasondotstar> the folx who run the surveys
15:06:01 <jasondotstar> we spoke briefly yesterday via IRC and he just responded this am in an email.....
15:06:12 <jasondotstar> we're going to try an email to the user committee mailing list
15:06:17 <jasondotstar> (im drafting it now)
15:06:28 <jasondotstar> and then if that doesn't work, he'll 'pinch hit'
15:06:33 <Ng> \o/
15:06:41 <Ng> I think that's a baseball reference?
15:06:45 <jasondotstar> oh yeah
15:06:46 <jasondotstar> lol
15:06:52 <jasondotstar> yes, that is a baseball ref
15:06:54 <Ng> I am so bad at sportsball jargon ;)
15:07:05 * jasondotstar chuckles
15:07:14 <jasondotstar> call in 'air support'?
15:07:17 <jasondotstar> does that work?
15:07:18 <jasondotstar> lol
15:07:28 <Ng> hah, yes
15:07:47 <jasondotstar> sorry, I played CoD some over the holiday....
15:08:07 <jasondotstar> anyway, we'll see how that goes
15:08:26 <jasondotstar> #action jasondotstar to reach out to the user committee via the mailing list regarding the ops survey
15:08:44 <jasondotstar> ok..... next:
15:08:57 <jasondotstar> jasondotstar to chat with -infra about public cloud api testing enviros. Report findings at the next mtg.
15:09:16 <jasondotstar> so I talked to clarkb and mordred yesterday on -infra
15:09:38 <jasondotstar> basically they suggested to use trystack, and/or any other free/publicly available openstack deployment.
15:09:58 <jasondotstar> trystack *does* give me API access
15:10:05 <Ng> oh cool
15:10:07 <jasondotstar> and I'm in the process of trying it out today.
15:10:33 <jasondotstar> I've got the API token
15:10:39 <jasondotstar> but that's abt as far as I've got this am.
15:11:14 <jasondotstar> #action jasondotstar to report on public api testing with trystack
15:11:55 <jasondotstar> ok next up:
15:11:58 <jasondotstar> Ng to follow up with -infra about setting up a git repository for the project
15:12:07 <Ng> #link https://review.openstack.org/#/c/266549/2
15:12:16 <jasondotstar> woooooot! \o/
15:12:31 <Ng> we need to get our project irc channel in order, then it should be good to go
15:12:44 <jasondotstar> very well
15:12:53 <jasondotstar> we can take care of that today if you like.
15:13:08 <Ng> yes please :)
15:13:12 <jasondotstar> ack.
15:13:38 <jasondotstar> I saw that one of the reviewers mentioned applying for Big Tent
15:13:46 <jasondotstar> is that something we need to look at as well?
15:14:11 <Ng> I'm not sure
15:14:30 <Ng> I mean, we dont need it to get a repo
15:14:40 <jasondotstar> +1
15:15:04 <jasondotstar> IIUC, Big Tent is sorta the 'catch-all' place for.... well.... non core module projects?
15:15:27 <Ng> aiui, yep
15:15:35 <jasondotstar> mmml
15:15:39 <jasondotstar> mmmk
15:15:54 <jasondotstar> nothing to worry about now then
15:16:16 <jasondotstar> (unless you suggest otherwise)
15:16:37 <Ng> I think let's get a bit further down the road and then look at it
15:17:03 <jasondotstar> #agreed Wait until the project matures prior to applying for Big Tent
15:17:05 <jasondotstar> ok
15:17:31 <jasondotstar> last action item:
15:17:34 <jasondotstar> jasondotstar to report on documenting a vahana/devstack local test environment
15:17:49 <jasondotstar> not ready yet. progressing, but not ready for prime time.
15:18:28 <jasondotstar> #action jasondotstar to report on documenting a vahana/devstack local test denvironment
15:18:37 <jasondotstar> moving that one fwd to next week's mtg
15:19:03 <jasondotstar> i think that's it for action items from last meeting
15:19:21 <jasondotstar> #topic R&D
15:19:49 <jasondotstar> k so for me, I'm concentrating on getting my AlamoFire/Playground setup
15:19:55 <jasondotstar> to work against TryStack
15:20:45 <jasondotstar> and still consuming the python-openstackclient code
15:21:05 <Ng> I've been fiddling around with my OSVIdentity class a bitm and reading python-openstackclient
15:21:20 <jasondotstar> nothing interesting to report yet
15:21:42 <jasondotstar> cool.
15:22:11 <jasondotstar> although we're iterating through each module
15:22:18 <jasondotstar> im hoping that the results of the survey
15:22:31 <jasondotstar> can give us a use case to poc
15:23:05 <jasondotstar> i.e. if the operators say 'i'd launch/terminate instances from a mobile device'
15:23:15 <jasondotstar> then that's a small poc we could demo
15:23:31 <Ng> yeah that would be cool
15:24:37 <jasondotstar> so I think we may get a clue on things to expose via our client libraries
15:25:02 <jasondotstar> based on things operators indicate are useful to see on a iOS device
15:25:13 <Ng> +1
15:26:15 <jasondotstar> other than that, there's not much else for me to report (yet). I'll get the ball rolling by completing the documentation
15:26:28 <Ng> I have nothing else to report
15:26:28 <jasondotstar> and toying with trystack
15:26:39 <jasondotstar> cool.
15:26:45 <jasondotstar> #topic Open Discussion
15:27:15 <jasondotstar> only thing I have here is that I haven't heard back from the local iOS/CocoHeads meetup group.  Waiting to hear back.
15:27:35 <jasondotstar> they do think it's a worthy topic to bring to the meeting though.
15:28:02 <jasondotstar> so we'll see what happens there.
15:28:24 <jasondotstar> if nothing else..... we can give 30mins back
15:29:00 <Ng> nothing from me
15:29:19 <jasondotstar> cool
15:29:28 <jasondotstar> thanks, until next week.
15:29:44 <Ng> thanks!
15:30:00 <jasondotstar> #endmeeting