15:00:00 <jasondotstar> #startmeeting vahana
15:00:01 <openstack> Meeting started Wed Feb 3 15:00:00 2016 UTC and is due to finish in 60 minutes. The chair is jasondotstar. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:05 <openstack> The meeting name has been set to 'vahana'
15:00:09 <jasondotstar> #topic roll call
15:00:12 <jasondotstar> o/
15:00:26 <Ng> .o/
15:00:30 <jasondotstar> howdy
15:00:49 <jasondotstar> piet: FYI...if you're interested
15:01:00 <jasondotstar> piet: the vahana meeting is happening
15:01:15 <jasondotstar> #topic Introduction
15:01:22 <jasondotstar> This meeting is for the OpenStack Vahana project
15:01:34 <jasondotstar> We're building an iOS-based client for OpenStack, in the form of one or more frameworks for interacting with the OS API, and *possibly* front end app
15:01:44 <jasondotstar> #link https://etherpad.openstack.org/p/openstack-mobile-ios-brainstorm
15:01:51 <jasondotstar> Interested parties are encouraged to join the #openstack-vahana IRC channel
15:02:14 <jasondotstar> #topic Action Items from Last Meeting
15:02:25 <jasondotstar> so i held a solo meeting last week
15:02:36 <Ng> :)
15:02:37 <jasondotstar> #link http://eavesdrop.openstack.org/meetings/vahana/2016/vahana.2016-01-27-15.00.html
15:03:12 <jasondotstar> just went through the motion just to collect a few thoughts in the public I guess
15:03:28 <jasondotstar> so here goes:
15:03:29 <jasondotstar> jasondotstar to continue reporting on the local dev documentation
15:03:49 <jasondotstar> status on this is I've got something worked up.
15:04:03 <jasondotstar> I'm working on generating the documentation from the openstack templates
15:04:17 <Ng> Nice
15:04:22 <jasondotstar> but I'll post what I've got on etherpad later today (few other things on my plate rt nw)
15:05:28 <jasondotstar> it's basically install Xcode. Create a project and incorporate AlamoFire. Create a playground. Profit.
15:05:48 <jasondotstar> trying to make it 'sexy' as possible
15:05:52 <jasondotstar> hehehe
15:06:02 <Ng> ;)
15:06:42 <jasondotstar> #action jasondotstar to publish local dev environment documentation for reviewing
15:06:53 <jasondotstar> ok that's really it from last week
15:07:03 <jasondotstar> #topic Todays Agenda
15:07:42 <jasondotstar> since last week, I've been working closely with the openstackux PTL, piet, on conducting interviews with OpenStack operators
15:07:52 <jasondotstar> we could really use more interviewees
15:08:08 <jasondotstar> Ng: do you know a group of Ops guys at HP that we can poke?
15:08:33 <jasondotstar> #link https://doodle.com/poll/3ehgtqh4kqrtx24y
15:08:48 <jasondotstar> this is the link to where interested parties can sign up to be interviewed
15:09:00 <Ng> jasondotstar: I did, but now that public cloud is shut down, I'm honestly not sure what they're doing
15:09:05 <jasondotstar> the process is very relaxed
15:09:08 <jasondotstar> Ng: ack
15:09:43 <jasondotstar> #action find a few more interviewees to participate in the mobile app use case interviews
15:10:08 <jasondotstar> so we did have a couple guys that we interviewed on Monday over Google Hangouts
15:10:20 <jasondotstar> one was an Ops guy from Intel
15:10:29 <purp> Ng jasondotstar: reach out to Ulf Baumann. He can get you connected to HP Ops folks.
15:10:29 <jasondotstar> and the other was from Best Buy
15:10:37 <purp> Oh, and hi. o/
15:10:42 <jasondotstar> purp: ohai!
15:10:46 <jasondotstar> purp++
15:10:47 <jasondotstar> thanks
15:10:52 <jasondotstar> I'll do that
15:10:55 <Ng> Hey purp :)
15:11:03 <purp> Howdy howdy.
15:11:17 <jasondotstar> #action jasondotstar to reach out to Ulf Baumann to get connected up with the HP Ops folks
15:11:27 <Ng> jasondotstar: any useful initial feedback from those interviews?
15:11:33 <jasondotstar> yes
15:11:38 <jasondotstar> in fact, let's take a look
15:12:03 <jasondotstar> #link https://etherpad.openstack.org/p/mitaka-openstackux-mitaka-mobile-interviews
15:12:27 <jasondotstar> so piet and i put together a few goals, you can read through those.
15:12:49 <jasondotstar> two things right off....
15:13:01 <jasondotstar> first, both interviewees used Android phones :-/
15:13:14 <Ng> Hah
15:13:45 <jasondotstar> secondly, they both felt strongly that alerting and monitoring are the strongest use case for developing something for mobile.
15:13:59 <jasondotstar> one VERY interesting comment
15:14:07 <jasondotstar> was regarding visual programming
15:14:17 <jasondotstar> im paraphrasing here but
15:14:59 <jasondotstar> he basically stated that having a visual programming interface could allow mobile devices to better PRODUCE content
15:15:05 <jasondotstar> as opposed to CONSUMING it.
15:15:19 <jasondotstar> one felt like his mobile device was purely for consumption
15:15:24 <Ng> for programming what?
15:15:35 <jasondotstar> programming was a term he used loosely.
15:15:54 <jasondotstar> programming in my mind, means taking actions from your phone with OpenStack
15:16:02 <Ng> ok
15:16:02 <jasondotstar> launching instances
15:16:06 <jasondotstar> adding storage
15:16:14 <jasondotstar> configuring networking
15:16:37 <jasondotstar> they talked about they return to their workstations (laptop, multi-monitor desktops, etc.)
15:16:48 <jasondotstar> to take action (look at horizon, console in, etc.)
15:17:03 <jasondotstar> he mentioned game programming engines
15:17:09 <jasondotstar> that have visual representations for ACTIONS
15:17:42 <jasondotstar> so having something like that might allow a phone or tablet to perform more actions
15:17:56 <jasondotstar> instead of just looking at mobile-ready monitoring dashboards
15:17:59 <jasondotstar> and receiving alerts
15:18:17 <jasondotstar> s/about they/about how they/
15:18:32 <Ng> so this maybe ties into something that purp suggested last week, which is that we may need a server component to this
15:18:42 <jasondotstar> +1
15:18:53 <Ng> if we're going to be diving around all over the shape of a cloud, that's a heck of a lot of data for a phone to be round-tripping
15:18:56 <jasondotstar> i can almost see tying an alert to an action
15:19:21 <jasondotstar> Ng: +1
15:19:56 <jasondotstar> i thought it was an interesting point that the interviewee brought up on his own
15:20:10 <purp> Very +1. We found it useful to make a set of aggregation and simplification APIs when we launched the original LinkedIn mobile app.
15:20:33 <purp> Also allows you to set up some web views (that aren't Horizon) if you care to.
15:20:42 <jasondotstar> indeed.
15:21:08 <Ng> jasondotstar: it is a very interesting idea
15:21:21 <jasondotstar> I thought so too :-)
15:21:27 <purp> (web views are very fast to iterate, then client lib can access underlying controller)
15:21:51 * purp ducks back out for a meeting. Yay, meetings!
15:21:54 <jasondotstar> i was impressed. I happen to know about Kismet (the visual programming tool in Unreal Engine)
15:21:59 <jasondotstar> purp: thx 4 your input
15:21:59 <Ng> purp: thanks for coming :)
15:22:21 <jasondotstar> he brought that up as an example which is spot on.
15:22:37 <Ng> I do feel like we're now moving slightly further away from having a good idea of what this project is about/for ;)
15:22:43 <Ng> but that is fine at this stage
15:22:53 <jasondotstar> still... most of the convo with both of them centered around alerting/monitoring
15:22:59 <jasondotstar> Ng: +1
15:23:15 <jasondotstar> we talked specifically about how they receive notifications
15:23:20 <jasondotstar> most are using email and SMS
15:23:25 <jasondotstar> or a combination
15:23:36 <jasondotstar> a BIG problem that surfaced
15:23:55 <jasondotstar> was the problem of finding the right SME to respond
15:24:09 <jasondotstar> Ops are in charge of it all. They're on call
15:24:26 <jasondotstar> and an alert pops up. sometimes it's obvious what to do.
15:24:46 <jasondotstar> other times, a better skilled SME and/or a stakeholder needs to be notified of the issue
15:25:10 <jasondotstar> they talked about how long it takes sometimes to find the right person to 'wake up'
15:26:01 <jasondotstar> so having a mobile solution that perhaps knows who the SMEs and/or stakeholders are would be valuable.
15:26:13 <Ng> hmm
15:26:16 <jasondotstar> that's not necessarily an OpenStack problem to solve
15:26:39 <jasondotstar> but, it could be interesting to add some metadata to the monitoring efforts
15:26:53 <jasondotstar> that include a 'persons to alert' field.
15:27:00 <Ng> yeah I think that's out of scope for us, and probably the wider project - monitoring/alerting is like deployment/orchestration, it's too religious and/or site-specific to make official ;)
15:27:25 <jasondotstar> the idea of watch alerting was positive
15:27:57 <jasondotstar> but the two we interviewed saw no issue with pulling out a phone in a meeting or at lunch to react to an alert received
15:28:16 <Ng> but an app that's surfacing state and offering actions, could have customisable actions that do something like "look up this device/service/object in my runbook/cmdb/etc" that lets people find the information they need from their external resources
15:28:44 <jasondotstar> +1
15:29:26 <jasondotstar> on that note, it was also mentioned that it 'Would like to be able to monitor the status of an alert' in a custom temporary dashboard via mobile
15:29:42 <jasondotstar> s/Would like/Would be nice/
15:29:59 <jasondotstar> i.e
15:30:03 <jasondotstar> utilization is high
15:30:18 <jasondotstar> you can quickly get a custom UI that pops up on your phone
15:30:36 <jasondotstar> that monitors that ONE item temporarily until the issue is gone.
15:31:25 <jasondotstar> i thought that one was interesting as well.
15:32:05 <Ng> yeah it is. This stuff all needs to live outside of openstack components though, in that if the issue is with Horizon, and your "show me an alert/issue" stuff is happening in Horizon, you're in trouble :)
15:32:06 <jasondotstar> piet and I began to think if there were ways to interface with some of the monitoring efforts already in play (ceilometer, monasca, etc)
15:32:23 <jasondotstar> Ng: lol
15:32:39 <jasondotstar> Ng: you're in trouble if your alert system is down
15:32:45 <jasondotstar> Ng: +100
15:33:56 <jasondotstar> we could already see a slight pattern
15:34:03 <jasondotstar> between the two guys we interviewed
15:34:17 <Ng> I also think we're blurring the boundaries a little between operators and tenants. Tenants will mostly be talking to openstack APIs, operators have a lot of concerns that are outside of openstack and I'm not sure how we can help involve those things. That doesn't mean it can't be done, it's probably just a matter of plugins that speak to different APIs
15:34:50 <jasondotstar> agreed. baremetal hosts or hypervisors going down
15:35:02 <jasondotstar> Ops care about that moreso than tenants
15:35:13 <jasondotstar> well they care too
15:35:31 <jasondotstar> but the actions taken to resolve it is often coming from the operators
15:35:34 <Ng> yeah
15:36:22 <jasondotstar> i think that it's apparent that whatever we end up with for this project, it appears to be centered around alerting and notification
15:37:00 <jasondotstar> and ***maybe*** mapping actions to alerts in a succinct way
15:37:23 <piet> We're currently running interviews with Ops folks to understand their use cases
15:37:25 <piet> I'm really excited with the ideas being thrown at us.
15:37:44 <jasondotstar> piet: ohai!
15:37:44 <piet> Yep
15:37:45 <piet> Like Android? ;^)
15:37:51 <jasondotstar> hehehehe
15:37:53 <piet> Nb Do you know any tenants?
15:37:53 <piet> Sorry Ng
15:37:54 <jasondotstar> i started off with that
15:37:57 <jasondotstar> :-)
15:38:01 <Ng> for operator use cases at least, I'd like to hear what some tenants think, but it does seem like there would be interest in having some kind of stateful openstack proxy client, that mobile interfaces can consume
15:38:01 <piet> I think the take-away is we need more heads to interview
15:38:03 <piet> Feel free to recruit people via https://doodle.com/poll/3ehgtqh4kqrtx24y
15:38:29 <jasondotstar> yes
15:39:03 <jasondotstar> we need more. i think that the during the Operators Summit we can get a lot of them done in one fell swoop
15:39:14 <jasondotstar> but, the more we can do online, the better.
15:39:23 <piet> Ng Can you describe specifically who the tenants are? Are these the folks that have a tenant/project within OpenStack? Likely worried about adding people and quotas?
15:40:06 <Ng> piet: yeah so the people who are consuming an openstack installation purely via its APIs. They talk to nova and launch instances of their applications, cinder/swift to attach their storage to instances, or store things, etc, etc.
15:40:07 <jasondotstar> IMHO, it's customers consuming openstack
15:40:20 <Ng> they never get to see behind the curtain of what is powering their cloud, they just consume it
15:40:24 <jasondotstar> piet: what he said :-)
15:41:03 <jasondotstar> perhaps there is a way to spin this
15:41:06 <Ng> I think I had originally envisioned that we'd be of more use to tenants, but that may not be the case at all
15:41:08 <jasondotstar> as an app for tenants?
15:41:25 <jasondotstar> Ng: damn, we're on the same wavelength
15:41:28 <jasondotstar> :-)
15:41:32 <Ng> :)
15:41:45 <jasondotstar> that could be interesting
15:41:54 <jasondotstar> especially in the spirit of DevOps
15:42:28 <jasondotstar> having an app where tenants can *somewhat* share the responsibility of their compute resources
15:43:14 <jasondotstar> Operators have multiple ways to be nagged by monitoring systems and failed health checks
15:43:50 <jasondotstar> in addition to providing a metering dashboard to tenants, maybe there's a way to provide alerting directly to the tenants
15:43:58 <jasondotstar> thinking aloud here...
15:45:12 <piet> Ng We kind of make a distinction between end users, tenant admins and DevOps.
15:45:35 <Ng> interesting
15:46:57 <jasondotstar> piet: true. but in true DevOps fashion, it's about having Devs (end-users consuming openstack) and Ops (admins who maintain the stability of openstack) work together
15:47:10 <jasondotstar> the whole 'Make Devs carry pagers' paradigm
15:47:36 <piet> Ng End Users and DevOps are slightly different skillsets. Also, DevOps seems to be a bit of a unicorn
15:47:47 <jasondotstar> it is
15:48:04 <jasondotstar> there's difference in perception across the board
15:49:05 <jasondotstar> still, perhaps theres some merit around offering tenants metering, alerting, and notifications from their resources directly via mobile
15:49:27 <piet> Also, Domain Admins typically manage the relationship w the cloud provider and are typically concerned with budget
15:49:44 <jasondotstar> +1
15:50:14 <jasondotstar> perhaps we've got more questions to add :-)
15:50:42 <jasondotstar> or another demographic to interview... tenants.
15:51:17 <jasondotstar> GOOD dialogue here, this is awesome.
15:51:32 <jasondotstar> let's move to the final 10 mins of the meeting
15:51:37 <jasondotstar> #topic Open Discussion
15:52:02 <jasondotstar> we can continue or if there's anything else we need to bring up please... floor is yours
15:52:33 <piet> I need to sneak out early to get ready to interview someone for another project
15:52:38 <Ng> I have nothing but questions now :)
15:53:13 <jasondotstar> piet: hey thx! i'll work on getting a few more ppl b4 ops summit
15:53:34 <piet> K - we need to hammer on Fifield to get a space
15:53:39 <jasondotstar> piet: we DO
15:54:06 <piet> Sent him and email, but he likes to ignore
15:54:07 <jasondotstar> follow up today
15:54:12 <jasondotstar> I will
15:54:18 <jasondotstar> sorry i sound like yoda
15:54:27 <Ng> haha
15:55:00 <jasondotstar> #action jasondotstar to follow up with fifield on getting some space at the ops summit
15:55:18 <jasondotstar> cool. I'll give you guys five mins back if nothing else
15:55:23 <Ng> :)
15:55:25 <jasondotstar> thanks piet, Ng, purp
15:55:32 <Ng> thanks all :)
15:55:38 <piet> Cheers
15:55:41 <jasondotstar> #endmeeting