15:00:32 <jasondotstar> #startmeeting vahana
15:00:37 <openstack> Meeting started Wed Feb 10 15:00:32 2016 UTC and is due to finish in 60 minutes.  The chair is jasondotstar. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:44 <openstack> The meeting name has been set to 'vahana'
15:00:44 <jasondotstar> #topic roll call
15:00:45 <jasondotstar> o/
15:00:47 <Ng> .o/
15:00:50 <jasondotstar> howdy
15:01:01 <jasondotstar> this will probably be a short one today
15:01:07 <jasondotstar> #topic Introduction
15:01:40 <jasondotstar> This meeting is for the OpenStack Vahana project
15:01:45 <jasondotstar> We're building an iOS-based client for OpenStack, in the form of one or more frameworks for interacting with the OS API, and *possibly* front end app
15:01:54 <jasondotstar> #link https://etherpad.openstack.org/p/openstack-mobile-ios-brainstorm
15:01:59 <jasondotstar> Interested parties are encouraged to join the #openstack-vahana IRC channel
15:02:10 <jasondotstar> #topic Action Items from Last Meeting
15:02:20 <jasondotstar> #link http://eavesdrop.openstack.org/meetings/vahana/2016/vahana.2016-02-03-15.00.log.html
15:02:44 <jasondotstar> jasondotstar to publish local dev environment documentation for reviewing
15:03:00 <jasondotstar> I've got some sphinx stuff to work out
15:03:17 <jasondotstar> been busy with other stuff so I haven't revisited this :-(
15:03:32 <jasondotstar> #action jasondotstar to close out on the local dev documentation
15:03:42 <jasondotstar> next one:
15:03:45 <jasondotstar> find a few more interviewees to participate in the mobile app use case interviews
15:03:58 <jasondotstar> we did have a chance to interview one yesterday
15:04:14 <jasondotstar> and I think that we've got a couple more lined up
15:04:27 <Ng> cool :)
15:04:35 <jasondotstar> piet: thx for lining up the one's we've had so far
15:04:36 <Ng> anything interesting come out of the one yesterday?
15:04:40 <jasondotstar> yes
15:04:44 <jasondotstar> couple things
15:04:52 <jasondotstar> #link https://etherpad.openstack.org/p/mitaka-openstackux-mitaka-mobile-interviews
15:05:13 <jasondotstar> first, this was our first Apple iOS user
15:05:19 <jasondotstar> \o/
15:05:31 <Ng> :)
15:05:35 <piet> Yep..I think there are some opportunities based on the feedback.
15:05:52 <jasondotstar> we heard this:
15:05:56 <jasondotstar> COULD BE HELPFUL to have a mobile-friendly dashboard that specifically tracks an area of concern
15:06:10 <jasondotstar> COULD BE HELPFUL to have the ability to narrow down dashboard views and push those views to your mobile device
15:06:20 <piet> I would be careful about developing for iOS, though.
15:06:27 <jasondotstar> NOT AS HELPFUL to worry about mapping alerts to interested parties
15:07:23 <jasondotstar> piet: +1 right now the majority of the interviewees have been android  users
15:07:47 <piet> There is also a conversation around whether a mobile app would be more helpful for end users than operators.  This is also based on a set of interviews that we've done with end users.
15:07:47 <jasondotstar> i think we've seen a pattern
15:07:55 <jasondotstar> piet: +1
15:08:31 <jasondotstar> the pattern is that operators have legacy monitoring systems that they have become accustom to
15:08:53 <jasondotstar> so dealing with notifications from their current monitoring systems via email and SMS
15:08:58 <jasondotstar> is how 'everybody is doing it'
15:09:32 <piet> A couple of other things.  I do know from other interviews that end users rarely go into Horizon after creating a VM.  They definitely don't use it for monitoring.  The only exception may be quotas.
15:10:27 <piet> BTW. quotas are a problem for operators because you can have a gazillion tenants and it becomes challenging to manage requests for more quota.
15:11:16 <jasondotstar> to piet's point
15:11:39 <jasondotstar> it has become apparent that *maybe* this effort would be better rec'd by tenants (i.e. customers)
15:12:22 <jasondotstar> instead of this being a companion app used by operators
15:12:32 <jasondotstar> perhaps it's better to offer this to tenants
15:12:39 <jasondotstar> piet: any thoughts you want to add on this?
15:12:43 <Ng> I think that makes a good deal of sense
15:12:50 <piet> Do you mind if I through a potential use case at you?
15:12:57 <piet> "throw"
15:13:18 <jasondotstar> go for it
15:14:34 <jasondotstar> piet: ^
15:14:40 <piet> Note that I need to find an etherpad for you where we asked then to identify improvements that were need over the next year.
15:15:04 <piet> The end user is running a bunch of VMs in a tenant.
15:16:34 <piet> S/he receives an alert on their phone that says "Hey, you are about to exceed the number instances allowed in your tenant! Would you like more?" [Yes] [No]
15:18:04 <piet> The operators receives an alert on their phone that says "Tenant A is requesting more instances! Would you like to approve?"  [Yes] [No] [Ask me later]
15:18:08 <jasondotstar> I'm with ya
15:18:39 <jasondotstar> I like the idea of having quick interactions between the customer
15:18:41 <jasondotstar> and the operator
15:19:34 <piet> Yep - and you can build on it - like adding a graph to show usage or previous requests.
15:19:43 <jasondotstar> very valuable and not 'too much'
15:19:53 <jasondotstar> Ng: thoughts?
15:20:56 <Ng> it sounds like a useful feature. I'm not sure how it would all be wired up though
15:21:15 <jasondotstar> ceilometer?
15:21:42 <jasondotstar> one other thing too (as far as wiring)
15:21:59 <jasondotstar> most of the folks we interviewed are supportint private cloud deployments
15:22:04 <jasondotstar> i.e behind the firewall
15:22:22 <jasondotstar> so an app would have to have access
15:22:57 <jasondotstar> to the 'pipeline' that gives us the data we would parse to figure out how/when to send notifications to the tenant and/or operator
15:23:20 <jasondotstar> another item to think about
15:23:38 <jasondotstar> s/supportint/supporting
15:24:29 <jasondotstar> #agreed it could be useful to provide a mobile application to the tenant/customer audience versus operators
15:26:42 <jasondotstar> #agreed another useful feature could be the combination of alerting the tenants on important 'happenings' and giving them the opportunity to communicate directly with the operators supporting their infra
15:26:54 <jasondotstar> any other thoughts?
15:27:37 <jasondotstar> multi-tasking a bit sorry for the delay
15:27:57 <jasondotstar> ok next:
15:27:57 <jasondotstar> jasondotstar to reach out to Ulf Baumann to get connected up with the HP Ops folks
15:28:10 <jasondotstar> sending this out today
15:28:13 <piet> I like the idea of facilitating communication  and the quotas use case would be a good place to start.
15:28:20 <jasondotstar> +1
15:28:32 <jasondotstar> very narrow field use case
15:28:40 <piet> Need to run - have a good day or evening!!
15:28:57 <Ng> thanks piet :)
15:29:08 <jasondotstar> yes, thanks
15:29:16 <jasondotstar> next:
15:29:17 <jasondotstar> jasondotstar to follow up with fifield on getting some space at the ops summit
15:29:26 <jasondotstar> ok so we followed up on this
15:29:36 <jasondotstar> we rec'd a response
15:30:29 <jasondotstar> but IMHO, i think his response was saying that this isn't the appropriate venue to talk about iOS libraries to operators
15:31:09 <jasondotstar> so i sent another email saying., "well, this is more the audience of ppl that we want to interview to validate that this is something that operators find valuable'
15:31:47 <jasondotstar> long story short - I've got travel booked to go.
15:31:57 <piet> Its somewhat problematic for me because Ops Summits and the larger Summit are perfect venues for user research
15:32:13 <jasondotstar> if we don't get the facility to run the focus group
15:32:19 <jasondotstar> there's no need for me to go.
15:32:27 <jasondotstar> so i hope we hear something today.
15:32:34 <piet> A lot of education needs to happen in the community which may need to be driven by the foundation
15:33:06 <jasondotstar> piet: +1
15:33:52 <jasondotstar> mobile is inevitable. but i have to adhere to the data we're collecting from the operators we've interviewed
15:34:05 <jasondotstar> it's not *as* important to them
15:34:29 <jasondotstar> so this customer/tenant/end-user angle might be better rec'd.
15:35:29 <Ng> I think broadly speaking tenants is the place to aim, although that slightly conflicts with the initial proof-of-concept working against the Ironic plugin
15:36:40 <jasondotstar> +1
15:37:20 <jasondotstar> i do think that putting together a POC is the way to prove to operators that there is value there, tho.
15:37:52 <Ng> yeah that may well help, but either way, I think it's still valid as a demonstration that we can do something useful in front of a service that aggregates data from the service APIs
15:38:12 <jasondotstar> sometimes all they need to do is see it
15:38:21 <jasondotstar> right
15:38:35 <jasondotstar> we can keep pushing on that
15:38:52 <jasondotstar> while we continue to interview ops and end-user types...
15:38:57 <jasondotstar> ok
15:39:04 <Ng> I'll take an action to keep talking to beth about ideas and progress
15:39:27 <jasondotstar> #action Ng to continue conversations with Beth regarding the Ironic plugin effort
15:39:32 <jasondotstar> good deal
15:39:34 <Ng> and try to get some more info about the shape of her plan, timescales and suchlike
15:39:51 <jasondotstar> +1
15:40:05 <jasondotstar> ok
15:40:15 <jasondotstar> that's all I've got at the moment
15:40:22 <jasondotstar> #topic Open Discussion
15:40:36 <jasondotstar> anything else worthy to bring up at this point?
15:41:00 <Ng> I don't think so, I feel like we're in limbo at the moment, so I haven't been doing very much R&D work, because I have no idea what will be useful
15:42:53 <jasondotstar> yeah
15:43:11 <jasondotstar> most of my work around this has been trying to narrow down what that 'golden nugget' is going to be
15:43:37 <jasondotstar> still, if we make sense of this ironic plugin idea
15:43:46 <jasondotstar> perhaps that will give us something to work on in tandem
15:44:36 <jasondotstar> alrighty....
15:44:47 <jasondotstar> thanks all - piet, Ng
15:45:04 <jasondotstar> we'll give the chan 15mins back
15:45:24 <Ng> thanks all :)
15:45:25 <jasondotstar> going once, twice?
15:45:32 <jasondotstar> thanks again.
15:45:35 <jasondotstar> #endmeeting