09:00:46 <ifat_afek> #startmeeting vitrage
09:00:47 <openstack> Meeting started Wed Jan 20 09:00:46 2016 UTC and is due to finish in 60 minutes.  The chair is ifat_afek. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:50 <openstack> The meeting name has been set to 'vitrage'
09:00:55 <nadav_yakar> hi
09:00:55 <emalin> hi
09:00:56 <eyalb> hello
09:00:57 <ifat_afek> hi everyone
09:00:58 <omer_etrog> hi
09:01:11 <alexey_weyl> hello
09:01:17 <lhartal> hi :)
09:01:24 <idan_hefetz> hello
09:01:26 <elisha_r> hi
09:01:49 <emalin> hello lhartal
09:03:24 <amir_gur> Hi
09:03:50 <emalin> hi amir_gur
09:04:12 <emalin> long time no see
09:05:02 <ifat_afek> Today’s agenda:
09:05:09 <ifat_afek> * Current status and progress
09:05:17 <ifat_afek> * Review action items
09:05:23 <ifat_afek> * Next steps
09:05:31 <ifat_afek> * Open Discussion
09:05:40 <ifat_afek> #topic Current status and progress
09:05:53 <ifat_afek> I’ll start with my updates
09:06:02 <umargolin> Hello
09:06:09 <ifat_afek> I finished writing down our design of the vitrage graph, and some use cases. I sent the link to everyone, and put it also in vitrage page.
09:06:24 <ifat_afek> #link https://github.com/openstack/vitrage/blob/master/doc/source/vitrage-graph-design.rst
09:06:25 <emalin> \exit
09:06:45 <ifat_afek> Last week, after our discussion regarding get topology API, I sent a detailed response to PinPoint. Yesterday I sent them also our documentation (graph design, synchronizer design and get topology api blueprint). I asked them to review our blueprint.
09:06:56 <ifat_afek> eyalb, can you explain about the changes in get_topology API?
09:07:10 <eyalb> yes
09:07:43 <eyalb> I added two new api requests after looking at pinpoint use cases
09:08:00 <eyalb> one is resource show with id
09:08:23 <inbar_stolberg> hi
09:08:44 <eyalb> which will give all data known to us in the entity graph for a resource
09:09:04 <eyalb> second is resource list
09:09:21 <Danoffek> Hi
09:09:27 <eyalb> which will list all resources in the entity graph even if not connected
09:09:47 <eyalb> an optional flag will be to filter it by resource type
09:09:48 <ifat_afek> eyalb: you mean return a list and not a connected graph?
09:09:55 <eyalb> yes
09:10:21 <ifat_afek> eyalb: so we are waiting for PinPoint to approve the api definition
09:10:27 <eyalb> yes
09:10:58 <ifat_afek> eyalb: ok, thanks
09:11:02 <ifat_afek> Regarding Aodh, I had a long talk with Gord in their IRC channel. Apparently we won’t be able to get their notifications in the message bus
09:11:17 <ifat_afek> I need to go over what he told me, and hopefully write down aodh blueprints and ask them to review
09:11:41 <ifat_afek> Note that our integration with aodh won’t be ideal... we will do the best we can with their current design
09:12:00 <ifat_afek> alexey_weyl, can you update about the status of the integration and the demo that we had?
09:12:23 <alexey_weyl> the integration finished
09:12:35 <alexey_weyl> we have all the steps working
09:12:46 <ifat_afek> cool!
09:12:50 <alexey_weyl> from the horizon ui to the vitrage api and to the handler api
09:13:07 <alexey_weyl> we will upload a demo today to our site
09:13:13 <alexey_weyl> recommended to all
09:13:33 <ifat_afek> alexey_weyl: great, you can send it to everyone
09:14:34 <alexey_weyl> and we also need to send the demo to pinpoint as well as promised
09:14:45 <emalin> alexey_weyl: great job !!!
09:15:14 <lhartal> alexey_weyl: good job :)
09:15:17 <ifat_afek> alexey_weyl: great, the demo is a major milestone
09:15:45 <ifat_afek> emalin, can you update about the synchronizer progress?
09:16:26 <emalin> yes
09:17:08 <emalin> The synchronizer has it's own initator which launch all needed services/process
09:17:33 <emalin> Currently their is snapshot collector that run get_all every x time
09:17:38 <emalin> x is configurable
09:18:50 <emalin> We still need to take user credentials from config
09:19:32 <emalin> I mean currenltly it's hard coded, and later we will take it from config file
09:19:40 <emalin> That's it
09:19:47 <ifat_afek> emalin: thanks
09:19:51 <ifat_afek> mkoushnir_, can you update about the tempest tests?
09:22:02 <adami_toga> emalin, what would you expect x to be? just to get a sense of the time scales...
09:23:56 <alexey_weyl> X at the moment is expected to be 15 menutes
09:24:26 <adami_toga> ok, thanks
09:25:43 <ifat_afek> I think mkoushnir_ is having technical problems. let's get back to her later
09:25:46 <ifat_afek> omer_etrog, what is the ui status?
09:27:14 <omer_etrog> We had progress in the information panel
09:27:34 <omer_etrog> next step is to add labeling in the sunburest
09:28:29 <omer_etrog> That's it
09:28:32 <ifat_afek> omer_etrog: ok, thanks
09:28:58 <mkoushnir> Sorry, problem with connection
09:29:01 <mkoushnir> I opened the sub project topology in the vitrage tempest folder and writing now base class for the topology api test. also added vitrage.conf - the configuration file for local devstack
09:29:24 <elisha_r> cool
09:29:29 <ifat_afek> mkoushnir: great, this is a great start
09:29:41 <ifat_afek> who else wants to update?
09:30:30 <idan_hefetz> as for my update
09:30:55 <idan_hefetz> The graph driver blueprint is mostly done, except the SubGraph Matching implementation..
09:31:21 <ifat_afek> idan_hefetz: we should consider splitting this blueprint to two blueprints
09:31:22 <idan_hefetz> i'll start working on this just need to make sure the requirements are clear
09:31:45 <idan_hefetz> i can split it if we want
09:32:08 <ifat_afek> idan_hefetz: ok, thanks
09:32:10 <lhartal> I think we should consider it as part of the evaluator design
09:32:22 <ifat_afek> lhartal: right, that's what I thought too
09:32:45 <ifat_afek> lhartal, any updates on your side?
09:32:48 <lhartal> I have also updates
09:33:01 <lhartal> I’m working on a new idea for the transformers
09:33:25 <lhartal> Overall, the idea is that the transformers will be defined in YAML file and Vitragw will be able to load those config files and by one transformer engine to parse the sync events
09:33:49 <alexey_weyl> Great! sounds good!
09:33:50 <lhartal> This is a solution for a problem that we have of cyclic dependencies between the transformers
09:34:06 <alexey_weyl> this will help us in the future for making plugins to vitrage easier
09:34:15 <ifat_afek> lhartal: cool. I know aodh are doing transformations by configuration files as well (for transforming notifications to events and events to alarms)
09:34:15 <lhartal> I’m  on POC stage and I’m optimist about it :)
09:34:39 <ifat_afek> alexey_weyl: I agree
09:35:08 <emalin> optimism is always good
09:35:59 <lhartal> ifat_afek: do you know which configuration file format they are use?
09:36:17 <ifat_afek> lhartal, I can find it for you in their documentation
09:36:41 <lhartal> ifat_afek: thanks!
09:36:51 <lhartal> also I have one more update
09:37:28 <lhartal> About the evaluator – elisha and I started to work on it
09:37:35 <lhartal> We are in the definitions stage and hopefully we will have a full design till next meeting
09:39:23 <lhartal> elisha_r: If you want, you can give more details
09:39:42 <elisha_r> sure
09:41:12 <elisha_r> I'll just add that the first step is defining the new format for RCA/deduced templates
09:41:21 <elisha_r> which will be in YAML format
09:42:11 <elisha_r> we're trying to think in advance about complex use cases so that the format will not need major changes in the future. For mitaka purposes it should be simple, though
09:42:29 <elisha_r> Other than that, I'll just add that we hope to send out portions of the design once we have a general sense of how we think it should be, to get comments early on.
09:42:33 <ifat_afek> elisha_r: sounds like a good idea
09:43:00 <elisha_r> And on a different topic - I plan on sharing this week the initial thoughts on how to replace networkx with a persistent graph DB like neo4j. Once I share this, comments and ideas will be welcome.
09:43:05 <elisha_r> that's it from my end
09:43:29 <ifat_afek> elisha_r: good, please send it to everybody
09:43:33 <ifat_afek> any other updates anyone?
09:43:45 <ifat_afek> ok
09:43:51 <lhartal> one more thinkg, the way we load and parse the new transformers is similar to the way we gonna load and parse the templates
09:44:09 <ifat_afek> lhartal: good idea
09:44:21 <ifat_afek> moving on
09:44:23 <ifat_afek> let’s see our status for mitaka-2, which is due tomorrow
09:44:31 <ifat_afek> Note that we are not committed to this milestone, as we are working in independent release mode
09:44:31 <emalin> lhartal : what about the relations between transformers and synchronizer plugins ?
09:44:54 <emalin> I guess each plugin has it's own transformer
09:45:28 <nadav_yakar> each entity has its own transformer, right?
09:46:16 <nadav_yakar> in the future we won't necessarily keep a plugin per entity
09:47:05 <emalin> But the transformer depended on the data that the plugin collect
09:47:48 <emalin> So maybe each plugins has serval transformers
09:47:52 <lhartal> yes each entity has its own transformer
09:47:54 <ifat_afek> I understood that the concept of transformers remains, just that they will be defined in a configuration file instead of a class
09:47:57 <nadav_yakar> exactly
09:48:46 <emalin> My questions is how do we configure both plugin and it's transformers in easy way
09:48:46 <lhartal> it will be exactly like today, but instead of writing a python file, you just need to add yaml file
09:49:22 <ifat_afek> emalin: I don't think you can define the plugin in an easy way, it's new code that you should write, right?
09:49:40 <emalin> It's new code, for sure
09:49:43 <ifat_afek> emalin: transformers are much more simple than plugins
09:50:14 <emalin> I'm just talking about how developer that develope new plugin
09:50:26 <emalin> know how to add it's transformers
09:50:40 <ifat_afek> emalin: obviously we will need to document it
09:50:40 <emalin> And what are the relations between them
09:50:47 <lhartal> after you write your plugin you need to create transformer configuration file and add it to your transformers lib
09:51:26 <ifat_afek> let's move on, ok? we are almost out of time
09:51:35 <ifat_afek> I'm sending links to mitaka blueprints
09:51:42 <ifat_afek> #link https://blueprints.launchpad.net/vitrage/mitaka/+specs?show=all
09:51:50 <ifat_afek> #link https://blueprints.launchpad.net/python-vitrageclient/mitaka
09:51:59 <ifat_afek> #link https://blueprints.launchpad.net/vitrage-dashboard/mitaka/+specs?show=all
09:52:07 <ifat_afek> Most blueprints are implemented, exceptions:
09:52:44 <ifat_afek> get-topology-api which is left open because we are making changes for PinPoint
09:52:45 <lhartal> in the configuration file, you should define the entity event fields (only the ones you want to add into Vitrage vertex)
09:53:05 <ifat_afek> networkx-graph-driver which should be split
09:53:22 <ifat_afek> We didn’t finish the api handler (which is related to get-topology-api)
09:53:37 <ifat_afek> Sunburst UI is almost finished, except from colors and titles
09:54:02 <ifat_afek> moving on to the action items...
09:54:12 <ifat_afek> #topic Review action items
09:54:26 <ifat_afek> • presenting first Vitrage demo
09:54:33 <ifat_afek> already discussed. done
09:54:50 <ifat_afek> • review PinPoint use cases and make sure it matches Vitrage implementation
09:54:54 <ifat_afek> in progress
09:55:01 <ifat_afek> • ifat_afek continue discussions with Aodh
09:55:04 <ifat_afek> in progress...
09:55:18 <ifat_afek> #action ifat_afek continue discussions with Aodh
09:55:25 <ifat_afek> • finalize get topology API
09:55:34 <ifat_afek> in progress, related to PinPoint discussions
09:55:48 <ifat_afek> #action  finalize get topology API
09:56:07 <ifat_afek> • ifat_afek update the documentation on vitrage main page with our latest design diagrams (of vitrage graph and the synchronizer)
09:56:09 <ifat_afek> done
09:56:17 <ifat_afek> #topic Next Steps
09:56:33 <ifat_afek> we should continue with the tempest tests
09:56:44 <ifat_afek> #topic Open Discussion
09:56:51 <ifat_afek> anything anyone wants to talk about?
09:58:04 <mkoushnir> Yes, we should continue with the tempest tests, and I need more api's and e2e scenarios
09:58:11 <ifat_afek> mkoushnir: right
09:58:21 <ifat_afek> goodbye everybody!
09:58:24 <eyalb> bye
09:58:27 <elisha_r> bye
09:58:33 <mkoushnir> bye
09:58:51 <ifat_afek> #endmeeting