09:00:37 <ifat_afek> #startmeeting vitrage
09:00:38 <openstack> Meeting started Wed Mar  2 09:00:37 2016 UTC and is due to finish in 60 minutes.  The chair is ifat_afek. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:42 <openstack> The meeting name has been set to 'vitrage'
09:00:44 <ifat_afek> hi everyone :-)
09:00:47 <omer_etrog> hi
09:01:06 <emalin> hi
09:02:53 <elisha_r> hey all
09:03:35 <idan_hefetz> Hi!
09:03:54 <lhartal> hi all :)
09:05:26 <ifat_afek> #topic Current status
09:05:43 <ifat_afek> Our last meeting was not recorded, due to a problem with OpenStack bot. You can find the meeting log in:
09:06:07 <ifat_afek> #link http://eavesdrop.openstack.org/meetings/vitrage/2016/vitrage.2016-02-24-09.01.log.txt
09:06:12 <eyalb> hi all
09:06:41 <ifat_afek> We are progressing well :-) you can look at our blueprints for mitaka, most of them are implemented or in good progress:
09:06:49 <ifat_afek> #link https://blueprints.launchpad.net/vitrage/mitaka
09:07:05 <ifat_afek> My updates:
09:07:19 <ifat_afek> I finished nagios plugin implementation
09:07:32 <alexey_weyl> Hello my friends
09:07:32 <ifat_afek> Started working on aodh. I plan to write two blueprints by tomorrow: one for get all alarms and the other one to notify them about vitrage alarms
09:07:41 <ifat_afek> . I’m working on it together with idan_hefetz.
09:08:30 <idan_hefetz> first, Graph Notifier blueprint should be closed soon, once the Integration with the Evaluator is complete.
09:08:30 <nofar_schnider> hi everyone
09:08:50 <idan_hefetz> second, I've began the research for the AODH-Notifier, it should be a pluggable solution for any type of notifier.
09:09:20 <idan_hefetz> Once all the details are clear we should create the blueprint and schedule a design meeting.
09:09:35 <ifat_afek> idan_hefetz: cool
09:09:43 <eyalb> I will update
09:10:02 <eyalb> I started to work on the puppet install of vitrage
09:10:12 <eyalb> thats it :-)
09:10:25 <elisha_r> I'll update
09:10:46 <elisha_r> (this is an update for myself and lhartal as well)))))
09:12:02 <dubigal> returned to work on the api handler
09:12:07 <dubigal> testing qpid
09:12:28 <elisha_r> hey - got disconnected...
09:13:24 <elisha_r> so, the evaluator is proceeding nicely. we hope to have, by the end of next week, support for set state templates
09:13:35 <danoffek> hi
09:13:39 <ifat_afek> cool!!
09:13:40 <alexey_weyl> Great elisha_r!!! :)
09:13:51 <ifat_afek> and great lhartal :-)
09:14:16 <elisha_r> once that flow is done, it will be much simpler to add more actions (raise alarm, RCA) and more templates
09:14:36 <elisha_r> that;s it
09:14:40 <nofar_schnider> elisha_r: nice!
09:14:59 <ifat_afek> these are great news, we'll have an end-to-end flow working
09:15:15 <danoffek> Great ! I know people are waiting for the final result outside our inner group
09:15:35 <elisha_r> cool
09:16:00 <Alon> Hi everyone, can I update from the UI side ? :) (Nofar this is for U)
09:16:09 <ifat_afek> sure
09:16:44 <Alon> RCA from client side is already finished last week ago, let me know if you installed it, and saw the results
09:17:16 <Alon> Today I have a meeting with Ohad and Alexey about the states of the topology, and how to visualize them in the UI
09:17:39 <Alon> That's all
09:17:40 <alexey_weyl> I have installed the updaed vitrage-dashboard and saw the jumping window
09:18:02 <alexey_weyl> but because i didn't have any RCA it was empty
09:18:12 <Alon> (Jumping window = modal)
09:18:13 <alexey_weyl> *popping window
09:18:31 <danoffek> I like jumping window better
09:18:43 <alexey_weyl> sorry for my jinglish
09:18:58 <Alon> OK, call me when the real data is there. I want to see it live
09:19:16 <alexey_weyl> ok
09:19:53 <nofar_schnider> I'll update
09:20:15 <nofar_schnider> I'm debugging the nova instance synchronizer to test the work with oslo messaging
09:22:02 <nofar_schnider> then I will work with the transformer and continue to the host and zone synchronizers
09:22:31 <ifat_afek> nofar_schnider: cool!
09:22:50 <nofar_schnider> hopefully I'll finish it as soon as possible, the hard part was figuring the work with the bus
09:23:05 <nofar_schnider> a week tops
09:23:11 <ifat_afek> great
09:23:25 <ifat_afek> who else wants to update?
09:24:04 <alexey_weyl> I will update
09:24:30 <alexey_weyl> I have finished to work on the states aggreagation and normalization blueprint
09:24:48 <alexey_weyl> need to write the documentation today
09:25:02 <alexey_weyl> finished :)
09:25:15 <ifat_afek> alexey_weyl: cool, so once you are done documenting we can close the blueprint?
09:25:26 <alexey_weyl> yes :)
09:25:31 <ifat_afek> great
09:25:37 <ifat_afek> any other updates anyone?
09:26:29 <ifat_afek> ok, let's move on
09:26:41 <ifat_afek> #topic Review action items
09:27:02 <ifat_afek> • action ifat_afek update aodh blueprints
09:27:13 <ifat_afek> I started working on it yesterday
09:27:22 <ifat_afek> #action ifat_afek update aodh blueprints
09:27:29 <ifat_afek> • action define what information that should appear in the alarms list
09:27:42 <ifat_afek> I think it makes sense to talk about it after I'm done with aodh blueprints
09:27:56 <ifat_afek> #action define what information that should appear in the alarms list
09:28:06 <ifat_afek> • action document vitrage configuration
09:28:15 <ifat_afek> I didn't get to it, and it won't happen this week either
09:28:26 <ifat_afek> • action copy vitrage API documentation to the developer guide
09:29:05 <eyalb_> I will work on the api documentation this week
09:29:11 <ifat_afek> eyalb_: thanks
09:29:19 <ifat_afek> #action eyalb_ copy vitrage API documentation to the developer guide
09:29:26 <ifat_afek> #topic Next Steps
09:30:05 <ifat_afek> I have nothing to say in this topic
09:30:10 <ifat_afek> #topic Open Discussion
09:30:17 <ifat_afek> anyone wants to discuss anything?
09:32:15 <ifat_afek> ok, so bye everyone, see you next week
09:32:24 <nofar_schnider> bye
09:32:42 <ifat_afek> #endmeeting