08:01:09 <ifat_afek> #startmeeting vitrage
08:01:11 <openstack> Meeting started Wed Aug 10 08:01:09 2016 UTC and is due to finish in 60 minutes.  The chair is ifat_afek. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:01:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:01:14 <openstack> The meeting name has been set to 'vitrage'
08:01:31 <ifat_afek> Hi everyone!
08:01:44 <nofar_schnider> Hi :)
08:01:54 <idan_hefetz> Good Morning!
08:02:23 <nbloom> hi
08:02:59 <Wendy_> hi
08:03:57 <ifat_afek> #topic Status and Updates
08:04:17 <ifat_afek> The voting for Barcelona sessions was closed yesterday. I believe we know the results in two weeks or so
08:04:43 <ifat_afek> Another update is that someone from infra pushed a change, that vitrage specs will appear in the official openstack site
08:04:53 <ifat_afek> #link https://review.openstack.org/#/c/352747/
08:05:05 <elisha_r> hi!
08:06:46 <ifat_afek> We need to finish our documentation for how to add a new datasource. Noam started it long ago, but it requires more work
08:07:09 <ifat_afek> Looks like everybody is busy or on vacation, but let’s try to do it soon
08:07:32 <ifat_afek> My updates: I startied to work on auto-evacuate vms from a failed host. Will also add a blueprint later today
08:07:40 <ifat_afek> Who wants to update?
08:08:57 <alexey_weyl> hellllooooooooooooo
08:09:08 <alexey_weyl> I will update
08:09:24 <alexey_weyl> I have started to work on the multi tenancy feature
08:10:05 <alexey_weyl> this feature main goal is to know what data to show for each on of the apis that we have depending on the tenant that asks that data
08:10:46 <alexey_weyl> i will upload a blueprint soon, and there we could discuss the design
08:10:53 <alexey_weyl> that's it for now
08:11:10 <ifat_afek> alexey_weyl: great, thanks
08:11:27 <ifat_afek> multi tenancy is very important, we must support it
08:12:10 <elisha_r> I'll update
08:12:41 <elisha_r> Been reviewing some of the work on the Zabbix Datasource modeling, and we have a problem we will need to address in the coming months
08:13:07 <elisha_r> currently, the alarms are connected (in the entity graph) to the resource on which they were raised
08:13:40 <elisha_r> so, if an alarm is raised in Zabbix on a host, the alarm will be a vertex in the entity graph, connected with "on" edge to the host
08:14:46 <elisha_r> however, there are cases where this is not the best modeling
08:15:51 <elisha_r> for example, if the hosts are using Ceph to handle Shared Storage between the hosts, if ceph has a problem on one host it will appear on all the hosts
08:16:54 <elisha_r> so, if we have 10 hosts, it would make sense to just raise on alarm in Vitrage, on a new vertex of type "ceph service" or something equivalent
08:17:06 <elisha_r> Another issue
08:18:03 <elisha_r> we have currently no way (as I understand it) to distinguish in Zabbix between tests on a host (compute) and tests on a switch
08:18:13 <ifat_afek> elisha_r: right… so first we need a way to model “ceph” vertex in the graph, and then to configure zabbix datasource to raise the alarm on ceph and not on each node separately
08:18:46 <ifat_afek> we solved it in nagios using a config file that determines the resource id. don’t we have something similar for zabbix?
08:18:58 <elisha_r> actually, I'm wrong about my last point. we use the same nagios config file to distinguish them. my bad
08:18:59 <elisha_r> :)
08:19:10 <ifat_afek> :)
08:19:32 <elisha_r> perhaps we need to expand that config file to solve the ceph issue
08:19:47 <ifat_afek> probably
08:19:55 <elisha_r> anyhow, we should open a BP for this, to have it addressed
08:20:05 <ifat_afek> right
08:21:07 <ifat_afek> we have this blueprint for nagios:
08:21:10 <ifat_afek> #link https://blueprints.launchpad.net/vitrage/+spec/nagios-configure-alarm-names
08:21:31 <ifat_afek> maybe it can be extended to include also the affected resource. or we can open another blueprint
08:21:35 <nofar_schnider> I think it will be nice to use the config file solution for other resources. we don't know what we'll encounter further on
08:21:56 <elisha_r> yup
08:22:25 <ifat_afek> cool. who else wants to update?
08:22:27 <nofar_schnider> Time for some Heat datasource updates!
08:23:22 <ifat_afek> #action open blueprint for configuring the affected resource in zabbix
08:23:44 <ifat_afek> #action ifat_afek open blueprint for nova host evacuation
08:23:51 <nofar_schnider> I am testing the heat notifications handling (from the messages bus) in Vitrage and the support we've added to get information regarding the stacks from heatclient.
08:24:07 <ifat_afek> (nofar_schnider: sorry for the interrupt :-))
08:24:17 <nofar_schnider> When I'm done with that I'll add support for stack resources.
08:25:08 <nofar_schnider> The main task there is to figure out which resources interest us and are important enought to be added to the graph
08:25:27 <ifat_afek> nofar_schnider: what kind of stack resources exist?
08:26:26 <nofar_schnider> that's ok
08:27:42 <nofar_schnider> ifat_afek: that's a really good question
08:28:05 <nofar_schnider> I still don't know but I will check and update
08:28:58 <ifat_afek> ok, thanks
08:29:06 <ifat_afek> anyone else wants to update?
08:29:49 <lhartal> hi :) I just want to update that I'm currently working on bug in Zabbix datasource. The bug is that after vitrage graph is loaded we can see all zabbix alarms in Vitrage, but after the second "get all" action some of the alarms disappear
08:30:24 <ifat_afek> lhartal: ok, thanks
08:30:37 <ifat_afek> any other updates?
08:32:16 <ifat_afek> moving on
08:32:29 <ifat_afek> #topic Open Discussion
08:32:39 <ifat_afek> anything you would like to talk about?
08:35:09 <ifat_afek> ok, so that’s it for today
08:35:17 <ifat_afek> goodbye  :)
08:35:23 <nofar_schnider> bye
08:35:23 <nbloom> goodbye
08:35:29 <elisha_r> see ya...
08:35:48 <ifat_afek> #endmeeting