08:00:23 <ifat_afek> #startmeeting vitrage
08:00:24 <openstack> Meeting started Wed Jan 18 08:00:23 2017 UTC and is due to finish in 60 minutes.  The chair is ifat_afek. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:28 <openstack> The meeting name has been set to 'vitrage'
08:00:38 <ifat_afek> Hi :-)
08:00:42 <yujunz> HI
08:00:42 <eyalb> hi
08:00:48 <eyalb> \o/
08:01:19 <idan_hefetz> Hi
08:02:26 <nofarsch> hi!
08:02:27 <nadav> hi
08:03:28 <ifat_afek> Today’s agenda:
08:03:33 <ifat_afek> •	Ocata Release
08:03:38 <ifat_afek> •	Status and Updates
08:03:44 <ifat_afek> •	Design sessions
08:03:49 <ifat_afek> •	Boston CFP
08:03:56 <ifat_afek> #topic Ocata Release
08:04:18 <ifat_afek> Let me correct the release dates I wrote in the last meeting. As Vitrage is following the cycle-with-intermediary release model, we do not have to follow m1, m2 and m3 milestones
08:04:31 <ifat_afek> The relevant milestones are:
08:04:54 <ifat_afek> Jan23-Jan27: requirements freeze. Unfortunately, Vitrage is not listed yet in the global-requirements. We should add it before the deadline. This also means that we should mark Vitrage versions by that date.
08:05:01 <ifat_afek> #action add Vitrage to global-requirements
08:05:17 <ifat_afek> Feb16 – the final deadline for Vitrage Ocata release
08:05:31 <ifat_afek> We should try to release before that, but it does give us some extra time to finish our development. Once we mark our release, we will request to create stable/ocata branch, and master will be used for Pike development.
08:05:50 <ifat_afek> The full schedule can be found here:
08:05:57 <ifat_afek> #link https://releases.openstack.org/ocata/schedule.html
08:06:04 <ifat_afek> Any comments regarding the release dates?
08:06:48 <yujunz> What's the result for adding to global-requirements
08:06:58 <yujunz> What is it used for?
08:08:01 <ifat_afek> Well… every other official project is there
08:08:32 <ifat_afek> The rule is that every library that you want to use must be defined there
08:08:47 <yujunz> OK
08:08:52 <ifat_afek> It is relevant for 3rd party libraries (like exrex…), but used also for openstack ones
08:09:20 <ifat_afek> Other projects can use vitrage even if it’s not listed there, but seems like adding python-vitrageclient to the list is the right thing to do
08:09:33 <janonymous> part
08:09:57 <ifat_afek> What do you mean?
08:10:04 <alexey_weyl> Hello
08:10:16 <janonymous> ops sorry for mistake, forgot /part
08:10:48 <ifat_afek> janonymous: ok, you are welcome anyway :-)
08:11:02 <janonymous> thanks :)
08:11:37 <ifat_afek> So my plan is to mark vitrage libraries tomorrow or on Sunday, and then to ask to add python-vitrageclient to global-requirments on Monday
08:11:51 <ifat_afek> And then we can continue our developement for 2-3 more weeks
08:12:08 <ifat_afek> Any other questions?
08:12:28 <yujunz> Nope
08:12:58 <ifat_afek> #topic Status and Updates
08:13:34 <ifat_afek> A short update about Vitrage mascot (the Giraffe): Heidi Joy Tretheway sent an email that they are still working on that. I hope we’ll be satisfied with the final result
08:13:46 <ifat_afek> They plan to start using the mascots in the PTG, but as we won’t attend I’m not sure if we will also get our mascot soon.
08:14:12 <ifat_afek> My updates: I’m working on the blueprint of adding a new API for post event to Vitrage, to be used by Doctor datasource (but not only).
08:14:19 <ifat_afek> #link https://blueprints.launchpad.net/vitrage/+spec/support-inspector-sb-api
08:14:24 <ifat_afek> Other updates?
08:14:59 <yujunz> My updates: static datasource done
08:15:00 <eyalb> I pushed all the collectd datasource with tests
08:15:01 <yujunz> #link https://review.openstack.org/#/c/419812/
08:15:18 <ifat_afek> great for both :-)
08:15:58 <yujunz> Started working on the skeleton generator
08:16:00 <yujunz> #link https://blueprints.launchpad.net/vitrage/+spec/datasource-skeleton-generator
08:16:02 <ifat_afek> yujunz: I guess you are waiting for alexey_weyl’s review?
08:16:16 <yujunz> But may not catch up with ocata since I have many tasks in parallel
08:16:56 <yujunz> Yes ifat_afek . Let me know if any additional amend requires on the static datasource
08:16:57 <ifat_afek> yujunz: I guess it can wait to Pike
08:17:20 <alexey_weyl> Yujun, Do you still think it is necessary after all the refactoring that we have done in the transformers and the drivers?
08:17:37 <yujunz> I suppose it would be implemented in python-vitrageclient
08:17:54 <alexey_weyl> Don't we just need a more detailed doc file that explains how to add a datasource?
08:17:59 <yujunz> Yes, alexey_weyl I think it will help removing the overhead of starting a new datasource
08:18:21 <yujunz> You need some copy and paste to get started with new datasource
08:18:37 <alexey_weyl> ok.
08:19:11 <yujunz> That's all from me
08:19:20 <alexey_weyl> but please also add some documentation that new users will know that there is such a thing (skeleton) and that they can use it to add new datasources
08:19:28 <alexey_weyl> Sound good
08:19:44 <yujunz> Sure
08:20:00 <ifat_afek> Great
08:20:27 <ifat_afek> One thing I forgot to say: I updated Vitrage architecture diagram, and added some explanations. I’ll update also Vitrage wiki soon
08:20:30 <ifat_afek> #link http://docs.openstack.org/developer/vitrage/
08:21:54 <nofarsch> Nice!
08:22:06 <alexey_weyl> I have pushed a couple of patches to aodh. I have some ping pong with the aodh commiters and hopefully soon it will be approved.
08:22:45 <alexey_weyl> Then of course I have some more tasks to do in aodh , but hopefully it will be easier
08:23:03 <ifat_afek> alexey_weyl: good luck in getting your changes approved
08:23:13 <ifat_afek> Any other updates?
08:25:28 <ifat_afek> #topic Design Sessions
08:25:36 <ifat_afek> We should finalize the dates for having Vitrage design sessions in Israel, around February or March.
08:25:43 <ifat_afek> Also, we should come up with a list of topics. I created an etherpad for this purpose:
08:25:52 <ifat_afek> #link https://etherpad.openstack.org/p/vitrage-pike-design-sessions
08:26:04 <ifat_afek> Feel free to add more ideas. We will arrange the design sessions schedule shortly before the meetings.
08:26:08 <yujunz> Great
08:27:41 <ifat_afek> #topic Boston CFP
08:27:42 <nofarsch> I have a question
08:27:55 <ifat_afek> nofarsch: sure
08:28:14 <nofarsch> but it can wait after we finish with the topics
08:28:32 <ifat_afek> Now it’s also fine :-)
08:28:54 <nofarsch> I see that the API does not allow updating a template
08:29:16 <nofarsch> are we going to add an option like that later?
08:29:36 <nofarsch> same regarding DELETE
08:30:19 <eyalb> i will start working on template CRUD
08:30:48 <nofarsch> planned for pike?
08:30:48 <eyalb> but there are issues with updating and deleting templates that should be considred
08:31:14 <eyalb> for the first stage we will simply store the templates in the database
08:31:31 <eyalb> instead of the file system
08:31:56 <eyalb> yep
08:32:15 <nofarsch> great. thanks eyalb
08:32:35 <ifat_afek> So back to Boston CFP
08:32:52 <ifat_afek> We already listed some ideas in our etherpad
08:33:02 <ifat_afek> #link https://www.openstack.org/summit/boston-2017/call-for-presentations/
08:33:07 <ifat_afek> #link https://etherpad.openstack.org/p/vitrage-boston-session-proposals
08:33:27 <ifat_afek> Feel free to add more ideas. The deadline for submitting is February 6.
08:33:57 <ifat_afek> yujunz: I saw that you and Tomi Juvonen talked about a performance session in Doctor meeting
08:34:11 <ifat_afek> I guess this might also be relevant for Vitrage
08:34:20 <yujunz> Yes, could be
08:34:34 <yujunz> #link https://etherpad.opnfv.org/p/doctor_openstack_summit_boston_2017
08:35:07 <ifat_afek> Looks good
08:35:28 <ifat_afek> If anyone has other ideas, please update the etherpad
08:35:37 <yujunz> Not sure if we need to merge mitmstack with that too
08:35:40 <yujunz> They are all about performance
08:35:56 <ifat_afek> But they check different aspects, right?
08:36:09 <yujunz> Yes, a bit different
08:36:25 <yujunz> Doctor's subject is more close to QTIP
08:36:29 <ifat_afek> Without thinking too much about the details, I would say suggest two sessions. But you should decide
08:36:46 <yujunz> I perfer two session also
08:36:56 <yujunz> Unless we find much overlap later on
08:37:01 <ifat_afek> And what about mitmstack? do you want to discuss it?
08:37:37 <yujunz> May I list vitrage team as co-speaker?
08:37:53 <ifat_afek> For mitmstack? sure, we’ll be happy to join
08:38:13 <yujunz> Great
08:38:26 <yujunz> Is there a way to share the proposal, it seems to be a private link
08:38:41 <ifat_afek> I don’t understand the question
08:38:57 <yujunz> #link https://www.openstack.org/summit/boston-2017/call-for-presentations/manage/17469/summary
08:39:00 <ifat_afek> When you submit a proposal, you can list a few speakers from different companies
08:39:14 <yujunz> Can you access the management link?
08:39:27 <ifat_afek> I’m trying
08:40:35 <ifat_afek> I’m supposed to have a login, I registed a while ago
08:40:43 <ifat_afek> Trying now
08:41:00 <yujunz> I have just added you as co-speaker
08:41:10 <yujunz> Maybe that will grant you access to the proposal
08:42:01 <ifat_afek> I just got an email that you updated my speaker bio :-)
08:42:07 <yujunz> Feel free to invite other root causer ifat_afek
08:42:28 <ifat_afek> ok. I’ll check it later, in order not to make eveyone else wait
08:42:39 <yujunz> Sure. Let's move on
08:42:42 <ifat_afek> Any other topics to discuss?
08:44:45 <ifat_afek> yujunz: I managed to get in. I like the title (copy&paste so others can see it): Large Scale OpenStack in Your Pocket - mitmstack OpenStack Service Faker
08:46:03 <yujunz> I have also an alternative title "Cheat the client - using MitmStack in Vitrage performance testing"
08:46:35 <ifat_afek> Big like to that too :-) And BTW, I always assumed that you have to fill all the details before submitting. Good to know you can do it in stages
08:47:16 <ifat_afek> Once you have something more concrete, we’ll be happy to discuss the details
08:47:40 <yujunz> Thanks. I think it is important to include the project title for searching optimization. So I would prefer the latter to include "Vitrage" in title
08:47:48 <ifat_afek> I agree
08:48:05 <ifat_afek> AFAIK the search is only by the title, not by the description
08:49:16 <ifat_afek> Ok, any other issues before we close the meeting?
08:50:48 <ifat_afek> See you next week!
08:50:59 <nofarsch> bye :)
08:50:59 <eyalb> bye
08:51:18 <ifat_afek> #endmeeting