17:03:53 <hartsocks> #startmeeting VMwareAPI
17:03:53 <openstack> Meeting started Wed Dec  4 17:03:53 2013 UTC and is due to finish in 60 minutes.  The chair is hartsocks. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:56 <openstack> The meeting name has been set to 'vmwareapi'
17:04:05 <hartsocks> greetings stackers!
17:04:20 <hartsocks> Let's go around and introduce ourselves since we've not done that in a bit.
17:04:33 <hartsocks> Just your name is fine since I don't know everyone's handles.
17:04:44 <hartsocks> I'll start:
17:04:46 <hartsocks> Shawn Hartock
17:04:50 <dims> Davanum Srinivas
17:04:56 <rgerganov> Radoslav Gerganov
17:05:00 <tjones> Tracy Jones
17:06:04 <hartsocks> okay.
17:06:18 <hartsocks> First on the agenda...
17:06:32 <hartsocks> Bugs, then Blueprints, then open discussion...
17:06:39 <hartsocks> #topic bugs
17:06:55 <hartsocks> Who has a bug we *need* to look at?
17:07:30 <tjones> the next havana freeze is tomorrow - so any bug we want backported needs to move today
17:08:08 <hartsocks> #link  http://goo.gl/Mzc1wU bugs for backport?
17:08:27 <hartsocks> Hmm… maybe that's not a good report.
17:08:46 <tjones> yeah that's the triage report
17:08:48 <tjones> L-D
17:08:49 <tjones> :-D
17:08:56 <rgerganov> I guess we want to backport https://bugs.launchpad.net/nova/+bug/1255609
17:08:56 <hartsocks> #undo
17:08:57 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x27bc110>
17:08:57 <uvirtbot> Launchpad bug 1255609 in nova "VMware: possible collision of VNC ports" [Low,In progress]
17:09:07 <rgerganov> this is the VNC security issue
17:09:22 <tjones> i'd say the stats issue
17:09:47 <tjones> the postgres issue
17:10:10 <tjones> #link https://bugs.launchpad.net/nova/+bug/1195139
17:10:12 <uvirtbot> Launchpad bug 1195139 in openstack-vmwareapi-team "vmware: error trying to store hypervisor_version as string in using postgresql" [Critical,In progress]
17:10:19 <hartsocks> I've targeted bug/1255609 to i1
17:10:36 <tjones> #link https://bugs.launchpad.net/nova/+bug/1252827
17:10:38 <uvirtbot> Launchpad bug 1252827 in openstack-vmwareapi-team "VMWARE: Intermittent problem with stats reporting" [Critical,In progress]
17:11:18 <tjones> hartsocks: do you think that one is done enough to ask for help from the core reviewers to get this in so we can backport?
17:11:33 <hartsocks> hmm… bug/1252827 is set for i2 … why?
17:11:45 <hartsocks> which one? bug/1252827 the stats bug?
17:11:51 <tjones> is
17:11:53 <tjones> yes
17:12:06 <hartsocks> Russell bumped us from i1 to i2.
17:12:20 <hartsocks> Looks like that happened 18 hours ago.
17:12:25 <tjones> bummer
17:12:44 <russellb> because iccehouse-1 deadline was yesterday
17:12:50 <russellb> it's frozen now
17:12:53 <hartsocks> ah.
17:13:15 <hartsocks> well then. we're just late to the party.
17:13:21 <tjones> ok then it looks like 1195139 and 1229994 should get backported asap
17:13:31 <tjones> to make havana freeze
17:13:49 <rgerganov> when is the havana freeze?
17:14:08 <hartsocks> havana stable branch freeze was yesterday.
17:14:19 <tjones> arg - i thought it was tomorrow
17:14:24 <tjones> missed the board
17:14:25 <tjones> boat
17:14:28 <hartsocks> I knew there was a release on the 12th ...
17:15:00 <hartsocks> We should probably dedicate somebody to watch those stable release deadlines.
17:15:07 <hartsocks> I de-nominate myself.
17:15:13 <rgerganov> does that mean that we can't get anything backported to havana?
17:15:14 <tjones> i'll do it :-(
17:15:36 <tjones> i thought the freeze was 1 week before not 1 week and 1 day :-(
17:15:49 <hartsocks> it's probably timezone things.
17:15:59 <tjones> oh that :-D
17:16:11 <hartsocks> It's tomorrow in Hong Kong :-)
17:16:36 <tjones> russellb: is the freeze 1 week before release in UTC?
17:17:02 <tjones> will be good to know since i just nominated myself to watch this
17:17:19 <hartsocks> #link https://wiki.openstack.org/wiki/Icehouse_Release_Schedule
17:17:45 <hartsocks> The i1 deadline is 12/5 which is tomorrow.
17:17:51 <tjones> yeah that icehouse - i need havana too
17:18:05 <tjones> https://wiki.openstack.org/wiki/StableBranchRelease
17:18:11 <hartsocks> The thing we weren't watching was the havana-stable release schedule.
17:18:39 <tjones> yes i have the schedule from that link - i just missed that there is a freeze (duh)
17:19:03 <hartsocks> So, anything in flight now we need to target for Jan 16th.
17:19:21 <hartsocks> I've not been beating the drums lately.
17:19:30 <tjones> ok we missed the next havana (bummer).  lets take a quick look at anything we have pending for tomorrow (
17:19:33 <hartsocks> I'll have to get back on that :-)
17:19:49 <tjones> L-D
17:19:50 <tjones> :-D
17:19:55 <tjones> can't type today
17:20:14 <hartsocks> tjones: so I'll watch IceHouse and you can watch Havana Stable?
17:20:35 <tjones> sure (and grizz)
17:20:49 <hartsocks> not to give you too much to watch :-)
17:21:06 <tjones> :-D  - just took a peek and we have nothing pending for i-1.  they all moved to i-2
17:21:36 * hartsocks gets out his drum, starts beating it
17:22:33 <hartsocks> okay. So we'll table this for now and come back to it next week. i2 is technically a short deadline for most of us with the holidays in there.
17:22:48 <hartsocks> On the topic of bugs...
17:23:04 <hartsocks> any problem bugs we've not hit on yet?
17:24:04 <hartsocks> #topic blueprints
17:24:19 <hartsocks> So last week we identified our top 3 blueprints (for the driver)
17:24:27 <hartsocks> *. https://blueprints.launchpad.net/openstack/?searchtext=vmware-vm-diagnostics
17:24:28 <hartsocks> *. https://blueprints.launchpad.net/openstack/?searchtext=vmware-image-cache-management
17:24:28 <hartsocks> *. https://blueprints.launchpad.net/nova/+spec/vmware-vsan-support
17:24:36 <tjones> for i-2 right?
17:24:39 <hartsocks> I targeted these all at i2
17:24:45 <tjones> heh
17:24:50 <hartsocks> wait...
17:24:56 <hartsocks> Gary had one pretty far along...
17:25:07 <tjones> his are the 1st 2
17:25:36 <hartsocks> broken links...
17:25:39 <hartsocks> hold on.
17:26:25 <hartsocks> hmm… I can't find that first one this week.
17:26:38 <hartsocks> https://blueprints.launchpad.net/nova/+spec/vmware-image-cache-management
17:26:51 <hartsocks> that one is i2 b/c it needs some rework.
17:27:28 <hartsocks> #action follow up with garyk on vmware-vm-diagnostics
17:27:47 <hartsocks> I literally can't find that diagnostics one. I thought it was pretty far along.
17:28:14 <hartsocks> oh well. so much for talking about that one.
17:28:41 <hartsocks> I did a quick patch last week on WSDL caching.
17:28:55 <hartsocks> It has "caching" as part of it.
17:29:16 <hartsocks> so I did some research on OSLO and how to maybe do generic "caching" for everything.
17:29:44 <hartsocks> There's an Oslo BP in flight right now doing a generic cache interface.
17:29:59 <tjones> cool
17:30:11 <hartsocks> So just like the config BP we had, we might be able to link these two things up. It's worth looking at anyway.
17:31:20 <danflorea> https://blueprints.launchpad.net/nova/+spec/vmware-vm-diagnostics
17:31:54 <hartsocks> hi dan!
17:32:00 <hartsocks> awesome.
17:32:05 <danflorea> hi
17:32:41 <tjones> the blueprint dashboard needs a blueprint for easier searching :-)
17:32:54 <hartsocks> *lol*
17:33:04 <hartsocks> that's our BP for i1
17:33:12 <hartsocks> Looks like it's on track.
17:34:11 <hartsocks> Gary's not around so we'll just wave as it goes by.
17:34:43 <danflorea> I think he was making good progress. There was a request to add namespaces for tempest purposes.
17:35:02 <hartsocks> #link https://review.openstack.org/#/c/51404/ <- very good progress indeed!
17:35:10 <hartsocks> Merged!
17:35:30 <vuil> gary should be joining in a couple of minutes.
17:36:14 <hartsocks> Well, while we're waiting.
17:36:45 <hartsocks> #link https://blueprints.launchpad.net/nova/+spec/vmware-vsan-support
17:36:52 <hartsocks> This is targeted for i2
17:37:10 <vuil> Good progress made. i2 coz it needs some refactoring a some more tests
17:37:49 <hartsocks> vuil: could you target i2 on the BP? I apparently don't have permissions.
17:38:23 <vuil> huh, let me see
17:38:47 <vuil> The BP will need to review eyes as well btw
17:39:30 <hartsocks> I've committed to getting out my "do reviews" drum and beating on it…
17:40:07 <tjones> im tempted to spend some time doing a dashboard that shows RED when things are just withering on the vine waiting for reviews
17:40:41 <hartsocks> well, I already burn a lot of time on that script that I run. What's a quick Django project on top of that? :-)
17:40:54 <tjones> exactly
17:41:11 <tjones> i'll do it since i've never used django ;-)
17:41:17 <vuil> I don't know how to give permission on the bp, but I updated the milestone to i2
17:41:22 <hartsocks> thanks.
17:41:41 <hartsocks> So speaking of OSLO and BP...
17:42:05 <hartsocks> Are we doing our Configuration Validation work as part of Oslo now?
17:42:22 <hartsocks> We had that validator BP
17:42:51 <tjones> im horribly behind on that - still have not met with ogelbukh….
17:43:38 <hartsocks> would you like some help with that?
17:43:42 <tjones> yes please
17:44:13 <hartsocks> okay. I'll ping ogelbukh and we'll try and set up an IRC/etherpad thing like I see the big-kids doing.
17:44:18 <garyk> hi, sorry for being terribly late
17:44:23 <hartsocks> np
17:44:33 <hartsocks> this is a horrible time of day for a meeting for you.
17:44:44 <garyk> :)
17:44:49 <hartsocks> We were discussing...
17:44:57 <hartsocks> https://blueprints.launchpad.net/nova/+spec/vmware-vm-diagnostics
17:45:10 <garyk> :) - that was approved today
17:45:17 <tjones> congrats!
17:45:17 <hartsocks> congrats!
17:45:30 <garyk> gracias
17:45:40 <hartsocks> also...
17:45:59 <hartsocks> #link https://blueprints.launchpad.net/nova/+spec/vmware-image-cache-management
17:46:08 <hartsocks> looks like that's for i2 now
17:46:17 <garyk> yeah - that is blocked due to the fact that we are not using common config options.
17:46:35 <danflorea> does vm diagnostics require tempest changes? or those are already done as well?
17:46:42 <garyk> i have posted https://review.openstack.org/#/c/59994/ and need to ping russelb about this
17:46:57 <garyk> i just need to solve issues with the tests which have cropped up
17:47:23 <garyk> locally they passed - something is fishy with the mock stuff
17:47:48 <garyk> i'll look at them after the meeting
17:47:55 <danflorea> Ok. I was under the impression that the namespace changes would apply to other drivers as well and would impact tempest. I can ask you about it later.
17:48:24 <garyk> danflorea: i am planning on addressing the namespaces tomorrow
17:48:45 <garyk> i plan to add it to libvirt, hyperv and xen. but that is another issue and not related ot the image caching
17:49:08 <hartsocks> for the record, namespace issues?
17:49:37 <garyk> hartsocks: the different drivers return different keys for the diagnostics. the spacial once are under a driver namespace
17:50:04 <garyk> this is due to the fact that there is no common diagnostics api and no set values to return
17:50:22 <hartsocks> thanks.
17:50:28 <danflorea> garyk: ok, sounds good to me
17:50:44 <garyk> danflorea: ok, thanks. it is on my to do list
17:51:25 <hartsocks> any other BP folks need to discuss?
17:52:12 <hartsocks> I think any BP we've not covered here probably gets pushed to i3
17:52:44 <hartsocks> #topic opendiscussion
17:53:07 <hartsocks> okay. open discussion.
17:54:08 <hartsocks> I noticed this https://blueprints.launchpad.net/oslo/+spec/cache-backend-abstraction
17:54:21 <jchan> quit
17:54:33 <hartsocks> okay. fine. I will.
17:54:48 <tjones> LOL
17:54:56 <hartsocks> geesh.
17:55:23 <hartsocks> so srsly.
17:55:39 <hartsocks> I noticed this was an abstract cache service.
17:56:30 <hartsocks> so I'm wondering how I would write and then use a cache based on this in our driver.
17:57:30 <tjones> what do you want to cache?  sessions (for example)?
17:57:50 <hartsocks> well, first off… we have an image cache right now… does that fit?
17:58:01 <hartsocks> I was writing a WSDL cache… does that fit?
17:58:02 <vuil> nope.
17:58:06 <hartsocks> Not sure.
17:58:07 <vuil> image cache on server side
17:58:31 <vuil> VC/ESX i mean.
17:58:57 <hartsocks> The examples are Memcache and Redis which leads down a certain path.
17:59:17 <hartsocks> a Datastore based one might make no sense.
17:59:36 <tjones> wsdl maybe?
18:00:01 <hartsocks> Yeah, I'll play with that.
18:00:06 <hartsocks> That's time.
18:00:09 <hartsocks> #endmeeting