17:01:07 <hartsocks> #startmeeting VMwareAPI
17:01:08 <openstack> Meeting started Wed Dec 11 17:01:07 2013 UTC and is due to finish in 60 minutes. The chair is hartsocks. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:11 <openstack> The meeting name has been set to 'vmwareapi'
17:01:18 <hartsocks> who's around?
17:01:25 <garyk> hi
17:01:30 <tjones> hi
17:01:47 <tjones> not to rub it in - but vmware has food trucks here this morning :-D
17:01:59 <rgerganov> hello
17:02:00 <hartsocks> heh.
17:02:20 <tjones> i should say vmware palo alto
17:02:25 <garyk> nice - was there one with potatoes on a stick?
17:02:32 <tjones> not that one
17:02:43 <garyk> :)
17:02:59 <tjones> french toast, biscuits and grazy, egg sandwiches
17:03:09 <hartsocks> I had food trucks come by my house sometimes, but my neighbors complained.
17:03:37 <hartsocks> :-)
17:03:42 <tjones> not to hijack the meeting
17:03:54 <hartsocks> *lol* s'okay
17:04:07 <hartsocks> I've not posted the agenda in a while because it's always the same...
17:04:10 <hartsocks> #link https://wiki.openstack.org/wiki/Meetings/VMwareAPI#Agenda
17:04:20 <hartsocks> We're in the part I call "salutations"
17:04:35 <hartsocks> You like that I officially made banter part of the official meeting agenda :-)
17:04:40 <tjones> lol
17:04:45 <dims> o/
17:05:17 <garyk> \o/
17:05:24 <rgerganov> \m/
17:05:44 <hartsocks> (╯°□°)╯
17:05:56 <garyk> ok, that wins.
17:06:06 <hartsocks> I totally stole that one.
17:06:40 <hartsocks> So, we need to get any blueprints we want included in Icehouse-2 ready to go in the next 7 days.
17:06:46 <hartsocks> #topic blueprints
17:07:08 <hartsocks> I've been working on a list...
17:07:31 <hartsocks> I've identified 4 bp for icehouse 2….
17:07:36 <hartsocks> in no particular order...
17:07:46 <hartsocks> #link https://blueprints.launchpad.net/openstack/?searchtext=vmware-image-cache-management
17:07:56 <garyk> quick update on that one
17:07:56 <hartsocks> garyk: I think that's yours...
17:08:02 <hartsocks> cool
17:08:37 <garyk> at the moment it is blocked. we are in the process of making the libvirt code generic and then hopefully that will free up this one
17:08:48 <garyk> it will require a rebase in a few days time and then it is ready for review
17:09:26 <garyk> patches are https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/vmware-image-cache-management,n,z
17:09:53 <zhiyan> hello folks, this my first time to join vmwareapi weekly meeting. i'm very interesting to allow vmware driver support ova image, so can i get some time in open discussion part? i have some question around it to like get your inputs..thanks
17:09:54 <garyk> please note that this is all based on https://review.openstack.org/#/c/52630/ (which has been in review for a very very very …very long time)
17:10:07 <garyk> zhiyan: wecome
17:10:17 <zhiyan> garyk: sorry to interrupt your discussion, but i have one queston on image-cache
17:10:24 <zhiyan> garyk: hello
17:10:25 <hartsocks> zhiyan: cool, we have open discussion every week at the last 10 minutes or so.
17:10:35 <garyk> zhiyan: sure, please ask
17:10:37 <zhiyan> hartsocks: hello
17:11:05 <hartsocks> zhiyan: obviously go ahead if it's on topic.
17:11:12 <zhiyan> garyk: you know currently we see image always a file, but i see image it's resource
17:11:53 <garyk> zhiyan: not sure i understand. can you please elaborate?
17:12:08 <zhiyan> garyk: in libvirt's cache fetching and cache manger, we alway use "file" approach to do handle that, for example, release image just always means delete file
17:12:29 <garyk> ah, ok. here is is similar
17:13:16 <garyk> when a vm is spawned we check if the image is on a datastore. if not then we load it from glance. for example a linked clone image. the vm then uses this when it spawns
17:13:45 <garyk> when these images are no longer used they should be aged similarly to those with libvirt - it ensures that these files do not checw up all of the disk on the datastore
17:14:03 <zhiyan> but maybe we need some handler to handle image fetching and release. for example, if we do some zero-copy approach to prepare template/cached image, we should using some particular approach to remove image from datastore
17:14:30 <garyk> that is something which we are working on in glance at the moment
17:14:54 <hartsocks> zhiyan, garyk: maybe you guys could chat about this in #openstack-vmware or #openstack-nova later? This seems like implementation level discussion. I encourage it but we have 5 other BP I want to at least touch on today. :-)
17:15:10 <garyk> sure - please see https://review.openstack.org/#/c/58883/
17:15:18 <zhiyan> hartsocks: sure :)
17:15:25 <hartsocks> np
17:16:04 <hartsocks> To recap the caching BP. I found 2 other BP with the keyword "cache" in the name. I think that probably causes some inquiries.
17:16:23 <hartsocks> So far I don't see these as related in any real way.
17:16:47 <hartsocks> But, we may have to clarify things to core-reviewers who are in a hurry, so be prepared.
17:17:18 <hartsocks> #link https://blueprints.launchpad.net/nova/+spec/vmware-vsan-support
17:17:23 <hartsocks> vuil: ping?
17:17:52 <tjones> if he's not here - i recall that at our last standup he said he is just adding tests
17:18:02 <hartsocks> cool.
17:18:07 <tjones> so it seems on track for i-2
17:18:15 <garyk> at the moment Vui has posted a wip patch
17:18:20 <garyk> https://review.openstack.org/#/c/53976/
17:18:25 <garyk> this is progressing nicely
17:18:27 <vuil> sorry I just got in
17:18:33 <hartsocks> We just need the BP to be targeted and ready for review by next week.
17:18:44 <hartsocks> The patch can be WIP for a few more weeks.
17:18:55 <hartsocks> vuil: talkin' about ya'
17:19:04 <garyk> hartsocks: not sure i understand. what needs to be ready for review?
17:19:11 <hartsocks> The BP
17:19:44 <vuil> Isn't it approved?
17:19:47 <hartsocks> We need to have the Blueprints out of draft, approved, and in progress.
17:20:13 <hartsocks> Yep. This one is approved so we're in good shape there.
17:20:30 <hartsocks> Sounds like it's making good progress too.
17:20:36 <vuil> yep
17:20:45 <hartsocks> Next up...
17:20:51 <hartsocks> #link https://blueprints.launchpad.net/oslo/+spec/pw-keyrings …
17:20:59 <hartsocks> which is actually an Oslo BP...
17:21:17 <hartsocks> We were going to leverage this for getting our passwords out of the .conf files.
17:21:22 <hartsocks> Looks like this is stalled.
17:21:46 <hartsocks> We will have to take over this BP or propose an alternate. I've put that on my plate to follow up on.
17:21:53 <tjones> ohhh - what i said about you working with rado on sso was wrong oops. 2 diff issues
17:21:57 <tjones> i'll let him know
17:22:05 <tjones> got confused
17:22:07 <hartsocks> There is an SSO thing over in keystone.
17:22:14 <tjones> yes i get it now
17:22:23 <rgerganov> one way to avoid usernames/passwords in clear text is to use SSO tokens
17:22:24 <hartsocks> 2 approaches 1 problem...
17:22:36 <tjones> yes
17:22:47 <hartsocks> rgerganov… yep… that's what the Keystone Federation thing is about...
17:22:50 * hartsocks digs for link
17:23:06 <hartsocks> #link https://wiki.openstack.org/wiki/Keystone/Federation/Blueprint
17:23:18 <dims> hartsocks, python-openstackclient has keyring support, may be there's something can be extracted from there
17:23:19 <hartsocks> This is something I planned on coordinating for icehouse-3 at the soonest.
17:23:30 <hartsocks> dims: cool!
17:23:40 <dolphm> (that bp is probably going to be dropped as it's being replaced with several other blueprints with narrower scope)
17:23:51 <hartsocks> Federation?
17:23:54 <dolphm> yes
17:23:56 <rgerganov> ok, but we can add support for VMware SSO tokens before the federation happens, right?
17:24:11 <hartsocks> What we need at the Nova driver level is to hook SAML tokens into the driver.
17:24:20 <rgerganov> hartsocks, right
17:24:24 <hartsocks> .. er… security context.
17:24:51 <hartsocks> I had hoped to lift authentication concerns out of the driver altogether and do SSO "the right way"
17:25:15 <hartsocks> #action follow up on SSO with rgerganov, hartsocks, and dolphm
17:25:45 <rgerganov> hartsocks, ok we can continue the discussion after the meetings
17:25:59 <hartsocks> we should probably chat and do an etherpad on this one. I'll document what I have so far.
17:26:27 <hartsocks> I have 2 more Blueprints that I'm tracking...
17:26:34 <hartsocks> #link https://blueprints.launchpad.net/nova/+spec/autowsdl-caching
17:26:56 <hartsocks> Which I'm breaking into 2 phases… 1 will be a naive CLI tool
17:27:03 <hartsocks> which I'll post shortly.
17:27:28 <hartsocks> Phase 2 will be the "auto" part which will make the WSDL repair seamless to the driver's admin.
17:27:55 <hartsocks> But I need to figure out how to work with Oslo for that (that's new for me).
17:28:01 <hartsocks> Last up...
17:28:19 <hartsocks> #link https://blueprints.launchpad.net/nova/+spec/config-validation-script
17:28:29 <tjones> is that for i-2?
17:28:31 <hartsocks> tjones: that's currently owned by you
17:28:43 <tjones> feel free to take it :-D
17:28:44 <hartsocks> ah, nope...
17:28:47 <hartsocks> it's i-3
17:28:52 <tjones> yeah that's what i was thinking too
17:28:55 <hartsocks> Could you assign it to me?
17:29:33 <hartsocks> I currently have no privs on it.
17:30:07 <hartsocks> I did chat with ogelbukh last week.
17:30:26 <hartsocks> They are actually making a fair bit of progress on the static validation component.
17:30:54 <hartsocks> There will need to be a service-level validation component … that's left unimplemented and probably needs some discussion.
17:31:06 <hartsocks> #link https://etherpad.openstack.org/p/w5BwMtCG6z
17:31:41 <hartsocks> So… that's all the BP I'm currently tracking for the team.
17:31:52 <hartsocks> Do we need to track others?
17:32:48 <hartsocks> nice 30 minute mark and I managed to list all of them! Sorry for the rush.
17:34:06 <tjones> sursure
17:34:07 <tjones> sure
17:34:14 <garyk> hartsocks: i think that next week we should try and track the glance and cinder ones too - but we can take that offline
17:34:42 <hartsocks> okay cool. I know they have some things in progress but I've not researched them yet.
17:34:59 <hartsocks> anything else before we move to bugs?
17:35:39 <hartsocks> #topic bugs
17:36:00 <hartsocks> I have 7 bugs I'm tracking for the team that are at priority High or Critical...
17:36:16 <hartsocks> heh… my report script links only reviews tho...
17:36:33 <hartsocks> #link https://review.openstack.org/52630
17:36:40 <hartsocks> #link https://review.openstack.org/43270
17:37:01 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1180044
17:37:04 <uvirtbot> Launchpad bug 1180044 in nova "nova failures when vCenter has multiple datacenters" [High,In progress]
17:37:11 <hartsocks> there… I'll link the bugs in here.
17:37:25 <hartsocks> garyk: that's yours…
17:37:51 <garyk> yea, that one has been in review for a very long time… it is critcial for backports and sadly we missed the boat for the stable havana
17:38:01 <hartsocks> bummer.
17:38:36 <garyk> uoside is i get to rebase it once every week or so
17:38:39 <hartsocks> I should be able to do more reviews now. I wanted to pull this one and do functional testing on it.
17:39:17 <hartsocks> BTW: I will do my bug reports once a week in conjunction with this meeting now. It's probably more topical that way.
17:39:37 <garyk> ok
17:39:53 <hartsocks> This bug is so important it's actually listed twice on my report :-)
17:40:06 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1230047
17:40:07 <uvirtbot> Launchpad bug 1230047 in nova "VMware: spawning large amounts of VMs concurrently sometimes causes "VMDK lock" error" [High,In progress]
17:40:22 <hartsocks> garyk: you *again* …
17:40:29 <tjones> im back - macbook crashed.
17:40:45 <tjones> yes i will transfer the BP to you - that;s the last thing i saw for me
17:41:05 <hartsocks> tjones: cool, I have no privs on that BP until you do so I can't alter it.
17:41:31 <tjones> hatsocks: i am sure you have moved on. but could you spilt that into 2 BP? Once for service validation and one for config validation?
17:41:39 <hartsocks> tjones: I'm listing the 6 tip priority bugs right now.
17:42:03 <hartsocks> tjones: yeah, I'll do that and document BP dependencies once I can edit it.
17:42:12 <tjones> L0D
17:42:16 <tjones> :-D
17:42:25 <hartsocks> #link https://review.openstack.org/#/c/58598/
17:43:03 <hartsocks> this concurrent downloads thing is just languishing… so I guess we all need to focus on this one a bit.
17:43:30 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1246848
17:43:32 <uvirtbot> Launchpad bug 1246848 in nova "VMWare: AssertionError: Trying to re-send() an already-triggered event." [High,In progress]
17:43:43 <garyk> i have dealt with that (and it works pretty well). just need to get it reviewed….
17:43:55 <garyk> the concurrent downloads that is
17:44:53 <hartsocks> yeah, I think reviews are the #2 priority after getting any icehouse-2 BPs that are still un-approved marked as 'approved'
17:45:11 <hartsocks> Or maybe these are both #1 priorities :-)
17:45:29 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1258179
17:45:31 <uvirtbot> Launchpad bug 1258179 in nova "VMware: timeouts due to nova-compute stuck at 100% when using deploying 100 VMs" [High,In progress]
17:45:34 <tjones> hartsocks: this one is still stuch with -2 from russellb. i've addressed the issues he raised but i need the -2 removed for people to review it https://review.openstack.org/#/c/56287/
17:45:54 <hartsocks> ugh.
17:46:16 <hartsocks> #action ping russellb on bug/1251021
17:46:53 <hartsocks> I've got only 2 more "high" to us priority bugs… these are marked "medium" to the nova community...
17:47:15 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1257038
17:47:18 <uvirtbot> Launchpad bug 1257038 in openstack-vmwareapi-team "VMware: instance names can be edited, breaks nova-driver lookup" [High,In progress]
17:47:24 <hartsocks> That one needs reviews.
17:48:06 <hartsocks> It's a Nova to vCenter robustness issue… I filed it because right now we use the vCenter name for the VM to link the VM to Nova's control. That's fragile.
17:48:22 <garyk> this one has actaully been addressed by https://review.openstack.org/#/c/60259/
17:48:24 <hartsocks> Fortunately the fix is nice and backwards compatible.
17:48:55 <garyk> the patch proposed by sidarth closes a edge case when the value is not set. issue here is the cpu spike
17:49:30 <hartsocks> Well, I took a moment to talk about this one here because I'm sure it's not clear what I'm complaining about in the bug.
17:49:44 <hartsocks> The "edge case" is what I'm complaining about.
17:49:44 <garyk> so https://review.openstack.org/#/c/59571/ make it really robust
17:50:03 <garyk> yup, agreed.
17:50:03 <hartsocks> right.
17:50:42 <hartsocks> actually, I feel I should never have approved the design we shipped in Havana. The vCenter name for an instance is a "vanity" kind of thing. It's far too easy to change and it makes vCenter hard to use.
17:50:52 <hartsocks> but that's a longer discussion.
17:51:17 <hartsocks> I classed it as Medium, but I would like to see the change backported … it should be backportable all the way through Grizzly.
17:51:53 <tjones> yes! and it's an easy one (for once)
17:52:08 <hartsocks> It's a longer range type of fix though and nobody's going to be unable to deploy OpenStack on vCenter without it.
17:52:31 <hartsocks> last bug on my short list:
17:52:55 <hartsocks> #link https://bugs.launchpad.net/nova/+bug/1213269
17:52:57 <uvirtbot> Launchpad bug 1213269 in openstack-vmwareapi-team "_check_if_folder_file_exists only checks for metadata file" [High,In progress]
17:53:12 <hartsocks> #link https://review.openstack.org/#/c/48544/
17:53:25 <tjones> i broke minesweeper
17:53:28 <tjones> with that one
17:53:31 <hartsocks> nice!
17:53:32 <tjones> i'll get back on it
17:53:50 <tjones> yeah! actually i was happy as it caught something my testing did not!
17:53:51 <hartsocks> So that's all the bugs I have in priority order.
17:54:04 <tjones> any new ones to triage?
17:54:40 <zhiyan> open discussing? :)
17:54:41 <hartsocks> #link http://goo.gl/pTcDG
17:55:01 <hartsocks> Man, I just cleaned up those triage area. I'll run triage later.
17:55:06 <tjones> *answers my own question* #link https://bugs.launchpad.net/nova/+bug/1259981
17:55:08 <uvirtbot> Launchpad bug 1259981 in nova "VMware: factor out the management of unit numbers" [Undecided,New]
17:55:09 <tjones> just one
17:55:29 <hartsocks> Okay.
17:55:46 <hartsocks> Let's do triage outside the meeting this week.
17:55:50 <tjones> ok
17:55:54 <hartsocks> #topic opendiscussion
17:56:15 <hartsocks> We have #openstack-vmware for any other discussion that won't fit into the meeting BTW.
17:56:16 <zhiyan> thanks hartsocks
17:56:26 <zhiyan> https://etherpad.openstack.org/p/vmware-ova-support
17:56:38 <garyk> how do we get the food trucks to my side of the world?
17:56:44 <zhiyan> for save time, i posted my text at there
17:56:48 <tjones> :-D i can send you a picture
17:57:12 <zhiyan> thanks for your input!
17:57:23 <hartsocks> zhiyan: nice. Sorry to have cut the open discussion part short this week. We have a deadline next week.
17:57:40 <zhiyan> hartsocks: sure, np at all
17:58:07 <hartsocks> Just a reminder if you have a BP that isn't *approved* for Icehouse-2 by this time next week you might not make it at all no matter how far along your code is.
17:58:59 <hartsocks> I know there's a general policy to −2 anything that is milestone targeted but the BP isn't approved. So just watch for that, it can ruin your release cycle.
17:59:45 <hartsocks> zhiyan: yeah, I think this is one of the glance BP that garyk mentioned … I should probably track those for the team too...
18:00:09 <hartsocks> This one isn't targeted for icehouse-2 either...
18:00:21 <hartsocks> it is approved tho'
18:00:29 <hartsocks> whoops… out of time.
18:00:33 <zhiyan> hartsocks: yes, and i think this work should involve glance and nova both
18:00:42 <tjones> moving to #openstack-vmware
18:00:57 <hartsocks> We're over in #openstack-vmware for anything you're not 100% belongs on #openstack-nova
18:01:00 <hartsocks> #endmeeting