17:01:07 <tjones> #startmeeting vmwareapi
17:01:07 <openstack> Meeting started Wed Apr 16 17:01:07 2014 UTC and is due to finish in 60 minutes. The chair is tjones. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:11 <openstack> The meeting name has been set to 'vmwareapi'
17:01:19 <browne> hi
17:01:19 <tjones> hi folks - who is here today?
17:01:37 <tjones> listening.....
17:01:43 <dims> o/
17:02:04 <tjones> hey dims - haven't seen you around in a while - welcome
17:02:15 * mdbooth is here briefly
17:02:38 <dims> tjones, :)
17:03:06 <tjones> ok mdbooth - i wanted to get an update from you - so lets flip the agenda for a minute and go right to pyvmomi. last meeting you and ssurana were going to look into it. any progress?
17:03:33 <tjones> #topic pyvmomi
17:04:47 <sabari> Hey all
17:05:46 <tjones> mdbooth: im guessing no progress since no response. I'll ping again next week
17:05:51 <tjones> lets move on to BP
17:05:57 <tjones> #topic Blueprints
17:06:14 <tjones> anyone have something they would like to discuss here?
17:06:50 <tjones> #link https://review.openstack.org/#/q/status:open+project:openstack/nova-specs+message:vmware,n,z
17:07:26 <browne> not sure what to do with https://blueprints.launchpad.net/nova/+spec/vmware-encrypt-vcenter-passwords
17:07:45 <tjones> *looking*
17:08:07 <browne> Joe Gordon reviewed the nova-spec and would like a more general solution that addresses passwords for rabbit, database connections, etc
17:08:30 <browne> https://review.openstack.org/#/c/85510/
17:08:39 <tjones> thanks was just searching for that
17:09:19 <tjones> his comment makes sense and i wonder if it should be something in oslo then?
17:09:19 <browne> might need to go back to the drawing board and propose something different
17:09:38 <tjones> browne: that's ok (to restart)
17:09:50 <mdbooth> Sorry, was driving. Also, I'm on a phone.
17:10:04 <browne> nobody likes the idea of encrypting those password strings either.
17:10:26 <tjones> mdbooth: lets wait to talk until you are out of the car
17:10:52 <mdbooth> Then I'll be gone
17:11:10 <mdbooth> I can catch up tomorrow, though
17:11:20 <tjones> mdbooth: that's fine. thanks
17:11:22 <mdbooth> Have looked at pyvmomi
17:11:53 <tjones> browne: im looking - it doesn't look like what you have proposed is very far off from a general solution at 1st glance
17:11:59 <mdbooth> tjones: ok, will lurk until I disconnect
17:12:05 <browne> fyi, the ssh key injection blueprint https://blueprints.launchpad.net/nova/+spec/vmware-inject-ssh-key, might be a no-op.
17:12:35 <sabari> browne: did you get a chance to try cloud-init images ?
17:12:36 <browne> after talking with sabari and researching, ssh key injection should already work as long as the image has cloud-init installed
17:12:58 <browne> sabari: still working on downloading ubuntu 13. taking forever
17:12:58 <tjones> browne: cool
17:13:05 <sabari> browne: :)
17:13:16 <browne> our default debian image does not have cloud-init
17:13:33 <tjones> browne: we should prob build a new one with it
17:13:41 <tjones> so anything else on BP?
17:13:45 <browne> and can't be installed either since cloud-init is in the unstable/testing repo of debian. i tried with no luck
17:13:51 <mdbooth> Libguestfs is excellent at guest mods
17:14:03 * mdbooth used to work on it
17:14:26 <mdbooth> Can detect guest os
17:14:29 <browne> looked at libguestfs, which i think gets complicated with vcenter in there
17:14:49 <mdbooth> Doesn't have to
17:15:15 <browne> plus it requires ssh enabled, no?
17:15:40 <mdbooth> It could use https with light mods
17:16:09 <browne> mdbooth: ok, maybe we can get together and discuss later. i'd like to understand more
17:16:19 <mdbooth> Ok.
17:16:43 * mdbooth still has commit on libguestfs
17:16:56 <tjones> #action browne and mdbooth discuss libguestfs offline
17:17:18 <tjones> any other BP for discussion?
17:18:00 <tjones> ok moving on to the summitt
17:18:05 <tjones> #summit
17:18:12 <tjones> #topic summit
17:18:45 <tjones> we have very few talks proposed for the summit - only 2 so far. the deadline for proposal is the 20th (4 days from now)
17:19:22 <tjones> any topics specific to the vmware driver that we need to discuss at the summit?
17:19:50 <sabari> host/node was something I wanted to talk about but it's already part of http://summit.openstack.org/cfp/details/145
17:20:01 <dims> tjones, has anyone picked up the new abstraction layer for vcenter/hyperv/ovirt stuff that we know of?
17:20:58 <dims> ah same topic as sabari's question :)
17:21:01 <tjones> dims: kinda - take a look at http://summit.openstack.org/cfp/details/145 and see if that is what you mean
17:21:03 <tjones> yes
17:21:15 <browne> i believe i saw on the ML there was a 3rd CI topic. might want to attend that one
17:21:23 <browne> 3rd party CI
17:22:32 <tjones> anything else we are missing?
17:23:15 <dims> any progress/talk about how oslo.vmware should work?
17:23:35 <tjones> dims: that could be very useful
17:24:05 <tjones> dims: do you want to propose that ?
17:24:17 <sabari> tjones: is there something about standardizing image metadata across hypervisors ?
17:24:20 <sabari> I am not able to find, but I remember was discussed at the mid-cycle.
17:24:25 <dims> tjones, i was hoping the people working on it actively would
17:24:43 <tjones> dims: i can talk to them. i don't think they are at this meeting today
17:24:48 <dims> possibly arnaud?
17:24:54 <sabari> tjones: can check with vipin, garyk, arnaud
17:25:08 <tjones> yes they are the ones i was thinking of
17:25:28 <tjones> #link http://summit.openstack.org
17:25:54 <tjones> sabari: i don't see anything that looks like that
17:26:15 <sabari> tjones: okay, not something I wanted to propose, but wanted to be part of :)
17:26:21 <tjones> lol
17:26:34 <tjones> well proposing just means you could lead the discussion
17:26:43 <tjones> you don't have to have all the answers
17:27:07 <tjones> #action ask vipin, arnaud, gary to propose a session on using oslo.vmware
17:27:22 <dims> +1 assign work to folks who are not here :)
17:27:22 <sabari> tjones: but i don't intent to standardize it yet :)
17:27:42 <tjones> #action see if anyone want to lead a session on standardizing image meta-data
17:29:00 <tjones> what about the issue that came up during image cache - multiple n-cpu accessing the same datastore and potentially messing eachother up (that's the technical description)
17:30:06 <tjones> http://summit.openstack.org/cfp/details/145guess that could be part of http://summit.openstack.org/cfp/details/145 a
17:30:09 <sabari> hmm yup that's a problem because all of them will try to fill up the temp directory.
17:30:34 <tjones> sabari: yes there are several issues there
17:30:49 <sabari> need to understand what ll happen with arnaud's patch with locking in place
17:31:02 <sabari> let me post it
17:31:17 <tjones> ok any other summit topics?
17:31:43 <sabari> https://review.openstack.org/#/c/75551/
17:31:56 <sabari> I will investigate or check with him
17:32:14 <tjones> ok thanks
17:32:34 <tjones> ok lets talk about refactoring
17:32:40 <tjones> #topic refactoring
17:32:55 <tjones> the phase 1 patches are all in and i am rebasing over and over as they get reviewed
17:33:34 <tjones> shawn has the phase 2 in review and there are issues and jenkins issues too.
17:33:45 <sabari> there some pep8 failures or so
17:33:45 <tjones> vui is not here unfortunately to talk about his part
17:34:25 <tjones> sabari: i fixed that this am and rebased
17:34:35 <sabari> tjones: great!
17:35:03 <tjones> please help out an review the phase 1 patches listed in #link https://blueprints.launchpad.net/nova/+spec/vmware-spawn-refactor
17:35:32 <browne> will do
17:35:46 <tjones> #topic other patches
17:35:55 <tjones> any other patches people want to discuss?
17:36:55 <tjones> *listening*
17:37:30 <tjones> #topic bugs
17:37:32 <sabari> strangely the bug fix patches are MIA :) should take a look at the bugs and look for imp ones.
17:37:41 <sabari> awesome :)
17:37:57 <tjones> we have a bunch of un-owned bugs - here is an ugly link
17:38:01 <tjones> #link https://bugs.launchpad.net/nova/+bugs?field.searchtext=&orderby=-importance&search=Search&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&assignee_option=none&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=vmware+&field.tags_combinator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_
17:38:11 <tjones> 13 with no owner. help yourself to a bug ;-)
17:38:27 <tjones> sabari: which ones were you referring to?
17:39:11 <tjones> here's an ugly link to the inprogress bugs
17:39:14 <tjones> #link https://bugs.launchpad.net/nova/+bugs?field.searchtext=&orderby=-importance&search=Search&field.status%3Alist=INPROGRESS&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=vmware+&field.tags_combinator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_patch.used=&field.has_branches.us
17:39:25 <tjones> sorry should use a tinyyrl
17:40:10 <sabari> tjones: nothing in particular, I was just looking for new reviews and there were far less bug fixes than usual.
17:41:32 <sabari> tjones: thankts for the links
17:41:46 <sabari> I ll scout for the important ones.
17:43:13 <tjones> garryk has a good query but i cannot find it
17:43:33 <tjones> #topic open discussion
17:43:40 <tjones> anyone have a topic for today?
17:44:26 <tjones> (btw the link was #link https://review.openstack.org/#/q/status:open+project:openstack/nova+message:vmware,n,z)
17:45:21 <tjones> if not we can stop early
17:45:42 <tjones> listening for slow typers.....
17:46:11 <tjones> thanks all. talk to you next week
17:46:14 <sabari> tjones: okay!
17:46:14 <tjones> #endmeeting