17:00:45 <tjones1> #startmeeting vmwareapi
17:00:46 <openstack> Meeting started Wed Dec 10 17:00:45 2014 UTC and is due to finish in 60 minutes. The chair is tjones1. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:50 <openstack> The meeting name has been set to 'vmwareapi'
17:01:00 <tjones1> hi folks
17:01:04 <tjones1> who;s here today?
17:01:04 <thangp> o/
17:01:08 <rgerganov> hello
17:01:47 <thangp> small crowd
17:01:56 <sabari> hello
17:01:58 <tjones1> sorry for all of the confusion about this meeting time. this IS the right time (since we are in DST in the US)
17:02:02 <rgerganov> gary will join in a minute
17:02:14 <tjones1> yeah it's been super small (like just me) for a few weeks :-)
17:02:31 <tjones1> ok lets get started
17:02:32 <garyk> hi
17:02:39 <tjones1> #topic BP in flight
17:03:04 <tjones1> garyk: SPBM done!!!!
17:03:14 <garyk> the ephemeral on has one patch outstanding - resize
17:03:24 <garyk> yay! - nearly a year in review :)
17:03:36 <rgerganov> two of the vSAN patches landed, two more to go
17:03:39 <tjones1> awesome - i think that someone started it before i started in nova - over 2 years now
17:03:49 <tjones1> how about ova?
17:03:58 <rgerganov> I have restored the OVA patch
17:04:05 <rgerganov> https://review.openstack.org/#/c/82715/
17:04:08 <rgerganov> it is ready for review
17:04:34 <tjones1> great - lets jump on that
17:04:53 <tjones1> so we *might* get this done by k1 (12/18)
17:05:00 <tjones1> 12/18 that was
17:05:27 <rgerganov> it's only one patch and it is in good shape IMO
17:05:30 <tjones1> realistically i suspect just vsan and ephemeral - but is is really much better progress than icehouse or havana for us
17:05:57 <garyk> yes, the reviews are great at the moment!
17:05:59 <tjones1> great - maybe even ova. lets please keep up on the reviews - i myself have been really bad about it but plan on getting better
17:06:02 <rgerganov> the last vSAN patch was approved but I had to rebase
17:06:08 <tjones1> awwww
17:06:33 <tjones1> ok moving on to BP not approved
17:06:51 <tjones1> rgerganov: how's the console work going ?
17:07:03 <tjones1> #link 127283
17:07:06 <tjones1> oops
17:07:17 <rgerganov> tjones1: it is on hold because I was busy with everything else
17:07:21 <rgerganov> I will start working on it soon
17:07:35 <tjones1> ah ok - 1st to update the api right?
17:07:39 <tjones1> #link https://review.openstack.org/#/c/127283
17:07:49 <rgerganov> yeah
17:07:55 <tjones1> need a new spec for that?
17:08:10 <rgerganov> yup, I will prepare a new spec for consolidating the console APIs
17:08:14 <tjones1> ok great
17:08:49 <tjones1> sorry - i've forgotten who took over for arnaud on the ova with multiple disks with tflower (and dims)
17:09:12 <tjones1> https://review.openstack.org/#/c/128691/14
17:09:20 <tjones1> looks like it's lost momentum
17:09:21 <rgerganov> I can take it because I am already working on OVA
17:09:27 <tjones1> ok great - thanks
17:09:47 <rgerganov> tflower needs to address the comments on the spec
17:09:54 <tjones1> yeah
17:09:57 <tjones1> i'll ping him
17:10:19 <tjones1> the other 2 in flight don't have their people here. thangp did you have any specs in review you wanted to discuss?
17:10:28 <garyk> could that be realted to the patches with the bdm support
17:11:00 <tjones1> garyk: ?
17:11:41 <garyk> the spec that you mentioned above
17:11:50 <garyk> sec.
17:12:07 <garyk> it may be related to https://review.openstack.org/128508
17:12:16 <garyk> that is, it should be able to use that patch
17:12:35 <rgerganov> garyk: when having multiple disks in the OVA?
17:12:44 <thangp> tjones1: not really
17:12:45 <tjones1> oh ok
17:13:18 <thangp> just waiting on https://review.openstack.org/#/c/128508/ to be approved
17:13:25 <thangp> it was rebased a few times
17:14:04 <tjones1> ok cool
17:14:06 <thangp> it got +1 from mbooth, garyk, etc. but was lost in the rebase
17:14:17 <tjones1> anything else on BP/spec in review?
17:14:30 <tjones1> if not...
17:14:39 <tjones1> #topic patches in flight
17:14:57 <tjones1> #link https://review.openstack.org/#/q/status:open+project:openstack/nova+message:vmware,n,z
17:15:32 <tjones1> there is one here that arnaud had - anyone interested in taking it over? #link https://review.openstack.org/136935
17:15:46 <rgerganov> surprisingly we don't have too many patches in review :)
17:16:18 <rgerganov> garyk is already babysitting this one
17:17:13 <tjones1> oh ok thanks garyk
17:17:27 <tjones1> last topic from me is bugs
17:17:32 <tjones1> #topic bugs
17:18:02 <tjones1> #link https://bugs.launchpad.net/nova/+bugs?field.searchtext=&orderby=-importance&search=Search&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=vmware&field.tags_combinator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit
17:18:04 <tjones1> ugh
17:18:05 <rgerganov> do you have a link handy?
17:18:05 <tjones1> sorry
17:18:14 <tjones1> yes it's that huge one
17:18:43 <tjones1> not getting many new ones
17:19:41 <tjones1> if we have new folks joining - we have plenty for them to start up on
17:20:17 <rgerganov> we have patches in flight for most of the high prio bugs
17:20:32 <tjones1> yeah i don't see anything really bad there (other than the count)
17:20:43 <rgerganov> :)
17:20:46 <tjones1> lets move on
17:20:56 <tjones1> #topic open discusssion
17:21:04 <tjones1> anyone want to bring anything up?
17:21:14 <tjones1> i have one thing
17:21:53 <tjones1> is this meeting useful and if so how can we make it more useful?
17:22:26 <garyk> it is useful - problem is we have lost momentum due to summit etc.
17:22:37 <thangp> usefule to me
17:22:40 <rgerganov> garyk: +1
17:22:44 <thangp> * useful
17:23:09 <rgerganov> if we want new contributors we need to keep this meeting
17:23:10 <thangp> it's the coffee and cappiccino
17:23:21 <tjones1> ok is there a better structure?? im not married to being the chair if someone else wants to do it also
17:23:27 <garyk> rgerganov: +1
17:23:32 <tjones1> thangp: :-)
17:23:38 <garyk> i think that the structure is good
17:23:54 <garyk> one of the concerns that i have is that we just do nova. we should also cover cinder, glance and neutron
17:24:13 <garyk> so maybe we can have sections for the updates.
17:24:15 <tjones1> funny - i was just thinking that this morning that we don't have a forum for all of them
17:24:36 <tjones1> does neutron already have a meeting?
17:24:40 <garyk> the nova is where the bulk of the work is at the moment but it would be good to have an item for the opthers - there may be integration points etc
17:24:58 <rgerganov> that's a very good point
17:25:00 <garyk> there is a general neutron meeting but not vmware specific stuff
17:25:22 <garyk> with the NSXv proposal in K we will have some issues with nova that we need to address (and naturally neutron)
17:25:29 <tjones1> ok that's a good idea.
17:25:53 <tjones1> i'll need to ask vipin if he can attend this late or move it to earlier
17:26:10 <garyk> thangp: i made one more pass on the bdm stuff and saw on minor issue if you could please look at it (sorry for chiming in late)
17:26:56 <tjones1> #action: tracy to send email on the ML letting people know that we will cover glance, nova, neutron, and cinder at this meeting going forward.
17:27:09 <thangp> garyk: sure, looking
17:27:24 <garyk> thanks!
17:27:44 <tjones1> im not hearing anyone clambering to be the chair of the meeting
17:27:50 <garyk> i am going to have to drop off now. nice chatting with you guys again. sorry and have a good day/night or whatever tz you are
17:27:57 <tjones1> ok see ya
17:28:07 <rgerganov> bye gary
17:28:11 <tjones1> i'll take that to be "im doing a good job" and not "no one else wants to do it"
17:28:13 <tjones1> :-)
17:28:17 <tjones1> ok that's it i think
17:28:23 <tjones1> thanks guys and talk to you next week
17:28:29 <rgerganov> thanks tracy
17:28:43 <tjones1> #endmeeting