15:01:36 <pc_m> #startmeeting vpnaas
15:01:36 <openstack> Meeting started Tue Jan 20 15:01:36 2015 UTC and is due to finish in 60 minutes.  The chair is pc_m. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:39 <openstack> The meeting name has been set to 'vpnaas'
15:01:44 <pc_m> hi numan
15:01:46 <numan> hi
15:01:50 <numan> pc_m, hi
15:02:21 <pc_m> OK. let's go...
15:02:27 <pc_m> #topic Announcements
15:03:08 <pc_m> I updated the Wiki with info on running VPN on a single DevStack with two routers
15:03:11 <pc_m> #link https://wiki.openstack.org/wiki/Neutron/VPNaaS/HowToInstall#VPNaaS_with_Single_DevStack_and_Two_Routers
15:03:38 <matrohon> pc_m : great!
15:03:39 <pc_m> We can use that to do a nice functional/scenario test for VPN.
15:03:57 <numan> pc_m, great
15:04:12 <Swami> pc_m: nice
15:04:52 <pc_m> Any other announcements?
15:05:31 <pc_m> #topic Bugs
15:06:05 <pc_m> Please take some time and look at the VPN bugs and provide comments so we can move everything forward.
15:06:21 <pc_m> Here's the list https://review.openstack.org/#/q/status:open+project:openstack/neutron-vpnaas,n,z
15:06:40 <pc_m> Want to touch on a few and get feedback from people...
15:07:09 <pc_m> One is PID issue on CentOS. #link https://review.openstack.org/#/c/147852/
15:08:10 <Swami> pc_m: I got a comment from you on one of my patch for the vpnaas support for DVR
15:08:35 <Swami> regarding manual testing.
15:08:39 <pc_m> I'm a little concerned about whether that temp fix is adequate. Anyone know of a long term solution?
15:08:58 <pc_m> Swami: hang on. we'll hit that one in a sec.
15:09:16 <Swami> pc_m: thanks
15:10:37 <pc_m> Appears to be that if dir is not owned by root, there are issues in CentOS.
15:11:34 <pc_m> Should we bring this up on ML or neutron IRC?
15:12:19 <numan> the temp solution solves this problem by adding '/' at the end of the pid path ?
15:12:36 <pc_m> numan: yeah
15:13:14 <numan> ok.
15:13:14 <pc_m> At the min. we need some comment to indicate this special workaround. Wondering about final solution.
15:14:04 <pc_m> #action Discuss 147852 on ML to see if there is a permanent solution.
15:14:35 <pc_m> Swami: We can talk about your review... do you have the review link...
15:14:54 <pc_m> I got it... #link https://review.openstack.org/143203
15:15:10 <Swami> yes
15:15:35 <Swami> #link https://review.openstack.org/#/c/143203/
15:15:49 <pc_m> I need to go over it again. My main concern was that we've manually tested setting up IPSec connections, as we don't have any functional/scenario tests.
15:15:49 <Swami> You have a comment in there to make sure that I do the manual testing.
15:16:37 <Swami> Yes we are planning to add some functional and scenario test for the ipsec vpn.
15:16:50 <pc_m> I see you have. Great!  I'll approve.
15:16:55 <Swami> But that should be submitted as a separate patch and will work on it.
15:17:34 <matrohon> Swami : please have a look at fullstack for functional tests
15:17:35 <pc_m> Swami: Yes, we badly need functional tests. I have a way to run on one node.
15:18:05 <matrohon> Swami : https://review.openstack.org/#/c/128259/
15:18:09 <pc_m> Was planning on talking to Maru and others about what is needed for a test.
15:18:09 <numan> pc_m,  Swami, presently jenkins doesn't run functional job for vpnaas. I have raised a bug for it. https://bugs.launchpad.net/openstack-ci/+bug/1412770
15:18:34 <pc_m> #action pc_m to investigate what is needed for function/scenario test.
15:18:37 <Swami> pc_m: Yes I understand, we are in the process of adding functional tests and vpn will be also under the radar. That is a good point.
15:19:16 <matrohon> Swami : do you have an assigned bug?
15:19:27 <pc_m> Can use help is creating the test cases, especially for variants, like DVR.
15:19:42 <pc_m> numan: Yeah, saw that. Do we have any functional tests?
15:20:04 <Swami> matrohon: no i have not created a bug for the functional test, but we are working with marun and carl_baldwin to fill in the issues with functional tests.
15:20:26 <numan> pc_m, not yet, but there are two patches which have functional tests
15:21:17 <pc_m> numan: Gotcha. So we have a place holder for enabling, once these are working.
15:21:50 <pc_m> Another bug is FQDN #link https://review.openstack.org/#/c/145005/
15:22:17 <numan> pc_m, i saw your comments. I will address them
15:22:34 <numan> pc_m, one question is about the functional tests. Are they really functional tests ?
15:23:18 <pc_m> Yeah, the test seems to just be testing the get next hop method. Seems just like a UT to me.
15:23:33 <numan> i added those tests in the functional test section because they interact with the system
15:23:39 <pc_m> numan: Did you have something different in mind, or am I missing something.
15:24:31 <numan> i can move them to unit tests. can the unit tests create namespace and other resources ?
15:24:40 <pc_m> I see your reply... good question. I'm not sure if it needs to be in functional test due to the namespace.
15:25:02 <numan> ok. In that case I will move them to unit tests
15:25:58 <pc_m> numan: Let's ask on IRC and see if they should be functional or unit.
15:26:07 <numan> sure
15:26:48 <pc_m> numan: Especially because getaddrinfo is mocked out, right?
15:26:48 <numan> Also do we need to support running functional tests in jenkins before the patch (with functional tests) merges ?
15:27:00 <numan> pc_m, right.
15:27:26 <pc_m> Yeah, that's a bit of a catch-22
15:27:48 <numan> pc_m, i will see if i can get away mocking getaddrinfo
15:27:48 <matrohon> numan : that seems reasonnable
15:27:53 <pc_m> #action numan to see if tests for 145005 need to be fucntional or UT.
15:28:18 <numan> matrohon, you mean mocking getaddrinfo ?
15:28:24 <pc_m> numan: I'm thinking if you just mock, and consider a UT, you avoid the whole issue.
15:28:56 <pc_m> In general though, I guess we need to determine what functional tests we need for VPN.
15:28:58 <matrohon> I meant waiting for functional test to be run in neutron-vpnaas
15:29:11 <numan> matrohon, ok
15:29:18 <pc_m> The one with StrongSwan seems to make sense.
15:30:17 <pc_m> numan: Check on the IRC. I think you can progress much faster, if you don't have the functional test dependency.
15:30:32 <numan> pc_m, ok sure
15:31:02 <pc_m> Next one is netns for StrongSwan #link https://review.openstack.org/#/c/146508/
15:32:10 <pc_m> I'm struggling a bit on netns_wrapper.py in that bug.
15:32:20 * pc_m not versed in /proc files
15:32:34 <matrohon> me too : it's very hard to review!
15:33:27 <pc_m> Logic in  execute_with_wount() is hard to understand.
15:33:49 <pc_m> I've been chatting with people on IRC. I'm questioning whether or not we can require kernel 3.8+ and thus use ns/mnt check.
15:34:42 <pc_m> #action pc_m discuss on ML whether we can require kernel 3.8+ for StrongSwan netns (146508)
15:35:07 <pc_m> Does anyone know what the check on L129-130 does?
15:35:39 * pc_m wondering if Zhang is on-line
15:36:42 <matrohon> I think he is located in beijing
15:37:18 <pc_m> matrohon: I'll post on ML as, we may be able to require kernel 3.8+ and be able to use /ns/mnt.
15:37:36 <matrohon> I think that nati_ueno could be asked to, this code is inspired from a previous patch of nati
15:37:47 <pc_m> Will see what the response is on the review.
15:38:01 <pc_m> matrohon: good point.  Checking...
15:38:28 <pc_m> don't see him on now, but can talk to him. It's an old file. Just not sure the assumptions are still true.
15:39:01 <pc_m> Next one is StrongSwan #link https://review.openstack.org/#/c/144391/
15:39:21 <numan> i think the code checks 2 points in one shot 1. if the caller is root or not 2. if the file /proc/1/ns/net exists or not
15:39:49 <pc_m> #undo
15:39:50 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x2000a50>
15:40:07 <pc_m> #redo
15:40:18 * pc_m oops. didn't mean to undo...
15:40:25 <pc_m> #topic Bugs
15:40:36 * pc_m might have messed that up.
15:41:17 <pc_m> numan: Yeah, but isn't this always called as root? Or is it a double check.
15:41:44 <numan> pc_m, if it isn't called as root os.getpid() will not be 1 i think
15:41:48 <pc_m> numan: Then the log message seems to confuse me as well.
15:42:08 <numan> pc_m, right. i think the code can be clearer.
15:42:32 <pc_m> numan: We'll let Zhang respond.
15:42:56 <pc_m> On StrongSwan review, 144391, I need to look it over again.
15:43:56 <pc_m> Anyone have any other bugs to discuss?
15:44:59 <pc_m> Please review the ones we have right now. We can use more eyes on these, from different perspectives.
15:45:16 <matrohon> numam reported a bug to enable functional test in neutron-vpnaas, but we already discussed that earlier
15:45:19 <matrohon> https://bugs.launchpad.net/openstack-ci/+bug/1412770
15:45:46 <pc_m> matrohon: Yes, appreciate the creation to track that.
15:46:06 <matrohon> I don't know if we have to wait for the infra to add the job
15:46:35 <numan> i am still not clear. if we need to fix this bug first or let some functional tests gets merged before enabling in infra
15:46:35 <matrohon> oh numan already assigned it to himself!
15:46:38 <pc_m> #action pc_m find out the sequencing for enabling functional tests and first reviews with functional pieces.
15:47:09 <numan> matrohon, i unassigned myself as i dont have the necessary expertise :)
15:47:56 <matrohon> I think you have to enable funct test job first, to have it voting on your new func test
15:48:09 <pc_m> numan: If you have bandwidth, do you want to pursue it though (none of us have expertise, I think)?
15:48:42 <numan> pc_m, i will try :)
15:48:46 <pc_m> I think we're all groping in the dark on the test stuff. Will need to consult with other.
15:48:51 <pc_m> numan: AWESOME!
15:49:10 <pc_m> #action numan to follow up on 1412770 needs
15:49:18 <matrohon> does anyone know who configured the job to run the vpnaas project
15:49:47 <pc_m> matrohon: I don't know.
15:50:17 <pc_m> numan: You may want to ask Maru on IRC. He may know.
15:50:45 <pc_m> #topic Open Discussion
15:50:46 <numan> ok
15:50:56 <pc_m> Anyone have anything to discuss?
15:51:22 <pc_m> Anything we're missing or need to do differently?
15:52:42 <pc_m> Thanks for joining in everyone!
15:52:49 <pc_m> #endmeeting