15:04:42 <pc_m> #startmeeting vpnaas
15:04:43 <openstack> Meeting started Tue Feb  3 15:04:42 2015 UTC and is due to finish in 60 minutes.  The chair is pc_m. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:46 <openstack> The meeting name has been set to 'vpnaas'
15:04:51 <pc_m> #topic Announcements
15:05:14 <pc_m> K-2 is in two days. Commits need to be in merge queue tomorrow to make it.
15:05:43 <pc_m> Functional gate is operating in experimental mode. Use "check experimental" to run.
15:06:09 <pc_m> Extension APIs for VPN are moving into tree.
15:06:44 <matrohon> is there any related link?
15:06:53 <pc_m> Zhang mentioned that OpenSwan will not be installed in Ubuntu 14.10
15:07:34 <pc_m> matrohon: There are a bunch of commits from Doug. Here is one: #link https://review.openstack.org/151544
15:08:01 <mhanif> Hi all
15:08:08 <matrohon> pc_m  : ok thanks
15:08:14 <pc_m> Doug is doing this for all *aaS repos.
15:08:27 <pc_m> Any other announcements?
15:09:00 <pc_m> #topic Functional Testing
15:09:15 <mhanif> pc_m: The stackforge project for edge VPN is up
15:09:30 <pc_m> mhanif: thanks!
15:09:45 <mhanif> The link to the spec is at #link https://review.openstack.org/#/c/152377/
15:10:12 <pc_m> mhanif: Thanks
15:10:25 <mhanif> Couldn't announce this before you changed the meeting topic :-)
15:10:51 <pc_m> mhanif: Sorry, going fast today...
15:11:04 <mhanif> pc_m: Sure.  No worries
15:11:14 <pc_m> Experimental queue is active and hooks are upstreamed, so everyone can create function tests and try them with the "check experimental" comment.
15:11:44 <pc_m> I'll be working on making the check queue active (non-voting), so that we can start checking functional test results.
15:12:15 <pc_m> Kyle suggested handling the functional tests as bugs, for now.
15:12:32 <pc_m> Any questions on  functional testing?
15:12:48 <pc_m> #action pc_m to get check queue running in non-voting mode.
15:12:57 <matrohon> pc_m : great work!
15:13:03 <pc_m> thanks
15:13:54 <pc_m> #topic Bugs
15:14:28 <pc_m> Check the list http://goo.gl/LxiN4E
15:15:28 <pc_m> Please help out and review these, so we can get things in.
15:15:54 <pc_m> Any comments/questions/concerns on any of the reviews?
15:16:20 <matrohon> is there a migration plan to move from openSwan to StrongSwan?
15:17:06 <pc_m> matrohon: Good question. Haven't seen anything specific, but will need to be addressed, given the news about OpenSwan and 14.10.
15:17:55 <pc_m> The two cannot coexist (cannot both be installed), so it is an either or usage.
15:18:31 <pc_m> AFAIK
15:19:11 <pc_m> Really need people to check out the StrongSwan review https:#link //review.openstack.org/#/c/144391/
15:19:27 <matrohon> according to the link you gave, it looks like libreSwan will be used instead of openswan for fedora based distro
15:20:27 <matrohon> I don't know which one red hat will prefer : libreswan or strongswan?
15:21:17 <pc_m> matrohon: Where did you see the libreSwan note? On the review link? (I didn't notice it)
15:21:34 <matrohon> on the meeting agenda
15:21:44 <matrohon> https://lists.fedoraproject.org/pipermail/scm-commits/Week-of-Mon-20130513/1022933.html
15:21:59 <pc_m> Ah, Zhang added that.
15:23:05 <pc_m> Sounds like we need to follow that.
15:23:37 <pc_m> matrohon: Do you know the difference between the two?
15:23:45 <pc_m> or difference(s)
15:24:15 <matrohon> not really!
15:24:33 <matrohon> I have always used strongswan
15:24:36 <pc_m> We'll have to ask Zhang. He may have more info.
15:25:19 <pc_m> Has anyone tested the StrongSwan implementation (144391 review)?
15:26:14 <pc_m> I've tried on two scenarios. One was single DevStack with two routers. IPSec tunnel is stuck in PENDING_CREATE. Not sure why at this point.
15:27:00 <pc_m> The other was two VMs running in VBOX, with DevStack on each. Having testbed issues, and cannot ping the router's public interface (before I even set up the tunnel).
15:27:41 <pc_m> Was able to do this with OpenSwan using older Jan 8th-ish image, so not sure if something has changed in neutron or not.
15:27:52 <pc_m> Still playing with it.
15:28:32 <pc_m> Could use help debugging, and more hands on checking out StrongSwan (which may be the reference impl in the future)
15:29:00 <matrohon> I'll try to give an hand
15:29:27 <matrohon> do you know what type of scenario Zhang is using for his tests
15:29:30 <pc_m> carl_baldwin: Do you have time today to talk about the issue I'm having with pinging neutron router with latest code?
15:30:16 <pc_m> matrohon: He has a blog with setup info (it's pretty complex - maybe more than what is needed).
15:30:37 <pc_m> #link http://blog.csdn.net/quqi99/article/details/30516665
15:30:37 <carl_baldwin> pc_m: I’m mobile at the moment but will be in the office soon.
15:30:53 <pc_m> carl_baldwin: ok. Will try to ping you later.
15:31:01 <pc_m> carl_baldwin: thanks!
15:31:47 <pc_m> Anything more on StrongSwan?
15:32:37 <pc_m> Anything anyone wants to discuss on bugs?
15:33:50 <pc_m> #topic Open Discussion
15:34:14 <pc_m> Anything else to discuss?
15:35:44 <pc_m> Ok. thanks for joining in!
15:35:50 <pc_m> #endmeeting