15:05:01 <pc_m> #startmeeting vpnaas
15:05:02 <openstack> Meeting started Tue Feb 10 15:05:01 2015 UTC and is due to finish in 60 minutes.  The chair is pc_m. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:05:06 <openstack> The meeting name has been set to 'vpnaas'
15:05:18 <pc_m> #topic Announcements
15:06:31 <pc_m> Function checks of all VPN commits are enabled for check queue (but temporarily disabled)
15:07:05 <pc_m> Coverage testing shuld be enabled, as soon as review gets another core +2/+A
15:07:41 <pc_m> #action Anyone with functional tests, please push for review, or update existing reviews.
15:08:01 <pc_m> Please look at any open bugs and review...
15:08:13 <pc_m> Any other new announcements?
15:08:42 <pc_m> #topic Functional Testing
15:09:01 <xuhanp> pc_m, is the strongswan driver going to be targeted at K-3?
15:09:38 <pc_m> xuhanp: It has been moved from K-2 to K-3, so that's the hope.
15:09:50 <xuhanp> sounds great. thanks!
15:10:07 <pc_m> Especially since Ubuntu is not installing OpenSwan in 14.10.
15:10:51 <xuhanp> yep
15:11:14 <pc_m> However, there are some issues with AppArmor interfering with StrongSwan operation, that we're trying to resolve (latest fix may work).
15:11:48 <pc_m> We should all try it and see if it works well (I plan to today and tomorrow), and comment on review.
15:11:52 <xuhanp> pc_m, I noticed that. will give it a try.
15:12:28 <pc_m> #action all to try StrongSwan implementation and comment on review.
15:12:30 <pc_m> #link https://review.openstack.org/144391
15:12:45 <pc_m> On functional tests...
15:13:19 <pc_m> The check-neutron-vpnaas-dsvm-functional was added to check queue (non-voting).
15:13:50 <pc_m> However, due to a acccidental reversion, it is back to experimental.  For now, one can do 'check experimental' to run.
15:14:24 <xuhanp> good to know
15:14:27 <pc_m> Once 154487 is upstreamed the tests should run on all commits (non-voting) again.
15:14:35 <pc_m> Should be today, I hope.
15:14:59 <pc_m> Once the tests are working reliably, we'll make them voting.
15:15:38 <pc_m> If you have any functional tests, please push them up (or update them, if already out for review).
15:16:01 <pc_m> Any other questions on functional tests?
15:16:30 <pc_m> #topic Bugs
15:16:45 <pc_m> Here's the current list:  https://review.openstack.org/#/q/status:open+project:openstack/neutron-vpnaas,n,z
15:17:39 <pc_m> Please sign up and review, especially the StrongSwan review.
15:17:56 <pc_m> Anyone have specific bugs they want to discuss?
15:19:16 <pc_m> xuhanp: Thanks for offering to try out the StrongSwan implementation (above). We can really use more eyes on this.
15:19:34 <xuhanp> pc_m, sure thing
15:19:59 <pc_m> #topic Open Discussion
15:20:08 <pc_m> Anyone have anything to discuss.
15:20:19 <pc_m> ?
15:20:19 <xuhanp> pc_m, I have a question to ask.
15:20:27 <pc_m> xuhanp: go ahead
15:20:51 <xuhanp> Do we have any plan to support functions like GRE over IPSec or VTI over IPSec?
15:21:11 <xuhanp> we have some requirement to connect two clouds by this kind of tunnels.
15:21:37 <pc_m> xuhanp: None that I know of. At least no one has proposed any blueprints.
15:22:04 <xuhanp> do you think I can propose that if I have some idea?
15:22:15 <xuhanp> maybe starting with discussing in mail list?
15:22:45 <pc_m> xuhanp: For some previous proposals, Neutron cores have suggested they be developed outside of OpenStack (e.g. StackForge), due to low community interest.
15:23:12 <pc_m> xuhanp: Yeah, you may want to start a discussion to gauge community interest.
15:23:49 <pc_m> If enough interest, you could do a blueprint, if not, you can decide to develop out of tree.
15:23:54 <xuhanp> pc_m, do you have an example of previous discussion? I am not sure what kind of features should be developed outside.
15:24:55 <pc_m> I don't have a link handy, but the Edge VPN was discussed and decided to be developed outside. There is a stackforge repo set up for that feature.
15:25:27 <xuhanp> I see. thanks for the information!
15:25:38 <xuhanp> I will try the mail list discussion first then
15:26:22 <pc_m> Manif mentioned in last meeting. Spec is here: https://review.openstack.org/#/c/152377/
15:26:49 <pc_m> You can look at some of the older logs for this team and there have been some links and discussions.
15:27:16 <pc_m> Yeah, may be good to gauge interest in the community.
15:27:33 <xuhanp> cool. Will do!
15:28:29 <pc_m> If there is, then it can be worked on in-tree, if not, it can be worked as StackForge by those interested and tied into OpenStack.
15:28:41 <pc_m> That's the path Edge VPN is going.
15:29:10 <xuhanp> got you. thanks for the advice!
15:29:25 <pc_m> np
15:29:42 <pc_m> Anything else to discuss?
15:30:50 <pc_m> OK, it's a wrap!
15:30:55 <pc_m> #endmeeting