16:00:02 <acabot> #startmeeting watcher
16:00:03 <openstack> Meeting started Wed Oct 21 16:00:02 2015 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:08 <openstack> The meeting name has been set to 'watcher'
16:00:17 <acabot> hi
16:00:52 <vincentfrancoise> Hi
16:00:58 <dtardivel_> hi
16:01:02 <jwcroppe> hello
16:01:19 <edleafe> o/
16:01:36 <sballe> o/
16:01:41 <jwcroppe> o/
16:01:47 <acabot> our meeting agenda #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda
16:02:46 <jwcroppe> acabot: ready... thanks for sending the email out
16:02:49 <tpeoples> hi
16:02:57 <acabot> ok lets start with announcements
16:03:09 <acabot> #topics announcements
16:03:20 <acabot> #topic announcements
16:04:09 <acabot> I'd like to introduce vincentfrancoise who is joining our watcher-drivers team
16:04:24 <sballe> cool!
16:04:28 <jwcroppe> welcome :)
16:04:46 <sballe> vincentfrancoise: are you from b-com?
16:05:10 <vincentfrancoise> Yeah I'm from b-com :)
16:05:11 <tpeoples> howdy vincentfrancoise
16:05:34 <sballe> welcome
16:05:41 <acabot> vincentfrancoise has been working on our metering chain for 3 months now and will jump on Watcher core components now
16:05:49 <dtardivel_> acabot: do we need to add vincent into Launchpad "watcher drivers" team ?
16:06:07 <acabot> dtardivel_: yes please do
16:06:26 <jwcroppe> vincentfrancoise: welcome aboard
16:06:44 <acabot> #action dtardivel_ add vincentfrancoise in watcher drivers
16:07:00 <acabot> any other annoucement ?
16:07:19 <jwcroppe> acabot: nothing here - ready for actions
16:07:33 <acabot> jwcroppe: ok
16:07:45 <acabot> #topic Review Action Items
16:08:29 <acabot> mailing to the community has been sent today
16:08:36 <jwcroppe> saw that - thanks
16:08:49 <sballe> yeah that was great!
16:08:49 <acabot> we already have an answer from a ceilometer contributor
16:09:28 <acabot> http://lists.openstack.org/pipermail/openstack-dev/2015-October/077627.html
16:09:39 <jwcroppe> yep, will be good to continue socializing Watcher
16:09:55 <acabot> I think we should definitely add Watcher to https://wiki.openstack.org/wiki/Ceilometer#Ceilometer_Extensions
16:10:01 <jwcroppe> +1
16:10:04 <sballe> also we need to look opnfv and the doctor project so we have an answer to the quesiton how is wathcer different from doctor
16:10:11 <sballe> acabot: +1
16:10:46 <jwcroppe> #link https://wiki.opnfv.org/doctor
16:11:32 <jwcroppe> sballe: they look to be quite different - we can add this to Wiki FAQ
16:12:01 <acabot> #action acabot sballe look at opnfv doctor project before the summit
16:12:07 <sballe> jwcroppe: yes and no. I think we just need to have a written down answer around why they are different
16:12:17 <jwcroppe> sballe: +1
16:12:24 <acabot> sballe: +1
16:13:18 <jwcroppe> "The goal of this project is to build fault management and maintenance framework for high availability of Network Services on top of virtualized infrastructure" ... I think the core missions are different.  We can get pen to paper on that.
16:13:26 <acabot> doctor is not part of openstack so even if its close, they can live in both openstack and opnfv
16:14:05 <sballe> agree with both of you. We just need to make sure we understand the difference
16:14:07 <acabot> opnfv is deeply related to NFV and I think we do not want to address this right now in Watcher
16:14:42 <jwcroppe> acabot: +1 ... we've got the action above to write that down, next topic?
16:14:47 <sballe> the question is doctor going ot be a sub-set of watcher?
16:14:56 <sballe> jwcroppe: +1
16:15:08 <jed56> +1
16:15:10 <jed56> a) Scheduled evacuation and Live migration would be considered to be actions to move VM from faulty host. If VM does not want to support this, no action.
16:16:03 <sballe> jed56: This could sound like watcher as well
16:16:13 <jed56> yes you can see that here https://wiki.opnfv.org/_media/doctor-opnfv-proposal.pptx
16:16:51 <acabot> as stated we will have a deeper look at it before the summit
16:16:53 <edleafe> but that's an aspect of live migration in general
16:16:58 <jwcroppe> I propose that we do some research on this and start compiling notes and write some notes
16:17:01 <tpeoples> seems like the difference is fault tolerance vs optimization, two kind of related but not quite the same goals
16:17:04 <jwcroppe> before summit
16:17:22 <sballe> jwcroppe: yes I believe that is the action above
16:17:28 <jwcroppe> sballe: agree
16:17:30 <acabot> lets move to stackforge code migration
16:17:39 <jed56> tpeoples i agree
16:17:42 <sballe> so did it happen?
16:17:48 <sballe> the stackforge migration/
16:18:01 <dtardivel_> watcher and python-watchercient projects have migrated to openstack namespace
16:18:07 <sballe> +1
16:18:28 <jwcroppe> dtardivel_: assume we also need watcher-specs created ?
16:18:40 <dtardivel_> but there is an issue on watcher project, due to bad oslo config version used
16:18:58 <wznoinsk> tpeoples: +1, watcher would be doing fault tolerance moves as well?
16:19:08 <dtardivel_> we alreay fixed this issue internaly
16:19:36 <jed56> we are waiting for a core review for watcher-specs
16:19:48 <dtardivel_> We will put a patch before the summit in order to finalize the migration
16:19:52 <sballe> can you send us the review
16:20:14 <jwcroppe> jed56: sounds good - do we have our core names loaded into specs and watcher-core ?
16:20:50 <jed56> yes  : https://review.openstack.org/#/c/233679/
16:20:53 <sballe> thx
16:21:09 <dtardivel_> sballe: yes of course
16:21:15 <jed56> the document was not always clear between openstack and stackforge
16:21:17 <jwcroppe> jed56: IIRC, for watcher-specs it was sballe, acabot and jwcroppe?  For watcher-core it was jed56, dtardivel_ and tpeoples, correct?
16:21:33 <tpeoples> wznoinsk: i don't think that is something we would try to handle with the first iteration of watcher, but it is something we can discuss and keep in mind.  you could think of "faults" as just some other stat that could reach a threshold to be optimized, so the framework watcher provides should allow that in the future
16:21:59 <acabot> jwcroppe: jed56 is talking about creating the watcher-specs repo
16:22:19 <acabot> jwcroppe: as it is still in review, we cannot add contributors yet
16:22:30 <jwcroppe> acabot: +1
16:22:47 <wznoinsk> tpeoples: yes, optimization is one thing and fault tolerance is another, it tend to treat tehse two separate, we can take any discussion off-meeting/in open discussion part ...
16:22:53 <sballe> tpeoples: we will be looking at sla and risk minization so we will be looking at risk for component failure after our initial poc around nergy comsumption
16:22:55 <jwcroppe> acabot: I think watcher-core should be ready, correct?
16:24:43 <acabot> jwcroppe: today watcher-core is the watcher-drivers team
16:25:15 <acabot> jwcroppe: we are still waiting for watcher-specs creation to start a dedicated launchpad with contributors
16:25:24 <jwcroppe> ok, sounds good
16:25:30 <acabot> jwcroppe: if its needed
16:27:20 <acabot> we also add a github repo for watcher toold
16:27:22 <acabot> tools
16:27:30 <acabot> helping people deploying Watcher
16:27:44 <acabot> #link https://github.com/b-com/watcher-tools
16:28:05 <dtardivel_> we are internaly on review on docker part
16:28:36 <dtardivel_> we will push also ansible playbook later (before the summit I hope)
16:28:43 <sballe> acabot: yeah I started doing the deploy the otehr day. Still working at it.
16:28:47 <jwcroppe> acabot: yeah and hopefully watcher can easily build on devstack as well (eventually)
16:29:06 <sballe> I have devstack deployed and was tryingot get watcher to work.
16:29:22 <sballe> I could use some more documentation :-)
16:29:52 <jwcroppe> sballe: code == documentation  ;-)
16:29:58 <jwcroppe> just kidding - agree
16:30:07 <acabot> sballe: I think we will do it together next week and will improve doc as well
16:30:22 <dtardivel_> please wait for next commit on docker part, because we updated container images (located on dicker hub), and we need to update documentation as well
16:31:19 <dtardivel_> for information we use gerrithub.io for reviews on this project
16:31:21 <jwcroppe> acabot: ok, so sounds like progress has been made on the repos
16:31:37 <jwcroppe> acabot: and we just need watcher-specs to complete review
16:32:11 <acabot> jwcroppe: I think everything will be OK before Tokyo
16:32:50 <jwcroppe> sounds good - shall we move on
16:32:51 <jwcroppe> ?
16:32:58 <sballe> +1
16:32:58 <acabot> yes Tokyo agenda
16:33:18 <acabot> sballe sent us an invit for tuesday morning
16:33:30 <sballe> yes let me know if you need to be added
16:33:47 <sballe> it is Tuesday at 10:45 during the coffee break
16:33:50 <jwcroppe> acabot: I started working on a doc I'd like to discuss when we get there with the team... it's not complete, but it will get the discussion going
16:33:52 <jwcroppe> #link https://docs.google.com/document/d/1xcLQY6532Ed2FS2_6d4s6CF4ijeTqr43k5GMSurFepM/edit#heading=h.vae16077waj6
16:34:26 <acabot> wznoinsk: do you want to join ?
16:34:33 <sballe> ok. Should we add all our session to our wiki? I am assuming we can't add them to the official list
16:35:03 <wznoinsk> sballe: yes, thanks
16:35:38 <jwcroppe> the doc I was using a 'scratch pad' of some thoughts we should explore during the PoC phase - with the goal of making things as simple as possible and start getting the framework built out
16:35:39 <sballe> done
16:35:50 <acabot> I think we can add them here https://wiki.openstack.org/wiki/Design_Summit/Mitaka/Etherpads
16:36:03 <sballe> ok let's do thta
16:36:27 <acabot> so I will add the tuesday session but we still have a problem with rooms for next days
16:36:38 <sballe> acabot: jwcroppe Do tou know who Federico Michele Facca is?
16:36:51 <jwcroppe> sballe: no
16:37:11 <jwcroppe> sballe: that's a new name t me
16:37:20 <acabot> sballe: yes sorry I met Federico at a conference on Monday and he is looking at Watcher
16:37:27 <sballe> ok
16:37:32 <jwcroppe> cool
16:37:59 <jwcroppe> acabot: So we have our first meeting setup by sballe, but we should carve out some other focused design slots
16:38:00 <acabot> #action acabot add watcher session to https://wiki.openstack.org/wiki/Design_Summit/Mitaka/Etherpads
16:38:02 <sballe> acabot: do oyu remember the name of the oher intel person that was interested in joining?
16:38:42 <acabot> sballe: isnt it wznoinsk ?
16:39:09 <sballe> no but I think I can find her name
16:39:54 <acabot> sballe: oh yes sorry Mrittika Ganguli
16:40:08 <sballe> yes taht was it. I will invite her too
16:40:36 <acabot> jwcroppe: +1 but we still have a problem with rooms, we should probably define on our tuesday meeting the next design slots
16:41:31 <acabot> everyone is OK with groupme ?
16:42:08 <sballe> feel free to invite people tot he GroupMe app
16:42:14 <tpeoples> yep
16:42:17 <acabot> ok
16:42:23 <jwcroppe> acabot: yeah, I'm not sure if we'll get a room this summit - we might have to take over some corners or some such :)
16:42:55 <acabot> jwcroppe: so we will ;-)
16:42:56 <sballe> +1
16:43:05 <acabot> jwcroppe: next to the coffee machine please
16:43:24 <sballe> Last year a lot of the LBaaS/FWaas discussions happened in the hallway on chairs
16:43:29 <sballe> acabot: +1
16:43:30 <jwcroppe> acabot: +1
16:43:32 <wznoinsk> during breaks the booths on the corridors are usually busy but we can try to use one of them (with couches)
16:43:41 <acabot> ok lets move to our last topic
16:43:43 <sballe> wznoinsk: +1
16:43:51 <acabot> #topic open discussions
16:44:07 <sballe> Just a reminder: Can people please sign in to GroupMe?
16:44:10 <jwcroppe> if people get a chance - take a look at the google doc I started above.  it's very rough admittedly, but it's a good straw man for some discussion
16:44:38 <acabot> jwcroppe: ok I will do it in the plane ;-)
16:44:42 <jed56> jwcroppe: i will
16:44:58 <jwcroppe> cool
16:45:24 <jwcroppe> and yes - to echo sballe - join GroupMe :)
16:46:23 <acabot> OK can we close our meeting and just say see you in Tokyo ?
16:46:32 <sballe> sounds good to me
16:46:37 <jwcroppe> Sounds like a plan
16:46:51 <sballe> bye
16:46:52 <tpeoples> safe travels
16:46:52 <acabot> #endmeeting