16:01:12 <acabot_> #startmeeting watcher
16:01:13 <openstack> Meeting started Wed Nov 11 16:01:12 2015 UTC and is due to finish in 60 minutes.  The chair is acabot_. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:16 <openstack> The meeting name has been set to 'watcher'
16:01:21 <acabot_> hi
16:01:26 <Kevin_Zheng> Hi
16:01:27 <tpeoples> hey
16:01:33 <sballe> o/
16:01:40 <jwcroppe> o/
16:01:46 <ostroverkhov> o/
16:01:49 <Ashavskiy> o/
16:01:50 <edleafe> o/
16:02:01 <vojtechcima> o/
16:02:04 <alexstav_> o/
16:02:05 <acabot_> our agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#11.2F11.2F2015_Agenda
16:02:21 <mehdi__> hi i am here
16:02:37 <cdupont> Hi everybody
16:02:38 <bruno_> o/
16:02:40 <alexchadin> o/
16:03:01 <seanmurphy_> hi all - a few of us are here from ZHAW (me, bruno, vojtech) - we are not proficient with IRC meetings, so apols if we don’t know conventions etc
16:03:04 <mehdi__> hi corentin
16:03:26 <acabot_> seanmurphy_: no problem ;-)
16:03:27 <tpeoples> welcome
16:03:32 <mehdi__> also a few of us from CREATE-NET are here
16:03:53 <sballe> wlecome
16:03:57 <alexchadin> Hello from Moscow!
16:04:00 <sballe> welcoe :-)
16:04:06 <alexchadin> Servionica is here:)
16:04:09 <acabot_> before we dig into the agenda, just to let you know that Monasca has been accepted yesterday in the big tent https://review.openstack.org/#/c/213183/
16:04:11 <samarinvv> Hi!
16:04:16 <sballe> +1
16:04:26 <mehdi__> great news for Monasca
16:04:33 <mehdi__> congrats guys
16:04:49 <jwcroppe> cool!
16:04:56 <alexstav_> congrats!
16:05:07 <acabot_> #topic Announcements
16:05:25 <samarinvv> congrats!
16:05:35 <acabot_> so took the opportunity to invite our friends from ICCLab Zurich today
16:05:43 <jwcroppe> welcome folks
16:05:48 <sballe> acabot_: +1
16:05:50 <jwcroppe> glad to have you attend!
16:05:52 <acabot_> maybe we can start by a quick intro guys
16:06:11 <seanmurphy_> thanks for the invitation antoine
16:06:38 <seanmurphy_> as you may see from agenda, we are a university applied research lab
16:06:48 <seanmurphy_> focused on cloud computing with different aspects
16:06:52 <seanmurphy_> one of which is energy
16:06:57 <seanmurphy_> we have done a bit of work
16:07:10 <seanmurphy_> it is modest, tbh - i don’t want to oversell it
16:07:11 <seanmurphy_> ;-)
16:07:18 <mehdi__> sure
16:07:34 <seanmurphy_> we have developed an energy monitoring tool which collects energy consumption from servers
16:07:40 <seanmurphy_> and shows it in a dashboard etc
16:07:47 <seanmurphy_> it is based on the kwapi project
16:07:48 <Kevin_Zheng> Greate
16:07:52 <seanmurphy_> in the larger openstack ecosystem
16:08:16 <seanmurphy_> it’s maybe a bit basic, but it’s open source and we can share a small video of it
16:08:31 <seanmurphy_> we also have done a bit of work on delay tolerant workload mgmt as a tool to achieve energy savings
16:08:41 <seanmurphy_> and have a horizon plugin to support deferred workload
16:08:54 <acabot_> seanmurphy_: you didn't put the link for the monitoring tool in the agenda, can you share it ?
16:08:56 <seanmurphy_> so you can tell openstack to schedule launch of a VM at a specific time
16:09:07 <seanmurphy_> i will do so
16:09:26 <acabot_> thx
16:09:29 <jwcroppe> seanmurphy_: interesting use cases indeed
16:09:46 <bruno_> Link for energy monitoring tool - http://blog.zhaw.ch/icclab/web-application-to-monitor-and-understand-energy/
16:09:52 <seanmurphy_> the idea with the deferred workload stuff is to add a scheduling component around it
16:10:06 <seanmurphy_> which can take delay tolerant workload from users of the system
16:10:09 <bruno_> and scheduler - http://blog.zhaw.ch/icclab/extending-the-openstack-dashboard-to-support-delay-tolerant-workload/
16:10:14 <seanmurphy_> and schedule them using the deferred workload mechanism
16:10:21 <seanmurphy_> then we have done a bit on load consolidation
16:10:40 <seanmurphy_> reading usage info from a system a having a basic mechanism to support consolidation
16:10:53 <seanmurphy_> it’s a bit heuristic rather than based on Hard Science
16:11:00 <seanmurphy_> but it’s prob a reasonable compromise
16:11:08 <jwcroppe> yeah, most things are in this space :)
16:11:39 <seanmurphy_> we also did work on live migration using so called post copy live migration rather than the standard pre copy mechanism which suffers from some issues if there is intense memory use in a VM
16:12:03 <seanmurphy_> that suffers from the prob of lacking support in linux kernel and also of distributed state within the migration process
16:12:13 <seanmurphy_> but is more certain to terminate than the pre copy approach
16:12:20 <seanmurphy_> that’s our work in a nutshell
16:12:25 <seanmurphy_> it’s not fully consolidated as yet
16:12:34 <jwcroppe> very cool, I'll read thru the material later today
16:12:47 <seanmurphy_> but we plan to bring it together over the coming months
16:13:04 <seanmurphy_> i think that’s abt it
16:13:10 <seanmurphy_> from our side
16:13:20 <seanmurphy_> acabot_: is that sufficient?
16:13:38 <sballe> same here
16:13:41 <tpeoples> thanks for the intro
16:13:41 <acabot_> seanmurphy_: seems great and interesting, I will look at the material
16:14:24 <jwcroppe> acabot_: shall we proceed with the agenda?
16:14:29 <seanmurphy_> we will put more of our content in the minutes
16:14:46 <acabot_> as I see we have people from create-net, federico ?
16:14:53 <cdupont> we're here :)
16:15:04 <cdupont> we can introduce ourselve quickly
16:15:10 <acabot_> yes please
16:15:25 <cdupont> so we are from Create-Net (www.create-net.org), in Italy
16:15:32 <cdupont> Our area is called Smart Infrastructure (Smarti), working on cloud computing infrastructure
16:15:42 <cdupont> Our project is DC4Cities, which aim at using more renewable energy in data centres
16:15:55 <cdupont> At the moment we have several prototypes we're working on...
16:16:09 <cdupont> one is the EASC (Energy Efficient Software Controller):
16:16:43 <cdupont> it will control the workload level of flexible apps to follow some constraints, such as renewable energies
16:16:47 <acabot_> cdupont: could you share links on the agenda or on IRC using # link ?
16:17:00 <cdupont> OK
16:17:15 <cdupont> Also Plug4Green: a VM consolidator based on constraint programming with an energetic model
16:17:17 <cdupont> But it's in Java
16:17:35 <cdupont> Plug4Green is based on BtrPlace
16:17:37 <mehdi__> EASC makes application adaptive to renewable energy availabilty
16:18:05 <mehdi__> by introducing a few working modes (execution modes) for each application
16:18:18 <cdupont> So we have 2 ways to optimize: VM consolidation to save energy
16:18:33 <cdupont> EASC to optimize renewable energies
16:18:53 <mehdi__> www.dc4cities.eu is for DC4Cities project
16:19:10 <acabot_> ok please share links (blogs & source code) as much as you can on the agenda and we will all look at it before our next meeting
16:19:31 <cdupont> there is also a tool called PaaS consolidator to consolidate containers but that might be out of topic for this meeting
16:19:47 <acabot_> cdupont: yes ;-)
16:20:03 <acabot_> #topic Review Action Items
16:20:13 <edleafe> #link www.dc4cities.eu
16:20:33 <mehdi__> tnx
16:20:34 <edleafe> #link http://blog.zhaw.ch/icclab/extending-the-openstack-dashboard-to-support-delay-tolerant-workload/
16:20:37 <mehdi__> I was looking for it
16:20:49 <cdupont> does this sound interresting for you? How could we collaborate :)
16:20:50 <edleafe> #link http://blog.zhaw.ch/icclab/web-application-to-monitor-and-understand-energy/
16:21:07 <acabot_> thx Ed (# link add the link to minutes)
16:21:09 <mehdi__> EASC is instantiated for various computing styles
16:21:14 <mehdi__> like PaaS and IaaS
16:21:19 <jwcroppe> acabot_: the watcher-specs templates are all merged now -- thanks for all the reviews from folks
16:21:30 <mehdi__> EASC-PaaS has been implemented with Cloud Foundry
16:21:30 <sballe> +1
16:22:00 <acabot_> cdupont: we will look at it in more detail and come back to you next week, as we have only an hour, we need to follow the agenda
16:22:11 <jwcroppe> (and big thanks to our nova colleagues allowing us to promote code reuse) :)
16:22:12 <cdupont> ok thanks :)
16:22:44 <sballe> I am working on two things. 1. end to end install of watcher and all the pieces in a vM. I hope to have that completed today. and 2. workingon a sec with Nishi for the PoC. we are meetign with jed56 tomorrow to discuss further
16:22:47 <mehdi__> #link http://www.fit4green.eu/
16:23:41 <acabot_> sballe: ok thx for all your feedback regarding the installation process, feel free to send reviews on doc if there are issues
16:24:03 <acabot_> sballe: it would be better if the next one has a better doc ;-)
16:24:10 <jwcroppe> sballe: thanks for that... I will appreciate that for when I set it up soon
16:24:12 <tpeoples> Zhenzan Zhou (is that you Kevin_Zheng ?) took care of my action item, creating the devstack plugin blueprint (#link https://blueprints.launchpad.net/watcher/+spec/devstack-plugin). i added a bit more detail and hope to start working on that soon
16:24:15 <sballe> acabot_: will do. I still have to do the final step around configuration
16:24:31 <Kevin_Zheng> No
16:24:35 <sballe> no Zhenzan Zhou is with Intel and his nick is bzhou
16:24:42 <tpeoples> ah okay
16:24:47 <jwcroppe> All... for each BP, we need to now submit the formal spec now that watcher-specs is ready
16:24:53 <Kevin_Zheng> He is a guy from Intel
16:25:02 <acabot_> jwcroppe: +1
16:25:03 <Kevin_Zheng> I'm from huawei
16:25:05 <sballe> Kevin_Zheng:  who are oyu with
16:25:09 <sballe> :-)
16:25:18 <jwcroppe> if it's a 'small' change, then no spec is needed... otherwise we should get started on the formal spec write-up and get those approved
16:25:30 <acabot_> yes sorry we didn't introduced you Kevin
16:25:48 <sballe> jwcroppe: we need the ceilometer integration for Devstack
16:26:21 <sballe> BTW any ETA on Ceilometer integration. I believe jed56 said yes to ETA of Dec 1
16:26:23 <Kevin_Zheng> That's ok I can do it in the open discussion
16:26:26 <acabot_> sballe: I agree we need to have the ceilometer integration and then we will be able to use Watcher in devstack env
16:26:41 <sballe> +1000 my thoughts exactly
16:27:02 <acabot_> yes we plan to do it next week
16:27:12 <sballe> you guys are the BEST!
16:27:14 <jwcroppe> Ok, so let's close on the specs stuff.  For those LP blueprints we've opened, we should now create the specs in the watcher-specs repo now that we are all ready for that
16:27:32 <acabot_> we had a great discussion yesterday with jed56 and thx to Ceilometer discussion in Tokyo, it would be pretty easy to do
16:27:44 <sballe> I'll work on Nishi's PoC spec with her. Should have a DRAFT early next week
16:27:49 <mehdi__> can we review on the spec?
16:28:00 <acabot_> medhi__: yes of course
16:28:11 <jwcroppe> acabot_: create an action for watcher-specs submission?
16:28:24 <jwcroppe> medhi___: yes, please review all specs :)
16:28:29 <mehdi__> sure
16:28:30 <acabot_> ok so I will approve BP regarding ceilometer, devstack and Nishi use case right ?
16:28:40 <sballe> yes
16:28:50 <sballe> and we'll work on the specs
16:28:57 <jwcroppe> sballe: wonderful
16:29:03 <mehdi__> what's BP?
16:29:06 <acabot_> #action acabot_ approve BP regarding ceilometer, devstack and Nishi use case
16:29:16 <acabot_> BP = blueprint
16:29:19 <mehdi__> ok
16:29:26 <jwcroppe> tpeoples: are you going to look at the devstack integration for watcher?  do you want to post up the spec review for that too?
16:29:27 <acabot_> https://blueprints.launchpad.net/watcher
16:29:45 <tpeoples> jwcroppe:  as time allows...yes
16:29:59 <jwcroppe> tpeoples: +1
16:30:18 <sballe> +1
16:30:18 <edleafe> fwiw, ceilometer is changing its name to 'telemetry'
16:30:39 <acabot_> edleafe: ok I will update the BP then
16:30:40 <sballe> thx for letting us know
16:30:42 <jwcroppe> edleafe: wonderful.  that's not confusing :)
16:30:54 <edleafe> jwcroppe: :)
16:30:59 <sballe> lol
16:31:08 <acabot_> bug triage has been done by dtardivel
16:31:19 <acabot_> https://bugs.launchpad.net/watcher
16:31:27 <acabot_> so feel free to fix them ;-)
16:31:40 <tpeoples> cool acabot_
16:31:55 <acabot_> and of course add new one if you have troubles installing Watcher
16:32:13 <Kevin_Zheng> Cool
16:32:28 <edleafe> #info change 'ceilometer' references to 'telemetry'
16:32:38 <acabot_> sballe: you asked for changing our meeting time
16:32:57 <acabot_> sballe: what would be best for US/China & Europe :-D
16:33:00 <sballe> yes the main reason is that it is 12am for bzhou
16:33:25 <Kevin_Zheng> Me too
16:33:29 <sballe> I could do as early as 6 or 7 amEST
16:33:37 <acabot_> UTC ?
16:33:39 <sballe> which is 8pm in China
16:33:50 <sballe> let me find a converter
16:33:58 <tpeoples> that'd be 5-6 am CST?
16:34:21 <jwcroppe> sballe: my biological clock does not compute anything between 5-6 am
16:34:40 <jwcroppe> lol
16:34:41 <acabot_> jwcroppe: :-D
16:34:59 <Kevin_Zheng> Maybe just move to 1 or 2 hour earlier, think it will be ok for us
16:35:11 <acabot_> 7am EST is 1pm Paris time and 8pm in China right ?
16:35:14 <sballe> I understand but how if we moved to 8 am EST == 7 am CST == 9pm in China
16:35:26 <edleafe> I can handle up to 3 hours earlier
16:35:54 <acabot_> jwcroppe: what about you ?
16:36:23 <jwcroppe> perhaps we try a model like others and alternate times every other week?  just a thought
16:36:24 <sballe> that would be 1pm UTC per my converter
16:36:25 <acabot_> 3h earlier is OK for France, Italy and Switzerland I suppose
16:37:19 <sballe> How about 2pm UTC == 9am EST == 10pm in China = 7am CSt
16:37:41 <Kevin_Zheng> I'm OK
16:37:43 <seanmurphy_> yes - 3h earlier is fine for CH
16:37:48 <Kevin_Zheng> In China
16:37:50 <edleafe> 9am EST == 8am CST
16:38:06 <sballe> oh yeah I went MST
16:38:07 <edleafe> so maybe 8am EST?
16:38:13 <jwcroppe> I'm fine with 8 am CT
16:38:26 <acabot_> so 2h earlier than today
16:38:29 <jwcroppe> 7 am will be almost impossible for me, but I don't want to be the bottleneck.
16:38:34 <sballe> 2pm UTC == 9am EST == 10pm in China = 8am CSt
16:38:39 <jwcroppe> right, 2h earlier
16:38:43 <alexstav_> +1
16:38:47 <alexchadin> +2
16:38:55 <Kevin_Zheng> +1
16:39:01 <samarinvv> +1
16:39:02 <ostroverkhov> +1
16:39:07 <Ashavskiy> +1
16:39:23 <edleafe> +1
16:39:30 <sballe> tpeoples: Can you check and see if you can find a day/channel for that time? You did it last time rigth?
16:39:30 <acabot_> #openstack-meeting is available at 2pm UTC on wednesday
16:39:41 <seanmurphy_> +1
16:39:42 <jwcroppe> +1
16:39:47 <sballe> acabot_: you were reading my mind :)
16:40:00 <sballe> acabot_: then let's grab it
16:40:01 <mehdi__> 10 pm for EU?
16:40:15 <acabot_> #action acabot_ ask for a new time slot for meeting at 2pm UTC on wednesday on #openstack-meeting
16:40:18 <Kevin_Zheng> No 10 for China
16:40:30 <jwcroppe> we can also try alternating times too eventually if needed
16:40:33 <acabot_> it would be 3pm for EU
16:40:45 <jwcroppe> (since the reality is there is no perfect world time)
16:40:45 <sballe> acabot_: it will be early if we want people from the west coast to join. But it all about balance between all the time zones
16:40:56 <sballe> jwcroppe: I agre
16:41:08 <tpeoples> sballe: acabot_ :  #openstack-meeting-4 is open during that time every week. #openstack-meeting is taken every other week during that slot by the doc team
16:41:09 <sballe> I agree on the alternate times down the road
16:41:47 <sballe> tpeoples: #openstack-meeting-4 it is
16:41:54 <acabot_> tpeoples: ok my cal is driving me crazy...
16:42:00 <tpeoples> acabot_:  :)
16:42:07 <jwcroppe> acabot_: you should use Notes :)
16:42:22 <acabot_> jwcroppe: lol
16:42:29 <acabot_> #topic Blueprint/Bug Review and Discussion
16:42:35 <edleafe> jwcroppe: don't be mean!
16:42:45 <jwcroppe> lol
16:42:59 <acabot_> I'd like to discuss BP regarding the Nova load balancer
16:43:17 <sballe> acabot_: +1
16:43:22 <alexchadin> Okay
16:43:32 <acabot_> to my understanding, it implies to change the nova configuration and this is something we definitely dont want to do
16:43:33 <alexchadin> We've made videos
16:43:58 <tpeoples> acabot_:  are you referring to https://blueprints.launchpad.net/watcher/+spec/watcher-overload-underload specifically?
16:44:41 <acabot_> tpeoples: yes
16:45:45 <tpeoples> i think that seems to be two specific algorithms (underload / overload) that would be written for watcher specific to the "reactive" part of watcher, which relies in getting the CEP working for that ?
16:45:48 <samarinvv> acabot_: In Tokyo we discussed, what Watcher already have some improvements to Nova functionality what we ned
16:46:03 <mehdi__> btw, who are Antoine Cabot and Jean-�mile DARTOIS?
16:46:07 <jwcroppe> I'm not seeing anything in there that would require a change to nova?
16:46:34 <acabot_> mehdi__: sorry I am Antoine, and Jean-Emile is jed56
16:46:52 <mehdi__> tnx
16:47:18 <tpeoples> what needs to change in nova for that blueprint samarinvv  acabot_  ?
16:47:21 <jwcroppe> acabot_: time check ... 13 mins remaining
16:47:32 <alexchadin> there is some changes in nova libvirt driver and nova db (models, api)
16:48:11 <acabot_> jwcroppe: yes sorry for that I looked at the videos at the end of the agenda just before the meeting and it seems to me that Nova has been modified
16:48:13 <Kevin_Zheng> Hmm I think we have tested something similar
16:48:19 <samarinvv> and extend nova-api
16:48:42 <jwcroppe> alexchadin: It's not clear to me why you'd need model/api changes for what's written in the description?  we can take that offline tho
16:49:24 <tpeoples> +1 jwcroppe , seems to me that could be implemented without nova changes. let's maybe get a written summary of the needed changes for next meeting and go from there?
16:50:08 <acabot_> alexchadin: what do you think ?
16:50:17 <samarinvv> acabor_: Ok, we should discuss this offline
16:50:20 <alexchadin> we are on the way to leave nova code
16:50:25 <samarinvv> *acabot
16:50:35 <alexchadin> jwcroppe: it could be good
16:51:00 <acabot_> alexchadin: samarinvv: ok that we can start iterate through a more detail spec right ?
16:51:21 <tpeoples> +1
16:51:40 <samarinvv> ok, right
16:51:42 <acabot_> as we now have a watcher-specs repo, we can start working on it and review specs
16:52:01 <jwcroppe> +1
16:52:09 <acabot_> it would be easier to discuss it later on
16:52:19 <samarinvv> okay, we should prepare some for next meeting to discuss
16:52:41 <sballe> acabot_: +1
16:52:43 <tpeoples> that's what i meant by written summary :$
16:52:46 <jwcroppe> acabot_, sballe: any further detail on mid-cycle to discuss this week?
16:52:46 <acabot_> but anyway thx for the videos, its really helpful to understand your current status
16:53:01 <sballe> I have not heard back from Orran yet
16:53:22 <sballe> give him 2 more weeks and then after we can look at planB
16:53:41 <acabot_> ok just to let all know about it, we plan a mid-cycle meetup end of January in Boston, MA
16:53:46 <mehdi__> link to the video?
16:53:50 <jwcroppe> ok, was Orran going to host at Boston Univ potentially?
16:54:09 <acabot_> medhi__: in the agenda
16:54:16 <sballe> jwcroppe: see above
16:54:32 <samarinvv> acabot_: thanks for watching
16:55:22 <acabot_> samarinvv: which of your 2 BP you want to start providing detailed specs ?
16:55:55 <jwcroppe> sballe: saw that, just wasn't sure if that was your pending question to him...
16:56:03 <alexchadin> acabot_: overload
16:56:11 <acabot_> ok thx
16:56:13 <samarinvv> acabot_: overload
16:56:15 <samarinvv> ok
16:56:28 <acabot_> #action acabot_ set overload BP as started
16:56:36 <sballe> I sent him email several time but I know heis busy
16:56:42 <jwcroppe> np
16:57:26 <acabot_> ok so before the end, ICCLab & Create-net please complete the agenda with links to your current work
16:57:53 <acabot_> we will look at it before next meeting and see how we can iterate from it
16:58:28 <cdupont> OK, thanks acabot_!
16:58:52 <acabot_> thanks for this great meeting, I will go back to my day off ;-)
16:58:53 <mehdi__> great
16:59:06 <sballe> lol
16:59:12 <mehdi__> have a nice evening all
16:59:22 <acabot_> thanks bye
16:59:26 <mehdi__> bye
16:59:29 <acabot_> #endmeeting