14:01:18 <acabot_> #startmeeting watcher
14:01:19 <openstack> Meeting started Wed Dec  2 14:01:18 2015 UTC and is due to finish in 60 minutes.  The chair is acabot_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:22 <openstack> The meeting name has been set to 'watcher'
14:01:30 <acabot_> hi
14:01:40 <vincentfrancoise> hi
14:01:45 <brunograz> hi
14:01:56 <tpeoples> hi, may be slow to respond during this, on another call right now
14:02:17 <jed56> hi
14:02:35 <vmahe_> hi
14:02:43 <sballe> o/
14:03:19 <acabot_> our agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#12.2F2.2F2015
14:03:50 <acabot_> #topic Announcements
14:04:19 <edleafe> o/
14:04:32 <acabot_> mid cycle meetup, we are still waiting for updates from jwcroppe
14:04:32 <sballe> junjie: is joining as well
14:04:46 <junjie> yes
14:04:51 <acabot_> he will give us updates next week
14:05:04 <sballe> ok
14:05:18 <edleafe> jwcroppe is traveling today, unfortunately
14:05:22 <acabot_> #action jwcroppe details for mid cycle meetup in Austin
14:05:52 <acabot_> I added versionning on launchpad and set target release for current BPs
14:05:58 <sballe> +1
14:06:10 <acabot_> mitaka-1 is planned for today :-)
14:06:12 <jed56> +1
14:06:19 <sballe> lol
14:06:46 <acabot_> so I suggest to merge all stable code and doc by end of week and then tag the version as mitaka-1
14:06:48 <acabot_> on friday
14:06:59 <sballe> +1
14:07:03 <tpeoples> sounds good
14:07:11 <vmahe_> +1
14:07:19 <vincentfrancoise> +1
14:07:20 <jed56> +2
14:07:23 <acabot_> #action acabot tag the version as mitaka-1 on friday
14:08:09 <acabot_> I also started to reference all etherpads we use
14:08:21 <acabot_> #link https://etherpad.openstack.org/p/watcher-etherpads
14:08:38 <acabot_> so please add yours as I may have missed some
14:08:55 <acabot_> any other announcement ?
14:09:51 <cdupont> Hello everybody
14:10:20 <acabot_> #topic Review Action Items
14:11:20 <acabot_> current work is related to documentation, vmahe_ could you give us an update ?
14:11:33 <vmahe_> yes
14:12:01 <vmahe_> I have pushed a new patch-set for glossary which takes into account many comments
14:12:23 <vmahe_> but not all of them because some of them were open questions and more related to the future of Watcher
14:12:49 <vmahe_> today the glossary explains the concepts and words for the current version of Watcher
14:12:57 <sballe> vmahe_: I will review it before Friday EOD
14:13:04 <tpeoples> vmahe_: will review again today.  the plan is to refactor the code based on these terms and then we will treat it as a living doc as things come up?
14:13:26 <vmahe_> we'll introduce some new concepts in the next release but we have to write some BP for it
14:13:27 <acabot_> tpeoples: yes
14:13:34 <chicco785> hi
14:13:43 <tpeoples> +1
14:13:44 <chicco785> sorry for being late (federico)
14:13:56 <brunograz> vmahe_: Sean was reviewing the new patch and already submitted some comments, afaik by the end of the week we will provide more inputs on it
14:13:57 <cdupont> hi fede
14:14:01 <jed56> hi chicco785
14:14:20 <vmahe_> Ideally, the glossary should be merged with mitaka-1 release
14:14:43 <acabot_> I'd like to have the glossary merged for mitaka-1 so please review it before friday if possible
14:14:58 <sballe> acabot_: will do
14:15:08 <acabot_> sballe: thx
14:15:12 <bzhou> acabot_: will do
14:15:31 <vmahe_> I have also pushed an review regarding the documentation explaining the current architecture of Watcher (not the future one)
14:15:58 <acabot_> #action bzhou sballe tpeoples review https://review.openstack.org/#/c/246370/ by friday
14:16:00 <vmahe_> See https://review.openstack.org/#/c/249869/
14:16:41 <vmahe_> It will reference some words of the glossary, and the glossary may also reference some technical components described in the architecture.rst file
14:17:00 <acabot_> vmahe_ the idea of this review is to have the current architecture diagram of Watcher (again for mitaka-1 release)
14:17:06 <cdupont> as CN we could review some items as well
14:17:09 <cdupont> if needed
14:17:19 <acabot_> then we will work on architecture v2 on watcher-specs repo
14:17:48 <vmahe_> acabot_: +1
14:17:57 <acabot_> #action cdupont chicco785 review https://review.openstack.org/#/c/246370/ by friday
14:18:02 <mmmm> hi
14:18:06 <cdupont> OK
14:19:26 <acabot_> anyone wants to work on architecture v2 right now ? I think we should wait the mid-cycle meetup to start this discussion
14:19:50 <cdupont> when is this meeting?
14:20:10 <acabot_> end of january
14:20:17 <cdupont> tks
14:20:32 <sballe> I thought it was Feb 3-4
14:20:49 <acabot_> yes sorry its around end of january ;-)
14:20:57 <sballe> :-)
14:21:29 <acabot_> sballe : what do you think about architecture v2, from my point of view we can wait a f2f meeting
14:21:49 <acabot_> sballe: it would be easier than reviews on Gerrit
14:22:06 <vmahe_> +1
14:22:19 <sballe> I agree plus I will have more time ot work on it at the meetup and right before
14:22:27 <sballe> I am swamped until the new year
14:22:39 <acabot_> ok
14:22:43 <acabot_> #topic Blueprint/Bug Review and Discussion
14:23:16 <acabot_> what about the split up of https://blueprints.launchpad.net/watcher/+spec/nishi-ahuja-energy-efficienct-dc ?
14:23:47 <acabot_> I suppose it is related to this one https://blueprints.launchpad.net/watcher/+spec/outlet-temperature-based-strategy
14:23:49 <bzhou> junjie has proposed the first algorithm
14:24:03 <junjie> yes, this is one of them
14:24:26 <acabot_> ok so what about the original BP, can I set it as obsolete ?
14:24:53 <junjie> sure
14:26:01 <acabot_> ok as vincentfrancoise mentionned, you need to fix the typo in our specs
14:26:04 <acabot_> your specs
14:26:13 <acabot_> https://review.openstack.org/#/c/252268/
14:26:23 <junjie> yes
14:26:35 <sballe> also you need to run the pep8 stuff
14:26:35 <junjie> i will work on this
14:27:03 <acabot_> ok thx
14:28:17 <acabot_> tpeoples has another BP to split up, will be done by 12/3
14:28:22 <sballe> Does anybody has a link to doc on the tooling need to be run before you submit a patch. the pep8
14:28:51 <bzhou> I think just run tox -epep8 should be good
14:29:03 <jed56> tox -e docs
14:29:16 <junjie> good to know
14:29:20 <jed56> tox  -e py27
14:29:37 <junjie> thx
14:29:45 <acabot_> if forgot to mention that I added a page on Watcher wiki on contributions https://wiki.openstack.org/wiki/Watcher/Contributing
14:30:25 <junjie> great
14:30:34 <Kevin_Zheng> great
14:30:36 <dtardivel> tox is mentioned in the README.rst file
14:30:44 <acabot_> feel free to add something about pep8 ;-)
14:30:51 <mmmm> good to know
14:31:59 <dtardivel> Please take care about your commit message. Detailed information is often missing :/
14:32:18 <sballe> and also there is somethign weird about not adding a "." at the end
14:32:47 <dtardivel> yes :-)
14:32:53 <tpeoples> acabot_:  sorry, just saw your previous message. yes, going to work on that today.  bit behind due to the US holiday last week
14:33:24 <acabot_> chicco785: could you please give us details about the consolidation rule modelling BP you want to work on ?
14:33:39 <chicco785> hi acabot_
14:33:40 <junjie> i will pay more attention to the docs
14:33:43 <dtardivel> good practice is defined on https://wiki.openstack.org/wiki/GitCommitMessages
14:33:53 <chicco785> we are working on two blueprints
14:34:20 <chicco785> the first bp is about the general API and management of "consolidation rules" supporting pluggable verifiers
14:34:37 <chicco785> ideally the verifiers will be linked to decision engines
14:35:07 <chicco785> which means, that there may be rules supported only by a certain subset of decision engines
14:35:50 <chicco785> second bp
14:36:10 <chicco785> propose an initial set of the actual consolidation rules grammar
14:36:30 <chicco785> taking into account existing work done inside btr place
14:36:52 <cdupont> I've started to work on that
14:36:54 <chicco785> i hope to commit a draft of the specs by friday (sorry a bit overloaded)
14:37:06 <chicco785> for the API
14:37:23 <chicco785> while as cdupont just mentioned he is working on the grammar
14:37:33 <acabot_> ok thats fine, please submit a quick abstract on launchpad and a spec on watcher-specs repo (mitaka/approved folder)
14:37:51 <chicco785> the abstract for the API part should be there
14:38:01 <sballe> tpeoples: regarding the grammar you guys migth want to make sure you review the bp since I know you are interested in that subject too
14:38:01 <chicco785> not sure i linked it correctly (in case i apologize)
14:38:08 <cdupont> I can submit for the rules part
14:38:19 <tpeoples> will do sballe
14:38:52 <chicco785> https://blueprints.launchpad.net/watcher/+spec/watcher-consolidation-rules-api
14:39:15 <Kevin_Zheng> chicco785: 今天
14:39:15 <sballe> acabot_: chicco785 does Congress have any grammar? given that they are the policy engine we might want to coordinate and sync-up around that
14:39:38 <sballe> bzhou: Do you know if Congress has a grammar to define its policies?
14:39:58 <chicco785> well the grammar of congress is basically datalog :)
14:40:07 <bzhou> correct
14:40:15 <chicco785> by grammar here we mean a specific grammar for the consolidation topic
14:40:27 <chicco785> which is not AFAIK implemented in congress
14:40:36 <sballe> chicco785: ok but any opportunity to collaborate with Congress and not end up with two grammars
14:40:39 <chicco785> anyhow cdupont should look into that
14:40:47 <cdupont> Ok
14:41:03 <acabot_> +1
14:41:27 <tpeoples> we use something akin to SQL with our solution which is nice since most people know SQL, but yeah, let's find something common
14:41:38 <brunograz> acabot_: we're also planning to submit a BP wrt to our consolidation model, due to other commitments we will most likely submit it next week
14:41:44 <sballe> cdupont: can you do a read-out of that at our next meeting or wen you have looked into it
14:42:05 <sballe> tpeoples: +1
14:42:25 <cdupont> sballe: sorry? didn't understand
14:42:49 <chicco785> sballe asked if next week you can report on your findings
14:42:53 <cdupont> should I do a summary of Congress rules for next meeting?
14:43:17 <cdupont> Should be OK
14:43:26 <sballe> cdupont: yes that was my understanding :-)
14:44:10 <sballe> bzhou: do you know if congress has any plans to do more elaborate grammar rules?
14:44:13 <cdupont> need to double check because next week I'm in a conf but probably I can participate in the meeting
14:44:31 <sballe> np just when you are ready
14:45:15 <cdupont> OK
14:45:18 <acabot_> ok I'd like to keep time for open discussions today
14:45:21 <chicco785> i saw very simple examples in congress, but now grammar for the consolidation
14:45:30 <acabot_> #topic Open Discussion
14:45:34 <chicco785> **no**
14:46:06 <acabot_> dtardivel: do you want to give a word about integration tests ?
14:47:32 <acabot_> we have to add integration tests all over the code of Watcher
14:47:41 <sballe> +1
14:47:45 <dtardivel> On previous patchset, we hd some issues on watcher integration test
14:47:50 <acabot_> does anyone here has experience on doing this in OpenStack ?
14:48:04 <sballe> Are we talking about Tempest tests?
14:48:13 <tpeoples> +1 to sballe's question
14:48:38 <dtardivel> do we decided, internally, to use a complete integration test framework (based on docker) to be able to validate a patchset
14:48:59 <sballe> dtardivel: I think we should agree to use devstack+ceilometer
14:49:16 <sballe> as the test framework
14:49:28 <tpeoples> won't we want to create a tempest test suite that gets run against devstack going forward (which will be needed by CI) ?
14:49:31 <dtardivel> sballe: + tempest :-)
14:49:56 <sballe> tpeoples: +1 exactely so devatsk should be our test framework
14:50:04 <chicco785> i think it is reasonable using devstack, but we should think to a configuration with more than one node
14:50:24 <sballe> chicco785: devstack can be multi-node
14:50:24 <tpeoples> yes chicco785 , we will do that as otherwise we aren't testing anything really :)
14:50:31 <chicco785> sure :)
14:50:36 <chicco785> that's what i meant
14:50:49 <tpeoples> i have a guide to set up devstack + watcher multi-node, will include with the devstack plugin review
14:50:54 <chicco785> using devstakc multinode conf
14:51:07 <dtardivel> are you able to test a patchset into devstack, before to merge it into master branch ?
14:51:08 <jed56> tpeoples : cool
14:51:08 <chicco785> tpeoples great!
14:51:11 <acabot_> tpeoples: thats great
14:51:13 <sballe> tpeoples: please share :-)
14:52:01 <acabot_> so we wait for tpeoples work on devstack and then we add a BP for tempest ?
14:52:05 <sballe> dtardivel: I thought that what the openstack CD/Ci system is doing
14:52:07 <tpeoples> dtardivel:  that should be doable, but will require us to stand up a CI system.
14:52:19 <tpeoples> sounds good acabot_
14:52:47 <dtardivel> acabot_: +1
14:52:55 <sballe> acabot_: I am assuming it will be one bp per Tempest test? or is it one BP for all Tempest tests?
14:53:00 <mmmm> what the link to new arch?
14:53:04 <tpeoples> related, i should have the devstack plugin up for review by end of week, need to work through some keystone conf issues i'm having with watcher (need your help dtardivel and jed56 probably)
14:53:15 <acabot_> sballe: that's THE question ? ;-)
14:53:33 <cdupont> mmmm: https://review.openstack.org/#/c/249869/
14:53:35 <cdupont> mmm: https://review.openstack.org/#/c/249869/
14:53:47 <sballe> tpeoples: also talk to bzhou he has wathcer+openstack running and ran into some keystone issues
14:53:55 <tpeoples> ok, thanks
14:53:56 <jed56> tpeoples  : of course
14:54:01 <sballe> acabot_: lol
14:54:27 <acabot_> mmmm: this review is the current architecture, we will start working on v2 at the mid-cycle meetup
14:54:46 <cdupont> mmmm=mehdi by the way ;)
14:55:14 <mmmm> ok
14:55:18 <tpeoples> sballe: acabot_ : i think one BP for getting tempest set up and working is fine
14:55:34 <tpeoples> one BP per test is way too much
14:55:52 <tpeoples> and that would set a precedent and barrier for adding test coverage in the future
14:56:17 <sballe> tpeoples: I understand but different people can work on different tests
14:56:28 <acabot_> we can submit a BP to run a large tempest test like "running an audit"
14:56:34 <sballe> but we can do one bp and assign it to you ;-)
14:56:43 <acabot_> and then add a new one to add other tests
14:56:49 <sballe> acabot_: +1
14:57:04 <tpeoples> either way i suppose
14:57:21 <tpeoples> i just don't want to have to do a whole BP in the future to add some random tempest test
14:57:23 <tpeoples> :)
14:58:03 <sballe> In the future I am hoping that the tempest test will be part of the code submission if needed so no bp needed
14:58:03 <acabot_> tpeoples: sure
14:58:43 <sballe> tpeoples: i agree
14:58:44 <acabot_> sballe: I agree, this is something we have to do right now on existing code
14:58:55 <sballe> acabot_: agreed
14:59:01 <jed56> +2
14:59:14 <acabot_> and then add it to the "done def" of a blueprint
14:59:41 <acabot_> ok so thx for this meeting
14:59:51 <acabot_> see you next week
14:59:51 <sballe> we have one minute left
14:59:59 <sballe> ok bye. thx
15:00:04 <brunograz> ok bye
15:00:08 <cdupont> bye bye
15:00:10 <junjie> thank you , bye
15:00:19 <acabot_> #endmeeting