13:59:38 <acabot> #startmeeting watcher
13:59:38 <openstack> Meeting started Wed May 4 13:59:38 2016 UTC and is due to finish in 60 minutes. The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:42 <openstack> The meeting name has been set to 'watcher'
13:59:48 <acabot> hi guys
13:59:56 <alexchadin> hi
13:59:58 <vincentfrancoise> o/
14:00:17 <sballe_> o/
14:00:26 <jed56> (0-0)
14:00:26 <acabot> our heavy agenda #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#05.2F04.2F2016
14:01:02 <acabot> #topic Announcements
14:01:36 <acabot> #info openstack Summit last week in Austin, all discussions in https://etherpad.openstack.org/p/watcher-newton-design-session
14:01:36 <tpeoples> o/
14:01:37 <alexchadin> a lot things to discuss:)
14:01:47 <jwcroppe> o/
14:02:29 <acabot> #info Watcher talk available on YouTube and Slideshare, of course, feel free to share them across social networks
14:03:29 <acabot> #info we had discussions with Monasca & Congress as we could have some overlap with these 2 projects
14:04:27 <tkaczynski> hi
14:04:55 <acabot> #info we will add a new timeslot for our weekly meeting separating odd and even weeks
14:05:16 <acabot> this will be easier for asian people to join this meeting every 2 weeks
14:05:40 <acabot> #action acabot fin a new timeslot for Watcher meeting on odd weeks
14:05:51 <sballe_> acabot: How do you suggest we move forward with discussing the possible overlap with Monasca and Congress? Also do we care? Not everybody will have Monasca.
14:06:22 <sballe_> I am just interested in us understanding where all the project overlap and then decide on who is doing what
14:06:38 <tkaczynski> sballe_ I guess we care about mission statement etc. we might not become big tent if there is overlap or something
14:06:40 <acabot> #info we agreed to propose Watcher for the big tent in May to clarify our mission
14:06:43 <sballe_> and if overlap is okay or if we can work together
14:07:05 <hvprash> sballe_ from walmart we are trying to evaluate all the solutions and coral a unified solution
14:07:28 <jed56> sballe_: in my opinion we have a different approach than Congress
14:07:34 <acabot> sballe_ : my point is that for now, we will let TC members decide if there is an overlap in our missions, then if we enter the big tent, we will start working with them
14:07:48 <sballe_> perfect
14:08:10 <tpeoples> the TC has stated in the past that competition isn't forbidden under the big tent, haven't they?
14:08:17 <jwcroppe> jed56: +1 ... but there is some alerting overlap (read: triggers for optimization), but I think it's minor
14:08:18 <acabot> jwcroppe : does is makes sense to you ?
14:08:21 <jwcroppe> tpeoples: right
14:08:21 <sballe_> yes they have :)
14:08:26 <dronshaw> tpeoples: correct
14:08:47 <jwcroppe> acabot: +1
14:08:53 <acabot> tpeoples : yes they did it for the monitoring but it was because ceilometer didn't work
14:09:04 <jed56> jwcroppe: I agree
14:09:14 <vmahe> I agree with Jed. You could trigger Watcher audits with Congress whenever some conditions are met. Watcher aims at providing deeper analysis strategies.
14:09:36 <vincentfrancoise> vmahe: +1
14:09:46 <sballe_> vmahe: I agree with you. I would like to add watcher+congress integration sooner rather than later
14:09:48 <jed56> we could create policies in congress
14:10:05 <sballe_> so we don;t have to have this discussion again with Congress inthe fall
14:10:15 <acabot> I think everybody should read this doc from the congress team https://docs.google.com/document/d/1ksDilJYXV-5AXWON8PLMedDKr9NpS8VbT0jIy_MIEtI/edit#heading=h.wy2kqfa4vhs2 and give its feedback in our next meeting
14:10:41 <jwcroppe> acabot: will do
14:11:10 <jed56> acabot: +2
14:11:11 <acabot> I really think we have a different approach in Watcher but I'd like to have everybody agree
14:11:11 <alexchadin> acabot: will do
14:11:46 <acabot> #action jwcroppe jed56 alexchadin sballe_ read https://docs.google.com/document/d/1ksDilJYXV-5AXWON8PLMedDKr9NpS8VbT0jIy_MIEtI/edit#heading=h.wy2kqfa4vhs2 and give feedback to the team
14:12:06 <acabot> #topic Review Action Items
14:12:39 <acabot> very quick review on specs
14:13:08 <alexchadin> I forgot to tell
14:13:18 <alexchadin> Add Overload standard deviation strategy spec is already megred
14:13:46 <jed56> acabot: +2
14:13:49 <acabot> https://review.openstack.org/#/c/283449/ needs reviews
14:14:21 <acabot> we really need reviews from core on https://review.openstack.org/301774 as the code is ready to be merged
14:14:39 <acabot> #action jwcroppe acabot sballe_ review asap https://review.openstack.org/301774
14:14:40 <sballe_> I will do so today ;-)
14:15:50 <acabot> I also have 2 new specs submitted by Greg from Intel, Greg are you there ?
14:15:57 <GregoryKatsaros> Yes, Hi
14:16:18 <acabot> hi Greg, so are your specs ready to be reviewed ?
14:16:34 <GregoryKatsaros> yes are ready
14:16:44 <acabot> cause today your BPs are not in top priority
14:16:51 <GregoryKatsaros> we are working on the code at the moment. Have not submitted anything
14:16:54 <sballe_> I'll review them today. GregoryKatsaros they are the graph model stuff right?
14:16:56 <acabot> but its great to have specs already
14:17:15 <GregoryKatsaros> are the graph model and the action plans consolidation
14:17:23 <jed56> I can read the spec next week
14:17:26 <acabot> greg, do you plan to deliver the code also on this 2 BPs ?
14:17:48 <GregoryKatsaros> for the graph we plan it. we are considering for the consolidation
14:17:52 <acabot> #action sballe_ jed56 review specs https://review.openstack.org/#/c/298891/ https://review.openstack.org/#/c/298871/
14:18:28 <acabot> tkaczynski : tomasz, I think it would be great to have your feedback on https://review.openstack.org/#/c/298891/
14:18:59 <tkaczynski> acabot: ok, I can have a look
14:19:07 <jed56> sballe_: do you think that thjis can take a look ?
14:19:20 <acabot> #action tkaczynski review https://review.openstack.org/#/c/298891/
14:19:25 <GregoryKatsaros> Thijs, has already reviewed that internally
14:19:34 <acabot> ok thx
14:19:35 <GregoryKatsaros> we wrote that together
14:19:36 <sballe_> yes just put him on and I'll let him know he has an action item when I send out the minutes notes
14:20:00 <acabot> moving to Watcher code
14:20:03 <jed56> sballe_: great
14:20:19 <jed56> GregoryKatsaros: okay
14:20:26 <sballe_> GregoryKatsaros: we also want him to +1 it
14:20:36 <acabot> There are a lot of code reviews open
14:21:10 <acabot> and there is bunch of it related to get-goal-from-strategy https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/get-goal-from-strategy
14:21:46 <acabot> this code have been reviewed by 2 cores on bcom side but we need another core reviewer
14:22:02 <tkaczynski> acabot: is known when all of this will be merged? there are a lot of changes and I think many people might be affected
14:22:33 <acabot> tkaczynski : this is exactly why I want to have this code merged asap
14:22:36 <jed56> IMO, we will merge this implementation next week.
14:22:42 <acabot> it will impact others contributors
14:22:57 <sballe_> +1
14:22:58 <jed56> We can't keep these patchets open more time :)
14:23:08 <tkaczynski> it would be also good to communicate that this is merged, maybe on the meeting next week?
14:23:14 <sballe_> +1
14:23:17 <acabot> so I propose to merge it next monday with 2 cores from bcom, does anyone has a problem with that ?
14:23:38 <jed56> before the next meeting :)
14:24:10 <acabot> #info get-goal-from-strategy will be merged next monday
14:24:16 <sballe_> acabot: Fine with me
14:24:44 <acabot> we have 2 strategies currently in review https://review.openstack.org/#/c/297590/ & https://review.openstack.org/#/c/292188/
14:25:14 <acabot> on Watcher client side
14:25:38 <acabot> a BP has been submitted to support the official unified openstack CLI
14:26:05 <acabot> and code is already available for review thx vincentfrancoise https://review.openstack.org/#/q/status:open+project:openstack/python-watcherclient+branch:master+topic:bp/openstackclient-plugin
14:26:32 <alexchadin> I'll review some of them
14:26:44 <acabot> #action alexchedin review https://review.openstack.org/#/q/status:open+project:openstack/python-watcherclient+branch:master+topic:bp/openstackclient-plugin
14:26:55 <acabot> #action alexchadin review https://review.openstack.org/#/q/status:open+project:openstack/python-watcherclient+branch:master+topic:bp/openstackclient-plugin
14:27:02 <alexchadin> Review for https://review.openstack.org/#/c/297590/ is very appreciate :)
14:28:06 <acabot> on Watcher dashboard, there is a review open related to get-goal-from-strategy https://review.openstack.org/#/c/301516/
14:28:26 <acabot> #topic Blueprint/Bug Review and Discussion
14:28:59 <jed56> #action jed56 review https://review.openstack.org/#/c/297590/
14:29:23 <acabot> #info as we will propose Watcher for the big tent, we will assign an essential BP to each contributor to Watcher for our next milestone (Newton-1)
14:29:41 <sballe_> +1
14:29:48 <acabot> #info next milestone is Newton-1 (May 30th) https://blueprints.launchpad.net/watcher
14:30:31 <acabot> alexchadin proposed to take https://blueprints.launchpad.net/watcher/+spec/continuously-optimization as the one for servionica
14:31:30 <acabot> tpeoples : you were interested in this BP, can alexchadin work on it ?
14:31:30 <hvprash> acabot question on milestone. so does that include the code to be ready for review by May 30th. I am owning one of the blueprints https://blueprints.launchpad.net/watcher/+spec/persistent-audit-parameters
14:31:52 <tpeoples> yes, that is fine acabot and alexchadin. i am focusing on the other BP, so feel free
14:32:00 <sballe_> cabot: this will involve listening on the Monasca/ceilomter message bus. right?
14:32:03 <acabot> hvprash : at least specs merged
14:32:10 <hvprash> ok, got it
14:32:24 <hvprash> sorry, if it was a stupid question since this is my first one ;)
14:32:25 <alexchadin> tpeoples: great. thanks!
14:32:29 <acabot> #action alexchadin submit specs for https://blueprints.launchpad.net/watcher/+spec/continuously-optimization
14:32:46 <sballe_> hvprash: stupid questions do not exist
14:33:07 <acabot> hvprash : not at all
14:33:54 <acabot> #info we have 7 BPs targeted as essential for Newton-1 (6 partners assigned and 1 free)
14:35:00 <acabot> #info there is a new BP on watcher CLI to improve tempest coverage on the new openstack CLI https://blueprints.launchpad.net/python-watcherclient/+spec/tempest-cli-test
14:35:15 <acabot> anyone wants to take it ?
14:35:42 <acabot> hvprash : you have set your BP as discussion state, any question about it ?
14:36:14 <hvprash> yes, i have some questions. So i did setup a devstack working env. Trying to recreate the issue and understand
14:37:04 <hvprash> i was able to create a alarm template and trying to test the p[ersistency issue we are trying to fix
14:37:45 <hvprash> we can discuss this in watcher channel too due to time limitaiton
14:37:54 <hvprash> need some inputs though
14:38:15 <acabot> the problem we have here is that when you create an audit template and then build an audit with this template, if in the future you change the original template, your audit will have a consistency issue
14:38:40 <acabot> but yes lets discuss it on our IRC channel in more details
14:38:43 <vincentfrancoise> hvprash: FYI, I can help you on #openstack-watcher if you want
14:39:04 <hvprash> vincentfrancoise awesome, will work you then
14:39:05 <acabot> #topic Open Discussion
14:39:55 <hvprash> acabot sballe_ i am talking to ramki from dell next week on the congress + policy based scheduling
14:39:56 <acabot> #info there are some interesting talks from the summit that I'd like to share https://www.openstack.org/videos/video/enforcing-application-slas-with-congress-and-monasca & https://www.youtube.com/watch?v=zxcfM9tSh7Y
14:40:10 <hvprash> if interested can send you the invites
14:40:22 <sballe_> hvprash: cool! how can I/we help
14:40:31 <sballe_> hvprash: yes please
14:40:59 <hvprash> sballe acabot : we are trying to find where thats headed
14:41:08 <acabot> hvprash : did you see this email http://lists.openstack.org/pipermail/openstack-dev/2016-May/093826.html ?
14:41:42 <hvprash> acabot, thx. i missed that
14:41:47 <hvprash> will go through it
14:41:49 <acabot> its a quick recap from Congress PTL but there are no actions yet
14:42:06 <acabot> sballe_ : I will not be able to attend the congress IRC meeting tomorrow
14:42:13 <acabot> sballe_ : can you go ?
14:42:35 <hvprash> acabot, as we discussed earlier there was another effort from cisco sometime back on solverscheduler.. so lot of parallel efforts
14:42:41 <acabot> sballe_ : just to check if there is any action related to us ?
14:42:45 <sballe_> no I have a full day of meeting. Can joe go?
14:43:40 <acabot> hvprash : I dont want to tell the full story again...we decided to build this project because there is no way to improve the Nova scheduler
14:44:03 <hvprash> :)
14:44:09 <sballe_> acabot: +1
14:44:11 <acabot> so we decided to build Watcher as a project that uses Nova scheduler as it is
14:45:47 <acabot> #info Valet is an interesting initiative coming from AT&T to try to do resource optimization at Heat level
14:46:07 <acabot> unfortunately code is not open source right now
14:46:27 <acabot> and it seems to be focused on telco use cases
14:46:36 <hvprash> for NFV etc ?
14:46:40 <acabot> but we need to keep an eye on it
14:46:47 <jed56> +1 , agree they seems to focus on network topologies
14:46:54 <tpeoples> acabot: are they periodically optimizing the environment or was it making more intelligent initial placement decisions?
14:46:56 <acabot> yes mostly to guarantee NFV performances
14:47:10 <hvprash> will try to get some details from comcast too ;)
14:47:43 <acabot> tpeoples : I think so, but you should look at the presentation (20 minutes) https://www.youtube.com/watch?v=zxcfM9tSh7Y
14:48:13 <acabot> sballe_ : can you share details about our next mid-cycle ?
14:48:25 <dronshaw> acabot: I had spoken to Joe about Valet at the summit and thought there were plans to open source soon, not positive on that
14:49:36 <acabot> dronshaw : yes, Joe said that they will test it on their infra before, my concern is that they will deliver a full stack of software and it will be hard for the community to jump in
14:50:03 <sballe_> acabot sure. It will be in Hillsboro, OR and the dates are 7/19-20 and maybe a half day on the 21
14:50:43 <acabot> sballe_ : ok can you register an event on eventbrite or you want me to do it ?
14:50:52 <sballe_> yes will do
14:51:10 <sballe_> If I need help I will ping you since I haven't done it before
14:51:12 <acabot> #action sballe_ register mid-cycle meetup details on eventbrite
14:51:20 <acabot> no pb
14:51:42 <acabot> pav0 : you want to talk about puppet recipe for Watcher ?
14:51:55 <pav0> acabot: hi, yes
14:52:01 <dronshaw> acabot: completely understand
14:52:29 <acabot> so dtardivel is our maintainer for Watcher repositories so I suggest he creates the puppet repo
14:52:38 <sballe_> +1
14:52:44 <acabot> but he is away until monday
14:52:44 <pav0> acabot: +1
14:53:02 <acabot> is it ok for you to wait until next monday ?
14:53:13 <pav0> acabot: no problem :)
14:53:16 <acabot> great
14:53:26 <pav0> acabot: I just start working on it
14:53:31 <acabot> #action dtardivel create a puppet repo for Watcher
14:53:44 <acabot> anything you need to have on the CI ?
14:55:08 <acabot> pav0 : dtardivel will come back to you on our IRC channel for details on Monday
14:55:13 <acabot> any other discussion ?
14:55:28 <pav0> acabot: should I parametrize all variables
14:55:35 <pav0> available in watcher.conf file
14:55:50 <vincentfrancoise> pav0: I can also help for project setup if you have questions
14:55:53 <pav0> or should I parametrize only the main variables like connection etc
14:56:08 <jed56> yes you should :)
14:56:29 <pav0> vincentfrancoise: okey, I will write to you
14:56:33 <jed56> you should parametrize all variables
14:57:41 <pav0> jed56: ok. Some variables in puppet-nova are not parametrize, so I wonder if I should do the same or not
14:57:50 <acabot> ok dtardivel has experience with puppet so he will give our needs
14:58:02 <acabot> thx pav0
14:58:05 <jed56> pav0: IMHO, we have less variable than nova :)
14:58:42 <acabot> time to end the meeting
14:58:55 <acabot> thank you guys, have a good day / night
14:59:03 <tpeoples> you too
14:59:06 <hvprash> thx, bye
14:59:07 <vincentfrancoise> bye
14:59:08 <pav0> jed56: not so. I reviewed watcher.conf.sample and there is a lot variables xD
14:59:12 <pav0> you yoo
14:59:14 <sballe_> bye
14:59:16 <jed56> :)
14:59:16 <pav0> you too
14:59:18 <acabot> #endmeeting