14:01:24 <acabot_> #startmeeting watcher
14:01:24 <openstack> Meeting started Wed May 11 14:01:24 2016 UTC and is due to finish in 60 minutes.  The chair is acabot_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:29 <openstack> The meeting name has been set to 'watcher'
14:01:34 <acabot_> hi guys
14:01:36 <sballe_> o/
14:01:41 <vincentfrancoise> o/
14:01:45 <hvprash> hi
14:01:46 <gzhai1> hi
14:02:01 <dtardivel> hi
14:02:01 <acabot_> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#05.2F11.2F2016
14:02:33 <jed56> \o
14:02:40 <acabot_> #topic Announcements
14:03:33 <acabot_> we planned last week to sync with Congress over their IRC meeting, does anyone attended ?
14:03:41 <sballe_> I wasn't able to
14:03:58 <acabot_> ok I will do it this week then
14:04:20 <acabot_> #action acabot attend the next Congress IRC meeting
14:04:34 <seanmurphy> hi guys - apols for being late and apols for not being present at last few meetings
14:05:09 <acabot_> #info in Austin, we talked about changing the meeting time for Asian contributors
14:05:28 <acabot_> I suggested it in the ML
14:05:49 <jwcroppe> o/
14:05:57 <acabot_> 9:00 UTC on odd weeks would be 5:00PM chineses time
14:06:22 <gzhai1> It's good :)
14:06:26 <jinquan> o/
14:06:48 * edleafe wanders in
14:06:54 <sballe_> that would be 5:00 AM Wednesday, Eastern Time (ET) which would work as long as it is every other week
14:07:28 <sballe_> the folks on the West Cost would not be able to attend since that is 2amPST
14:07:38 <acabot_> so even weeks same time as today, and odd weeks 9:00UTC on the same channel
14:07:44 <sballe_> What time zone is hvprash in?
14:07:45 <jwcroppe> 4 am CT is probably too early for me and Taylor
14:07:53 <hvprash> sballe_ I am in ET
14:07:56 <edleafe> jwcroppe: zzzzzzz
14:07:59 <hvprash> that should work :)
14:08:05 <sballe_> oh cool! so we are in the same timezone
14:08:19 <jwcroppe> edleafe: or just pull all nighters :)
14:08:31 <acabot_> jwcroppe : I know that it would be too late for you ;-)
14:08:38 <acabot_> too early sorry
14:08:48 <edleafe> jwcroppe: wayyyy too old for that. And if I did, I wouldn't be on IRC :)
14:08:49 <sballe_> yeah I cannot promise I will be awake ;-) (coffee_
14:08:49 <jwcroppe> acabot_: I know it'll be a tough time find times.... so let's try this and see what happens
14:09:17 <acabot_> I tried to find a time before 6PM in China
14:09:25 <edleafe> the main thing is that people get to participate at least every other week
14:09:27 <sballe_> acabot_: make sense
14:09:28 <jwcroppe> yeah, understand
14:09:40 <edleafe> that's always better than only a few participating every week
14:09:44 <sballe_> jwcroppe: you work all the time anyway.
14:10:11 <acabot_> ok so next week will be the same time as today
14:10:15 <sballe_> aren't you awake at 4am ;-) I assumed you had customer meetings at that time.. ;-)
14:10:20 <jwcroppe> yes, only offline when in the airplane.
14:10:21 <acabot_> and the week after will be 9:00UTC
14:10:30 <sballe_> perfect!
14:10:37 <jwcroppe> acabot_: sounds good
14:10:52 <sballe_> acabot_: can you please send out a new calendadr invite. I find taht very useful
14:11:11 <acabot_> #info Watcher mid-cycle details are available on eventbrite #link https://www.eventbrite.com/e/watcher-newton-mid-cycle-developer-meetup-tickets-25267323244
14:11:32 <acabot_> #action acabot update the calendar invite for our next meetings
14:11:42 <jwcroppe> sballe_: so it's safe to book travel - we're all systems go there?
14:12:29 <sballe_> yep. everything is ready. Just sign up via the eventbrtite site so I can get you wirelss access
14:12:38 <acabot_> sballe_ : I have created the wiki page #link https://wiki.openstack.org/w/index.php?title=Watcher_newton_mid-cycle_meetup_agenda , can you update the link on eventbrite ?
14:12:41 <sballe_> and a badge so oyu can get in
14:12:47 <sballe_> aca
14:12:51 <sballe_> acabot_: yes will do
14:13:30 <sballe_> I'll update the hotels, etc as well
14:13:51 <acabot_> #info pav0 started a discussion with puppet team to build a repo for Watcher puppet scripts
14:14:52 <acabot_> feedback about congress delegation VM-placement #link https://docs.google.com/document/d/1ksDilJYXV-5AXWON8PLMedDKr9NpS8VbT0jIy_MIEtI/edit# ?
14:15:10 <dtardivel> yes, we received an ack from Emilien, PTL of openstack-puppet
14:15:22 <EmilienM> +1
14:15:32 <EmilienM> let me know if you need help
14:15:42 <dtardivel> So, I will push 2 new patchsets for end of the week
14:15:50 <dtardivel> EmilienM: +1
14:16:23 <dtardivel> pav0 will be free to add its puppet source code in the new project later
14:16:51 <acabot_> #action dtardivel submit 2 patchsets for Watcher module for Puppet #link http://lists.openstack.org/pipermail/openstack-dev/2016-May/094517.html
14:17:13 <acabot_> ok, any other announcement ?
14:17:17 <alexchadin> hi
14:17:23 <alexchadin> I'm sorry for being late
14:17:46 <acabot_> alexchadin : any feedback regarding Congress Delegation for VM-placement ?
14:18:11 <alexchadin> I've not read it completely
14:18:18 <acabot_> ok
14:18:28 <acabot_> #topic Review Action Items
14:18:29 <alexchadin> I may write feedback at openstack-watcher channel
14:18:40 <alexchadin> a little bit later
14:18:50 <acabot_> Watcher specs
14:19:00 <acabot_> #info Provide efficacy indicators has been merged
14:19:13 <acabot_> #info Cluster model objects wrapper work items are still missing
14:19:14 <jwcroppe> I'll be reviewing specs today (anything still in backlog)
14:19:43 <acabot_> #action jwcroppe review https://review.openstack.org/301774 https://review.openstack.org/#/c/275474/ https://review.openstack.org/#/c/312143/
14:20:23 <sballe_> ditto
14:20:25 <acabot_> tpeoples needs to complete https://review.openstack.org/#/c/287019/
14:20:25 <jwcroppe> acabot_: +1
14:20:37 <acabot_> #action sballe_ review https://review.openstack.org/301774 https://review.openstack.org/#/c/275474/ https://review.openstack.org/#/c/312143/
14:21:28 <acabot_> #action tpeoples complete work items https://review.openstack.org/#/c/287019/
14:22:02 <acabot_> there are also 2 specs open for larger reviews https://review.openstack.org/#/c/298891/ & https://review.openstack.org/#/c/298871/
14:22:20 <acabot_> Watcher
14:22:49 <acabot_> vincentfrancoise : can you give us a quick update on https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/get-goal-from-strategy ?
14:23:27 <sballe_> acabot_: Did get goal from strategy merge?
14:23:29 <vincentfrancoise> well, since yesterday we had an issue on Watcher because of oslo.messaging
14:23:41 <vincentfrancoise> the fix has been merge just before the meeting
14:23:56 <vincentfrancoise> and now get-goal-from-strategy is working fine
14:24:09 <sballe_> acabot_: never mind .. I wasn't paying attention I guess
14:24:18 <vincentfrancoise> dtardivel did most of the reviews and tested it on a devstack as well (can you confirm)
14:24:26 <dtardivel> vincentfrancoise: +1
14:24:34 <vincentfrancoise> so I guess we can give it a go anytime soon
14:25:02 <acabot_> ok so I think we can +W all patchsets right after the meeting
14:25:56 <acabot_> #action vincentfrancoise +W all patchsets related to get goal from strategy
14:26:04 <dtardivel> vincentfrancoise: yes, but we need to wait for gate jobs, and it is very slow the afternoon :/
14:27:19 <acabot_> gzhai1 : you will be able to work on your patchset right after the merge https://review.openstack.org/#/c/297556/
14:27:26 <vincentfrancoise> dtardivel: agreed
14:27:48 <gzhai1> acabot_:ok
14:28:09 <acabot_> we still have 2 strategies that need reviews for a long time https://review.openstack.org/#/c/297590/ https://review.openstack.org/#/c/292188/
14:29:02 <acabot_> Watcher client
14:29:15 <vincentfrancoise> the strategies will have a merge conflict as soon as we merge get-goal-from-strategy BTW
14:29:54 <acabot_> #info vincentfrancoise is waiting for reviews on the openstackclient-plugin for watcher #link https://review.openstack.org/#/q/status:open+project:openstack/python-watcherclient+branch:master+topic:bp/openstackclient-plugin
14:30:33 <acabot_> #action alexchadin junjie update their strategies after get goal from strategy merge
14:30:43 <alexchadin> will do
14:30:49 <dtardivel> I will take time to review them
14:31:06 <acabot_> #action dtardivel review https://review.openstack.org/#/c/297590/ https://review.openstack.org/#/c/292188/
14:31:14 <alexchadin> jed56 also wanted to review https://review.openstack.org/#/c/297590/
14:31:29 <acabot_> #action jed56 review https://review.openstack.org/#/c/297590/
14:31:34 <dtardivel> acabot_: I talked about vincentfrancoise ones :)
14:31:54 <acabot_> dtardivel : oups
14:32:07 <acabot_> #action dtardivel review https://review.openstack.org/#/q/status:open+project:openstack/python-watcherclient+branch:master+topic:bp/openstackclient-plugin
14:32:08 <dtardivel> nevermind
14:32:29 <acabot_> #topic Blueprint/Bug Review and Discussion
14:32:58 <acabot_> sballe_ : do you want to talk about the scoring module ?
14:33:18 <sballe_> sure.. is thomas here?
14:33:40 <acabot_> no
14:34:00 <sballe_> Anyway we have had a temporary change in priorities to tkaczynski will work on TAP release until the end of May
14:34:22 <sballe_> He will be back on the socring module at the end of May once the realease is done
14:34:58 <sballe_> acabot_: does that summarize it?
14:35:03 <dtardivel> sballe_: acabot_ jwcroppe : We're waiting for a +2/+1 on #link https://review.openstack.org/#/c/301774/20
14:35:03 <acabot_> #info tkaczynski will be back on the socring module at the end of May once the TAP realease is done
14:35:49 <acabot_> #action acabot review https://review.openstack.org/#/c/301774/20
14:36:02 <jwcroppe> dtardivel: will look after this
14:36:12 <acabot_> #action jwcroppe review https://review.openstack.org/#/c/301774/20
14:36:32 <acabot_> hvprash : any update on Audit parameters should be persistent in Db ?
14:36:33 <dtardivel> thx
14:36:39 <hvprash> Drafting the spec and will have it ready for review by tomorrow. Sorry, this is taking time since I am still going over the code.
14:37:02 <acabot_> #action hvprash send specs for review for Audit parameters should be persistent in Db
14:37:13 <acabot_> hvprash : great thx
14:37:19 <hvprash> sure
14:37:43 <vincentfrancoise> hvprash: nice !
14:37:50 <acabot_> #info current target is Newton-1 with 12 BPs & 20 bugs #link https://launchpad.net/watcher/+milestone/newton-1
14:38:27 <acabot_> there is a lot of code in review right now and the release is in 2 weeks
14:38:41 <acabot_> we need more code reviewers
14:39:05 <acabot_> 5 BPs are in review currently
14:39:28 <alexchadin> I'll send continuous-opt tomorrow
14:39:30 <alexchadin> for review
14:39:39 <acabot_> gzhai1 : Edwin, can you do more reviews in the next 2 weeks ?
14:40:07 <gzhai1> acabot_:sure
14:40:16 <acabot_> #action alexchadin send specs for review for https://blueprints.launchpad.net/watcher/+spec/continuously-optimization
14:40:34 <acabot_> gzhai1: thx
14:40:35 <alexchadin> Will make more reviews
14:41:09 <acabot_> #action alexchadin gzhai1 code reviews on BPs with "needs code review" state
14:41:23 <pav0> acabot_: I will ask guys from my team if they can review
14:41:25 <jwcroppe> https://review.openstack.org/#/c/301774/20 looks good - but needs another +2 +W (acabot_)
14:41:35 <acabot_> there is still one unassigned BP #link https://blueprints.launchpad.net/watcher/+spec/watcher-policies
14:41:46 <acabot_> pav0 : thx
14:41:49 <dtardivel> pav0: +1
14:42:44 <acabot_> does any of the BPs targeted for Newton-1 has no chance to land in 2 weeks ?
14:43:26 <acabot_> I think https://blueprints.launchpad.net/watcher/+spec/persistent-audit-parameters & https://blueprints.launchpad.net/watcher/+spec/cluster-model-objects-wrapper should be re-targeted for Newton-2
14:43:45 <acabot_> as specs are not finished yet
14:43:52 <sballe_> jwcroppe: I +2 https://review.openstack.org/#/c/301774/20
14:44:05 <vincentfrancoise> if you retarget persistent-audit-parameters <https://blueprints.launchpad.net/watcher/+spec/persistent-audit-parameters>, you also have to retarget efficacy-indicators since there is a dependency
14:44:08 <sballe_> acabot_: make sense
14:44:09 <hvprash> acabot_ I agree
14:44:46 <acabot_> jwcroppe : what do you think about https://blueprints.launchpad.net/watcher/+spec/cluster-model-objects-wrapper ?
14:45:07 <acabot_> jwcroppe : I think tpeoples will need more than 2 weeks to code this feature
14:45:31 <acabot_> #action acabot move https://blueprints.launchpad.net/watcher/+spec/persistent-audit-parameters to Newton-2
14:45:36 <jwcroppe> acabot_: probably yes - agree.  he is at a conference this morning
14:46:05 <acabot_> #action acabot move https://blueprints.launchpad.net/watcher/+spec/cluster-model-objects-wrapper to Newton-2
14:46:59 <acabot_> seanmurphy : jed56 found a bug in your strategy, he will submit it to launchpad
14:47:29 <acabot_> #topic Open Discussion
14:48:01 <edleafe> I have a junior dev on my team who is interested in Watcher
14:48:06 <seanmurphy> acabot_: cool - thanks
14:48:12 <acabot_> regarding the big tent inclusion, we need to provide a commit message explaining how watcher follow the OpenStack way
14:48:25 <edleafe> He is reviewing the current code, and I'd like to give him some direction
14:48:32 <acabot_> I suggest to write it on an etherpad that can be reviewed
14:48:38 <sballe_> acabot_: +1
14:49:03 <sballe_> acabot_: can you take a first stab? I am happy to add to the sections
14:49:05 <edleafe> acabot_: you can steal^^^ borrow wording from previous team proposals
14:49:14 <sballe_> acabot_: just let me know what I need to do
14:49:23 <acabot_> edleafe : interesting, does he start reviewing on gerrit ?
14:49:58 <jwcroppe> edleafe_: nova allowing any more BPs for Newton?  Or really just backlog reduction?
14:50:06 <jwcroppe> edleafe: ^^^
14:50:13 <acabot_> sballe_ : yes I will take the first stab and use gerrit history ;-)
14:50:17 <edleafe> He just said he would review the code. We have our regular mentor meeting tomorrow
14:50:44 <acabot_> edleafe : ok
14:50:50 <edleafe> I was hoping to give him something concrete to learn
14:50:56 <jwcroppe> edleafe: I've had https://review.openstack.org/#/c/288819/ out for review for quite some time - it's trivial, but not getting any spec review traffic
14:51:14 <jwcroppe> edleafe: several +1s FWIW :)
14:51:26 <edleafe> jwcroppe: yes, but the check-destinations spec hasn't landed, as far as I know, and that's a requirement for my BP
14:51:54 <edleafe> jwcroppe: ok, I'll point him to that, as well as reviews in general.
14:52:03 <acabot_> #action acabot start writing the commit msg for the big tent and share the etherpad on IRC
14:52:06 <jwcroppe> edleafe: take a look at https://review.openstack.org/#/c/288819/ if you get a sec too, please
14:52:11 <jwcroppe> edleafe: thanks
14:52:26 <acabot_> does any partner has a larger test infrastructure than 10 nodes to test Watcher scalability ?
14:52:38 <edleafe> jwcroppe: you have no idea how overloaded I am right now
14:52:40 <edleafe> :)
14:52:56 <acabot_> this is something we discussed in Austin, it becomes crucial to be able to test Watcher on a larger infra that devstack ;-)
14:53:22 <sballe_> acabot_: I thought somebody had offered to test at 50. Was that OVH?
14:53:23 <acabot_> it could be for a limited time
14:54:04 <acabot_> I'm looking at OSIC #link https://osic.org/
14:54:29 <acabot_> OVH told me that it could be possible but for a very limited time (3 or 4 days)
14:54:36 <pav0> sballe_:  I check it
14:55:02 <acabot_> pav0 : I had this discussion with pilgrimstack
14:55:04 <pav0> sballe_: I will check it*
14:55:09 <edleafe> sballe_: could you get some machines for testing from the Intel-Rackspace project?
14:55:18 <edleafe> (forgot the name)
14:55:37 <gzhai1> We need physical machine, right?
14:55:39 <sballe_> edleafe: nope I do not have access to those
14:56:00 <sballe_> I can ask but I am not hopeful
14:56:03 <edleafe> sballe_: any team can request machines
14:56:19 <acabot_> gzhai1 : in an ideal world we need a production ready OpenStack cluster with 50 nodes
14:56:35 <edleafe> OpenStack Innovation Center (OSIC) - thanks google!
14:56:49 <acabot_> edleafe : thats what I'm looking at
14:57:07 <pav0> acabot_:  ok, I will ask him
14:57:09 <pav0> dtardivel: thanks for creating puppet-watcher project on launchpad. I try to push today to openstack-infra repo iformations about puppet-watcher project
14:57:11 <acabot_> I think it would be easier to request access if we are a big tent project
14:57:16 <gzhai1> I can have a check within our team.
14:57:27 <acabot_> gzhai1 : thx
14:57:35 <edleafe> sballe_: from last July: "Largest OpenStack Developer Cloud– Rackspace and Intel will build and make available to the community two 1,000 node clusters to support advanced, large-scale testing of OpenStack and new features developed through the joint engineering work. The companies anticipate having the clusters available for community use within the next six months"
14:57:41 <gzhai1> But you can check it as community:)
14:58:32 <acabot_> #link https://osic.org/sites/osic.org/files/OSIC_Exposed_final_web.pdf page 2
14:58:44 <acabot_> there are clusters available
14:59:19 <acabot_> time to end the meeting
14:59:22 <edleafe> acabot_: https://osic.org/clusters
14:59:22 <acabot_> thank you
14:59:26 <edleafe> the request form
14:59:45 <acabot_> edleafe : ok lets talk about it next week
14:59:50 <vincentfrancoise> see you next week
14:59:59 <dtardivel> bye
15:00:00 <gzhai1> bye
15:00:01 <acabot_> #endmeeting