09:00:05 <acabot> #startmeeting watcher
09:00:06 <openstack> Meeting started Wed May 25 09:00:05 2016 UTC and is due to finish in 60 minutes. The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:10 <openstack> The meeting name has been set to 'watcher'
09:00:13 <acabot> hi
09:00:30 <jed56> hello
09:00:38 <gzhai2> hi
09:00:38 <jinquan> hi
09:00:42 <vtech> hi
09:00:46 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#05.2F25.2F2016
09:00:57 <dtardivel> hi
09:01:14 <acabot> #topic Announcements
09:02:01 <acabot> #info we will submit Watcher to the big tent today, its still time to review the commit msg https://etherpad.openstack.org/p/watcher-big-tent-commit-msg
09:02:24 <acabot> #info Watcher puppet repository creation currently in still in review
09:03:11 <vincentfrancoise> hi
09:03:17 <acabot> #info sballe started a scope benchmark between Congress/Watcher/Craton, feel free to complete slides https://docs.google.com/presentation/d/1B_Wa_xSqj-Ovf_qTMdpFt7NrwobB2UhHcmwCTApk2OY/edit?usp=sharing
09:03:48 <eil397> o/
09:04:20 <acabot> #info next mid-cycle will be announced next week on the ML and we will have only 10 seats so if you plan to join, please register asap on https://www.eventbrite.com/e/watcher-newton-mid-cycle-developer-meetup-tickets-25267323244
09:05:37 <acabot> #info gzhai2 & sballe also started a discussion about infra requirements to test Watcher at the end of the Newton cycle, discussions are in an etherpad https://etherpad.openstack.org/p/watcher-test-environment-specifications
09:07:03 <acabot> #info a discussion has been started on the ML regarding Nova deprecated APIs that are needed by Watcher http://lists.openstack.org/pipermail/openstack-dev/2016-May/095726.html
09:07:07 <gzhai2> acabot: I'll give hardware spec
09:07:34 <acabot> #action gzhai2 complete required hardware specs in https://etherpad.openstack.org/p/watcher-test-environment-specifications
09:07:43 <acabot> any other announcement ?
09:08:30 <acabot> #topic Review Action Items
09:08:39 <acabot> Watcher specs
09:08:59 <acabot> #info Specs for plugins-parameters & Airflow event based migration strategy spec have been merged
09:09:23 <acabot> gzhai2 : do you plan to work on Airflow event based migration strategy implem ?
09:09:33 <acabot> or is it junjie ?
09:09:34 <gzhai2> acabot:yes
09:10:42 <acabot> #action gzhai2 assign the BP https://blueprints.launchpad.net/watcher/+spec/uniform-airflow-migration-strategy to you
09:11:13 <acabot> gzhai2 : https://review.openstack.org/#/c/297556/ is still in merge conflict
09:11:39 <acabot> gzhai2 : can you rebase it asap, I'd like to have it merged EOW
09:11:53 <gzhai2> acabot: should be ok on tomorrow.
09:12:10 <acabot> #action gzhai2 rebase https://review.openstack.org/#/c/297556/
09:12:32 <acabot> #info Audit parameters should be persistent in Db needs review from core
09:12:42 <acabot> #action acabot jwcroppe sballe_ review https://review.openstack.org/#/c/317130/
09:12:57 <acabot> Add Watcher Continuosly Optimization spec, Graph model describing virtual and physical elements in a data center & Consolidation of multiple Action-plans into a single one need reviews
09:13:16 <acabot> the priority is on https://review.openstack.org/#/c/315551/
09:13:34 <acabot> who wants to review it ?
09:13:47 <jed56> I can
09:13:54 <acabot> #action jed56 review https://review.openstack.org/#/c/315551/
09:14:00 <jed56> thanks
09:14:03 <acabot> #action acabot review https://review.openstack.org/#/c/315551/
09:14:18 <acabot> #info Cluster model objects wrapper work items are still missing
09:14:56 <acabot> #action tpeoples complete work items on https://review.openstack.org/#/c/287019/ or free this BP for our next meeting
09:15:07 <acabot> Watcher
09:15:22 <acabot> #info Add Overload standard deviation strategy needs a new PS
09:15:38 <acabot> #action alexchadin add a new PS on https://review.openstack.org/#/c/297590/
09:15:53 <acabot> #info Workload balance migration strategy implementation needs a new PS
09:16:17 <alexchadin> Already added new PS
09:16:31 <acabot> alexchadin : sorry
09:16:58 <jed56> ah yes Updated 7 minutes ago
09:17:00 <jed56> :)
09:17:04 <acabot> gzhai2 : is junjie available to submit a new PS for https://review.openstack.org/#/c/292188/ ?
09:17:20 <alexchadin> soory for offtop: will agenda always be at 9:00 UTC?
09:17:26 <gzhai2> i'll ask him
09:17:41 <gzhai2> alexchadin: biweekly
09:17:44 <acabot> alexchadin : no only on odd weeks
09:17:57 <alexchadin> acabot, gzhai2: thank you
09:18:31 <acabot> gzhai2 : can you check with junjie that we will be able to have this strategy merged for Newton-1 (next monday) ?
09:19:21 <acabot> #action gzhai2 junjie add a new PS to https://review.openstack.org/#/c/292188/ (we will merge it by EOW)
09:19:30 <gzhai2> acabot:sure.
09:19:58 <acabot> #info more reviewers are needed to complete plugins parameters https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/plugins-parameters
09:19:59 <gzhai2> If no other big comments, it should be ok.
09:20:12 <acabot> gzhai2 : ok thx
09:20:39 <acabot> alexchadin : could you review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/plugins-parameters ?
09:21:15 <alexchadin> acabot: I can, a little bit later though
09:21:34 <vincentfrancoise> alexchadin: thanks, I appreciate :)
09:21:39 <acabot> we need reviews by end of week to release Newton-1 version
09:22:06 <acabot> #action alexchadin review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/plugins-parameters
09:22:25 <acabot> Watcher client
09:22:50 <acabot> #info most of the openstackclient-plugin has been merged https://review.openstack.org/#/q/status:open+project:openstack/python-watcherclient+branch:master+topic:bp/openstackclient-plugin
09:23:17 <acabot> gzhai2 : we still have a merge conflict on https://review.openstack.org/#/c/297557/
09:23:45 <dtardivel> acabot: about openstackclient-plugin related doc updates will be merged ASAP
09:24:07 <acabot> #action dtardivel merge openstackclient-plugin related doc updates asap
09:24:09 <gzhai2> acabot: It should be ok with watcher changes by tomorrow
09:24:15 <acabot> ok thx
09:24:18 <dtardivel> FYI, commands are now :
09:24:26 <dtardivel> https://www.irccloud.com/pastebin/5x3ZfH1I/
09:24:34 <acabot> #action gzhai2 rebase https://review.openstack.org/#/c/297557/
09:25:22 <acabot> #topic Blueprint/Bug Review and Discussion
09:25:48 <acabot> #info Newton-1 is due to May 30th https://launchpad.net/watcher/+milestone/newton-1
09:26:03 <acabot> we have 7 BPs in code reviews
09:26:18 <sballe_> Hi sorry for being late
09:26:58 <acabot> does any of your assigned BP cannot be delivered by next monday ?
09:27:59 <vincentfrancoise> well
09:28:12 <vincentfrancoise> I have my efficacy-indicator blueprint
09:28:17 <vincentfrancoise> it is 80% done
09:28:45 <vincentfrancoise> but I need the blueprint on perisistent-audit-parameters to do the remaining 20%
09:29:11 <vincentfrancoise> So given the deadline, I think it would be best to postpone mine for n-2
09:29:19 <acabot> ok and https://blueprints.launchpad.net/watcher/+spec/persistent-audit-parameters has been postponed to Newton-2
09:29:28 <acabot> ok that makes sense
09:29:57 <acabot> #action acabot postpone https://blueprints.launchpad.net/watcher/+spec/efficacy-indicator to Newton-2
09:30:22 <acabot> ghzai2 alexchadin junjie : are you confident with your BPs ?
09:30:57 <acabot> jinquan : are you confident with your BP ?
09:31:00 <gzhai2> acabot: i'm ok. Think junjie should be ok
09:31:57 <acabot> ok so I will keep a 6 BPs list for Newton-1, keep in mind that your code must be merged by next monday
09:32:52 <jinquan> acabot: i thinkit's ok
09:33:11 <acabot> #action ghzai2 alexchadin junjie jinquan we will merge your code by next monday so please be ready to review and patch your code
09:33:22 <sballe_> Is junjie on IRC? I sent him a reminder to come to the meeting
09:33:34 <acabot> sballe_ : he is not right now
09:33:37 <gzhai2> seems no
09:33:45 <gzhai2> I'll ping him offline
09:33:52 <sballe_> Ok thx
09:34:05 <acabot> #topic Open Discussion
09:34:35 <acabot> I dont have any topic today in the agenda, does anyone wants to open a discussion ?
09:34:44 <sballe_> Please sign up for the mid cycle so we know how many people will come
09:35:04 <gzhai2> acabot: pls. provide more details of the watcher test case
09:35:04 <acabot> #action acabot jed56 sign up for the mid-cycle
09:35:46 <acabot> gzhai2 : what do you mean by watcher test case ? the infra needed ? the strategy we want to test ?
09:36:11 <gzhai2> strategy.
09:36:30 <gzhai2> what to test
09:36:48 <acabot> ok so for now the idea is to validate that all strategies we have implemented in Watcher scale
09:37:09 <acabot> and if not, find a way to make them scalable
09:37:27 <gzhai2> We'll have concrete plan later, right?
09:37:49 <sballe_> acabot: we'll need to write down the command we want to run
09:37:57 <acabot> we will look at what we can do with Rally to stress the infrastructure
09:38:24 <sballe_> Maybe we can start writing down everything on the ether pad
09:38:25 <acabot> sballe_ : ok
09:38:42 <alexchadin> oh
09:38:45 <alexchadin> about Rally
09:38:54 <alexchadin> I know boris-42 personally
09:39:17 <alexchadin> If You have any questions, I may ask him
09:39:20 <sballe_> I am assuming that gzhai2 is talking about the intel system in September
09:39:26 <dtardivel> alexchadin: +1
09:39:32 <sballe_> We won't have rally
09:39:38 <acabot> alexchadin : and do you know if Rally would be a good tool to validate Watcher ?
09:39:48 <acabot> alexchadin : I mean testing strategies
09:40:11 <acabot> sballe_ : why ?
09:40:13 <alexchadin> I don't think it is probably good for strategies testing
09:40:36 <acabot> alexchadin : why ?
09:40:56 <gzhai2> sballe_: yes.
09:41:34 <sballe_> acabot: I don't think we'll have access to rally on the system in September
09:41:39 <alexchadin> It works better with atomic operations like create keystone user, project, etc
09:41:48 <alexchadin> We tested it with nova vm create
09:42:03 <alexchadin> It fails after 100 vms created
09:42:16 <acabot> sballe_ : you mean that it will not be possible to deploy Rally on your infra ?
09:42:38 <acabot> alexchadin : ok
09:42:41 <alexchadin> I will introduce him in watcher and ask if there could be any problems with strategies
09:42:48 <alexchadin> BTW
09:43:13 <acabot> alexchadin : the idea is to use Rally to load the infrastructure and then run Watcher strategies
09:43:15 <sballe_> gzhai2: can ask
09:43:36 <acabot> alexchadin : if you can discuss that case with boris-42 it would be great
09:44:02 <alexchadin> acabot: I will discuss it by EOW, ok?
09:44:04 <gzhai2> sballe_: Rally is also one project. Deploying it should be ok
09:44:19 <acabot> sballe_ : when you said that we should write down all commands, do you mean we wont have access to the infra outside of Intel ?
09:44:20 <sballe_> acabot: I know the lab people will deploy openstack for us
09:44:59 <gzhai2> acabot: there are 2 options: OSIC and intel internal.
09:45:08 <gzhai2> latter is more feasible.
09:45:11 <alexchadin> I got huawei server today, will try to run sd-strategy on it
09:45:27 <acabot> #alexchadin ask boris-42 if he thinks that we can use Rally to load the infra and test Watcher strategies
09:45:28 <alexchadin> to have stress test
09:45:33 <gzhai2> don't know if you guys requested OSIC nodes.
09:46:01 <acabot> gzhai2 : do you want me to do it in parralel ?
09:46:03 <sballe_> acabot: I was assuming that the internal system would it be available from outside
09:46:22 <gzhai2> acabot: yes.
09:46:25 <acabot> sballe_ : ok and is it still the case ?
09:46:29 <alexchadin> I'm sorry, I should leave meeting
09:46:33 <sballe_> acabot: yes let's do Osic in parallel
09:46:40 <alexchadin> goodbye everyone!
09:46:47 <gzhai2> goodbye
09:46:53 <vincentfrancoise> bye
09:47:01 <sballe_> acabot: I meant NOT available
09:47:03 <eil397> bye
09:47:23 <acabot> sballe_ : can you complete the OSIC form ? (I think it will better if it comes from Intel)
09:47:38 <sballe_> gzhai2: will do that
09:48:00 <gzhai2> acabot: should be better come from outside intel.
09:48:09 <acabot> :-)
09:48:12 <acabot> ok
09:48:16 <gzhai2> It's for community work.
09:48:25 <gzhai2> :)
09:48:48 <acabot> #action acabot submit a request to OSIC to get a test cluster
09:49:25 <acabot> any other topic ?
09:49:49 <sballe_> acabot: I am worried that the internal cluster can only be accessed from inside so Osic is better for community work
09:50:03 <acabot> sballe_ : ok
09:50:29 <sballe_> acabot: do we still want it?
09:50:54 <sballe_> In September that is
09:51:14 <acabot> sballe_ : actually, I will do the same request on bcom side :-) with the same concern that it will not be available from the outside
09:51:47 <acabot> sballe_ : so lets do 3 requests and see what we have in September :-D
09:51:58 <sballe_> Make sense
09:52:47 <sballe_> gzhai2: and I can ask to have rally installed and see what they say
09:52:55 <acabot> can we close the meeting ?
09:53:00 <sballe_> Yes
09:53:10 <gzhai2> yes
09:53:13 <acabot> thank you guys
09:53:16 <vincentfrancoise> bye everyone :)
09:53:18 <acabot> bye
09:53:19 <sballe_> Bye
09:53:20 <gzhai2> thank you
09:53:21 <gzhai2> bye
09:53:24 <jinquan> bye
09:53:24 <vtech> bye
09:53:24 <eil397> bye
09:53:27 <acabot> #endmeeting