14:00:17 <acabot> #startmeeting watcher
14:00:18 <openstack> Meeting started Wed Jul 13 14:00:17 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:22 <acabot> hi
14:00:22 <openstack> The meeting name has been set to 'watcher'
14:00:24 <alexchadin> hi
14:00:28 <hvprash> hi
14:00:30 <tkaczynski> hi
14:00:34 <sballe_> o/
14:00:48 <vincentfrancoise> o/
14:00:50 <acabot> a big agenda today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#07.2F13.2F2016
14:00:54 <jinquan1> hi
14:01:12 <acabot> #topic Announcements
14:01:25 <acabot> #info Today is the deadline to submit talks
14:01:31 <acabot> #link https://etherpad.openstack.org/p/Watcher_abstracts_barcelona2016
14:01:44 <jwcroppe_> o/
14:01:51 <jed56> hi
14:01:58 <jwcroppe_> hi
14:02:01 <acabot> we need a leader per talk to submit it right after the meeting
14:02:16 <acabot> I have set a leader in bold in the etherpad
14:02:20 <sballe_> I see you are missing a leader on the hands-on lbab
14:02:36 <acabot> missed dtradivel ;-)
14:02:49 <sballe_> oh I see :)
14:03:04 <acabot> dtardivel sballe_ jed56 hvprash good for you to submit your talk ?
14:03:25 <jed56> I need to work on the teaser
14:03:30 <hvprash> for the watcher use case talk, it would be me or michael gugino. anyone else from core would like to be part of this talk ?
14:03:51 <acabot> hvprash : sballe_ will
14:04:04 <jed56> I'm going to do it today with vmahe
14:04:04 <hvprash> ok
14:04:39 <acabot> dtardivel : ok to submit your talk today ?
14:04:40 <jed56> sballe_: do you know if Edwin Zhai have something in mind
14:05:09 <sballe_> no but since he should be part of running the scalability tests
14:05:20 <sballe_> I am sue he will have some stuff to say
14:05:25 <sballe_> s/sure
14:05:29 <acabot> jwcroppe : can we remove tpeoples from the hands-on as we need 3 speakers max ?
14:05:44 <jwcroppe> acabot: yep, that's OK
14:06:08 <sballe_> acabot: We have 4 people on the Watcher roadmap one
14:06:13 <sballe_> Who should be taken off?
14:06:38 <acabot> jinquan1 : I will also have to remove hanrong from the second talk, is that ok for you ?
14:07:09 <jinquan1> i don't know if hanrong are here?
14:07:19 <acabot> she's not
14:07:35 <acabot> actualy she's connected
14:08:07 <jinquan1> she is attendi旯 openstack china day
14:08:08 <hanrong> I am here
14:08:09 <sballe_> acabot: Shouldn't we have a b-com person on that talk?
14:08:12 <acabot> i'm sorry about that but a team from Intel asked us to introduce fingerprinting in this talk
14:08:34 <sballe_> We could tak Ananth off and just have him talk anyway
14:08:44 <acabot> sballe_ : I would love to but you will have to take you off
14:08:46 <sballe_> I feel bad iht 2 intel people on the Watcher roadmap
14:09:03 <acabot> ok
14:09:20 <acabot> so jed56, do you want to be part of it ?
14:09:40 <jwcroppe> sballe, acabot: so we'd have 3 people on the roadmap item?  I'm fine with however we want to swing that.
14:10:13 <jed56> yes but i want to have only one talk :)
14:10:17 <acabot> just to clarify who needs to be registered today, of course we can change speakers at the summit
14:10:40 <vincentfrancoise> maybe we can put back hanrong then?
14:11:06 <acabot> vincentfrancoise: +1 for diversity
14:11:23 <acabot> and we will see later if one person from bcom can talk
14:11:24 <sballe_> Can we have more thn 3 speakers on the submittion/
14:11:32 <acabot> sballe_ : no
14:11:36 <sballe_> ok
14:11:53 <acabot> thats why I'm trying to have as many possible as possible on 4 talks !
14:12:35 <acabot> looks good now
14:12:38 <sballe_> acabot: Edwin do not have to be n 2 talks
14:12:42 <jed56> we can maybe add in the TCO the fingerprint part
14:12:52 <jed56> TCO talk
14:12:54 <jwcroppe> I want to ensure we give others a chance to talk as well to maximize 'publicity' :)
14:13:01 <sballe_> Would it make sense to move the fingerprintng down on the TCO Optimization talk
14:13:19 <sballe_> jed56: Great mind think a like :)
14:13:34 <acabot> sballe_ I think the TCO will be more focused on benchmark results that adding strategies
14:13:38 <sballe_> and that way Ananth is on a talk
14:13:57 <sballe_> acabot: but it doesn't matter. We cn have 15 mins at the end on fingerprinting
14:14:24 <acabot> ok done
14:14:28 <alexchadin> Will we speak about the strategies and the differences between them?
14:14:31 <acabot> Ananth replacing Edwin on TCO
14:14:58 <acabot> 11 speakers !
14:15:03 <acabot> amazing
14:15:03 <sballe_> I mv the fingerprinting text down t TCO
14:15:24 <acabot> everybody will talk about Watcher in Barcelona ! :-D
14:15:45 <sballe_> this is so great! We have a great community now
14:16:08 <hvprash> :)
14:16:28 <jinquan1> great
14:16:39 <acabot> #action dtardivel sballe_ jed56 hvprah : submit your talk today$
14:16:56 <acabot> #info mid-cycle agenda is open for additions / sync with Nova team in progress
14:17:05 <acabot> #link https://etherpad.openstack.org/p/newton-watcher-midcycle
14:17:17 <acabot> I'd like to freeze the topics list today
14:17:24 <acabot> and adjust the agenda EOW
14:17:43 <acabot> so if you want to add any topic to discuss, please add it now
14:18:11 <jwcroppe> Yes, 11 speakers - very nice
14:18:53 <acabot> jwcroppe : any IBM topic there https://etherpad.openstack.org/p/newton-watcher-midcycle
14:18:57 <acabot> ?
14:19:19 <jwcroppe> acabot: It's on my list to review this week
14:19:38 <acabot> ok before EOW please as I plan to finalize the agenda
14:19:53 <jwcroppe> Will do by tomorrow
14:20:21 <acabot> #info sync with Nova scheduler team in progress, we will add a topic in their agenda and try to attend an unconference session
14:20:28 <acabot> #link https://etherpad.openstack.org/p/nova-newton-midcycle
14:20:42 <acabot> for now "(acabot & jed56): Watcher host selection should respect the Nova policies. However, currently in Watcher we are bypassing the nova scheduler which results in the violation of nova placement policies."
14:21:14 <sballe_> acabot: Please add me to taht topic. I want to help on that on
14:21:14 <acabot> we probably wont have any timeslot allocated so the best would probably be to have a common social event
14:21:29 <sballe_> I mentioned taht to edleafe
14:21:38 <acabot> sballe_ could you think with mriedemm about that ?
14:21:48 <acabot> s/think/sync
14:22:03 <sballe_> on the dinner?
14:22:16 <acabot> dinner or lunch
14:22:32 <sballe_> Will do
14:23:01 <acabot> #action sync with mriedemm to set up a Nova/Watcher event (lunch or dinner)
14:23:08 <acabot> #action sballe_ sync with mriedemm to set up a Nova/Watcher event (lunch or dinner)
14:23:19 <acabot> #info Mascot for Watcher please come at the midcyle with a couple of animals or natural features in mind that represent Watcher
14:23:34 <acabot> #link http://lists.openstack.org/pipermail/openstack-dev/2016-July/099046.html
14:23:46 <sballe_> acabot: that is a great idea. That way we can make stickers for the openstack summit
14:23:51 <acabot> the foundation propose to create a mascot for Watcher
14:24:12 <acabot> so I think we need to agree on something end of next week
14:24:13 <jwcroppe> acabot: I take reach out to Matt on that
14:24:16 <jed56> ;)
14:24:32 <acabot> I will add a "brainstorming" slot in the agenda to find the good animal ;-)
14:24:40 <jwcroppe> acabot: he's an IBMer as well, I'll take that action to see if there's an evening that works
14:24:55 <acabot> jwcroppe : great
14:25:06 <acabot> #action sballe_ jwcroppe sync with mriedemm to set up a Nova/Watcher event (lunch or dinner)
14:25:23 <acabot> #info Release naming process is open for Q & P, you should have received an email with a link to vote
14:25:47 <acabot> #info no meeting next week due to the midcycle
14:25:58 <acabot> #topic Review Action Items
14:26:15 * edleafe just makes it back to the computer
14:26:26 <acabot> a lot of things merged this week as the n2 release is due
14:26:45 <acabot> Make default Planner generic has been merged #link https://review.openstack.org/#/c/337049/
14:27:06 <acabot> Update define-the-audit-scope spec needs reviews #link https://review.openstack.org/#/c/339456/
14:27:45 <jed56> acabot: you add add me on it
14:27:58 <alexchadin> It should be hold for now
14:28:06 <acabot> #action jed56 review https://review.openstack.org/#/c/339456/
14:28:21 <alexchadin> until we get generic way to get resources
14:28:34 <jed56> alexchadin: +2 we have to discuss that
14:28:35 <acabot> alexchadin : yes we will add a BP that will be a dependancy on audit scope
14:28:40 <vincentfrancoise> +1 ^^^
14:29:00 <acabot> Blueprint priorities for Newton needs reviews https://review.openstack.org/#/c/341163/
14:29:01 <jed56> alexchadin: after Portland I'm going with vincentfrancoise to work on that
14:29:13 <alexchadin> jed56: appreciate it!
14:29:15 <acabot> thx sballe_ for submitting it (I was very late)
14:29:32 <michaelgugino> hi all
14:29:41 <acabot> #action jwcroppe review https://review.openstack.org/#/c/341163/ before midcycle
14:29:55 <acabot> Graph model describing virtual and physical elements in a data center & Consolidation of multiple Action-plans into a single one need reviews
14:30:11 <acabot> #link https://review.openstack.org/#/c/298891/ https://review.openstack.org/#/c/298871/
14:30:26 <acabot> moving to Watcher
14:30:29 <sballe_> acabot: happy to help
14:30:37 <jed56> I still have to review "Consolidation of multiple Action-plans into a single one"
14:30:54 <acabot> #info Watcher n2 released today
14:31:02 <acabot> #link https://review.openstack.org/#/c/341520/
14:31:24 <acabot> congrats to all our team for this release !
14:31:30 <sballe_> +1
14:31:35 <jwcroppe> +2
14:31:45 <vincentfrancoise> +2
14:31:53 <acabot> 7 BPs & 12 bugs
14:32:01 <acabot> sorry 6 BPs
14:32:20 <alexchadin> +2
14:32:25 <jinquan1> +1
14:32:31 <jed56> great job !
14:32:40 <acabot> a lot of code as been merged
14:32:42 <hvprash> nice !
14:32:58 <acabot> actually all code related to n2 :-)
14:33:18 <acabot> Add scoring engines to database and API layers needs reviews
14:33:24 <acabot> #link https://review.openstack.org/#/c/330382/
14:33:50 <acabot> Add rally-jobs folder to get rally support needs more tests
14:33:57 <acabot> #link https://review.openstack.org/#/c/333371/
14:34:21 <acabot> Watcher-client
14:34:29 <acabot> Add scoring engine commands needs reviews from core
14:34:35 <acabot> #link https://review.openstack.org/#/c/330385/
14:35:09 <acabot> #action jed56 vincentfrancoise review https://review.openstack.org/#/c/330385/
14:35:30 <gzhai-mobl> i can for 333371
14:35:40 <tkaczynski> I believe it was already reviewed, but is waiting for review the other part in watcher repo
14:35:56 <acabot> #action gzhai-mobl review https://review.openstack.org/#/c/333371/
14:36:24 <acabot> tkaczynski : what do you mean ?
14:36:48 <acabot> ok you mean we are waiting for other part of your code ?
14:36:50 <alexchadin> gzhai-mobl: I'll update it as soon as watcher plugin is released
14:36:58 <tkaczynski> acabot: see the comment in https://review.openstack.org/#/c/330385/
14:37:34 <gzhai-mobl> alexchadin:ok
14:37:36 <acabot> ok the depends-on
14:38:08 <acabot> #topic Blueprint/Bug Review and Discussion
14:38:47 <acabot> #info next milestone is Newton-3 (August 29th)
14:39:02 <jed56> tkaczynski: in order to review the scoring engine. I would appreciate to have the whole implementation
14:39:12 <acabot> #link https://launchpad.net/watcher/+milestone/newton-3
14:39:41 <jed56> do you think this is something possible ?
14:40:06 <alexchadin> acabot: please take a look when you have time: https://blueprints.launchpad.net/watcher/+spec/refactor-continuous-type
14:40:32 <tkaczynski> jed56: cannot we close on this already sent for review? the whole idea is to submit work in batches. the next part is coming
14:40:58 <alexchadin> acabot: I've added it just before meeting
14:41:15 <tkaczynski> the submitted part is fairly independent from the rest
14:41:26 <acabot> alexchadin : sure let me add to open discussions
14:42:03 <acabot> #topic Open discussion
14:42:20 <acabot> alexchadin : can you explain your BP a little bit ?
14:42:47 <jed56> alexchadin: we should discuss "refactor-continuous-type" I'm not sure that this add a real value
14:42:58 <alexchadin> I propose to store audit jobs in DB
14:43:17 <michaelgugino> I'd like some reviews on https://review.openstack.org/#/c/330165/  It's not finished, but it's getting close.  But the patch set is getting rather large, and I'd prefer to get some eyes on this sooner than later so I don't have to keep rebasing
14:43:19 <jed56> moreover, apscheduler can handle that
14:43:23 <alexchadin> jed56: if it is possible, I may work on it without BP
14:43:57 <acabot> michaelgugino : sorry for missing it
14:43:58 <alexchadin> jed56: yes, it would be good to use this feature
14:44:47 <acabot> alexchadin : I dont see the value of itl
14:45:02 <michaelgugino> specifically, if there are any glaring test cases anyone would like to see covered, please post them in a review, and I'll be happy to write them into the patch set.  There's just a ton of changes, scope of this patch was larger than I thought it would be.
14:45:04 <acabot> why do you want to store audit jobs in DB ?
14:45:33 <acabot> who wants to review https://review.openstack.org/#/c/330165/ ?
14:46:21 <hvprash> agree with michaelgugino.. need more reviews
14:46:29 <alexchadin> acabot: if decision engine service is restarted, we can add audit jobs back to memory and run them according their schedule
14:46:54 <jinquan1> i can review  330165
14:46:56 <vincentfrancoise> michaelgugino: I'll review your code
14:47:02 <michaelgugino> great, thanks
14:47:33 <acabot> #action jinquan1 vincentfrancoise review https://review.openstack.org/#/c/330165/
14:48:20 <gzhai-mobl> alexchadin:we can just restart according to the period, right?
14:48:28 <acabot> alexchadin : do you think this case will happened often ?
14:49:20 <gzhai-mobl> acanot: engine may crash.
14:50:16 <acabot> ok I suggest to discuss it next week and set a priority
14:50:46 <alexchadin> acabot: otherwise we need to recreate continuous audits to run them properly
14:51:39 <acabot> does all midcycle attendees will be in Hillsboro on tuesday morning ?
14:52:07 <gzhai-mobl> jul17?
14:52:07 <sballe_> dd everybody see the buildings for each day?
14:52:16 <sballe_> I added that to the etherpad
14:52:37 <acabot> https://etherpad.openstack.org/p/newton-watcher-midcycle
14:52:38 <sballe_> acabot: I will be there
14:52:46 <acabot> sballe_ I hope so :-D
14:52:51 <sballe_> :)
14:52:56 <gzhai-mobl> sballe: i saw it. thank you
14:53:14 <acabot> we will start at 9am as we will have european folks in remote
14:53:48 <sballe_> Let's meet in the lobby at 8:45am or 9?
14:54:03 <sballe_> and we'll walk up to the room from there
14:54:04 <acabot> 8:45
14:54:36 <acabot> ok so see you next week for most of you
14:54:55 <acabot> no IRC meeting next week
14:55:07 <acabot> bye
14:55:15 <acabot> #endmeeting