09:01:19 <acabot> #startmeeting watcher
09:01:20 <openstack> Meeting started Wed Sep 14 09:01:19 2016 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:01:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:01:23 <openstack> The meeting name has been set to 'watcher'
09:01:27 <acabot> o/
09:01:28 <alexchadin> o/
09:01:52 <acabot> hi alex
09:01:57 <Yumeng_> hi everyone, hi acabot
09:02:05 <acabot> hi Yumeng_
09:02:10 <Yumeng_> Can I have 1 minute to introduce myself ?
09:02:15 <acabot> sure go ahead
09:02:20 <Yumeng_> thank you
09:02:26 <vincentfrancoise> o/
09:02:32 <Yumeng_> My name is Yumeng, I work for ZTE Corporation.
09:02:40 <Yumeng_> I newly jioned the Openstack team of my company and my intrest is in coding about watcher projects.
09:02:55 <dtardivel> Hi
09:02:55 <Yumeng_> Since I am totally new to watcher projects and i am not an experienced developer, my goal at this stage is to get familar with the work in community asap and start with some low-hanging fruits.
09:03:10 <acabot> are you working with jinquan & hanrong ?
09:03:24 <Yumeng_> yes ,we are in the same team
09:03:28 <acabot> ok great
09:03:43 <Yumeng_> that's all. thanks for your time
09:03:46 <dtardivel> hi
09:04:04 <acabot> Yumeng_ : can you connect to #openstack-watcher ?
09:04:20 <vincentfrancoise> Yumeng_: welcome :)
09:04:38 <acabot> you can ask any question or discuss bug assignments on this channel
09:04:39 <Yumeng_> yes sure
09:04:50 <hanrong> hi
09:04:57 <Yumeng_> thank you vincentfrancoise
09:05:13 <acabot> Yumeng_ : has a quick intro of our processes, please look at https://wiki.openstack.org/wiki/Watcher/Contributing
09:05:21 <alexchadin> welcome, Yumeng_!
09:05:26 <acabot> and welcome in Watcher team !
09:05:34 <hanrong> welcome
09:05:48 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#09.2F14.2F2016
09:06:01 <acabot> #topic Announcements
09:06:06 <Yumeng_> Thank you guys.
09:06:14 <acabot> #info PTL candidates should submit their candidacy before Sunday
09:06:22 <acabot> #link https://governance.openstack.org/election/
09:06:43 <acabot> FYI i'm the only candidate right now :-)
09:06:52 <acabot> so feel free to candidate
09:07:05 <acabot> #info Official Ocata schedule has been released
09:07:11 <acabot> #link https://releases.openstack.org/ocata/schedule.html
09:07:37 <acabot> all milestones have been registered in launchpad for watcher, watcher-dashboard & python-watcherclient
09:08:00 <acabot> #info project Kolla has packaged Watcher a few weeks ago
09:08:08 <acabot> #link https://review.openstack.org/#/c/337362/
09:08:23 <acabot> does anybody here use kolla to deploy openstack ?
09:08:43 <acabot> it would be great to get some feedback about watcher deployment using kolla
09:09:17 <acabot> petergurinov : Hi Peter
09:09:36 <acabot> #info We will have 1 fishbowl, 3 working sessions & 1 contributors meetup during the Design Summit in Barcelona
09:09:42 <acabot> #link http://lists.openstack.org/pipermail/openstack-dev/2016-September/103560.html
09:09:57 <acabot> who plans to be in Barcelona ?
09:10:05 <alexchadin> me
09:10:13 <petergurinov> hi!!
09:10:42 <dtardivel> me
09:10:49 <acabot> #info alexchadin, vincentfrancoise, dtardivel, jed56, vmahe, jwcroppe, sballe will attend the Barcelona summit
09:11:01 <acabot> anyone from ZTE planning to join ?
09:11:12 <alexchadin> hi petergurinov:)
09:11:19 <Yumeng_> hanrong will be there too
09:11:35 <acabot> #info hanrong will attend the Barcelona summit
09:11:57 <acabot> around 8 people for design summit sessions, looks great
09:12:01 <hanrong> acabot:Still not sure
09:12:09 <acabot> #undo
09:12:09 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x7f23bdbd2410>
09:12:26 <hanrong> acabot: I emailed to you about speaker
09:12:33 <acabot> #info hanrong is still waiting for confirmation for Barcelona summit
09:13:14 <hanrong> acabot: so I may be not attend the summit
09:13:17 <acabot> hanrong : yes thank you for your email, I will answer as soon as I have a bcom speaker ;-)
09:13:31 <acabot> hanrong : ok
09:13:36 <acabot> any other announcement ?
09:13:50 <acabot> is jinquan back to work ?
09:14:34 <acabot> #topic Review Action Items
09:14:39 <acabot> Watcher specs
09:14:45 <acabot> Resize instance base on workload should be retargeted to Ocata
09:14:52 <acabot> #link https://review.openstack.org/#/c/359690/
09:15:02 <acabot> does anyone from ZTE wants to do it ?
09:15:44 <hanrong> acabot: I think jinquan will work next work
09:15:52 <acabot> next week ?
09:15:58 <hanrong> yes
09:16:11 <acabot> hanrong : can you just retarget the spec ?
09:16:23 <acabot> I'm asking for it for 3 weeks now
09:16:39 <hanrong> acabot: ok, I can retarget it.
09:16:43 <acabot> thx
09:16:49 <hanrong> :)
09:16:58 <acabot> #action hanrong retarget https://review.openstack.org/#/c/359690/ to Ocata
09:17:06 <acabot> Limit concurrent actions invoked by Watcher needs reviews
09:17:12 <acabot> #link https://review.openstack.org/#/c/348049/
09:17:21 <acabot> alexchadin : I saw that you added PS
09:17:35 <acabot> alexchadin : can we start reviewing it ?
09:17:45 <alexchadin> acabot: I think so
09:18:11 <acabot> #action acabot hvprash sballe_ review https://review.openstack.org/#/c/348049/
09:18:23 <acabot> automatic triggering audit needs a new PS and we should probably limit the scope
09:18:33 <acabot> #link https://review.openstack.org/#/c/342473/
09:18:41 <acabot> diga doesn't seems to be there
09:19:15 <acabot> #action diga join openstack-watcher channel to discuss the scope of https://review.openstack.org/#/c/342473/
09:19:23 <acabot> Watcher
09:19:35 <acabot> rc-1 release is due tomorrow
09:19:51 <acabot> so we need to merge a couple of bug fixes and test improvements
09:20:20 <acabot> #link https://review.openstack.org/#/c/364464/
09:20:28 <acabot> #link https://review.openstack.org/#/c/366032/
09:20:35 <acabot> #link https://review.openstack.org/#/c/363443/
09:20:42 <acabot> #link https://review.openstack.org/#/c/364149/
09:20:55 <acabot> #link https://review.openstack.org/#/c/357938/
09:21:02 <acabot> #link https://review.openstack.org/#/c/366219/
09:21:10 <acabot> #link https://review.openstack.org/#/c/367968/
09:21:17 <acabot> #link https://review.openstack.org/#/c/366120/
09:21:23 <acabot> #link https://review.openstack.org/#/c/368913/
09:21:23 <dtardivel> acabot: I will work on them this afternoon. I hope the gate will be quick enough ...
09:21:43 <acabot> #action dtardivel review all these reviews
09:21:50 <alexchadin> will review some of them too
09:22:07 <acabot> #action alexchadin review all these reviews
09:22:22 <acabot> alexchadin : we will need your help on this https://review.openstack.org/#/c/366120/ specifically
09:22:33 <acabot> because its a big one
09:22:44 <alexchadin> I got request from vincentfrancoise about this, will see
09:23:02 <acabot> alexchadin : if you can do it first, its great
09:23:18 <vincentfrancoise> alexchadin: thanks :)
09:23:24 <acabot> we can also merge rally support for rc-1
09:23:30 <acabot> #link https://review.openstack.org/#/c/333371/
09:24:08 <acabot> #info I will send the last commit to the release team for rc-1 in 24h
09:24:11 <alexchadin> I really do want to test this gate test asap:)
09:25:06 <acabot> Yumeng_ : most of these reviews will be merged so please add a +1 when you review them before they get merged
09:25:51 <acabot> #topic Blueprint/Bug Review and Discussion
09:26:16 <acabot> we need to work on new specs for Ocata BPs
09:26:29 <acabot> #info we need a spec for Notifications in Watcher
09:26:35 <acabot> #link https://blueprints.launchpad.net/watcher/+spec/watcher-notifications-ovo
09:26:56 <acabot> vincentfrancoise : as you already started working on this, could you initiate a spec ?
09:27:47 <acabot> #info we need a spec for Define grammar for workload characterization
09:27:55 <acabot> #link https://blueprints.launchpad.net/watcher/+spec/workload-characterization-grammar
09:28:07 <acabot> #action hvprash initiate a spec for https://blueprints.launchpad.net/watcher/+spec/workload-characterization-grammar
09:28:11 <Yumeng_> ok. I will do that . sorry. got lost for a few seconds due to network problem
09:28:23 <vincentfrancoise> vincentfrancoise: it's in my todo list
09:28:28 <vincentfrancoise> acabot: *
09:28:50 <acabot> #action Yumeng_ review all candidates for rc-1
09:29:26 <acabot> #action vincentfrancoise initiate a spec for https://blueprints.launchpad.net/watcher/+spec/watcher-notifications-ovo
09:29:39 <acabot> any open bug that needs discussion ?
09:30:52 <acabot> feel free to submit new bugs in https://bugs.launchpad.net/watcher
09:31:40 <vincentfrancoise> Yumeng_: BTW if you need some explanations on bugs that you want to work on, please do ask because their description are sometimes very short
09:31:44 <acabot> petergurinov : do you have a status for https://blueprints.launchpad.net/python-watcherclient/+spec/tempest-cli-test ?
09:32:40 <acabot> #topic Open discussions
09:33:27 <acabot> #info it's now possible to display a contributor report from stackalytics
09:33:39 <acabot> #link http://stackalytics.com/report/contribution/watcher/180
09:33:52 <hanrong> vincentfrancoise: Yumeng_ is lost for network problem. Her last answer is for "most of these reviews will be merged so please add a +1 when you review them before they get merged"
09:34:02 <acabot> the star next to the contributor's name means core contributor
09:34:51 <acabot> so it gives you an idea of the amount of contributions needed to become a core contrib
09:35:26 <acabot> #info we need to review priorities for Ocata because all BPs are medium or low
09:35:35 <acabot> #link https://blueprints.launchpad.net/watcher/ocata
09:35:37 <vincentfrancoise> hanrong: fair enough :)
09:36:13 <acabot> #action acabot suggest priorities for Ocata BPs before next meeting
09:36:27 <petergurinov> acabot: I hope to finish till the end of the week
09:36:53 <vincentfrancoise> petergurinov: nice :)
09:37:15 <acabot> #action petergurinov submit your code for review for https://blueprints.launchpad.net/python-watcherclient/+spec/tempest-cli-test
09:37:46 <acabot> as we are in the "europe-russia-china" time meeting
09:38:04 <acabot> and most of you will not be at the Barcelona summit
09:38:42 <acabot> I'd like to know how do you plan to suggest Watcher orientations in the future
09:39:18 <acabot> is submitting blueprints in launchpad enough ?
09:40:22 <acabot> I'd really like to understand your priorities in Watcher to be able to set them high during summit and mid-cycles...
09:41:54 <acabot> anyone here ?
09:42:09 <alexchadin> I think submitting in launchpad + discussions on openstack-watcher channel is pretty enough to tell about our visions of Watcher in future
09:42:15 * acabot thinking that he is asking tricky questions...
09:43:20 <acabot> alexchadin : well, I think on your side, you are very familiar with the process now ;-)
09:43:52 <alexchadin> acabot: that's right:)
09:44:42 <acabot> I'm just concerned that any company should be able to join Watcher and influence the priorities without having to be at each physical meeting
09:45:16 <acabot> most of the time, we order BPs priorities during mid-cycle and summits
09:45:53 <acabot> and maybe we should do it somewhere else to ensure that anybody can give his word
09:46:11 <acabot> any toughts ?
09:46:24 <acabot> s/toughts/thoughts
09:46:40 <hanrong> bp
09:47:31 <acabot> hanrong : ?
09:48:05 * acabot will close the meeting soon :-)
09:48:13 <hanrong> I think we can discuss bp priorities with irc
09:48:19 <hanrong> and summit
09:48:33 <hanrong> mid-cycles, I am not attended
09:49:21 <hanrong> so  I don't know if there is anybody from zte to attend mid-cycles
09:49:35 <acabot> hanrong : IMHO, today, you have to be at least at one of the event (summit or mid-cycle) per year to influence priorities
09:50:15 <hanrong> I would prefer summit
09:50:22 <acabot> hanrong : I think its really important that someone from ZTE comes to the summit
09:50:33 <acabot> hanrong : sure
09:50:57 <acabot> any other discussion to open ?
09:51:45 <acabot> so we can end the meeting for today, thank you for your time
09:51:49 <acabot> and see u next week
09:52:00 <acabot> #endmeeting