14:01:39 <dtardivel> #startmeeting watcher
14:01:39 <openstack> Meeting started Wed Nov 30 14:01:39 2016 UTC and is due to finish in 60 minutes.  The chair is dtardivel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:42 <openstack> The meeting name has been set to 'watcher'
14:01:59 <diga> o/
14:02:19 <licanwei> hi
14:02:30 <pshedimb> hi
14:02:34 <brunograz> o/
14:02:37 <dtardivel> agenda for today: https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#11.2F30.2F2016
14:03:23 <dtardivel> #topic Announcements
14:03:54 <dtardivel> acabot is currently introducing Watcher at Cloud Expo Europe, Paris
14:04:04 <seanmurphy> cool!
14:04:08 <sballe_> +2
14:04:12 <dtardivel> so, he asked me to lead this meeting today ;)
14:04:12 <hvprash_> nice !
14:04:25 <dtardivel> #link http://www.cloudexpoeurope.fr/english/about-cloud-expo-europe-paris
14:05:15 <dtardivel> This is meanly a summit for french cloud experts
14:05:39 <sballe_> you mean 'mainly" right ;-)
14:05:42 <dtardivel> He is on stage now for 30mn :)
14:05:50 <sballe_> very cool!
14:05:51 <dtardivel> mainly yep
14:06:29 <dtardivel> another point: If you have a look on github project, we have now a flag 'project/official' on README page
14:06:47 <sballe_> very cool!
14:06:48 <dtardivel> #link: https://github.com/openstack/python-watcherclient#team-and-repository-tags
14:07:16 <jwcroppe> nice, that's great to see
14:07:34 <dtardivel> sballe_: can you merge this patch for watcher-specs project please #link https://review.openstack.org/#/c/402979/
14:07:37 <sballe_> hey jwcroppe! your are back! great to see you again
14:07:42 <jwcroppe> tangential question - is reviwew.openstack.org slow for anyone today?
14:08:11 <dtardivel> jwcroppe: it is ok from France
14:08:46 <sballe_> dtardivel: done
14:08:47 <jwcroppe> sballe_: hey there - yes, thanks - finally all moved and things settled down a bit.  I've been trying to get the new house all organized in my 'spare time'  :)
14:09:48 <dtardivel> Other announcements from you side ?
14:10:19 <sballe_> no not from me
14:10:46 <jwcroppe> will review https://review.openstack.org/#/c/402979/ after the meeting
14:11:23 <dtardivel> jwcroppe: sballe has just set W+1 :)
14:11:35 <dtardivel> #topic Review Action Items
14:11:42 <dtardivel> Watcher specs
14:11:45 <sballe_> I figured it looked straight forward
14:12:00 <jwcroppe> yep, looked good
14:12:01 <dtardivel> Define grammar for workload characterization need a new PS
14:12:09 <dtardivel> #link https://review.openstack.org/#/c/377100/
14:12:12 <hvprash_> yes dtardivel, i will add a new PS
14:12:15 <hvprash_> seanmurphy, thanks for the review and comments. I will take a look on your comments and a new PS.
14:12:32 <seanmurphy> hvprash_: np - hope it was useful
14:12:38 <sballe_> hvprash_: we can work on it together I have thougth about some of the comments
14:12:48 <sballe_> seanmurphy: it was
14:13:05 <hvprash_> frankly, i haven't had a chance to look into your comments. Its been a big week for us due to thanks giving retail etc..
14:13:21 <sballe_> 100% understand...
14:13:22 <hvprash_> i am going to spend sometime this week
14:13:28 <sballe_> I am glad you guys are doing well
14:13:37 <hvprash_> thanks sballe_ :)
14:14:03 <dtardivel> #action hvprash_, seanmurphy complete  https://review.openstack.org/#/c/377100/
14:14:14 <dtardivel> Define when an action plan is stale/invalid needs reviews
14:14:20 <dtardivel> #link https://review.openstack.org/#/c/386293/
14:15:14 <dtardivel> sballe_: or jwcroppe : as core reviewer, could you have a look on this one ?
14:15:24 <sballe_> yes I will do it
14:15:32 <hvprash_> will do
14:15:35 <jwcroppe> yep
14:15:43 <dtardivel> thx
14:16:00 <dtardivel> #action sballe_, jwcroppe, hvprash_ review https://review.openstack.org/#/c/386293/
14:16:15 <dtardivel> Audit tag in VM Metadata needs reviews as well
14:16:22 <dtardivel> #link https://review.openstack.org/#/c/391374/
14:16:32 <sballe_> yes I thought I had reviwed it but I guess not
14:16:44 <sballe_> it is my plan to look at it
14:16:49 <hvprash_> yes, thanks to vincent for thoise comments.
14:16:58 <hvprash_> I need to review that
14:17:29 <dtardivel> #action sballe_ dtardivel will review https://review.openstack.org/#/c/391374/
14:17:46 <dtardivel> Add improvements to the planner and workflow mechanisms needs reviews as well :)
14:17:56 <dtardivel> #link https://review.openstack.org/#/c/385871/
14:18:48 <dtardivel> alexchain is not online.
14:19:37 <dtardivel> I think we have now a complete description of what we should implement. Core reviews is now required :)
14:20:11 <dtardivel> #action acabot will review https://review.openstack.org/#/c/385871/
14:20:19 <sballe_> ok. I would like some +1s here from non core members as well
14:20:38 <dtardivel> sballe_: ok
14:20:57 <dtardivel> #action dtardivel will review last update on https://review.openstack.org/#/c/385871/
14:20:58 <sballe_> this is an important specs so I would like some more eyes on it and then we +2 it
14:21:33 <licanwei> +1
14:21:53 <dtardivel> licanwei: do you want review it ?
14:21:59 <licanwei> yes
14:22:10 <dtardivel> licanwei: thx
14:22:22 <dtardivel> #action licanwei will review https://review.openstack.org/#/c/385871/
14:22:32 <dtardivel> Support Description For Dynamic Action needs reviews
14:22:41 <dtardivel> #link https://review.openstack.org/#/c/401111/
14:23:19 <dtardivel> I reviewed it this morning. We can ask to hanrong a new update first
14:23:34 <sballe_> yes just saw that
14:24:01 <dtardivel> #action hanrong will update https://review.openstack.org/#/c/401111/
14:24:59 <dtardivel> Other specs in your mind ?
14:25:24 <sballe_> just as an FYI I will start working on: https://review.openstack.org/#/c/398162/
14:25:35 <sballe_> pshedimb:  will be co-author as well
14:26:24 <dtardivel> sballe_: ok. is it something you would like for ocata ?
14:26:39 <sballe_> yes I believe we have it for ocata-3
14:26:48 <dtardivel> sballe_: ok
14:27:15 <dtardivel> Let's review actions for watcher project
14:27:27 <dtardivel> centralise-config-opts needs reviews
14:27:36 <dtardivel> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/centralise-config-opts
14:27:54 <pshedimb> i'm working on your comments dtardivel
14:28:15 <sballe_> pshedimb: did you have questions on the dbmanage one?
14:28:28 <pshedimb> Yeah I did
14:28:33 <dtardivel> pshedimb: yes I reviewed one changeset this morning.
14:29:03 <sballe_> pshedimb:  did you get them answered?
14:29:11 <pshedimb> Not yet
14:29:24 <pshedimb> Can I ask it here?
14:29:34 <sballe_> sure if it is quick
14:29:36 <dtardivel> pshedimb: please ask on openstack-watcher, just after the meeting
14:29:45 <sballe_> ok :-)
14:29:54 <dtardivel> pshedimb: you have just 1mn :)
14:30:00 <pshedimb> watcher/cmd/dbmanage.py
14:30:10 <pshedimb> which opt group does this come under?
14:30:43 <dtardivel> pshedimb: ok on openstack-watcher later :) I have not the answer
14:30:44 <pshedimb> Default?
14:30:56 <pshedimb> okay.
14:31:07 <dtardivel> pshedimb: please ring me later
14:31:27 <dtardivel> check the state of action plan needs discussions
14:31:35 <dtardivel> #link https://review.openstack.org/#/c/391383/
14:31:58 <sballe_> dtardivel: so pshedimb can chat with you rigth after the meeting?
14:32:05 <dtardivel> licanwei: What is the status ?
14:32:08 <dtardivel> sballe_: yep
14:32:14 <pshedimb> okay dtardivel
14:33:07 <licanwei> dtardivel: I'll add a new PS
14:33:51 <dtardivel> #action licanwei will add a new PS on https://review.openstack.org/#/c/391383/
14:34:19 <dtardivel> Add auto_trigger support to watcher needs reviews ?
14:34:29 <dtardivel> #link https://review.openstack.org/#/c/403718/
14:35:25 <dtardivel> alexchain is not online. This changeset is tagged [WIP]. Let move to the next ...
14:35:37 <dtardivel> Specific exception for stale cluster state was added needs reviews
14:35:45 <dtardivel> #link https://review.openstack.org/#/c/399202/
14:36:40 <dtardivel> no update ?
14:37:25 <dtardivel> no update ... :) I will ask to acabot to contact Anton to get news
14:37:39 <hvprash_> dtardivel, i will try to find from anton
14:37:49 <hvprash_> he was working on it
14:38:00 <dtardivel> hvprash_: what is the Anton's nickname ?
14:38:21 <hvprash_> eil397
14:38:38 <dtardivel> hvprash_: yes of course, :)
14:38:49 <hvprash_> sure :)
14:39:09 <dtardivel> eil397: ^^^^
14:39:13 <dtardivel> trying ....
14:39:59 <dtardivel> Add auto_trigger in audit API needs a status
14:40:08 <dtardivel> #link https://review.openstack.org/#/c/398044/
14:40:17 <dtardivel> diga: any update ?
14:41:16 <dtardivel> #action diga please update your changeset to fix failure jobs
14:41:45 <dtardivel> Fix rally gate test has been merged this morning
14:41:56 <dtardivel> #link https://review.openstack.org/#/c/398180/
14:43:07 <dtardivel> Since last week, I merged several little patches improving our source code. Thx a lot everybody :)
14:43:36 <dtardivel> let's move to actions on watcherclient project
14:43:43 <dtardivel> Add auto_trigger support needs reviews ?
14:43:50 <dtardivel> #link https://review.openstack.org/#/c/403716/
14:44:11 <dtardivel> who want to review it ?
14:44:30 <dtardivel> oups sorry it is tagged [WIP] as well
14:45:07 <dtardivel> #action alexchadin please update status on https://review.openstack.org/#/c/403716/
14:45:32 <dtardivel> Add functional tests to watcherclient needs reviews
14:45:42 <dtardivel> #link https://review.openstack.org/#/c/389181/
14:46:32 <dtardivel> I asked to alexchain a new section in README doc. But more reviewer is welcome on this changeset
14:48:12 <dtardivel> nobody want to know how Tempest works for cli ? :)
14:48:20 <sballe_> lol
14:49:11 <dtardivel> changes to make consistent with other openstack component needs reviews
14:49:19 <dtardivel> #link https://review.openstack.org/#/c/403434/
14:49:55 <dtardivel> ok I reviewed it this morning. I waiting for an update from Lucky
14:50:41 <dtardivel> 10 mn left .... quick quick quick
14:50:43 <dtardivel> #topic Blueprint/Bug Review and Discussion
14:51:03 <dtardivel> sballe_: your strategy documentation has been merged
14:51:18 <sballe_> yes thank you
14:51:27 <sballe_> thx for all the reviews, comments, and +1s
14:51:34 <sballe_> I will work on the next two docs now
14:52:00 <sballe_> dtardivel: and off course your +2
14:52:04 <dtardivel> sballe_: what about nishi's strategy doc (airflow) ?
14:52:19 <sballe_> I will do all the intel docs
14:52:30 <dtardivel> sballe_: cool
14:52:55 <dtardivel> Any comments on BP ?
14:52:57 <sballe_> I just wanted this one completed first so I didn;t have 3 in flux with the same comments
14:54:01 <dtardivel> #topic Open discussions
14:54:16 <sballe_> I would like to understand if I have to pay $100 to attend the cross project meet up in Feb.
14:54:29 <sballe_> I tried to register abd evenbrite wanted $100
14:54:44 <sballe_> acabot: was suppose to ask ttx but I haven't heard back from him
14:54:53 <dtardivel> sballe_: I really don't know
14:55:08 <sballe_> ok has anybody signed up for the meetup?
14:55:08 <dtardivel> sballe_: I will discuss with acabot tomorrow if you want
14:55:14 <sballe_> yes please
14:56:04 <dtardivel> #action dtardivel query acabot about $100 tax from eventbrite for cross project meet up
14:56:12 <sballe_> also atuly is trying to figure out who to talk to to get a letter for his visa
14:56:32 <hvprash_> sballe_ do you have the eventbrite link ?
14:56:36 <sballe_> i refered himto acabot
14:56:46 <sballe_> hvprash_: yes one sec
14:57:30 <sballe_> https://www.eventbrite.com/e/project-teams-gathering-tickets-27549298694#tickets
14:57:37 <hvprash_> thanks
14:57:46 <sballe_> http://www.openstack.org/ptg
14:58:22 <dtardivel> sballe_: thx
14:58:45 <dtardivel> Other points (in 2mn)
14:59:27 <sballe_> nope I am done :-)
14:59:50 <dtardivel> no, so have a good day, afternoon, night everyone
15:00:16 <dtardivel> please see you again next week
15:00:17 <dtardivel> #endmeeting