09:01:11 <acabot_> #startmeeting watcher
09:01:11 <alexchadin> O/
09:01:12 <openstack> Meeting started Wed Dec 7 09:01:11 2016 UTC and is due to finish in 60 minutes. The chair is acabot_. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:01:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:01:15 <openstack> The meeting name has been set to 'watcher'
09:01:27 <alexchadin> Hello:)
09:01:35 <hidekazu> hello
09:01:46 <brunograz> o/
09:01:50 <acabot_> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#12.2F07.2F2016
09:02:12 <diga> o/
09:02:31 <acabot_> lets start
09:02:40 <acabot_> #topic Announcements
09:03:03 <acabot_> I dont have any announcement today :-)
09:03:09 <acabot_> do you have some ?
09:03:20 <alexchadin> nope
09:03:35 <acabot_> ok lets go to action reviews
09:03:43 <acabot_> #topic Review Action Items
09:03:50 <acabot_> Watcher specs
09:03:58 <acabot_> Define grammar for workload characterization needs a new PS after answering comments
09:04:07 <acabot_> #link https://review.openstack.org/#/c/377100/
09:04:22 <acabot_> #action hvprash add a new PS for https://review.openstack.org/#/c/377100/
09:04:29 <acabot_> Define when an action plan is stale/invalid needs final reviews from core
09:04:38 <acabot_> #link https://review.openstack.org/#/c/386293/
09:05:11 <acabot_> I'd like to have more reviewers on this one
09:05:15 <acabot_> before +2
09:05:29 <jed56> Hi
09:05:33 <acabot_> hop sorry it has been merged :-)
09:05:42 <acabot_> jwcroppe W+1 it
09:05:54 <Yumeng> hi
09:06:07 <alexchadin> hi
09:06:11 <hanrong> hi
09:06:29 <acabot_> is licanwei here ?
09:06:33 <alexchadin> no
09:06:35 <licanwei> yes
09:06:46 <licanwei> :)
09:06:56 <acabot_> licanwei : your spec has been merged
09:07:04 <alexchadin> oh, sorry:)
09:07:04 <licanwei> thank you all
09:07:05 <acabot_> you can continue implementing
09:07:15 <licanwei> ok
09:07:17 <acabot_> Add improvements to the planner and workflow mechanisms needs final reviews from core
09:07:27 <acabot_> #link https://review.openstack.org/#/c/385871/
09:07:59 <acabot_> I'd like to have more reviewers on this one as well
09:08:25 <acabot_> who wants to review it ? I'd like to have it merge by end of week
09:08:37 <acabot_> as alexchadin alreday started implementing it
09:08:39 <diga> will look at this
09:08:48 <licanwei> +1
09:08:50 <acabot_> #action diga review https://review.openstack.org/#/c/385871/
09:08:52 <hidekazu> i will once again
09:09:00 <diga> +1
09:09:05 <acabot_> #action licanwei hidekazu review https://review.openstack.org/#/c/385871/
09:09:11 <acabot_> thx you guys
09:09:25 <acabot_> Audit tag in VM Metadata needs reviews
09:09:35 <acabot_> #link https://review.openstack.org/#/c/391374/
09:09:54 <Yumeng> +1
09:10:06 <acabot_> #action Yumeng review https://review.openstack.org/#/c/391374/
09:10:22 <acabot_> #action acabot review https://review.openstack.org/#/c/391374/
09:10:23 <alexchadin> +1
09:10:29 <alexchadin> will review it
09:10:35 <acabot_> #action acabot_ alexchadin review https://review.openstack.org/#/c/391374/
09:10:44 <acabot_> Support Description For Dynamic Action needs work items
09:10:55 <acabot_> #link https://review.openstack.org/#/c/401111/
09:11:06 <acabot_> hanrong : are you working on work items ?
09:11:16 <hanrong> yes
09:11:24 <acabot_> great thx
09:11:35 <acabot_> #action hanrong complete work items for https://review.openstack.org/#/c/401111/
09:11:42 <acabot_> Add specs for cache occupancy strategy needs reviews
09:11:50 <acabot_> #link https://review.openstack.org/#/c/398162/
09:11:53 <pshedimb> I'm still working on it
09:12:11 <pshedimb> Susanne asked me to add GUI compenent to it
09:12:15 <acabot_> pshedimb : ok I thaught it was ready to be reviewed
09:12:40 <pshedimb> acabot_, This is a last minute thing that came up.
09:12:43 <acabot_> pshedimb : I'm not sure GUI must be part of the spec
09:13:13 <acabot_> pshedimb : maybe it should be done as a BP in watcher-dashboard ?
09:13:32 <pshedimb> acabot_, oh ok. susanne asked me to add it. In that case it is open for review
09:13:54 <acabot_> pshedimb : ok thx
09:14:00 <acabot_> who wants to review ?
09:14:08 <hidekazu> i want
09:14:14 <licanwei> +1
09:14:23 <acabot_> #action acabot_ licanwei review https://review.openstack.org/#/c/398162/
09:14:47 <acabot_> moving to Watcher
09:14:53 <acabot_> centralise-config-opts needs reviews & jenkins fixes
09:15:11 <pshedimb> yes
09:15:22 <acabot_> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/centralise-config-opts
09:15:29 <acabot_> pshedimb : anything wrong with jenkins ?
09:15:35 <pshedimb> yeah.
09:15:51 <pshedimb> but it is fixed now. few inutes ago, dtardivel merged code t fix it
09:16:01 <pshedimb> minutes*
09:16:20 <acabot_> ok great
09:16:36 <acabot_> who wants to review config opts ?
09:17:30 <pshedimb> common someone :_
09:17:32 <pshedimb> :)
09:17:45 <hanrong> +1
09:17:49 <acabot_> pshedimb : I think you will have to wait that vincentfrancoise come back from holidays ;-)
09:18:07 <pshedimb> acabot_, hahaa
09:18:10 <acabot_> #action hanrong review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/centralise-config-opts
09:18:14 <pshedimb> hanrong, yayy!
09:18:18 <atuly> hi
09:18:18 <acabot_> check the state of action plan needs reviews
09:18:30 <acabot_> #link https://review.openstack.org/#/c/391383/
09:19:13 <acabot_> I haven't looked at this one in detail, is there still open issues ?
09:19:21 <acabot_> in comments
09:19:30 <acabot_> licanwei alexchadin : ?
09:19:43 <acabot_> brunograz
09:19:47 <alexchadin> acabot_: I will recheck
09:19:52 <alexchadin> it
09:20:00 <acabot_> ok
09:20:01 <brunograz> Need to review it again as well
09:20:18 <acabot_> #action brunograz alexchadin review https://review.openstack.org/#/c/391383/
09:20:29 <acabot_> Add auto_trigger support to watcher should be merged
09:20:37 <acabot_> #link https://review.openstack.org/#/c/403718/
09:21:12 <acabot_> #action dtardivel jed56 merge https://review.openstack.org/#/c/403718/
09:21:25 <acabot_> Specific exception for stale cluster state was added needs reviews
09:21:34 <acabot_> #link https://review.openstack.org/#/c/399202/
09:21:49 <diga> acabot_: alexchadin : why we dont write auto trigger logic in seperate file
09:21:51 <jed56> Okay I will take a look today
09:21:59 <diga> with inserting into the base
09:22:34 <acabot_> diga : ok lets discuss https://review.openstack.org/#/c/398044/
09:22:42 <diga> ok
09:22:52 <acabot_> is this patch doing the same thing that https://review.openstack.org/#/c/403718/ ?
09:23:15 <diga> acabot_: https://review.openstack.org/#/c/407291/
09:24:30 <diga> acabot_: and more thing, I dont see any migration files added in the alembic under the versions
09:24:31 <acabot_> alexchadin diga : I'm sorry but its unclear to me what you are doing on automatic-triggering-audit
09:24:34 <diga> acabot_: will add that
09:25:05 <alexchadin> acabot_: It will launch action plan just after creating of audit
09:25:21 <alexchadin> acabot_: both for ONESHOT and CONTINUOUS types
09:25:32 <diga> acabot_: when we found auto_trigger in api to true, it will launch the action plan
09:25:35 <diga> alexchadin: +1
09:25:51 <acabot_> yes I know but I dont understand why we have multiple patches like https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/automatic-triggering-audit
09:26:10 <acabot_> subjects look the same
09:26:18 <alexchadin> yeap
09:26:18 <diga> acabot_: one has submitted by alexchadin & one from my side
09:26:38 <acabot_> I can see that but does it implement the same feature ?
09:26:49 <alexchadin> It does
09:27:03 <alexchadin> I've uploaded it on 28.11
09:27:14 <alexchadin> diga uploaded his version on 05.12
09:27:14 <acabot_> ok and diga's version does not pass the gate
09:27:29 <acabot_> so I think diga you should abandon your change
09:27:44 <diga> acabot_: alexchadin : yeah
09:27:48 <acabot_> and we will merge alexchadin code as it has been reviewed and checked by jenkins
09:28:00 <acabot_> diga : sorry for that
09:28:04 <diga> :( okay
09:28:17 <acabot_> #action diga abandon https://review.openstack.org/#/c/407291/
09:28:32 <acabot_> Documentation for Workload Balance Migration Strategy needs reviews
09:28:43 <acabot_> #link https://review.openstack.org/#/c/404972/
09:29:16 <diga> acabot_: should I start work on parallel execution of action plan for audit
09:29:30 <acabot_> diga : no no
09:29:42 <diga> ok
09:29:48 <acabot_> let me look at other open BPs later
09:29:56 <diga> ok
09:30:02 <acabot_> who wants to review doc strategy ?
09:30:11 <hidekazu> +1
09:30:14 <licanwei> +1
09:30:16 <Yumeng> i want to review
09:30:28 <acabot_> #action acabot_ hidekazu licanwei Yumang review https://review.openstack.org/#/c/404972/
09:30:35 <acabot_> thx
09:30:46 <acabot_> Watcher CLI
09:30:52 <acabot_> Add auto_trigger support should be merged
09:31:00 <acabot_> #link https://review.openstack.org/#/c/403716/
09:31:09 <acabot_> #action dtardivel jed56 merge https://review.openstack.org/#/c/403716/
09:31:22 <acabot_> Add functional tests to watcherclient needs reviews
09:31:30 <acabot_> #link https://review.openstack.org/#/c/389181/
09:31:54 <Yumeng> +1
09:31:58 <acabot_> alexchadin : I think you will also have to wait for vincentfrancoise ;-)
09:32:05 <alexchadin> dtardivel: I've added documentation of how to start tempest
09:32:07 <acabot_> thank you Yumeng !
09:32:27 <Yumeng> :) always welcome
09:32:29 <acabot_> #action Yumeng review https://review.openstack.org/#/c/389181/
09:32:42 <alexchadin> Yumeng: thanks!
09:32:44 <atuly> +1
09:33:02 <acabot_> #action atuly review https://review.openstack.org/#/c/389181/
09:33:07 <alexchadin> atuly: Yumeng: thank you, guys:)
09:33:08 <Yumeng> alexchadin: :)
09:33:16 <acabot_> so many reviewers today ! great meeting :-D
09:33:21 <atuly> :)
09:33:25 <acabot_> changes to make consistent with other openstack component needs reviews
09:33:32 <acabot_> #link https://review.openstack.org/#/c/403434/
09:34:26 <acabot_> it doesn't pass jenkins
09:34:28 <atuly> this need some clarification
09:34:31 <acabot_> forget it
09:34:37 <acabot_> atuly : yes
09:35:09 <acabot_> #topic Blueprint/Bug Review and Discussion
09:35:21 <acabot_> #info Our current target is ocata-2 due next week
09:35:29 <acabot_> #link https://launchpad.net/watcher/+milestone/ocata-2
09:36:31 <acabot_> diga : could you start writing a spec for https://blueprints.launchpad.net/watcher/+spec/license-cost-aware-vm-placement-strategy ?
09:36:42 <diga> acabot_: sure
09:36:46 <diga> :) nice stuff
09:37:22 <acabot_> #action diga start writing a spec for https://blueprints.launchpad.net/watcher/+spec/license-cost-aware-vm-placement-strategy
09:37:36 <diga> +1
09:37:39 <acabot_> hanrong : could you share the link for the BP you updated ?
09:39:13 <acabot_> #link https://blueprints.launchpad.net/watcher/+spec/cluster-energy-saving
09:39:35 <acabot_> hanrong updated the description to fit ZTE strategy
09:39:54 <acabot_> we decided to superseed this BP a couple of months ago
09:40:42 <acabot_> I would suggest that everyone had a quick look at it before next meeting
09:41:19 <acabot_> to remove the "superseded" state on launchpad
09:41:36 <acabot_> I should also check dependencies
09:43:04 <acabot_> alexchadin : do you think we can have https://blueprints.launchpad.net/watcher/+spec/planner-storage-action-plan merged before ocata-2 ?
09:43:12 <acabot_> or its too short ?
09:43:38 <alexchadin> acabot_: we can merge planner improvements before ocata-2
09:43:52 <alexchadin> acabot_: but applier changes will not be merged
09:43:59 <acabot_> ok
09:44:29 <alexchadin> acabot_: it passes almost all tests:)
09:44:31 <acabot_> alexchadin : do you want to create a dedicated BP for applier changes ?
09:44:47 <acabot_> alexchadin : so we can have the planner BP merged
09:45:01 <alexchadin> acabot_: I will create spec, since existed BP describes planner and applier changes
09:45:55 <alexchadin> acabot_: could two specs describe one BP?
09:46:15 <acabot_> alexchadin : if you create a new spec for applier, please update existing BP and create a new one
09:46:19 <alexchadin> acabot_: or you want to close this BP before ocata-2?
09:46:32 <acabot_> alexchadin : it would be easier for me
09:46:33 <alexchadin> acabot_: ok, will do
09:46:48 <alexchadin> We will have new BP and spec to it
09:46:55 <alexchadin> about applier changes
09:47:09 <acabot_> #action alexchadin split bp https://blueprints.launchpad.net/watcher/+spec/planner-storage-action-plan in 2 BP (planner & applier)
09:47:39 <acabot_> #action hvprash give acabot_ a status about assigned BPs for ocata-2
09:48:20 <acabot_> pshedimb : could we merge all code related to https://blueprints.launchpad.net/watcher/+spec/centralise-config-opts for ocata-2 ?
09:48:46 <acabot_> ocata-2 is due next week
09:49:58 <acabot_> #topic Open discussions
09:50:06 <diga> acabot_: can we add migration for each field we add in db table ?
09:50:36 <acabot_> diga : we have decided to handle db migration starting at 1.0 version
09:50:42 <pshedimb> acabot_, yes
09:50:48 <diga> ok
09:50:50 <pshedimb> It is all done.
09:50:53 <acabot_> 1.0 should be delivered at the end of ocata cycle
09:51:17 <diga> ok
09:51:22 <acabot_> pshedimb : do you mean DB migration is already supported ?
09:51:40 <diga> acabot_: alexchadin : I am still thinking of its a better way to seperate out the logic of auto trigger in seperate file
09:51:51 <diga> let me know you thoughts on it
09:52:08 <pshedimb> sorry, I meant we could merge all code related to centralizing config options for ocata-2
09:52:27 <acabot_> pshedimb : ok thx ;-)
09:52:31 <pshedimb> :)
09:52:36 <alexchadin> diga: auto_triggering is not another audit type
09:52:51 <alexchadin> diga: we have separated oneshot and continuous types
09:53:08 <alexchadin> both of them should support auto_triggering
09:53:36 <alexchadin> that's why I've placed this function in base class
09:54:20 <diga> alexchadin: but adding something in base file
09:54:36 <diga> alexchadin: let it be there
09:55:15 <acabot_> ok any other discussion to open ?
09:55:23 <diga> alexchadin: actually we don;t usually add something in base file that's the reason I raised this question here
09:55:43 <diga> alexchadin: fine, if everyone is ok with it
09:56:34 <alexchadin> diga: I've added function, that will take effect to all child classes
09:56:46 <diga> alexchadin: ok
09:56:55 <alexchadin> diga: it seems ok to me:)
09:57:26 <diga> ok
09:57:36 <acabot_> ok thank you all
09:57:42 <acabot_> have a good day/night
09:57:49 <acabot_> bye
09:57:52 <alexchadin> bye
09:57:56 <hidekazu> thx
09:57:57 <licanwei> bye
09:57:59 <acabot_> #endmeeting