14:00:25 <acabot> #startmeeting watcher
14:00:25 <openstack> Meeting started Wed Jan 11 14:00:25 2017 UTC and is due to finish in 60 minutes. The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:28 <openstack> The meeting name has been set to 'watcher'
14:00:30 <acabot> o/
14:00:34 <sballe_> o/
14:00:44 <vincentfrancoise> o/
14:01:18 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#01.2F11.2F2016
14:01:55 <dtardivel> hi
14:02:14 <acabot> sballe_ : anyone else from intel ?
14:02:43 <sballe_> I was hoping so. chrispencer should be here
14:02:48 <acabot> courtesy ping hvprash hvprash_
14:02:52 <sballe_> Pru is ion vacation
14:03:06 <sballe_> Thijs should be here too
14:03:30 <acabot> Yumeng__ just joined
14:03:51 <acabot> ok lets start, I will go fast to keep time for open discussions
14:04:01 <acabot> #topic Announcements
14:04:02 <Yumeng__> Hi
14:04:13 <acabot> #info a new video demo of Watcher is available on YouTube
14:04:24 <acabot> #link https://www.youtube.com/watch?v=FJttohkf0sM
14:04:37 <acabot> feel free to share it worldwide :-)
14:04:43 <sballe_> +2
14:04:53 <acabot> #info Call for presentations for Boston summit is now open (deadline is February 6th)
14:05:08 <acabot> thx sballe_ for reminding me the deadline :-)
14:05:31 <sballe_> yeah it is coming up soon
14:05:32 <acabot> #info an etherpad to submit talks is now open #link https://etherpad.openstack.org/p/Watcher_abstracts_boston2017
14:05:44 <acabot> thx sballe_ for your proposition
14:06:03 <acabot> I copy pasted the previous description from Barcelona as a second talk
14:06:29 <acabot> the category "project updates" doesn't exist anymore
14:06:34 <sballe_> I am interested in being on the "Watcher, the Infrastructure Optimization service for OpenStack: Plans for the P&Q-releases" talk but I am okay with giving somebody else a chance
14:06:59 <acabot> so I would suggest to focus on strategies or business cases for Boston
14:07:11 <sballe_> make sense
14:07:42 <acabot> do you know if Ananth would be interested in submitting a talk for fingreprinting ?
14:08:08 <sballe_> I am not sure but can ask.
14:08:12 <acabot> ok
14:08:22 <acabot> #info Pike PTLs self nomination will start January 23rd and Watcher needs to find a new PTL
14:08:29 <acabot> #link http://lists.openstack.org/pipermail/openstack-dev/2016-December/109019.html
14:08:39 <acabot> #topic Review Action Items
14:09:02 <acabot> a lot of specs are open right now and we need to merge them asap
14:09:12 <acabot> Add improvements to the planner and workflow mechanisms needs to be merged soon as code is already available
14:09:17 <acabot> #link https://review.openstack.org/#/c/385871/16
14:09:40 <vincentfrancoise> acabot: waiting for alexchadin to come back on this one
14:09:41 <acabot> we are waiting for alexchadin to come back from holidays...
14:10:43 <acabot> #action alexchadin add a new PS for https://review.openstack.org/#/c/385871/
14:10:53 <acabot> Add improvements to Applier to make it parallel should be reviewed and merged as its dependant from previous spec
14:11:02 <acabot> #link https://review.openstack.org/#/c/413079/2
14:11:14 <acabot> #action alexchadin add a new PS for https://review.openstack.org/#/c/413079/ so that we can merge it
14:11:37 <acabot> Define grammar for workload characterization needs a new PS answering previous comments
14:11:44 <acabot> #link https://review.openstack.org/#/c/377100/19
14:11:56 <sballe_> I have been trying to sync-up with hvprash
14:11:59 <acabot> #action hvprash add a new PS answering comments on https://review.openstack.org/#/c/377100/19
14:12:27 <acabot> sballe_ : we are waiting for specs improvements for a month now
14:12:39 <sballe_> yeah I know lol
14:12:59 <acabot> Audit tag in VM Metadata still has TODOs
14:13:06 <acabot> #link https://review.openstack.org/#/c/391374/
14:13:21 <acabot> #action hvprash complete TODOs in https://review.openstack.org/#/c/391374/
14:13:32 <acabot> Support Description For Dynamic Action needs a new PS
14:13:40 <acabot> #link https://review.openstack.org/#/c/401111/
14:13:53 <acabot> #action hanrong submit a new PS for https://review.openstack.org/#/c/401111/
14:14:01 <acabot> Noisy Neighbor Strategy has still work in progress
14:14:07 <sballe_> somebody asked for details on the algorithm so that is what I am working on.
14:14:08 <acabot> #link https://review.openstack.org/#/c/398162/
14:14:27 <acabot> sballe_ : could you complete WIP on this spec ?
14:14:29 <sballe_> I'll update the spec with a high level view of the algorithm
14:14:34 <acabot> ok
14:14:53 <acabot> #action sballe_ complete https://review.openstack.org/#/c/398162/ with a high level view of the algorithm
14:15:05 <acabot> cluster energy saving needs to be resubmitted as launchpad does not allow to change the superseded state
14:15:14 <acabot> #link https://blueprints.launchpad.net/watcher/+spec/cluster-energy-saving
14:15:47 <acabot> thix BP has moved from hanrong to jinquan but it needs to be replaced as I cant remove the superseded state
14:16:08 <acabot> #action jinquan create a new BP replacing https://blueprints.launchpad.net/watcher/+spec/cluster-energy-saving
14:16:17 <acabot> Watcher
14:16:23 <acabot> Add auto_trigger support to watcher needs a gate fix to be merged
14:16:29 <acabot> #link https://review.openstack.org/#/c/403718/
14:16:48 <vincentfrancoise> acabot: actually this probably is not only for this PS
14:17:12 <vincentfrancoise> acabot: all multinode jobs are currently failing for some reason
14:17:27 <acabot> vincentfrancoise : right, who can have a look at the multinode gate ?
14:17:35 <vincentfrancoise> acabot: seems like only 1 node is detected instead of 2, hence the failure
14:17:56 <vincentfrancoise> acabot: I probably will
14:18:04 <acabot> vincentfrancoise : ok thx
14:18:22 <acabot> #action vincentfrancoise fix gate issue on multinode gate
14:19:13 <acabot> dtardivel : can you do a final review on https://review.openstack.org/#/c/403718/ ?
14:19:21 <dtardivel> +&
14:19:23 <dtardivel> +1
14:19:32 <acabot> #action dtardivel review and merge https://review.openstack.org/#/c/403718/
14:19:41 <acabot> New default planner needs a gate fix to be merged
14:19:48 <acabot> #link https://review.openstack.org/#/c/406991/
14:20:13 <acabot> in fact it is the same gate issue
14:20:26 <acabot> this patch needs a sync with alexchadin
14:20:40 <acabot> #action alexchadin sync with the team for https://review.openstack.org/#/c/406991/
14:20:43 <alexchadin> Hello
14:20:53 <acabot> alexchadin : hello !!!
14:21:02 <acabot> we were waiting for you !
14:21:18 <alexchadin> I will be available tomorrow, were on holiday
14:21:20 <alexchadin> Sorrt
14:21:30 <vincentfrancoise> alexchadin: happy new year :)
14:21:47 <alexchadin> Happy new year, guys!
14:21:56 <acabot> alexchadin : no problem and happy new year !
14:22:04 <dtardivel> alexchadin: Bonne Année 2017 :)
14:22:05 <alexchadin> Thank you!
14:22:11 <acabot> vincentfrancoise suggested some code here https://review.openstack.org/#/c/415505/
14:22:15 <alexchadin> С новым годом :)
14:22:26 <alexchadin> I saw
14:22:46 <alexchadin> I read your patches
14:22:59 <acabot> lets discuss this on openstack-watcher
14:23:09 <alexchadin> Ok ok
14:23:14 <acabot> Added Monasca Helper needs a new PS
14:23:20 <acabot> #link https://review.openstack.org/#/c/348891/
14:23:32 <acabot> #action vincentfrancoise add a new PS for https://review.openstack.org/#/c/348891/
14:24:13 <acabot> Multi datasource support for Basic Consolidation needs a new PS and reviews
14:24:25 <acabot> #link https://review.openstack.org/#/c/414617/
14:24:26 <alexchadin> I am in airport, let's meet tomorrow!
14:24:34 <alexchadin> Bye:)
14:24:34 <acabot> #action vincentfrancoise add a new PS for https://review.openstack.org/#/c/414617/
14:24:39 <vincentfrancoise> alexchadin: bye :)
14:24:41 <acabot> alexchadin : ok bye
14:24:51 <acabot> who wants to review https://review.openstack.org/#/c/414617/ ?
14:25:23 <acabot> check the state of action plan needs a new PS
14:25:29 <acabot> #link https://review.openstack.org/#/c/391383/
14:25:41 <acabot> #action licanwei submit a new PS answering comments for https://review.openstack.org/#/c/391383/
14:25:42 <sballe_> I can review one or two this week
14:25:53 <acabot> sballe_ : ok
14:26:12 <acabot> #action sballe_ review https://review.openstack.org/#/c/348891/ & https://review.openstack.org/#/c/414617/
14:26:35 <acabot> dynamic action description needs a status
14:26:42 <acabot> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/dynamic-action-description
14:26:54 <acabot> #action hanrong provide status on https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/dynamic-action-description
14:27:25 <acabot> Watcher CLI
14:27:33 <acabot> Add functional tests to watcherclient needs final reviews
14:27:39 <acabot> #link https://review.openstack.org/#/c/389181/
14:28:00 <acabot> will be merged when planner improvements will be merged
14:28:10 <dtardivel> acabot: yep
14:28:54 <acabot> there are also minor fixes on watcher-dashboard
14:29:07 <acabot> #topic Blueprint/Bug Review and Discussion
14:29:20 <acabot> #info all unstarted BPs have been moved to ocata-rc1, ocata-3 is due January 23rd
14:29:27 <acabot> #link https://launchpad.net/watcher/+milestone/ocata-3
14:29:53 <acabot> I'm concerned about https://blueprints.launchpad.net/watcher/+spec/dynamic-action-description because we don't know the status
14:30:27 <acabot> I'm also concerned by hvprash BPs that I have moved to ocata-rc1 but dont evolve at all...
14:31:07 <acabot> ocata-rc1 deadline is January 30th...
14:31:33 <acabot> #info non-client libraries (watcher CLI) must be freezed on January 19th
14:32:18 <acabot> we need to check that we won't need to upgrade the CLI after January 19th
14:32:30 <acabot> until the end of the cycle
14:33:04 <acabot> as requested by the release team, we shouldn't work on new features after ocata-3
14:33:33 <vincentfrancoise> acabot: +1
14:33:35 <dtardivel> acabot: ok
14:33:59 <acabot> sballe_ : I moved your new strategy to ocata-rc1, is the implementation already done on your side ?
14:34:13 <sballe_> not yet but we are close
14:34:25 <sballe_> we ran into some issue with system access but
14:34:41 <sballe_> hopefully that will be fixed.
14:34:48 <acabot> ok
14:35:15 <acabot> rc-1 is January 30th, are you confortable with this ?
14:35:36 <sballe_> if we get the systems back up today then yes
14:35:43 <acabot> ok
14:35:52 <acabot> #topic Open discussions
14:36:03 <acabot> graph model
14:36:07 <sballe_> I would like to talk about hte IRC meeting. 4am is really early for me
14:36:51 <acabot> sballe_ : ok what would be the best option for you ?
14:37:08 <sballe_> can we move the second meeting to a better time for the US. chrisspencer has no chance to attend since it is at 1am
14:37:12 <acabot> sballe_ : I mean good time for you but also for possible intel contributors in Chian
14:37:30 <sballe_> we no longer have people in china contributing from Intel
14:37:44 <sballe_> both Chris and Pru are US timezone
14:37:54 <acabot> a suitable time for Chris would be 7 hours later then it will be late for chinese
14:38:27 <sballe_> could we just do the same time every weel for hte meeting? like it used to be?
14:38:49 <acabot> sballe_ : ok but we have good contributions from hanrong, yumeng, licanwei, hanrong, hidekazu, all at asian time
14:39:08 <sballe_> ok totally fair.
14:39:30 <acabot> I just want to avoid having them "off meetings"...
14:39:57 <acabot> what time would be better for you sballe_ ? 3 hours later ?
14:40:15 <acabot> 11.00 UTC
14:40:46 <acabot> if chris can be there every 2 weeks its probably fine
14:40:56 <acabot> as chinese do
14:41:12 <chrisspencer> acabot: ack. That is what I am currently doing.
14:41:14 <sballe_> ok yes that would work for me and hopefully Pru too
14:41:44 <acabot> sballe_ : I can look for a new slot at 11 UTC on odd weeks
14:41:50 <sballe_> Pru is in central time zone so only one hour behind me
14:42:13 <acabot> I know that ttx did a bit of clean-up recently on meetings agenda
14:42:18 <sballe_> even 2 hours would work
14:43:08 <acabot> 10.00 UTC would be easier for us as well
14:43:40 <acabot> #action acabot look for a new meeting slot on odd weeks at 10.00 or 11.00 UTC
14:43:55 <acabot> next graph model
14:44:19 <acabot> sballe_ : vincentfrancoise looked in more detail in kevin contributions
14:44:39 <acabot> sballe_ : and it appears that kevin handle network and storage in the data model
14:44:52 <acabot> things that we dont have yet in watcher
14:45:03 <acabot> as we deal only with compute resources
14:45:33 <acabot> we have 2 possible options now
14:45:35 <sballe_> ok. I was hoping thijs would behere
14:46:14 <acabot> - we remove/comment all code related to storage and network because we dont know how to maintain it
14:47:02 <acabot> - we keep the code but we need to create many new BPs to handle sync with Neutron & Cinder
14:47:29 <acabot> hello jwcroppe :-)
14:47:48 <sballe_> acabot: Let me talk to kevin and thijs and we will sync-up with vincentfrancoise
14:47:49 <vincentfrancoise> acabot: it's not that we don't know per se, it's more that it requires us to maintain the consistency of these data over time by consuming neutron and cinder notifications
14:48:13 <acabot> vincentfrancoise : +1
14:48:39 <jwcroppe> acabot: greetings - just trying to catch tail end of the discussion :)
14:49:00 <acabot> #action sballe_ sync with kevin & thijs about graph model
14:49:03 <vincentfrancoise> sballe_: because I reckon that a graph data model makes more sense, I am working to integrate what you guys did
14:49:19 <sballe_> vincentfrancoise: great!
14:49:48 <sballe_> vincentfrancoise: we'll setup sometime to go over this wth you
14:49:56 <acabot> s a:
14:50:04 <acabot> sballe_ : there is a poc here https://review.openstack.org/#/c/418434/
14:50:16 <vincentfrancoise> sballe_: but integrating cinder and neutron data will have to be handled at a later notice so we do things right
14:50:20 <acabot> if you can share it with kevin and thjis
14:50:31 <sballe_> will do
14:50:46 <acabot> Sync with fingerprinting work from Intel presented at Barcelona summit ?
14:50:48 <vincentfrancoise> I discussed this matter with them already
14:51:05 <vincentfrancoise> but please do share the code I pushed with them :)
14:51:43 <acabot> sballe_ : do you if Ananth still plan to deliver a watcher strategy ?
14:52:08 <sballe_> I just sent him email.
14:52:13 <acabot> I think you had discussion about it in Barcelona (and vincentfrancoise reminds me that)
14:52:31 <vincentfrancoise> acabot: +1
14:52:52 <acabot> #action sync with Ananth about delivering a watcher strategy based on fingerprinting
14:53:00 <acabot> #action sballe_ sync with Ananth about delivering a watcher strategy based on fingerprinting
14:53:18 <acabot> any other topic to discuss ?
14:53:24 <vincentfrancoise> I remember that the strategy was doable for ocata bu the dashboard was the bit he didn't if it could be integrated for this cycle
14:54:53 <vincentfrancoise> sballe_: even if it's not fully finished on his side, throwing his code over the fence can help us see/help with what's left ;)
14:54:55 <jwcroppe> acabot: is there a list of PTG attendees somewhere that's being maintained?
14:55:06 <sballe_> vincentfrancoise: agreed
14:55:06 <acabot> jwcroppe : we plan to move the meeting on odd weeks 2/3 hours later, would it be good for you ?
14:55:20 <jwcroppe> acabot: yes, that would
14:55:30 <acabot> jwcroppe : I will open the etherpad for PTG by next meeting
14:55:48 <acabot> jwcroppe : we should be at least 8 people
14:56:30 <jwcroppe> acabot: ok, cool.
14:56:54 <acabot> thank you guys
14:56:59 <acabot> have a good day/night
14:57:04 <dtardivel> bye
14:57:07 <vincentfrancoise> bye
14:57:18 <acabot> #endmeeting