13:00:23 <acabot> #startmeeting watcher
13:00:25 <openstack> Meeting started Wed Feb  1 13:00:23 2017 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:29 <openstack> The meeting name has been set to 'watcher'
13:00:29 <acabot> o/
13:00:32 <alexchadin> o/
13:00:34 <chrisspencer> o/
13:00:37 <sballe_> o/
13:00:40 <hidekazu_> hello
13:00:51 <acabot> I hope this new time is good for everyone :-)
13:01:00 <acabot> hidekazu : whats your local time ?
13:01:05 <hidekazu_> i am sleepy ;)
13:01:09 <acabot> :-D
13:01:13 <hidekazu_> 10 pm in japna
13:01:15 <hidekazu_> japan
13:01:20 <acabot> thanks for joining us anyway
13:01:39 <acabot> agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#02.2F01.2F2016
13:01:43 <vincentfrancoise> o/
13:01:51 <acabot> last meeting before Watcher 1.0.0 !
13:02:01 <sballe_> +2
13:02:06 <acabot> that should be released tomorrow !
13:02:19 <acabot> #topic Announcements
13:02:21 <sballe_> hidekazu_: +2
13:02:42 <acabot> #info alexchadin will be appointed as our new PTL soon
13:02:48 <acabot> #link https://governance.openstack.org/election/
13:02:51 <sballe_> congrats! alexchadin
13:02:57 <acabot> congrats alex !
13:03:00 <vincentfrancoise> +2
13:03:03 <alexchadin> thank you all!
13:03:06 <pshedimb> Congrats Alex
13:03:23 <hidekazu_> +1
13:03:33 <acabot> election should start tomorrow so I suppose it will become official by the end of this week
13:03:45 <sballe_> we don;t have to vote rigth/
13:03:55 <acabot> yes
13:04:01 <dtardivel> hi
13:04:03 <sballe_> ok just making sure
13:04:07 <sballe_> hi dtardivel
13:04:20 <acabot> as alexchadin will not attend the PTG, I will continue leading the project until Atlanta
13:04:42 <sballe_> acabot: make sense thx for doing this
13:04:45 <alexchadin> acabot: it is great
13:04:46 <hidekazu_> acabot: i can meet you!
13:04:58 <acabot> and we will have a couple of f2f hangouts sessions to deal with the release process
13:05:04 <alexchadin> BTW, I will be available online
13:05:21 <alexchadin> Hope to meet you at Summit
13:05:24 <sballe_> I can be available for some of the F2F if it make sense
13:05:33 <sballe_> I will be ta the summit
13:05:39 <acabot> I will try to move all "release related" subjects in the morning so that alexchadin can join us
13:05:49 <sballe_> +2
13:06:03 <acabot> #info PTG is in 3 weeks, a dedicated etherpad is now open, please submit topics that you want to discuss
13:06:09 <acabot> #link https://etherpad.openstack.org/p/pike-watcher-ptg
13:06:36 <acabot> I will start building the agenda by our next meeting so please add your contributions now
13:07:05 <acabot> #info Call for presentations for Boston summit will close next Monday; our dedicated etherpad already has 4 talks suggested (1 has already been submitted). Please review them by EOW and add a "submitter" for each proposal.
13:07:14 <acabot> #link https://etherpad.openstack.org/p/Watcher_abstracts_boston2017
13:07:21 <acabot> thanks for all these contributions
13:07:33 <acabot> I hoped to have at least 4 talks to submit
13:07:51 <acabot> sballe_ : is the 1st one submitted already ?
13:08:06 <sballe_> yes
13:08:21 <alexchadin> sballe_: I've added myself to Plans for P&Q Releases
13:08:24 <acabot> could you please add the category and technical level in the etherpad ?
13:08:49 <sballe_> https://www.openstack.org/summit/boston-2017/call-for-presentations/manage/17598/summary
13:08:52 <acabot> alexchadin : thx in this case I will remove myself for now
13:08:54 <sballe_> will do
13:09:09 <acabot> sballe : "You can't edit this presentation"
13:09:17 <acabot> sballe_ : :-)
13:09:20 <sballe_> alexchadin: great I thought you should be on it
13:09:42 <acabot> sballe_ : I want to avoid having all our talks in the same category
13:10:00 <acabot> last time in Barcelona it was not really successful ;-)
13:10:17 <sballe_> yeah I have it in OPs tools and I am thinking it might be a use case
13:10:22 <sballe_> any thought on thta
13:10:25 <acabot> could you please also add a "submiter" to each talk ?
13:11:00 <hidekazu_> acabot: main speaker?
13:11:08 <acabot> alexchadin : could you submit plans for P&Q ?
13:11:29 <sballe_> acabot
13:11:30 <sballe_> done
13:11:34 <acabot> hidekazu_ : I mean the person who submit the talk in https://www.openstack.org/summit/boston-2017/call-for-presentations/
13:11:56 <hidekazu_> acabot: ok
13:12:10 <acabot> hidekazu_ : could you submit the 4st one ?
13:12:31 <alexchadin> acabot: I got "You can't edit this presentation"
13:12:47 <hidekazu_> acabot: my customer kentaro will do.
13:13:08 <acabot> hidekazu_ : ok
13:13:33 <acabot> #action alexchadin submit talk Watcher, the Infrastructure Optimization service for OpenStack: Plans for the P&Q-releases by sunday EOD
13:13:59 <acabot> #action yumeng submit talk Help telecom operators save energy and reduce cost of data center with Openstack Watcher by Sunday EOD
13:14:30 <acabot> #action hidekazu_ ask kentaro to submit Software-Defined Migration: How to migrate bunch of VMs and Volumes within a limited time frame? by Sunday EOD
13:14:37 <hidekazu_> if ptl join my session, more attractive :)
13:14:52 <sballe_> I was super happy to see the new extra talks by hidekazu and yumeng
13:15:06 <sballe_> cool usecases!
13:15:10 <acabot> #action acabot look at categories to find the best possible category for each talk
13:15:26 <acabot> alexchadin : do you want to join hidekazu_ talk ?
13:15:30 <sballe_> acabot: please check mine too. I am not sure I am in the rigth categories
13:15:40 <acabot> sballe_ : ok
13:15:51 <acabot> I will add a suggested category for each talk
13:16:04 <alexchadin> acabot: hidekazu_ I will discuss it with you this week
13:16:11 <acabot> #info Watcher has been released in v0.34
13:16:17 <acabot> #link https://releases.openstack.org/ocata/#ocata-python-watcher
13:16:26 <acabot> #info Watcher Dashboard has been released in v0.8
13:16:32 <acabot> #link https://releases.openstack.org/ocata/#ocata-watcher-dashboard
13:16:45 <acabot> we will release everything in 1.0.0 this week
13:16:58 <acabot> #topic Review Action Items
13:17:03 <acabot> Watcher specs
13:17:09 <acabot> Specs for action-plan-versioned-notifications-api needs final reviews from core
13:17:16 <acabot> #link https://review.openstack.org/#/c/420576/
13:17:23 <dtardivel> +1
13:17:37 <acabot> we'd like to have this feature merged before tomorrow
13:17:49 <acabot> all code has been written by vincentfrancoise
13:18:03 <sballe_> I will review right now (actually after the meeting ;) )
13:18:12 <acabot> #action sballe_ acabot hvprash review and merge https://review.openstack.org/#/c/420576/
13:18:21 <acabot> Define grammar for workload characterization needs a new PS answering previous comments
13:18:28 <acabot> #link https://review.openstack.org/#/c/377100/19
13:18:38 <acabot> #action hvprash add a new PS for https://review.openstack.org/#/c/377100/19
13:18:47 <vincentfrancoise> sballe_: thx
13:18:51 <acabot> this BP has been moved to Pike cycle
13:19:00 <acabot> Support Description For Dynamic Action needs a new PS
13:19:09 <acabot> #link https://review.openstack.org/#/c/401111/
13:19:13 <acabot> is hanrong here ?
13:19:39 <acabot> we are still looking for a status on this feature (moved to Pike as well)
13:19:47 <acabot> #action hanrong add a new PS for https://review.openstack.org/#/c/401111/
13:19:55 <acabot> Noisy Neighbor Strategy has still work in progress
13:20:01 <acabot> #link https://review.openstack.org/#/c/398162/
13:20:05 <sballe_> working on it
13:20:06 <pshedimb> acabot, working on it
13:20:09 <sballe_> lol
13:20:15 <pshedimb> haha
13:20:19 <acabot> pshedimb : ok great !
13:20:41 <acabot> I already moved it to pike but we will have to do it before Boston as you plan to demonstrate it :-D
13:21:02 <sballe_> we have a watcher-dashboard spec too
13:21:03 <acabot> #action pshedimb add a new PS for https://review.openstack.org/#/c/398162/
13:21:11 <alexchadin> pshedimb: It's very interesting strategy
13:21:20 <pshedimb> thank you alexchadin
13:21:21 <acabot> sballe_ : yes I saw that, lets discuss it later
13:21:27 <pshedimb> me and sballe_ working on algo
13:21:48 <acabot> Audit tag in VM Metadata needs reviews
13:21:55 <acabot> #link https://review.openstack.org/#/c/391374/
13:22:11 <acabot> jwcroppe added a couple of comments that needs to be answered
13:22:24 <sballe_> I will review right after the meeting because I know this crucial to Walmat making progress
13:22:24 <acabot> #action hvprash add a new PS for https://review.openstack.org/#/c/391374/
13:22:36 <acabot> #action sballe_ review https://review.openstack.org/#/c/391374/
13:22:48 <acabot> Spec for noisy-neighbor-dashboard needs reviews
13:22:53 <acabot> #link https://review.openstack.org/#/c/427308/
13:22:56 <sballe_> yes please
13:23:12 <acabot> thx for submitting a spec for watcher-dashboard (its not so common) :-)
13:23:20 <sballe_> We have realized that sometimes looking at the metrics give people a hint of what is going on so this is super impoartant
13:23:42 <sballe_> this helps understand the NN algorithm
13:23:50 <acabot> well yes the problem is that there is currently no metrics view in Watcher dashboard
13:23:53 <pshedimb> +2
13:24:05 <acabot> we rely on Monasca dashboard for that
13:24:36 <sballe_> I think it is important to have it in wathcer and not worry where the metrics come from
13:24:45 <pshedimb> acabot, we can introduce a tab for live metrics in watcher dashboard right?
13:25:09 <pshedimb> That way it is wasier to see the progress watcher makes
13:25:21 <pshedimb> easier*
13:25:39 <acabot> pshedimb : of course we can, the question is, who is the most legitimate to do that (Watcher or Monasca ?)
13:25:39 <alexchadin> pshedimb: you mean something like metrics changelog?
13:25:44 <vincentfrancoise> pshedimb: I just wonder how you plan on connecting the metrics then
13:25:56 <vincentfrancoise> acabot: +1
13:26:16 <pshedimb> alexchadin, vincentfrancoise I mean something that displays the meters collected from ceilo in terms of graphical plots
13:26:34 <sballe_> the issue I have with Monasca is hwta if people not using Monasca ?
13:26:42 <acabot> I think there are plenty of tools available to see live metrics so I'm not sure that building our own inside Watcher creates value
13:26:50 <dtardivel> we already have dasboard with ceilometer/Monasca horizon plugin
13:27:14 <alexchadin> We have already discussed it in Barcelona
13:27:39 <pshedimb> okay. got it. makes sense
13:27:45 <acabot> sballe_ : people usually use other off-the-shelf solutions so they already have live metrics dashboards
13:27:57 <dtardivel> Monasca plugin allows us to open a grafana tab, with a pre configured settings, to see live metrics collected from our cluster.
13:28:00 <sballe_> I guess we can just write our own and keep it in house
13:28:00 <alexchadin> The question is which way to use to demonstrate it
13:28:27 <sballe_> alexchadin: I agree
13:28:50 <sballe_> we want to show different plots and have it be synchornized with the stratgey in Watcher
13:28:57 <acabot> I would suggest to add it to the topics list for the PTG, it will be easier in f2f ;-)
13:29:18 <acabot> #action acabot add https://review.openstack.org/#/c/427308/ in the PTG topics list
13:29:19 <sballe_> make sense both chrisspencer and pshedimb  will be there
13:29:28 <acabot> moving to Watcher
13:29:29 <pshedimb> okay. will do :)
13:29:30 <chrisspencer> +1 I will add
13:29:46 <acabot> be my guest ;-)
13:29:59 <acabot> check the state of action plan needs to be fixed to be part of Ocata release
13:30:05 <acabot> #link https://review.openstack.org/#/c/391383/
13:30:19 <acabot> is licanwei here ?
13:30:46 <acabot> we are waiting for a patch for 1 week now, I'm sorry but I will have to move to Pike
13:31:15 <acabot> #action acabot move https://blueprints.launchpad.net/watcher/+spec/stale-action-plan to Pike cycle
13:31:24 <acabot> action-plan-versioned-notifications-api needs final reviews from core to be merged before the release
13:31:30 <acabot> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/action-plan-versioned-notifications-api
13:31:50 <acabot> dtardivel alexchadin : could you review it and test it by tomorrow ?
13:32:00 <dtardivel> yep
13:32:02 <alexchadin> since I'm working on action notifications add me as reviewer
13:32:16 <acabot> #action dtardivel alexchadin review & merge https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/action-plan-versioned-notifications-api
13:32:26 <acabot> Add first alembic version for db migration needs final review from core
13:32:32 <acabot> #link https://review.openstack.org/#/c/419031/
13:32:45 <alexchadin> me too
13:32:46 <acabot> alexchadin vincentfrancoise : could you review and test it ?
13:32:57 <acabot> alexchadin : thx
13:33:04 <vincentfrancoise> acabot: I gave it a -1
13:33:06 <dtardivel> I will push a new patch this afternoon
13:33:12 <dtardivel> I'm working on it
13:33:35 <acabot> #action vincentfrancoise alexchadin review https://review.openstack.org/#/c/419031/ as soon as dtardivel submited a patch
13:33:43 <acabot> Use RPC cast() to be asynchronous needs a new PS
13:33:44 <vincentfrancoise> acabot: will do
13:33:49 <acabot> #link https://review.openstack.org/#/c/421268/
13:34:11 <acabot> is this one mandatory for Ocata ?
13:34:34 <vincentfrancoise> acabot: just a nice to have
13:34:44 <acabot> ok
13:34:52 <acabot> workload-balance-tempest needs reviews
13:34:58 <acabot> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:detached/workload-balance-tempest
13:35:07 <acabot> vincentfrancoise : nice to have too ?
13:35:25 <vincentfrancoise> acabot: yup
13:35:43 <acabot> ok anyone wants to review these 2 patches ?
13:36:08 <alexchadin> will take RPC
13:36:22 <acabot> #action alexchadin review https://review.openstack.org/#/c/421268/
13:36:38 <acabot> Adding additional details to notification logs needs a status
13:36:44 <acabot> #link https://review.openstack.org/#/c/422295/
13:36:57 <acabot> chrispencer : anything wrong with the gate
13:37:01 <acabot> ?
13:37:24 <pshedimb> acabot, I think the master was failing tox tests
13:38:18 <acabot> ERROR: InvocationError: '/opt/stack/new/tempest/.tox/all-plugin/bin/tempest run --regex watcher_tempest_plugin --concurrency=4'
13:38:20 <chrisspencer> acabot: still working on getting the logs modified.  it wasn't working the last I checked.  I may need to sync up with vincentfrancoise to see what I might be missing
13:38:20 <acabot> strange
13:39:08 <acabot> chrisspencer : ok I think vincentfrancoise will be a bit overloaded until the release
13:39:17 <chrisspencer> +1
13:39:17 <acabot> chrisspencer : I will move this bug to Pike
13:39:32 <acabot> chrisspencer : I hope it's fine for you
13:39:39 <vincentfrancoise> chrisspencer: made a quick comment that may solve the problem
13:39:40 <chrisspencer> acabot: that's fine
13:40:10 <acabot> #topic Blueprint/Bug Review and Discussion
13:40:27 <chrisspencer> will try, thanks vincentfrancoise
13:40:28 <acabot> #info Watcher O3-rc1 will be release tomorrow and Ocata stable branch will be created
13:40:37 <acabot> #link https://launchpad.net/watcher/+milestone/ocata-rc1
13:40:54 <acabot> as soon as the branch will be created, master will be dedicated to Pike cycle
13:41:18 <acabot> and now the branch creation is automated thx to the release team
13:42:21 <acabot> FYI, we have completed 13 BPs in this cycle �
13:42:40 <acabot> which is very good and quite similar as the Newton cycle
13:42:54 <acabot> so congrats to every contributor !
13:43:04 <vincentfrancoise> +2
13:43:08 <alexchadin> my congratulations!
13:43:11 <sballe_> acabot: I migth add the finerprinting stuff from ananth and mrittika. It looks like I will take this over
13:43:22 <acabot> sballe_ : ;-)
13:44:02 <sballe_> I know lol
13:44:14 <acabot> we should also now that thanks to vincentfrancoise holidays, dtardivel is now our 1st contributor !! http://stackalytics.com/report/contribution/watcher/180
13:44:24 <sballe_> +2
13:44:58 <vincentfrancoise> dtardivel: nice one!
13:45:16 <pshedimb> great job :)
13:45:24 <dtardivel> I will take a snapshot quickly :)
13:45:29 <acabot> pshedimb : you are our 6th contributor, I hope you will be able to join the top 5 in the coming weeks !
13:45:40 <hidekazu_> cool
13:46:11 <acabot> #info we will also release watcher-dashboard v1.0 tomorrow
13:46:13 <sballe_> pshedimb: +2
13:46:32 <acabot> #topic Open discussions
13:46:40 <pshedimb> acabot, sure. looking forward to it. :)
13:46:41 <acabot> 15 minutes left for open discussions
13:47:07 <acabot> I have a subject I forgot to mention
13:47:16 <acabot> I have been contacted by the Documentation team
13:47:34 <acabot> to know whats going on regarding doc on Watcher
13:47:46 <acabot> did we do anything special regarding the doc team ?
13:48:22 <acabot> I planned to meet in Atlanta to check that we are compliant with doc requirements
13:48:49 <alexchadin> acabot: You talk about Install Docs?
13:49:26 <acabot> I dont really know what the openstack doc team is doing :-)
13:49:36 <vincentfrancoise> ahaha
13:49:44 <vincentfrancoise> me neither
13:49:46 <alexchadin> it would be great to have Watcher install docs in Installation Tutorials And Guides
13:49:58 <hidekazu_> +1
13:50:07 <acabot> they contacted me because I'm here https://wiki.openstack.org/wiki/CrossProjectLiaisons#Documentation
13:50:07 <sballe_> +1
13:50:16 <acabot> "by default" :-)
13:50:22 <acabot> maybe I should put alex ;-)
13:50:39 <pshedimb> The new Docs PTL is part of our OSIC team here in San Antonio ;)
13:51:16 <acabot> pshedimb : good to know
13:51:43 <acabot> I will try to join there weekly meeting and see if we have anything to do
13:51:44 <pshedimb> So I can push for something here if we need any help with docs. :)
13:52:11 <sballe_> +2
13:52:13 <acabot> #action acabot join docs meeting and ask to have Watcher install docs in Installation Tutorials And Guides
13:52:30 <alexchadin> oh
13:52:41 <acabot> alexchadin : do you have a link for these turorials ?
13:52:51 <alexchadin> acabot: http://docs.openstack.org/project-install-guide/newton/
13:53:09 <dtardivel> acabot: Lana Brindley seems to be the contact for installation guides
13:53:13 <alexchadin> As I know, OpenStack have Translation Team
13:53:41 <alexchadin> What do they do?
13:53:57 <acabot> alexchadin : translation I guess :-D
13:54:06 <alexchadin> translation for what?
13:54:09 <vincentfrancoise> seems like the projects that are listed are only the ones we also see in https://www.openstack.org/software/project-navigator/
13:54:12 <alexchadin> Documentation?
13:54:38 <hidekazu_> i18n is another team.
13:54:39 <acabot> alexchadin : yes these assist project with doc translation
13:55:04 <hidekazu_> https://wiki.openstack.org/wiki/CrossProjectLiaisons#I18n
13:55:28 <acabot> vincentfrancoise : there is a dicussion about project navigator here http://lists.openstack.org/pipermail/openstack-dev/2017-January/110193.html
13:55:48 <acabot> we should probably look a it closely if we want Watcher to be part of it
13:57:25 <vincentfrancoise> acabot: thx for the link
13:58:00 <alexchadin> acabot: seems that we need to meet some mature indicators to be placed there
13:59:18 <acabot> yes and it comes from tags here https://governance.openstack.org/tc/reference/projects/watcher.html
13:59:28 <acabot> I will look at it
13:59:35 <vincentfrancoise> we just hit 1.0.0 so "standard deprecation" has yet to be put in place
13:59:46 <acabot> yes
13:59:51 <acabot> time is over
13:59:54 <acabot> thank you all
13:59:59 <vincentfrancoise> bye
14:00:00 <acabot> have a good day/night
14:00:02 <sballe_> bye
14:00:04 <hidekazu_> bye
14:00:08 <acabot> #endmeeting