14:00:57 <acabot> #startmeeting watcher
14:00:58 <openstack> Meeting started Wed Feb  8 14:00:57 2017 UTC and is due to finish in 60 minutes.  The chair is acabot. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:02 <openstack> The meeting name has been set to 'watcher'
14:01:03 <acabot> o/
14:01:08 <Yumeng__> hi
14:01:10 <pshedimb> hi
14:01:14 <chrisspencer> o/
14:01:18 <adisky_> hi
14:01:21 <hvprash> hi
14:01:41 <acabot> #info agenda for today #link https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#02.2F08.2F2016
14:01:47 <licanwei_> hi
14:02:10 <acabot> as always feel free to add things in open discussions along the meeting
14:02:56 <vincentfrancoise> o/
14:03:19 <acabot> #topic Announcements
14:03:39 <alexchadin> Hi
14:03:42 <acabot> #info Watcher has been released in v1.0.0
14:03:43 <alexchadin> :)
14:03:49 <acabot> #link http://lists.openstack.org/pipermail/openstack-dev/2017-February/111576.html
14:03:49 <pshedimb> Yayy :)
14:03:57 <acabot> thats a great achievement !
14:04:04 <acabot> congrats everybody
14:04:06 <vincentfrancoise> acabot: +2
14:04:12 <alexchadin> We have made it!
14:04:14 <hvprash> good work team ! congrats !
14:04:34 <acabot> #info Watcher Dashboard has been released in v1.0.0
14:05:00 <acabot> so now all our components are in 1.0.0 (watcher, dashboard & CLI)
14:05:24 <acabot> #info alexchadin is elected as Watcher PTL
14:05:36 <acabot> #link http://lists.openstack.org/pipermail/openstack-dev/2017-February/111769.html
14:06:01 <hvprash> woo hoo ! congrats alex !
14:06:01 <alexchadin> I am glad to be part of this project!
14:06:18 <acabot> I planned to add alexchadin as core reviewer on Watcher specs as our new PTL
14:06:39 <acabot> do we agree that we can do it without candidacy on the ML ?
14:06:43 <sballe_> Morning stick in traffic will be there in 5 minutes
14:06:57 <pshedimb> +2
14:07:00 <hvprash> +2
14:07:01 <vincentfrancoise> +2
14:07:09 <acabot> ok
14:07:14 <Yumeng__> +2
14:07:25 <acabot> #action acabot add alexchadin as spec core reviewer
14:07:27 <licanwei_> +2
14:07:33 <alexchadin> Thank you!
14:08:03 <acabot> alexchadin : if its OK for you, I will continue leading the IRC meeting until the PTG
14:08:22 <acabot> alexchadin : and then we will have to build your own agenda ;-)
14:08:30 <acabot> s/we/you
14:09:00 <alexchadin> Yes, i will take this time to get ready for meetings
14:09:08 <acabot> #info PTG is in 2 weeks, etherpad is open and a 1st draft of agenda is available
14:09:14 <acabot> #link https://etherpad.openstack.org/p/pike-watcher-ptg
14:10:44 <acabot> feel free to add topics in the list, we still have some time left for other topics
14:10:54 <pshedimb> No time for lunch during PTG :P
14:11:09 <acabot> pshedimb : we never eat during meetings ;-)
14:11:19 <pshedimb> hahaa :D
14:11:22 <Yumeng__> LoL
14:11:51 <acabot> pshedimb : actually I dont know exactly how it will be organized but there will probably be a buffet
14:12:07 <pshedimb> acabot, okay. cool!
14:12:26 <acabot> but I tried to put "light" topics at lunch time :-D
14:13:11 <acabot> again, it still possible to add topics so feel free to add things you definitely want to have in Pike
14:13:49 <pshedimb> yes, i will discuss with sballe_ today and add to in etherpad
14:13:58 <acabot> we have plenty of BPs to discuss (https://blueprints.launchpad.net/watcher)
14:14:38 <hvprash> yeah, got some reviews on audit vm metatadata. like to discuss in ptg
14:14:48 <acabot> so if you have a very important one and you won't be there to explain it, please do it on the etherpad, so that we can take decisions
14:15:33 <alexchadin> acabot: do you plan to organize video translation?
14:15:47 <acabot> hvprash : added
14:15:56 <hvprash> thanks :)
14:16:01 <acabot> alexchadin : I asked for hangout session
14:16:12 <vincentfrancoise> hvprash: I won't be attending so if you want me to review what we discussed last time about audit vm metadata, make sure you push it before then ;)
14:16:26 <acabot> alexchadin : but the foundation cannot guarantee the wifi connectivity
14:16:33 <hvprash> oh ! i thought you will be there. I will work on the PS then
14:16:58 <alexchadin> acabot: anyway, I will be available in IRC
14:17:17 <acabot> alexchadin : anyway, I tried to put release related topics between 10am and 2pm
14:17:40 <acabot> alexchadin : so that you can follow them
14:17:54 <acabot> #info 3 lightning talks & 1 presentation submitted for Boston summit
14:18:00 <acabot> #link https://etherpad.openstack.org/p/Watcher_abstracts_boston2017
14:18:21 <alexchadin> acabot: I saw your agenda, thanks :)
14:18:24 <acabot> I'm surprised that 3 talks have been submitted as lightning talks
14:18:50 <acabot> FYI, lightning talks replace vBrowBag sessions in previous summit
14:18:55 <acabot> 10 minutes max
14:20:15 <acabot> the deadline for submission has been moved to today
14:20:31 <alexchadin> I have submitted Plans for P and Q as presentation
14:20:37 <acabot> so its still possible to change a lightning talk into a presentation if it makes sense
14:21:02 <acabot> alexchadin : yes, it is the only one, the 3 others are lightning talks
14:21:23 <alexchadin> Sorry for delaying, I'm on smartphone
14:21:25 <acabot> Yumeng__ : is your talk ok in 10 minutes ?
14:21:52 <Yumeng__> I'm not sure at this stage
14:22:07 <Yumeng__> I will discuss with licanwei_
14:22:40 <Yumeng__> And if possible , I will resubmit it
14:23:02 <acabot> Yumeng__ : I think you can just update it
14:23:08 <Yumeng__> Ok
14:23:09 <alexchadin> +1
14:23:54 <acabot> #action Yumeng__ check that the submited presentation is a lightning talk or a presentation
14:24:25 <acabot> sballe_ hvprash : your talk is a lightning talk (10 minutes), is that OK for you ?
14:24:39 <sballe_> hi just got here
14:24:51 <sballe_> the RDT talk>
14:25:02 <sballe_> sorry the noisy neighbor talk?
14:25:11 <acabot> sballe_ : Automating noisy neighbor detection with OpenStack Watcher
14:25:12 <hvprash> sballe_ yes
14:25:22 <sballe_> I would have prefered a normal talk but I will take waht i can get
14:25:31 <acabot> FYI, I will be track chair for Boston summit
14:25:38 <sballe_> cool!
14:25:44 <alexchadin> I have to leave IRC, will read talks history this evening.
14:25:44 <hvprash> i think it should be a normal talk > 10 mins if we are covering case studies too
14:25:48 <acabot> and there are many lightning talks submitted
14:25:50 <sballe_> yeah I wanted to ask you about that ... mybe offline
14:26:06 <vincentfrancoise> alexchadin: bye ;)
14:26:08 <sballe_> acabot: I didn;t submit it as a lightning talk
14:26:08 <alexchadin> Have a nice day/evening!
14:26:14 <acabot> sballe_ hvprash : I would suggest to update it as a presentation
14:26:23 <sballe_> yeah me too
14:26:34 <sballe_> can I still do thta?
14:26:41 <pshedimb> sballe_, yes.
14:26:45 <acabot> DEADLINE EXTENDED: PRESENTATION SUBMISSIONS FOR OPENSTACK SUMMIT BOSTON UNTIL 11:59PM PST ON FEBRUARY 8, 2017 (7:59 ON FEBRUARY 9, 2017 UTC)!
14:26:49 <sballe_> ok I will do that right now
14:26:49 <pshedimb> Deadline has been extended
14:26:57 <acabot> before tonight
14:27:30 <acabot> #topic Review Action Items
14:27:36 <acabot> Watcher specs
14:27:48 <acabot> All those specs should be completed and retargeted to Pike
14:28:08 <sballe_> acabot: I am surprised I have it as a presentation
14:28:13 <acabot> so please abandon or update your review in the right folder (pike/approved)
14:28:43 <acabot> sballe_ : could be a bug in the track chair tool...
14:29:08 <sballe_> ok I just checked and resubmitted making sure it was a presentaiton
14:29:16 <acabot> sballe_ : ok
14:29:32 <acabot> #link https://review.openstack.org/#/c/425204/
14:29:38 <sballe_> can you give me the link?
14:29:57 <acabot> sballe_ : open only to track chairs
14:30:22 <sballe_> ok so I do not udnerstand "so please abandon or update your review in the right folder (pike/approved)"
14:30:26 <acabot> #action Yumeng__ resubmit in PIke https://review.openstack.org/#/c/425204/
14:30:48 <acabot> sballe_ : sorry, as these specs have not been implemented in Ocata
14:31:01 <acabot> sballe_ : we need to resubmit them for Pike
14:31:19 <sballe_> oh sorry! Was still on the old topic ;-)
14:31:29 <acabot> sballe_ : ;-)
14:31:46 <acabot> #link https://review.openstack.org/#/c/398162/
14:32:06 <pshedimb> acabot, Working on the algo.
14:32:12 <acabot> #action sballe_   resubmit in Pike https://review.openstack.org/#/c/398162/
14:32:25 <sballe_> acabot: yeah we finally got the system working including live migration ;-)
14:32:42 <acabot> pshedimb : ok great, we need to have the spec ready in Pike
14:32:46 <sballe_> acabot: please have pshedimb do the action
14:32:49 <pshedimb> Yes sure.
14:32:55 <acabot> #undo
14:32:55 <openstack> Removing item from minutes: #action sballe_   resubmit in Pike https://review.openstack.org/#/c/398162/
14:33:07 <acabot> #action pshedimb   resubmit in Pike https://review.openstack.org/#/c/398162/
14:33:19 <acabot> #link https://review.openstack.org/#/c/391374/
14:33:31 <acabot> #action hvprash resubmit in Pike https://review.openstack.org/#/c/391374/
14:33:35 <pshedimb> acabot, sballe_ yeah. will do it.
14:33:39 <hvprash> acabot: will do
14:33:46 <acabot> #link https://review.openstack.org/#/c/427308/
14:33:49 <sballe_> I will review
14:34:04 <acabot> #action chrisspencer resubmit in Pike https://review.openstack.org/#/c/427308/
14:34:17 <acabot> #link https://review.openstack.org/#/c/401111/
14:34:31 <acabot> #action hanrong resubmit in Pike https://review.openstack.org/#/c/401111/
14:34:40 <acabot> #link https://review.openstack.org/#/c/420612/
14:34:50 <acabot> #action vincentfrancoise resubmit in Pike https://review.openstack.org/#/c/420612/
14:34:57 <acabot> #link https://review.openstack.org/#/c/377100/
14:35:05 <acabot> #action hvprash resubmit in Pike https://review.openstack.org/#/c/377100/
14:35:11 <acabot> #link https://review.openstack.org/#/c/386293/
14:35:12 <chrisspencer> acabot: my spec is already submitted under specs/pike/approved do I need to do something differently?
14:35:16 <sballe_> acabot: just as an FYI chrisspencer will take over the grammar bp from hvprash
14:35:24 <vincentfrancoise> acabot: I don't know if alexchadin wants to do it since he's the one implementing it
14:35:35 <chrisspencer> sballe_: acabot I will resubmit the grammar bp as well
14:35:47 <acabot> chrisspencer : sorry I missed it, thats good then :-)
14:35:57 <hvprash> sballe_ yeah please assign to chris
14:36:04 <sballe_> lol will do :)
14:36:12 <acabot> #undo
14:36:12 <openstack> Removing item from minutes: #link https://review.openstack.org/#/c/386293/
14:36:16 <vincentfrancoise> acabot: but I'll sync with him
14:36:16 <acabot> #undo
14:36:17 <openstack> Removing item from minutes: #action hvprash resubmit in Pike https://review.openstack.org/#/c/377100/
14:36:37 <acabot> #action chrisspencer resubmit in Pike https://review.openstack.org/#/c/377100/
14:37:10 <acabot> #link https://review.openstack.org/#/c/386293/
14:37:40 <acabot> licanwei_ dtardivel : I think https://review.openstack.org/#/c/386293/ should be improved
14:38:12 <acabot> licanwei_ : could you resubmit your spec in Pike so that we can work on it again ?
14:38:18 <sballe_> chrisspencer: what's your launchpad id?
14:38:39 <licanwei_> acabot: ok
14:38:49 <chrisspencer> sballe_: christopher-m-spencer
14:39:09 <acabot> #action licanwei_ resubmit in Pike https://review.openstack.org/#/c/386293/
14:39:10 <sballe_> thx
14:39:30 <acabot> moving to Watcher
14:39:36 <acabot> workload-balance-tempest needs core final reviews
14:39:43 <acabot> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:detached/workload-balance-tempest
14:39:54 <acabot> #action alexchadin dtardivel review https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:detached/workload-balance-tempest
14:40:09 <dtardivel> +1
14:40:12 <acabot> Add Action Notification needs core final reviews
14:40:20 <acabot> #link https://review.openstack.org/#/c/427646/
14:40:37 <acabot> #action vincentfrancoise dtardivel review https://review.openstack.org/#/c/427646/
14:40:46 <vincentfrancoise> acabot: already did
14:40:52 <acabot> #undo
14:40:53 <openstack> Removing item from minutes: #action vincentfrancoise dtardivel review https://review.openstack.org/#/c/427646/
14:41:00 <acabot> #action dtardivel review https://review.openstack.org/#/c/427646/
14:41:13 <acabot> check the state of action plan needs specs rework
14:41:19 <acabot> #link https://review.openstack.org/#/c/391383/
14:41:35 <acabot> dynamic-action-description needs a status
14:41:43 <acabot> #link https://review.openstack.org/#/q/status:open+project:openstack/watcher+branch:master+topic:bp/dynamic-action-description
14:41:47 <acabot> is hanrong here ?
14:42:08 <acabot> or anyone working with hanrong ?
14:42:31 <licanwei_> me
14:43:02 <acabot> licanwei_ : thx, do you know whats the status for this BP ? https://blueprints.launchpad.net/watcher/+spec/dynamic-action-description
14:43:35 <licanwei_> i dont know
14:43:36 <acabot> is hanrong working on it or should we give it to someone else as we are resubmitting specs ?
14:43:39 <licanwei_> sorry
14:43:52 <licanwei_> i'll confirm it
14:44:23 <acabot> #action licanwei_ see with hanrong what is the status for https://blueprints.launchpad.net/watcher/+spec/dynamic-action-description
14:44:50 <acabot> I will probably remove her from the BP at the PTG if we dont get any update until then
14:45:06 <acabot> #topic Blueprint/Bug Review and Discussion
14:45:16 <acabot> Bug fixing in progress for Ocata-rcfinal targeted for February 16th (all fixed bugs should be backported to stable/ocata branch)
14:45:24 <acabot> #link https://launchpad.net/watcher/+milestone/ocata-rc-final
14:45:59 <acabot> I retargeted all bugs currently in review in Gerrit to ocata-rcfinal
14:46:14 <acabot> but maybe not all of them will be backported to stable/ocata
14:46:29 <adisky_> acabot: i want to discuss about https://blueprints.launchpad.net/watcher/+spec/stop-action-plan
14:47:04 <acabot> adisky_ : ok could you please add it to open discussions in the wiki
14:47:26 <acabot> #topic Open discussions
14:47:37 <acabot> adisky_ : please go ahead
14:48:11 <acabot> adisky_ : do you want to be able to stop an action plan
14:48:16 <acabot> s/do/so
14:48:19 <adisky_> acabot:
14:48:21 <adisky_> yes
14:48:46 <acabot> adisky_ : what will happens then, do you want to rollback previous actions ?
14:49:16 <acabot> adisky_ : because your cluster could be in an unstable state
14:49:24 <vincentfrancoise> acabot: +2
14:49:39 <adisky_> acabot: yes, rollback of previous action, abort of ongoing, dont start pending actions
14:50:26 <adisky_> acabot: roll-back operation can be left as user's choice
14:50:32 <acabot> adisky_ : ok in this case you have to check that all previous actions can be rollbacked
14:51:02 <adisky_> acabot: yes
14:51:44 <vincentfrancoise> adisky_: rollbacking is supported by taskflow so it shouldn't be a problem
14:51:46 <acabot> adisky_ : I think with a basic action plan it could work but we have to think about more advanced strategies (and actions)
14:52:31 <adisky_> acabot: it is a possible case that, an action plan is in "ONGOING" state from a long time. user may want to stop it.
14:52:33 <vincentfrancoise> adisky_: but workflow engines are pluggable so you have to think generic
14:52:51 <adisky_> vincentfrancoise: ok
14:52:55 <acabot> adisky_ : I think you can submit a spec so that we can start iterate on it, as suggested by vincentfrancoise, we can first leverage taskflow to do it
14:53:18 <adisky_> acabot: ok
14:53:33 <acabot> #action adisky_ submit a spec for https://blueprints.launchpad.net/watcher/+spec/stop-action-plan
14:53:44 <acabot> Should we enable Watcher dashboard by default ?
14:53:51 <acabot> #link https://review.openstack.org/#/c/429256/
14:54:25 <acabot> vincentfrancoise : you deactivated Watcher dashboard a couple of months ago, is the issue still present ?
14:54:29 <vincentfrancoise> acabot: if we do, it has to be tested via a gate job
14:55:09 <acabot> vincentfrancoise : do you mean that we need to add a new gate job for it ?
14:55:15 <vincentfrancoise> acabot: I don't know, but that's why I'm saying we should have it covered because no one deploys a devstack everyday to check that out
14:55:57 <vincentfrancoise> acabot: could be a new one or we could modify the existing one, whichever is fine by me
14:56:14 <acabot> chrisspencer yumeng__ : did you deploy watcher dashboard using devstack ?
14:56:34 <Yumeng__> yes
14:56:36 <chrisspencer> acabot: yes, I have it running
14:56:41 <Yumeng__> I have tried
14:56:56 <zhurong> hello, I have a question, as the stackalytics http://stackalytics.com/report/contribution/watcher-group/180, licanwei from ZTE, had many contribute to watcher, I think he is qualified to be a core member in watcher
14:57:56 <acabot> zhurong : why not, could you please send an email on the openstack-dev mailing list to nominate licanwei ?
14:58:44 <adisky_> vincentfrancoise : still not able to run any strategy with current devstack deployment due to ceilometer API deprecated, any update on this
14:58:52 <zhurong> This should be PTL nominate, I can not do this. :(
14:59:10 <acabot> zhurong : no no, anyone can nominate a new core
14:59:50 <acabot> we dont have time left to discuss ceilometer API issue
14:59:51 <vincentfrancoise> acabot: but to be core, existing cores have then to approve it right?
15:00:07 <acabot> vincentfrancoise : yes, vote on the ML
15:00:33 <adisky_> acabot: ok
15:00:36 <acabot> I have to end the meeting
15:00:38 <acabot> thanks
15:00:40 <vincentfrancoise> bye all
15:00:42 <hvprash> bye
15:00:44 <Yumeng__> Bye
15:00:44 <acabot> have a good day/night
15:00:46 <adisky_> bye
15:00:52 <acabot> #endmeeting