14:00:19 <alexchadin> #startmeeting watcher
14:00:20 <openstack> Meeting started Wed Apr 19 14:00:19 2017 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:25 <openstack> The meeting name has been set to 'watcher'
14:00:33 <alexchadin> o/
14:00:35 <sballe_> o/
14:01:21 <alexchadin> Our agenda: https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#04.2F19.2F2017
14:01:46 <alexchadin> #topic Announcements
14:02:00 <alexchadin> Watcher Pike-1 has been released. #link http://lists.openstack.org/pipermail/openstack-dev/2017-April/115470.html
14:02:14 <sballe_> +2 Congrats
14:03:11 <alexchadin> Congratulations to everyone who made it possible :)
14:04:24 <alexchadin> Overview Presentation of Watcher for Pike release is ready to be shared #link https://docs.google.com/presentation/d/1TYdBBd7jEmLlC0kgsh10LfIaRS1pNmmPE-L_2hXQK6Q/edit?usp=sharing
14:04:36 <chrisspencer> o/
14:05:10 <sballe_> alexchadin: I updated the contributor slide and can send it to ou
14:05:16 <sballe_> hi chrisspencer
14:05:25 <alexchadin> sballe_: As I've mentioned before, I've left some first slides AS IS and changed some release-related slides
14:05:34 <sballe_> cool
14:05:35 <alexchadin> hi chrisspencer
14:05:50 <alexchadin> sballe_: it would be great :)
14:05:56 <vincentfrancoise> o/
14:06:02 <alexchadin> hi vincentfrancoise
14:06:08 <vincentfrancoise> sorry for being late
14:06:59 <alexchadin> We have released Pike-1 and overview presentation is almost ready https://docs.google.com/presentation/d/1TYdBBd7jEmLlC0kgsh10LfIaRS1pNmmPE-L_2hXQK6Q/edit?usp=sharing
14:07:06 <alexchadin> chrisspencer, vincentfrancoise ^
14:08:01 <alexchadin> Any other announcements?
14:08:17 <vincentfrancoise> alexchadin: looks good!
14:08:34 <sballe_> alexchadin: do you want to change to the new logos too?
14:08:57 <sballe_> I am happy to help and update the slide set. We could condense some of the TAP stuff that Intel did
14:09:28 <alexchadin> sballe_: what logos do you speak about? Companies?
14:09:37 <sballe_> no the Watcher logo
14:10:03 <sballe_> Is that the latest you sent us?
14:10:06 <sballe_> maybe it is ..
14:10:35 <chrisspencer> alexchadin: I've got an announcement
14:10:36 <alexchadin> sballe_: the last one was the same logo with DRAFT across the image
14:10:50 <sballe_> oh ok ;-)
14:11:00 <alexchadin> chrisspencer: great!
14:11:23 <alexchadin> BTW, don't open presentation in Safari browser, it really looks bad there
14:11:47 <alexchadin> Chrome works great
14:12:13 <chrisspencer> alexchadin:  I am being pulled off of OpenStack work.  For those who don't know Intel and Rackspace decided to end their joint collaboration known as OSIC last week.  I was part of that group and unfortunately will no longer be working on Watcher.
14:12:57 <vincentfrancoise> chrisspencer: Sad to hear :(
14:13:03 <alexchadin> chrisspencer: it is sad
14:13:03 <sballe_> chrisspencer: sorry to see this happening. Hopefully you will be back in a couple of month
14:13:46 <chrisspencer> thank you.  I've had a lot of working working with all of you
14:14:03 <alexchadin> chrisspencer: you've made a lot of great jobs
14:14:13 <sballe_> +2
14:14:21 <chrisspencer> a lot of fun*
14:14:26 <vincentfrancoise> +2
14:14:52 <alexchadin> chrisspencer: don't forget, if you have a chance to return in future, our doors are opened for you
14:14:54 <vincentfrancoise> chrisspencer: when will you actually stop working on Watcher then?
14:15:53 <sballe_> +2 on the retun
14:15:55 <chrisspencer> alexchadin: thank you.  vincentfrancoise: officially I was told to stop working on all openstack work last tuesday.
14:15:57 <sballe_> s/return
14:17:30 <alexchadin> chrisspencer: we will decide who can take your work then
14:17:53 <alexchadin> let's move on to review items
14:18:00 <alexchadin> #topic Review Action Items
14:18:09 <alexchadin> Watcher specs
14:18:18 <alexchadin> Define grammar for workload characterization needs reviews #link https://review.openstack.org/#/c/377100/
14:19:01 <sballe_> I will review
14:19:05 <alexchadin> last two PSs were provided by chrisspencer
14:19:27 <alexchadin> so some should end the work if it needs some fixes
14:19:33 <alexchadin> someone*
14:19:46 <alexchadin> #action sballe_ review https://review.openstack.org/#/c/377100/
14:19:53 <alexchadin> sballe_: thank you
14:21:08 <alexchadin> Spec for noisy-neighbor-dashboard needs new PS #link https://review.openstack.org/#/c/427308/
14:22:05 <alexchadin> vincentfrancoise: couldn't you take it if there is some nits to do left?
14:23:06 <vincentfrancoise> alexchadin: sorry, I can only dedicate some time on reviews
14:23:20 <alexchadin> vincentfrancoise: ah sorry
14:23:36 <alexchadin> #action alexchadin decide who can take https://review.openstack.org/#/c/427308/
14:23:38 <vincentfrancoise> alexchadin: but I can help on doing more at the summit though
14:24:24 <alexchadin> vincentfrancoise: if we won't get some progress here before summit, help is needed then :)
14:25:22 <vincentfrancoise> alexchadin: fine by me :)
14:25:30 <alexchadin> Audit tag in VM Metadata needs final code review #link https://review.openstack.org/#/c/391374/
14:25:52 <alexchadin> sballe_: could you please get final core review?
14:26:04 <sballe_> yes I was just going to suggest that
14:26:12 <alexchadin> great
14:26:31 <alexchadin> #action sballe_ give final review https://review.openstack.org/#/c/391374/
14:26:52 <alexchadin> Add new actions "power on" and "power off" in Watcher needs new PS #link https://review.openstack.org/#/c/435436/
14:27:14 <alexchadin> Yumeng and David are not here
14:27:24 <sballe_> this imply integration with ironin?
14:27:28 <sballe_> s/ironinc
14:27:38 <alexchadin> sballe_: it is one of the part of it
14:27:42 <sballe_> ok
14:28:36 <alexchadin> Noisy Neighbor Strategy needs reviews #link https://review.openstack.org/#/c/398162/
14:30:08 <alexchadin> #action alexchadin review https://review.openstack.org/#/c/398162/
14:30:22 <alexchadin> Add spec for Supporting HA for background jobs in Watcher needs reviews #link https://review.openstack.org/#/c/447996/
14:31:29 <alexchadin> vincentfrancoise started to review it
14:31:50 <vincentfrancoise> alexchadin: put me on https://review.openstack.org/#/c/447996/
14:32:05 <alexchadin> #action vincentfrancoise review https://review.openstack.org/#/c/447996/
14:32:14 <alexchadin> Add spec for cron based continuous audits needs reviews #link https://review.openstack.org/#/c/442388/
14:32:38 <alexchadin> vincentfrancoise: you've also reviewed it some time ago
14:33:33 <alexchadin> #action vincentfrancoise review https://review.openstack.org/#/c/442388/
14:33:43 <alexchadin> Add spec for Cinder model integration needs new PS #link https://review.openstack.org/#/c/450173/
14:34:14 <alexchadin> seems that it is too late for Hidekazu to visit our meeting
14:34:46 <alexchadin> They have 23:34 already
14:34:47 <vincentfrancoise> alexchadin: I did some reviews on his work. LGTM but needs some unittests
14:35:45 <alexchadin> vincentfrancoise: you speak about spec? He has mentioned unit tests in appropriate section
14:36:16 <vincentfrancoise> alexchadin: ah yeah sure my bad :p
14:36:34 <alexchadin> :)
14:36:36 <vincentfrancoise> alexchadin: I was referring on both for the spec part and unittests was for the implem
14:37:11 <alexchadin> sballe_: don't you want to review this spec?
14:37:23 <sballe_> yes
14:37:57 <sballe_> alexchadin: you are talking about he Cinder one.ritgh
14:38:08 <alexchadin> sballe_: yeap
14:38:21 <sballe_> assign me an action ;-)
14:39:35 <alexchadin> #action sballe_ alexchadin review https://review.openstack.org/#/c/450173/
14:39:56 <alexchadin> Build baremetal data model in watcher needs new PS #link https://review.openstack.org/#/c/448016/
14:40:25 <alexchadin> well, Yumeng is still not with us :)
14:40:34 <alexchadin> move on to Watcher
14:40:37 <alexchadin> Watcher
14:40:46 <alexchadin> Add Watcher JobStore for background jobs needs reviews #link https://review.openstack.org/#/c/449659/
14:40:50 <sballe_> alexchadin: quick question
14:41:04 <alexchadin> vincentfrancoise: you know what I would ask ;)
14:41:07 <alexchadin> sballe_: yes?
14:41:12 <sballe_> is Build baremetal data model in watcher needs new PS #link https://review.openstack.org/#/c/448016/ about having Watcher do action on baremetal server
14:41:31 <sballe_> or non virtualized environments?
14:41:32 <vincentfrancoise> alexchadin: please add me on it
14:42:31 <alexchadin> sballe_: if I understand it right, she writes about integration with Ironic
14:42:40 <vincentfrancoise> sballe_: The idea is I think to build a generic baremetal model
14:42:46 <sballe_> oh I see
14:42:51 <alexchadin> sballe_: it means it would be baremetal model
14:43:05 <sballe_> ok but what is the end goal
14:43:20 <alexchadin> #action vincentfrancoise review https://review.openstack.org/#/c/449659/
14:43:23 <vincentfrancoise> sballe_: and then ZTE needs to relate it to Nova to have baremetal-deployed compute nodes that they can power on-off on demand
14:43:40 <sballe_> ok
14:43:48 <vincentfrancoise> sballe_: at least that's my understanding of it
14:44:13 <sballe_> ok
14:45:16 <alexchadin> Add host_aggregates in exclude rule of audit scope needs new PS #link https://review.openstack.org/#/c/457166/
14:45:58 <alexchadin> Add action description needs reviews #link https://review.openstack.org/#/c/450720/
14:47:36 <alexchadin> #action alexchadin review https://review.openstack.org/#/c/450720/
14:47:44 <sballe_> I can review too
14:47:49 <alexchadin> Add ironicclient needs reviews #link https://review.openstack.org/#/c/456996/
14:48:03 <alexchadin> #action sballe_ review https://review.openstack.org/#/c/450720/
14:48:36 <alexchadin> I love clients so I will review it :D
14:49:03 <alexchadin> vincentfrancoise: don't you want?
14:49:34 <sballe_> :)
14:49:47 <vincentfrancoise> alexchadin: I can try :)
14:50:23 <alexchadin> #action vincentfrancoise review https://review.openstack.org/#/c/456996/
14:51:05 <alexchadin> Add action description notification needs reviews #link https://review.openstack.org/#/c/454638/
14:52:22 <alexchadin> #action alexchadin vincentfrancoise review https://review.openstack.org/#/c/454638/
14:52:34 <alexchadin> Noisy Neighbor Strategy needs new PS #link https://review.openstack.org/#/c/454359/
14:53:17 <sballe_> we are working on it.
14:53:23 <sballe_> should be there really soon
14:54:08 <alexchadin> sballe_: should we mark it as WiP or your new PS will be 'ready to review'?
14:54:18 <sballe_> ready to review
14:54:33 <alexchadin> beautiful :)
14:54:34 <sballe_> we are putting some fine tuning on the spec
14:54:43 <sballe_> and/or code
14:55:12 <sballe_> the summit is getting closer ;-)
14:55:16 <alexchadin> sballe_: we are waiting:)
14:55:18 <alexchadin> yeah!
14:55:28 <alexchadin> sballe_: what about non-official part?
14:55:41 <alexchadin> sballe_: I'm about team dining somewhere
14:56:12 <sballe_> I asked for people ot write their name if they could attend: https://etherpad.openstack.org/p/watcher-Boston-meetings
14:56:18 <alexchadin> dinner*
14:56:32 <sballe_> rght now it is just me ;-)
14:57:00 <alexchadin> here we go ;)
14:57:24 <sballe_> I'll find a not too expensive place close to the confernce but would like to know who can attend and any food restrictions
14:57:46 <alexchadin> vincentfrancoise: did acabot stop his work on OpenStack?
14:58:22 <sballe_> alexchadin: thx
14:59:15 <alexchadin> well, let's end our meeting on such tasty point
14:59:22 <alexchadin> thank you for coming
14:59:49 <alexchadin> bye!
14:59:56 <sballe_> bye and thx
15:00:10 <alexchadin> #endmeeting