13:00:06 <alexchadin> #startmeeting watcher
13:00:07 <openstack> Meeting started Wed Aug 2 13:00:06 2017 UTC and is due to finish in 60 minutes. The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:11 <openstack> The meeting name has been set to 'watcher'
13:00:14 <alexchadin> hi
13:00:45 <suzhengwei> hi
13:00:49 <adisky__> hi
13:00:51 <licanwei> hi
13:01:23 <Yumeng__> hi
13:01:41 <alexchadin> let's start!
13:02:26 <alexchadin> but before, I'd like to thank hidekazu for holding previous meeting
13:02:57 <alexchadin> I'm sure, he has done his best :)
13:03:14 <alexchadin> #topic Announcements
13:03:25 <alexchadin> Aditi Sharma is nominated to the core team for Watcher.
13:03:52 <alexchadin> I've sent voting mail to the openstack-dev ML
13:04:03 <alexchadin> please vote +1/-1
13:04:29 <Yumeng__> 👌
13:04:53 <adisky__> Yumeng__: alexchadin Thanks
13:05:28 <alexchadin> adisky__: I wish you good luck!
13:05:44 <alexchadin> We have released Watcher Pike-3, stable Pike branch for watcherclient has been created.
13:06:24 <alexchadin> Yumeng__: do you have installed Horizon?
13:06:40 <Yumeng__> Yes I have
13:07:37 <alexchadin> Yumeng__: could you please test watcher-dashboard along with cron syntax?
13:08:18 <Yumeng__> alexchadin: of course. I will try.
13:09:05 <alexchadin> Yumeng__: thanks a lot
13:09:13 <alexchadin> Pike release candidate will be released on next week. We need to make every effort to review and merge bug fixes.
13:10:08 <alexchadin> Reminder: don't merge any specs or features for now
13:10:55 <alexchadin> We have reached all Pike goals. #link https://governance.openstack.org/tc/goals/pike/index.html
13:11:13 <alexchadin> Congratulations, team!
13:11:29 <licanwei> great!
13:12:12 <licanwei> alexchadin: thank you alexchadin!
13:12:16 <suzhengwei> well done
13:12:41 <alexchadin> thank you, licanwei
13:13:01 <alexchadin> Goals for Queens are ready to be implemented. #link https://governance.openstack.org/tc/goals/queens/index.html
13:13:44 <alexchadin> I've been starting my work on splitting up tempest plugin into watcher-tempest-plugin repo
13:13:57 <alexchadin> so, Register and Document Policy in Code is free to take
13:14:06 <vincentfrancoise> o/
13:14:44 <alexchadin> hi vincentfrancoise
13:16:24 <alexchadin> Don't forget to vote for Watcher presentations #link https://www.openstack.org/summit/sydney-2017/vote-for-speakers/#/19404
13:17:39 <alexchadin> Saving Energy Strategy has been merged. Congratulations Yumeng__ and licanwei!
13:18:32 <Yumeng__> alexchadin: thanks! And thanks hidekazu
13:19:21 <alexchadin> Any other announcements?
13:19:24 <licanwei> thanks all for review:)
13:20:34 <alexchadin> #topic Review Action Items
13:20:37 <alexchadin> Watcher specs
13:21:18 <alexchadin> Although we don't merge them, you can still review specs and they will be merged once it is possible
13:21:41 <alexchadin> cluster-maintenance-strategy needs reviews #link https://review.openstack.org/#/c/464602/
13:23:49 <alexchadin> hidekazu reviews it many times, who wolud like to review it too?
13:23:54 <Yumeng__> +1
13:24:12 <licanwei> specs should change path to Queen
13:24:47 <alexchadin> licanwei: +1
13:24:58 <alexchadin> #action Yumeng__ review https://review.openstack.org/#/c/464602/
13:25:00 <vincentfrancoise> alexchadin: add me on it too
13:25:18 <suzhengwei> thx
13:25:22 <alexchadin> #action vincentfrancoise review https://review.openstack.org/#/c/464602/
13:25:40 <alexchadin> add name for audit probably is ready to be merged in Queens cycle #link https://review.openstack.org/#/c/474865/
13:26:43 <alexchadin> suzhengwei: when we remove all merge restrictions, I'll give W+1 on it
13:27:03 <alexchadin> Add notfications for actionplan cancel probably is ready to be merged in Queens cycle #link https://review.openstack.org/#/c/482902/
13:27:31 <alexchadin> extend-node-status needs to be updated #link https://review.openstack.org/#/c/464549/
13:28:36 <suzhengwei> yes, this need more discussion
13:28:51 <alexchadin> adisky__, Yumeng__ please review it again
13:29:03 <alexchadin> there are your -1's
13:29:08 <adisky__> alexchadin: +1
13:29:26 <Yumeng__> Ok, add me on it.
13:30:12 <alexchadin> #action adisky__ Yumeng__ review https://review.openstack.org/#/c/464549/
13:30:46 <alexchadin> Spec for multi-datasource support needs reviews #link https://review.openstack.org/#/c/467102
13:31:24 <licanwei> +1
13:31:42 <alexchadin> #action licanwei review https://review.openstack.org/#/c/467102
13:31:46 <adisky__> alexchadin: will review it again
13:31:57 <alexchadin> #action adisky__ review https://review.openstack.org/#/c/467102
13:32:13 <alexchadin> Support workload fingerprinting should be taken by sballe_ (in accordance with Ananth Narayan S mail)
13:32:54 <alexchadin> Ananth Narayan S has left Intel and give this BP to sballe_
13:33:01 <alexchadin> sballe_: are you here?
13:34:01 <suzhengwei> It seems he is not here.
13:34:19 <alexchadin> well let's move on
13:34:30 <alexchadin> Watcher
13:34:51 <alexchadin> Validation of states for actionplan delete needs new PS #link https://review.openstack.org/#/c/486007/
13:34:57 <adisky__> alexchadin:
13:35:04 <adisky__> alexchadin: it is abandoned
13:35:28 <adisky__> alexchadin: I have filed a new bp for api validation using json
13:35:30 <alexchadin> oh I see
13:35:52 <adisky__> https://blueprints.launchpad.net/watcher/+spec/api-validation
13:36:00 <alexchadin> adisky__: got it
13:36:10 <alexchadin> refactor action change_nova_service_state needs reviews #link https://review.openstack.org/#/c/474871/
13:38:24 <adisky__> suzhengwei: does it not dependent on extend node status??
13:39:42 <alexchadin> There are lots of bug fixes in openstack/watcher repo, I won't list them here
13:39:44 <suzhengwei> it dependents
13:40:16 <alexchadin> just check them out time by time and review
13:40:48 <adisky__> alexchadin: ok
13:41:02 <alexchadin> I think that's all for today
13:41:29 <suzhengwei> some commits need more review
13:41:58 <alexchadin> We have some time to make Watcher more stable, let's use this opportunity
13:42:09 <suzhengwei> Fix compute CDM to include disabled compute node https://review.openstack.org/#/c/489440/
13:42:48 <suzhengwei> I think this is important for watcher usage.
13:43:24 <alexchadin> +1
13:43:53 <alexchadin> let's end up this meeting
13:44:18 <alexchadin> thank you for coming!
13:44:27 <suzhengwei> bye
13:44:29 <vincentfrancoise> bye
13:44:32 <licanwei> bye
13:44:33 <Yumeng__> Bye
13:44:47 <alexchadin> #endmeeting