08:00:04 <alexchadin> #startmeeting watcher
08:00:05 <openstack> Meeting started Wed Feb 14 08:00:04 2018 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:09 <openstack> The meeting name has been set to 'watcher'
08:00:32 <alexchadin> hi
08:00:37 <hidekazu> hi
08:00:47 <watanabe_isao> good afternoon
08:01:00 <alexchadin> is it better time for you?:)
08:01:21 <watanabe_isao> alexchadin, yes. Thanks for the help. :)
08:01:35 <hidekazu> alexchadin: healthier time
08:02:34 <alexchadin> agree. it's 11:00 in Moscow and taking meeting earlier is better than later in the evening
08:03:06 <hidekazu> alexchadin: both happy, great.
08:03:43 <alexchadin> we have the following agenda today: https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#02.2F14.2F2018
08:03:51 <alexchadin> #topic Announcements
08:04:21 <alexchadin> Watcher has got stable/queens branch
08:04:26 <alexchadin> finally!
08:04:44 <alexchadin> IMHO it's more stable release than pike
08:05:03 <watanabe_isao> Congratulations!
08:05:57 <alexchadin> We are still working on adding PTG topics here. Please, add something you'd like to discuss.
08:05:59 <adisky__> hi all
08:06:01 <alexchadin> https://etherpad.openstack.org/p/rocky-watcher-ptg
08:06:03 <alexchadin> hi adisky__
08:06:14 <hidekazu> adisky__: hi
08:06:23 <watanabe_isao> hi adisky__
08:06:36 <alexchadin> adisky__: we will have meetings on odd week at 08:00 from today
08:06:45 <alexchadin> 08:00 UTC
08:07:09 <adisky__> alexchadin: ya i was aware, but i thought it will start from later week
08:08:07 <alexchadin> I'll still continue to add blueprints to discuss
08:08:38 <alexchadin> I've had a discussion with my manager and cloud architect
08:09:25 <alexchadin> Having affinity/anti-affinity filters (like it's done in Nova) is the number one request from customers
08:11:01 <adisky__> alexchadin: +1
08:11:41 <adisky__> alexchadin: so are you going to propose a strategy, or something in watcher-applier for it??
08:12:01 <alexchadin> I think it's not about strategy
08:12:01 <watanabe_isao> alexchadin,  I'm not quite understand about the request, is there any docs?
08:12:24 <alexchadin> this filters should be taken into account when we migrate virtual machines between nodes
08:12:54 <adisky__> alexchadin: i think, it would be like some restrictions like this two vm's should be on same node
08:13:24 <alexchadin> adisky__: yeah, or like this two vm's should never been on the same node
08:13:39 <alexchadin> be*
08:14:03 <adisky__> alexchadin: yea, so how do we now that this two resources have affinity or anti-affinity??
08:14:30 <adisky__> alexchadin: cloud admin will provide some input, or tagging in metadata??
08:16:54 <alexchadin> adisky__: I suppose it comes whether with the request to create several vms or with metadata tagging
08:17:07 <adisky__> alexchadin: ok
08:17:33 <alexchadin> I'll add this question to the PTG agenda
08:17:42 <alexchadin> the next announcement
08:17:43 <alexchadin> Odd weekly meeting time has been set on 08:00 UTC.
08:18:01 <alexchadin> as you already know :)
08:18:45 <alexchadin> any other announcements?
08:21:01 <watanabe_isao> alexchadin, I have created a local UT server. Watcher server is still pending. Will start to touch watcher in next 2 weeks. :) self-announcement.
08:21:58 <alexchadin> what version of openstack do you use?
08:22:05 <alexchadin> watanabe_isao: ^
08:22:56 <watanabe_isao> alexchadin, pike?  cc: hidekazu
08:24:03 <watanabe_isao> hidekazu, ^ is just a local environment, not the one we are going to build. But is pike OK?
08:24:32 <hidekazu> watanabe_isao: what do you mean  "pike?"
08:24:34 <alexchadin> watanabe_isao: take a look at this patch
08:24:38 <alexchadin> https://review.openstack.org/#/c/543925/
08:26:00 <alexchadin> before you install watcher, restrict networkx <2.0 version
08:26:33 <watanabe_isao> alexchadin, thanks for the information.
08:27:46 <alexchadin> let's move on
08:27:52 <alexchadin> #topic Review Action Items
08:27:53 <watanabe_isao> hidekazu, I would like to build a watcher test environment in my laptop, just want to practice APIs. Is pike OK?
08:27:57 <alexchadin> Blueprint/Bug Review and Discussion
08:28:07 <alexchadin> add resource name in action input bp should be discussed. https://blueprints.launchpad.net/watcher/+spec/add-resource-name-in-action-input-parameter-filed
08:28:31 <hidekazu> watanabe_isao: it should be OK
08:28:43 <watanabe_isao> alexchadin, sorry, please move on. hidekazu, got it.
08:29:55 <alexchadin> Unfortunately, Yumeng Bao hasn't come to meeting
08:31:29 <alexchadin> if I get it right, she wants to show resource name (like vm name) in action description
08:32:21 <watanabe_isao> maybe we should add him/her as the reviewers of https://review.openstack.org/#/c/543398/
08:32:57 <hidekazu> alexchadin: add name for resource_id ? https://github.com/openstack/watcher/blob/master/watcher/applier/actions/base.py#L34
08:33:15 <alexchadin> hidekazu: probably
08:33:26 <hidekazu> maybe she is in vacation already.
08:33:34 <alexchadin> ah
08:33:40 <alexchadin> Chinese New Year!
08:34:01 <watanabe_isao> alexchadin, yes. tomorrow evening.
08:34:07 <alexchadin> I've completely forgotten about it
08:35:58 <hidekazu> we have action name description, i am not sure why we should add resource name to resource id.
08:36:55 <alexchadin> hidekazu: that's why we should get description of this BP from her
08:37:47 <hidekazu> alexchdin: we can get answer at ptg.
08:39:21 <alexchadin> hidekazu: yeap
08:39:30 <alexchadin> Watcher (we don't merge BP's commits until rocky cycle)
08:39:40 <alexchadin> create audit failed needs reviews #link https://review.openstack.org/#/c/530105/
08:40:13 <alexchadin> hidekazu, watanabe_isao: your reviews are appreciate
08:41:18 <hidekazu> alexchadin: i will review
08:41:32 <watanabe_isao> alexchadin, sure
08:42:26 <alexchadin> thanks!
08:42:37 <alexchadin> #action watanabe_isao hidekazu review https://review.openstack.org/#/c/530105/
08:42:49 <alexchadin> filter exclude instances during migration needs reviews #link https://review.openstack.org/#/c/508108/
08:44:06 <hidekazu> alexchadin: i feel i should
08:45:13 <alexchadin> hidekazu: I'll review it too
08:45:36 <alexchadin> #action alexchadin hidekazu review https://review.openstack.org/#/c/508108/
08:45:43 <hidekazu> alexchadin: thanks.
08:45:57 <alexchadin> and there are some bugs
08:46:26 <watanabe_isao> I wish I can get level up after this mission. : )
08:46:38 <alexchadin> I don't think we need to discuss them here, committers are already submitting new PS
08:47:28 <alexchadin> watanabe_isao: open source is one of the best places to get level up :)
08:47:47 <watanabe_isao> alexchadin, what is PS?
08:49:34 <alexchadin> watanabe_isao: patch set
08:51:05 <watanabe_isao> alexchadin, I see
08:51:12 <alexchadin> well, seems that it's done
08:51:22 <alexchadin> let's end up this meeting?
08:52:37 <hidekazu> yeah, thanks!
08:53:08 <adisky__> Bye everyone!!!!!
08:53:17 <alexchadin> bye!
08:53:24 <alexchadin> #endmeeting