08:00:23 <alexchadin> #startmeeting watcher
08:00:25 <openstack> Meeting started Wed Mar 14 08:00:23 2018 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:29 <openstack> The meeting name has been set to 'watcher'
08:00:45 <alexchadin> hi!
08:00:58 <licanwei> hi~
08:01:30 <alexchadin> our agenda: https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#03.2F14.2F2018
08:01:34 <alexchadin> licanwei: how are you?
08:02:29 <licanwei> alexchadin: i'm fine, thanks
08:04:06 <licanwei> anyone else?
08:05:07 <adisky__> hi
08:05:10 <alexchadin> licanwei: I've invited Aditi and Yumeng, Hidekazu is offline
08:05:16 <alexchadin> adisky__: hi
08:06:51 <Yumeng> hi
08:06:55 <alexchadin> hi Yumeng
08:07:36 <alexchadin> adisky__, Yumeng was your flight back fine?
08:08:25 <adisky__> alexchadin: ya it was mostly fine delayed though!
08:08:27 <Yumeng> Yumeng: Really tiring.... Finally went back on Sun morning.
08:08:39 <adisky__> alexchadin: what about you?
08:10:09 <alexchadin> adisky__: my flight DUB-FRA had been delayed and I was late for FRA-DME!
08:10:51 <alexchadin> adisky__: fortunately, lufthansa has changed my flight and I made it by Aeroflot in 1:40 hours :D
08:11:11 <adisky__> alexchadin: great
08:11:21 <alexchadin> so, let's start
08:11:26 <alexchadin> #topic Announcements
08:11:34 <alexchadin> We have got through the blueprints and bugs. There are 17 actual bugs and 16 blueprints targeted to Rocky cycle.
08:12:11 <alexchadin> I've invited Egor Panfilov to Watcher, he will help us with Watcher bugs at least
08:12:25 <Yumeng> great!
08:13:26 <alexchadin> I'm trying to stabilize tempest-plugin, I propose to make it voting once it's merged. #link https://review.openstack.org/#/c/549062/
08:14:59 <alexchadin> zuulv3 migration patch should ready soon as well. #link https://review.openstack.org/#/c/551790/
08:15:38 <alexchadin> these two patches are related
08:15:43 <alexchadin> to each other
08:18:01 <alexchadin> any other announcements/questions about zuulv3/tempest?
08:19:18 <Yumeng> Nope
08:20:59 <alexchadin> I'd like to ask you about privileges to make one person merges of these patches since they are placed in different repos
08:21:31 <alexchadin> once zuulv3 job is stable and tested at least one week, we can make it voting
08:23:52 <alexchadin> #topic Review Action Items
08:23:58 <alexchadin> Blueprint/Bug Review and Discussion
08:24:30 <alexchadin> HA blueprint and Event-driven optimization based blueprint should be reviewed and implemented by as many as possible watcher members.
08:24:49 <alexchadin> #link https://blueprints.launchpad.net/watcher/+spec/support-watcher-ha-active-active-mode #link https://blueprints.launchpad.net/watcher/+spec/event-driven-optimization-based
08:25:28 <alexchadin> licanwei, adisky__, Yumeng are you agree?
08:25:46 <adisky__> alexchadin: i didn't get it??
08:26:51 <alexchadin> HA and event-driven opt specs and implementation should be discussed and reviewed by all active watcher member
08:26:54 <alexchadin> adisky__: ^
08:26:56 <Yumeng> alexchadin: yeah we may need find sometime to discuss HA
08:27:09 <Yumeng> alexchadin: I agree.
08:27:14 <alexchadin> Yumeng: we have already done it during PTG
08:27:38 <alexchadin> Yumeng: now our discussion may continue in spec context since licanwei already proposed one
08:27:52 <Yumeng> I wasn't there, right?
08:27:52 <alexchadin> Yumeng: https://review.openstack.org/#/c/549706/
08:28:30 <alexchadin> Yumeng: yeah, it was third day, you were cold
08:28:37 <Yumeng> alexchadin: ok.
08:28:56 <Yumeng> alexchadin: I will review
08:30:28 <alexchadin> #action Yumeng review https://review.openstack.org/#/c/549706/
08:30:40 <alexchadin> Watcher specs
08:30:51 <alexchadin> Exclude Project By Audit Scope needs reviews #link https://review.openstack.org/#/c/546960/
08:30:54 <licanwei> alexchadin: where can i see your discussion conclusion?
08:31:24 <alexchadin> licanwei: I will add it to HA blueprint
08:31:47 <licanwei> alexchadin: OK, thanks
08:32:17 <alexchadin> licanwei: usually we left comments here https://etherpad.openstack.org/p/rocky-watcher-ptg or under appropriate blueprint/bug on whiteboard
08:33:54 <alexchadin> who would like to review Exclude Project By Audit Scope?
08:34:14 <licanwei> alexchadin: +1
08:35:33 <alexchadin> #action licanwei alexchadin review https://review.openstack.org/#/c/546960/
08:35:46 <alexchadin> Add replace cold migration to use nova API spec needs reviews #link https://review.openstack.org/#/c/551851/
08:36:55 <licanwei> alexchadin: +1
08:36:59 <alexchadin> I take it, who else?
08:37:02 <alexchadin> licanwei: thanks!
08:39:03 <alexchadin> #action alexchadin licanwei review https://review.openstack.org/#/c/551851/
08:39:16 <alexchadin> Add the start and end time for CONTINUOUS audit needs reviews #link https://review.openstack.org/#/c/551058/
08:39:27 <Yumeng> +1
08:39:43 <alexchadin> adisky__: would you like to take it?
08:39:50 <alexchadin> Yumeng: thanks!
08:39:53 <adisky__> alexchadin: +1
08:41:32 <alexchadin> thanks!
08:41:50 <alexchadin> #action adisky__ Yumeng alexchadin review https://review.openstack.org/#/c/551058/
08:42:02 <alexchadin> Enhance Watcher workflow Engine needs reviews #link https://review.openstack.org/#/c/551861/
08:42:47 <Yumeng> +1
08:43:05 <alexchadin> #action alexchadin Yumeng https://review.openstack.org/#/c/551861/
08:43:11 <alexchadin> #action alexchadin Yumeng review https://review.openstack.org/#/c/551861/
08:43:28 <alexchadin> Support Watcher HA active-active Mode needs reviews #link https://review.openstack.org/#/c/549706/
08:44:48 <Yumeng> add me
08:44:56 <Yumeng> I would like to
08:45:31 <alexchadin> #action adisky__ Yumeng alexchadin review https://review.openstack.org/#/c/549706/
08:45:46 <alexchadin> Watcher
08:46:01 <alexchadin> We can continue to merge commits since Rocky cycle has started
08:46:18 <alexchadin> add strategy host_maintenance should be updated to fix jobs issues #link https://review.openstack.org/#/c/479200/
08:46:31 <alexchadin> filter exclude instances during migration needs reviews #link https://review.openstack.org/#/c/508108/
08:47:18 <alexchadin> #action alexchadin review https://review.openstack.org/#/c/508108/
08:47:28 <alexchadin> Watcher Bug Fixes
08:47:42 <alexchadin> create audit failed needs new PS #link https://review.openstack.org/#/c/530105/
08:49:00 <alexchadin> Fix sort of audit templates by goal name needs new PS #link https://review.openstack.org/#/c/552534/
08:49:06 <alexchadin> Egor will provide new PS soon
08:50:44 <alexchadin> seems that's all for today
08:52:01 <alexchadin> end up this meeting?
08:52:24 <alexchadin> a lot of work to do :)
08:53:52 <alexchadin> thank you for coming!
08:54:48 <licanwei> alexchadin: thanks~
08:54:59 <alexchadin> bye!
08:55:22 <alexchadin> #endmeeting