14:00:09 <alexchadin> #startmeeting watcher
14:00:10 <openstack> Meeting started Wed Mar 21 14:00:09 2018 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <openstack> The meeting name has been set to 'watcher'
14:00:20 <alexchadin> hi
14:00:46 <alexchadin> Agenda: https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#03.2F21.2F2018
14:00:50 <Yumeng__> hi
14:01:27 <alexchadin> Yumeng__: hi
14:01:56 <suzhengwei> hi
14:02:05 <alexchadin> suzhengwei: hi
14:02:31 <alexchadin> let's wait for additional 5 minutes?
14:02:43 <suzhengwei> ok
14:02:51 <Yumeng__> No pb
14:02:51 <alexchadin> suzhengwei, Yumeng__ how are you?
14:02:58 <Yumeng__> good
14:03:05 <suzhengwei> fine
14:03:17 <Yumeng__> BTW did you get feedback from aditi?
14:04:18 <alexchadin> Yumeng__: nope, I propose you to send a confirmation mail to Anne (and cc Kendall). We will add Aditi later if she would like to
14:04:50 <Yumeng__> Ok then I will confirm after meeting
14:05:16 <alexchadin> Yumeng__: thanks
14:05:37 <alexchadin> well, let's begin
14:05:44 <alexchadin> #topic Announcements
14:05:51 <alexchadin> watcher-tempest-plugin has been stabilised and will be turned into zuulv3 job soon.
14:06:15 <alexchadin> say welcome back to our tempest tests! :)
14:07:21 <suzhengwei> good news
14:07:36 <alexchadin> Watcher will have functional job for each strategy once zuulv3 patch is merged #link https://review.openstack.org/#/c/551790/
14:08:11 <alexchadin> I'm trying to fix it, hope to end up with it soon
14:08:44 <alexchadin> OpenStack-wide goals should be represented as bugs cause they are clear and have redundant description #link https://governance.openstack.org/tc/goals/#release-cycles
14:10:28 <alexchadin> I'll register them
14:10:43 <alexchadin> #action alexchadin register openstack-wide goals as bugs
14:10:51 <alexchadin> #action Review Action Items
14:10:55 <alexchadin> #redo
14:11:00 <alexchadin> #undo
14:11:01 <openstack> Removing item from minutes: #action Review Action Items
14:11:13 <alexchadin> #topic Review Action Items
14:11:20 <alexchadin> Blueprint/Bug Review and Discussion
14:11:30 <alexchadin> sync datamodel before audit execution has been registered #link https://blueprints.launchpad.net/watcher/+spec/sync-datamodel-before-audit-execution
14:12:37 <alexchadin> well, I'm not sure that we need additional way to sync DEs
14:13:33 <alexchadin> I have a patch here: https://review.openstack.org/#/c/551963/ and it adds DEs into one pool, that is connected to versioned notification topic of nova
14:14:25 <alexchadin> you may try this patch in your own env, it makes broadcast notifications
14:14:55 <suzhengwei> sync datamodel before audit execution will bring more pressure to Nova APIs.
14:15:08 <alexchadin> suzhengwei: yes
14:15:44 <alexchadin> suzhengwei: unfortunately, licanwei isn't here so we can't discuss it right now
14:16:25 <Yumeng__> sync datamodel could be useful for watcher HA.
14:16:39 <suzhengwei> I think this is about desion-engine ha problem.
14:16:47 <alexchadin> Yumeng__: yes and we can achieve it by listening to notifications
14:17:28 <alexchadin> Yumeng__: we can broadcast notifications from Nova to DEs using this patch https://review.openstack.org/#/c/551963/
14:18:45 <alexchadin> so any discussions here or we can continue?
14:19:40 <Yumeng__> Pls continue, maybe we can discuss more tomorrow in our channel
14:19:55 <alexchadin> ok
14:20:02 <alexchadin> Watcher specs
14:20:08 <suzhengwei> cycle sync and notifications seems reliable to me
14:20:18 <alexchadin> Add team priorities for Rocky should be reviewed by Yumeng Bao #link https://review.openstack.org/#/c/551914/
14:20:20 <alexchadin> suzhengwei: +1
14:20:50 <alexchadin> Yumeng__: your final vote is required here :)
14:21:04 <Yumeng__> Ops
14:21:13 <Yumeng__> I will vote
14:23:13 <alexchadin> #action Yumeng__ review https://review.openstack.org/#/c/551914/
14:23:28 <alexchadin> Support Watcher HA active-active Mode needs new PS #link https://review.openstack.org/#/c/549706/
14:24:17 <alexchadin> Yumeng__: please take a look at this spec and especially comments
14:25:46 <suzhengwei> I review it yestoday. I think it is not a complete solution.
14:25:54 <Yumeng__> Yeah I have reviewed this afternoon and see your comments Note 3
14:26:07 <suzhengwei> It need more discuss.
14:26:20 <Yumeng__> Yeah agree
14:27:06 <alexchadin> suzhengwei: of course, more problems should be represented there
14:27:30 <alexchadin> Add the start and end time for CONTINUOUS audit needs new PS #link https://review.openstack.org/#/c/551058/
14:27:48 <alexchadin> suzhengwei: would you like to review it?
14:28:06 <suzhengwei> yes.
14:28:43 <alexchadin> thanks
14:28:55 <alexchadin> #action suzhengwei review https://review.openstack.org/#/c/551058/
14:29:11 <alexchadin> Exclude Project By Audit Scope needs new PS #link https://review.openstack.org/#/c/546960/
14:29:26 <alexchadin> Yumeng__, suzhengwei would you like to review it?
14:29:38 <suzhengwei> I will
14:30:00 <Yumeng__> Ok
14:32:17 <alexchadin> #action Yumeng__ suzhengwei review https://review.openstack.org/#/c/546960/
14:32:27 <alexchadin> Add replace cold migration to usenova API spec needs reviews #link https://review.openstack.org/#/c/551851/
14:33:39 <alexchadin> I've already reviewed it
14:34:29 <suzhengwei> interested of it. add me
14:34:48 <alexchadin> #action suzhengwei review https://review.openstack.org/#/c/551851/
14:34:58 <alexchadin> Enhance Watcher workflow Engine needs reviews #link https://review.openstack.org/#/c/551861/
14:35:02 <alexchadin> I will take it
14:35:12 <alexchadin> #action alexchadin review https://review.openstack.org/#/c/551861/
14:35:16 <alexchadin> Watcher
14:35:25 <alexchadin> add strategy host_maintenance should be updated to fix jobs issues #link https://review.openstack.org/#/c/479200/
14:35:57 <suzhengwei> I will
14:36:12 <alexchadin> suzhengwei: thanks
14:36:26 <alexchadin> filter exclude instances during migration needs reviews #link https://review.openstack.org/#/c/508108/
14:36:42 <alexchadin> suzhengwei: I will review it with new functional tests
14:36:54 <alexchadin> suzhengwei: just to make sure that it works fine
14:37:04 <suzhengwei> thx
14:37:22 <alexchadin> Watcher Bug Fixes
14:37:31 <alexchadin> create audit failed needs new PS #link https://review.openstack.org/#/c/530105/
14:39:03 <alexchadin> watcher docs should be updated. as we have discussed during the PTG, documentation regarding strategies should be updated #link https://bugs.launchpad.net/watcher/+bug/1757423
14:39:04 <openstack> Launchpad bug 1757423 in watcher "watcher docs should be updated" [Undecided,New]
14:40:27 <alexchadin> Fix sort of *list command output needs reviews #link https://review.openstack.org/#/c/552534/
14:41:01 <alexchadin> Yumeng__: will you take it?
14:42:51 <alexchadin> suzhengwei: what about you?
14:43:31 <Yumeng__> alexchadin: add me
14:43:48 <alexchadin> #action Yumeng__ review https://review.openstack.org/#/c/552534/
14:44:01 <alexchadin> well, seems that's all
14:44:23 <alexchadin> is there anything you'd like to discuss?
14:44:32 <suzhengwei> yes
14:44:48 <suzhengwei> https://etherpad.openstack.org/p/unfriendly-table-of-apscheduler-jobs
14:46:10 <alexchadin> suzhengwei: this table isn't for users, only for developers
14:48:32 <suzhengwei> Do you think it is intuitive to developers? It takes me many days to study apscheduler
14:49:27 <alexchadin> suzhengwei: you may register it as a bug and we will find out what can be done here
14:49:30 <suzhengwei> so I think there may be improvement about this
14:49:46 <suzhengwei> yes
14:49:51 <alexchadin> thanks
14:50:02 <alexchadin> thank you for attending!
14:50:07 <alexchadin> bye!
14:50:11 <suzhengwei> bye
14:50:19 <Yumeng__> bye
14:50:41 <alexchadin> #endmeeting watcher