08:00:10 <alexchadin> #startmeeting watcher
08:00:11 <openstack> Meeting started Wed Mar 28 08:00:10 2018 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:14 <openstack> The meeting name has been set to 'watcher'
08:00:39 <alexchadin> morning folks
08:01:51 <licanwei> alexchadin: hi
08:01:54 <alexchadin> licanwei: hi
08:01:57 <hidekazu> hi
08:02:01 <alexchadin> licanwei: how are you?
08:02:04 <alexchadin> hidekazu: hi!
08:02:24 <licanwei> alexchadin: fine, and you?
08:02:46 <alexchadin> licanwei: better than in last weeks :)
08:03:05 <licanwei> alexchadin: :)
08:03:51 <licanwei> hidekazu: hi~
08:04:13 <hidekazu> licanwei: ~
08:04:31 <alexchadin> #topic Announcements
08:04:43 <alexchadin> Aditi Sharma and Yumeng Bao will take Watcher Project Update on Vancouver Summit!
08:05:12 <alexchadin> licanwei hidekazu do you plan to be there?
08:05:22 <alexchadin> Unfortunately, I won't be there
08:05:32 <hidekazu> alexchadin: i am not sure. maybe not.
08:06:57 <licanwei> alexchadin: I won't be there, too
08:07:22 <alexchadin> ah, it's so far...
08:08:07 <alexchadin> All watcher jobs have been migrated to zuulv3 syntax. Rest of strategy scenarios should be delivered during this cycle.
08:08:54 <alexchadin> There are last some nits with watcherclient job, hope to fix it today
08:09:06 <hidekazu> alexchadin: thanks
08:10:17 <licanwei> alexchadin: great!
08:10:25 <alexchadin> as we have discussed on PTG, here is the list of assignments to scenario jobs:
08:10:49 <alexchadin> licanwei: I propose you to take some strategy to implement its scenario job
08:11:21 <licanwei> alexchadin: ok
08:11:46 <alexchadin> workload stabilization job has already been done, I plan to take outlet_temp_control strategy
08:12:21 <alexchadin> Yumeng: hi, are you here?
08:12:28 <Yumeng> yes
08:12:37 <alexchadin> Yumeng: hi!
08:12:44 <Yumeng> hi
08:13:33 <alexchadin> should be provide either blueprint for each scenario job or bug?
08:14:15 <adisky__> hi all
08:14:22 <adisky__> sorry for joining late
08:14:47 <hidekazu> alexchadin: for tracking implementing scenario job, it is good to register blueprint.
08:15:29 <adisky__> hidekazu: +1
08:15:48 <Yumeng> alexchadin,hidekazu: agree. we can propose one blueprint for all scenarios
08:16:04 <alexchadin> hidekazu: +1
08:16:25 <alexchadin> Who'd like to register it?
08:16:41 <Yumeng> I can hel[
08:16:44 <Yumeng> help
08:16:50 <alexchadin> Yumeng: thanks
08:17:16 <alexchadin> #action Yumeng register blueprint to track scenarios jobs
08:17:18 <Yumeng> :)
08:17:28 <alexchadin> adisky__: hi!
08:17:34 <alexchadin> any other announcements?
08:17:53 <alexchadin> adisky__ Yumeng congratulations with taking Watcher Project Update! :)
08:18:10 <adisky__> alexchadin: thanks
08:19:50 <alexchadin> let's move on
08:20:05 <alexchadin> #topic OpenStack-wide Goals
08:20:19 <alexchadin> Enable mutable configuration is assigned to Egor Panfilov. We have to track this goal via storyboard #link https://storyboard.openstack.org/#!/story/2001545
08:20:37 <alexchadin> there should be pretty trivial fix
08:21:25 <alexchadin> Remove Use of mox/mox3 for Testing should be assigned and fixed in watcher-dashboard #link https://bugs.launchpad.net/watcher/+bug/1758388
08:21:26 <openstack> Launchpad bug 1758388 in watcher "Remove Use of mox/mox3 for Testing" [High,Triaged]
08:21:36 <alexchadin> who'd like to take this one?
08:24:02 <licanwei> alexchadin: me
08:24:29 <alexchadin> licanwei: you're in
08:24:42 <alexchadin> #action licanwei implement https://bugs.launchpad.net/watcher/+bug/1758388
08:24:43 <openstack> Launchpad bug 1758388 in watcher "Remove Use of mox/mox3 for Testing" [High,Triaged] - Assigned to licanwei (li-canwei2)
08:24:53 <alexchadin> licanwei: thank you!
08:25:06 <alexchadin> #Review Action Items
08:25:10 <alexchadin> #topic Review Action Items
08:25:15 <alexchadin> Watcher specs
08:25:22 <alexchadin> Exclude Project By Audit Scope needs to be updated #link https://review.openstack.org/#/c/546960/
08:25:32 <alexchadin> adisky__: Yumeng left some comments for you
08:27:05 <adisky__> alexchadin: sure, i will update
08:27:18 <adisky__> Yumeng: help me out in updating watcher dashboard :0
08:27:36 <Yumeng> adisky__:ok no pb
08:28:12 <alexchadin> #action adisky__ update https://review.openstack.org/#/c/546960/
08:28:32 <alexchadin> Add team priorities for Rocky has been merged #link https://review.openstack.org/#/c/551914/
08:29:21 <alexchadin> sometimes we approve additional 1-3 blueprints during the cycle, I suppose it's ok
08:29:41 <hidekazu> tracking scenario jobs bp will be added though.
08:29:46 <alexchadin> hidekazu: +1
08:30:14 <alexchadin> and Egor Panfilov will take one of my blueprints
08:30:42 <alexchadin> he consults with me about it, of course
08:31:43 <alexchadin> Support Watcher HA active-active Mode needs new PS #link https://review.openstack.org/#/c/549706/
08:32:19 <alexchadin> licanwei: we definitely need new PS that takes into account out comments
08:32:45 <licanwei> alexchadin: yea, I'll update
08:33:07 <alexchadin> licanwei: thank you
08:33:22 <alexchadin> #action licanwei submit new PS https://review.openstack.org/#/c/549706/
08:33:44 <alexchadin> Add the start and end time for CONTINUOUS audit needs new PS #link https://review.openstack.org/#/c/551058/
08:34:32 <licanwei> alexchadin: I'll update this bp, too
08:35:00 <alexchadin> #action licanwei submit new ps https://review.openstack.org/#/c/551058/
08:35:04 <alexchadin> Add replace cold migration to use nova API spec #link https://review.openstack.org/#/c/551851/
08:35:11 <alexchadin> has been merged
08:35:35 <hidekazu> thanks reviewing.
08:37:10 <alexchadin> Enhance Watcher workflow Engine needs reviews #link https://review.openstack.org/#/c/551861/
08:37:35 <alexchadin> licanwei: I'll review it soon since I definitely have questions about it
08:37:57 <licanwei> alexchadin: thanks!
08:38:26 <alexchadin> who'd like to review it too?
08:38:40 <suzhengwei> +1
08:39:13 <alexchadin> #action alexchadin suzhengwei review https://review.openstack.org/#/c/551861/
08:39:24 <adisky__> +1
08:39:37 <alexchadin> #action adisky__ review https://review.openstack.org/#/c/551861/
08:39:43 <alexchadin> Watcher
08:39:53 <alexchadin> Replace cold migration to use Nova migration API needs new PS #link https://review.openstack.org/#/c/555665/
08:40:38 <hidekazu> i will update
08:41:12 <alexchadin> hidekazu: thanks
08:41:20 <alexchadin> #action hidekazu https://review.openstack.org/#/c/555665/
08:42:32 <alexchadin> add strategy host_maintenance should be updated to fix jobs issues #link https://review.openstack.org/#/c/479200/
08:42:45 <suzhengwei> I will
08:44:04 <alexchadin> #action suzhengwei review https://review.openstack.org/#/c/479200/
08:44:09 <alexchadin> #undo
08:44:10 <openstack> Removing item from minutes: #action suzhengwei review https://review.openstack.org/#/c/479200/
08:44:19 <alexchadin> #action suzhengwei submit new PS https://review.openstack.org/#/c/479200/
08:44:48 <alexchadin> filter exclude instances during migration needs final core review #link https://review.openstack.org/#/c/508108/
08:45:25 <alexchadin> I will review
08:45:45 <suzhengwei> thanks
08:45:49 <licanwei> alexchadin: +1
08:46:10 <alexchadin> hidekazu adisky__ Yumeng what about you?
08:46:34 <Yumeng> +1
08:46:40 <hidekazu> alexchadin: yes, i will review it.
08:47:08 <alexchadin> #action alexchadin licanwei Yumeng hidekazu review https://review.openstack.org/#/c/508108/
08:47:31 <alexchadin> Watcher Bug Fixes
08:47:44 <alexchadin> add lower-constraints job needs reviews #link https://review.openstack.org/#/c/556286/
08:47:52 <alexchadin> Update links in README needs reviews #link https://review.openstack.org/#/c/551708/
08:47:59 <alexchadin> create audit failed needs new PS #link https://review.openstack.org/#/c/530105/
08:48:07 <alexchadin> Fix sort of *list command output needs reviews #link https://review.openstack.org/#/c/552534/
08:48:22 <alexchadin> please review it once you have some free time
08:50:39 <alexchadin> so any other discussions? :)
08:51:29 <alexchadin> we have good activity so far, let's keep it well
08:52:14 <hidekazu> bye
08:53:23 <alexchadin> thank you for attending!
08:53:27 <alexchadin> bye!
08:54:31 <suzhengwei> bye
08:54:57 <licanwei> bye~
08:56:15 <alexchadin> #endmeeting