08:00:19 <alexchadin> #startmeeting watcher
08:00:19 <openstack> Meeting started Wed Apr 11 08:00:19 2018 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:23 <openstack> The meeting name has been set to 'watcher'
08:00:28 <alexchadin> greetings!
08:00:33 <adisky__> hi
08:00:46 <licanwei> hi
08:00:52 <hidekazu> hi
08:01:21 <alexchadin> our agenda: https://wiki.openstack.org/wiki/Watcher_Meeting_Agenda#04.2F11.2F2018
08:01:56 <alexchadin> as some of you have already known, I plan to add blueprint regarding watcher filters
08:02:28 <alexchadin> #topic Open Discussions
08:02:35 <alexchadin> alexchadin proposes to add filtering mechanism with at least affinity/anti-affinity, HA/AZ filters.
08:03:06 <alexchadin> my manager and customers requests this mechanism to respect Nova's filters
08:03:15 <hidekazu> alexchadin: can we use the filter for audit scope as well?
08:03:16 <alexchadin> during live-migration
08:03:22 <hidekazu> sorry ,go on.
08:03:34 <alexchadin> hidekazu: along with, I suppose
08:03:38 <adisky__> its great
08:03:53 <hidekazu> alexchadin: nice.
08:03:55 <Yumeng> hi
08:04:01 <alexchadin> filters should be implemented as additional part of strategy's workflow
08:04:05 <alexchadin> Yumeng: hi!
08:04:09 <hidekazu> Yumeng: hello
08:04:12 <adisky__> Yumeng: hi
08:04:20 <Yumeng> hi all!
08:04:45 <Yumeng> pls go on
08:05:05 <Yumeng> sorry for late
08:05:14 <hidekazu> alexchadin: you mean workflow engine?
08:05:29 <alexchadin> sorry for delaying
08:05:51 <alexchadin> hidekazu: no, during execution of strategy
08:06:09 <hidekazu> alexchadin: ok
08:06:32 <alexchadin> when we choose what instances where should we move
08:07:00 <alexchadin> strategies should be reworked to support filters and to save backward compatibility
08:07:30 <alexchadin> I've come to this decision as trade-off between architectural design and business requirements
08:08:05 <alexchadin> I submit spec soon (by EOW) and we will discuss it there in details
08:09:14 <alexchadin> watcher scope and watcher filters will live together since their goals are different
08:09:42 <hidekazu> yes, i agree.
08:10:47 <alexchadin> well, any other discussions or announcements?
08:11:08 <alexchadin> oh, I'm preparing API reference that we discussed on PTG
08:11:19 <alexchadin> should be ready to review soon
08:11:37 <alexchadin> https://review.openstack.org/#/c/558559/
08:13:48 <alexchadin> well, let's move on
08:13:55 <alexchadin> #topic Review Action Items
08:14:01 <alexchadin> Watcher specs
08:14:13 <alexchadin> Support Watcher HA active-active Mode needs new PS #link https://review.openstack.org/549706
08:15:16 <licanwei> alexchadin: I reply to your questions
08:16:11 <alexchadin> licanwei: yeah, I've seen, you have wanted to update problem description section
08:16:32 <licanwei> alexchadin: yes
08:17:23 <alexchadin> :)
08:17:59 <alexchadin> licanwei: I'll continue spec discussions in gerrit comments :)
08:18:11 <alexchadin> #action licanwei submit new PS https://review.openstack.org/549706
08:18:14 <licanwei> alexchadin: welcome
08:18:32 <alexchadin> Add the start and end time for CONTINUOUS audit needs reviews #link https://review.openstack.org/551058
08:18:52 <alexchadin> while licanwei submits new PS for HA, I will review this one
08:19:01 <alexchadin> who would like to review it too?
08:20:31 <hidekazu> alexchadin: i will
08:21:33 <alexchadin> #action alexchadin hidekazu review https://review.openstack.org/551058
08:21:46 <alexchadin> Enhance Watcher applier Engine needs to answer Egor's question. #link https://review.openstack.org/551861
08:22:19 <alexchadin> suzhengwei: hi
08:22:34 <suzhengwei> hi
08:22:42 <suzhengwei> sorry for late
08:22:50 <erakli> hi all
08:22:51 <hidekazu> suzhengwei: hi
08:23:00 <alexchadin> welcome Egor
08:23:01 <erakli> sorry for so late comming
08:23:07 <erakli> bad connection
08:23:25 <hidekazu> erakli: are you Egor Panfilov?
08:23:29 <erakli> yep
08:23:30 <alexchadin> hidekazu: +
08:23:44 <hidekazu> erakli: hi
08:23:59 <hidekazu> erakli: thanks active reviewing.
08:24:39 <licanwei> alexchadin: I will
08:24:48 <alexchadin> licanwei: thanks
08:24:49 <erakli> hidekazu: you are welcome)
08:25:09 <alexchadin> #action licanwei answer question on https://review.openstack.org/551861
08:25:20 <alexchadin> Watcher Planner Selector needs new PS #link https://review.openstack.org/558614
08:25:28 <adisky__> Its a good day for watcher, all are present :)
08:25:42 <erakli> alexchadin: in work
08:25:44 <alexchadin> erakli: you should submit new PS
08:25:46 <alexchadin> fine
08:25:59 <alexchadin> #action erakli submit new PS https://review.openstack.org/558614
08:26:16 <alexchadin> I suppose it's done with specs
08:26:20 <alexchadin> Watcher
08:26:32 <alexchadin> Enhance Watcher Applier Engine needs reviews #link https://review.openstack.org/#/c/554765/
08:26:37 <alexchadin> who'd like to take this one?
08:26:55 <alexchadin> BTW I will
08:27:19 <adisky__> alexchadin: +1
08:27:37 <alexchadin> adisky__: thanks
08:27:46 <alexchadin> Yumeng suzhengwei what about you?
08:28:53 <Yumeng> +1
08:29:21 <alexchadin> Yumeng: thanks
08:29:38 <alexchadin> #action adisky__ Yumeng alexchadin review https://review.openstack.org/#/c/554765/
08:29:53 <alexchadin> Replace cold migration to use Nova migration API needs reviews #link https://review.openstack.org/#/c/555665/
08:30:04 <adisky__> alexchadin: +1
08:30:07 <alexchadin> I'll take this one
08:30:26 <alexchadin> adisky__: I like this bp :)
08:30:29 <Yumeng> alexchadin: +1 I'm interested in this one.
08:30:36 <alexchadin> Yumeng: great!
08:31:23 <alexchadin> erakli: what about you?
08:32:26 <erakli> alexchadin: I reviewed it already and only find that there is no API version check
08:32:46 <erakli> alexchadin: I can do it again
08:33:10 <alexchadin> oh found out your review
08:33:19 <hidekazu> i want comment from other reviewer's opinion about api version check.
08:33:29 <alexchadin> erakli: you know the magic about +1/-1 :)
08:33:36 <alexchadin> hidekazu: I will
08:33:54 <erakli> alexchadin: I will use it, I promise :)
08:34:22 <alexchadin> hidekazu: I've fixed something with API version during ZuulV3 migration
08:34:42 <alexchadin> #action adisky__ Yumeng erakli alexchadin review https://review.openstack.org/#/c/555665/
08:35:11 <adisky__> erakli: for backward compatibility we need to add api microversioning in watcher
08:35:23 <adisky__> and it will be a seperate blueprint
08:35:55 <erakli> adisky__: got it
08:36:26 <alexchadin> is api of clients part of microversioning?
08:36:30 <alexchadin> adisky__: ^
08:37:06 <alexchadin> adisky__: I thought its' rather about our own API changes
08:37:08 <adisky__> alexchadin: if we introduce microversioning in watcher, we can make watchera-api version dependent on nova-api version
08:38:00 <hidekazu> review comment is about nova api version check.
08:38:03 <alexchadin> adisky__: part of bp discussion, I suppose
08:38:12 <alexchadin> adisky__: do you want to take it?
08:38:29 <erakli> adisky__: In this review I propose to check, If user have nova with API version older, than we use now. In this case it would be a good idea to notify user in-place
08:39:04 <erakli> adisky__: and, IMO, it's better to introduce with this change
08:39:48 <adisky__> e.g. watcher 1.1 is supporting till nova 5.1, if user using 1.1  (old)  we can use cold migration the previous way, if user using  say 1.2 and it supports nova 5.1 above it will call nova cold migration
08:40:11 <alexchadin> we're limited by time, let's move this discussion to openstack-watcher channel
08:40:12 <adisky__> erakli: ya, it can be a short term option
08:40:32 <erakli> alexchadin: agreed
08:40:42 <alexchadin> add strategy host_maintenance needs new PS #link https://review.openstack.org/#/c/479200/
08:40:49 <alexchadin> suzhengwei: we're still waiting :)
08:40:55 <suzhengwei> ok
08:40:58 <erakli> adisky__: +1
08:41:25 <alexchadin> Try to use requeue to sync CDM needs reviews as possible part of HA (alexchadin should update commit description). #link https://review.openstack.org/#/c/551963/
08:41:33 <alexchadin> licanwei: take a look at this one
08:41:46 <licanwei> alexchadin: OK
08:41:59 <alexchadin> licanwei: decision-engine logs on controller and compute especially
08:42:27 <alexchadin> licanwei: we can sync CDM of DEs by this commit
08:42:34 <hidekazu> alexchadin: is that the result of we discussed before?
08:42:48 <licanwei> alexchadin: I'll review
08:43:35 <alexchadin> hidekazu: yeah, it brings notification broadcasting from Nova notifications
08:43:48 <alexchadin> #action licanwei review https://review.openstack.org/#/c/551963/
08:43:49 <hidekazu> alexchadin: i got it.
08:44:33 <hidekazu> alexchadin: did you tried in your env?
08:44:56 <alexchadin> hidekazu: yes, it works
08:45:06 <alexchadin> hidekazu: try in your env too
08:45:06 <hidekazu> alexchadin: thanks, great.
08:45:17 <alexchadin> hidekazu: add you to reviewers?
08:45:34 <hidekazu> alexchadin: unfortunately i do not have multi DEs now.
08:46:04 <alexchadin> oh no worries
08:46:08 <hidekazu> alexchadin: i can review code of course.
08:46:29 <alexchadin> #action hidekazu review https://review.openstack.org/#/c/551963/
08:46:39 <alexchadin> licanwei hidekazu thanks :)
08:46:50 <alexchadin> Watcher Bug Fixes
08:47:11 <alexchadin> Several fixes of strategies docs needs final core review #link https://review.openstack.org/#/c/557430/
08:47:21 <alexchadin> woah it's on the way to be merged
08:47:25 <alexchadin> Yumeng: thanks!
08:47:52 <Yumeng> alexchadin: :)
08:48:30 <alexchadin> add unittest for execute_audit in audit/continuous.py needs reviews #link https://review.openstack.org/#/c/559653/
08:48:54 <alexchadin> erakli: our turn
08:49:04 <alexchadin> erakli: if you don't mind
08:49:06 <erakli> alexchadin: i'm in
08:49:19 <alexchadin> #action alexchadin erakli review https://review.openstack.org/#/c/559653/
08:49:32 <alexchadin> Update auth_uri option to www_authenticate_uri needs new PS #link https://review.openstack.org/#/c/559542/
08:50:30 <erakli> wow, there's fix already
08:50:36 <alexchadin> I'll contact caoyuan to ask him about fixing
08:50:39 <erakli> alexchadin: i catch it
08:51:29 <alexchadin> erakli: I suggest caoyuan to fix zuul's tests first
08:51:53 <erakli> alexchadin: ok
08:52:03 <alexchadin> Trivial fix of user guide doc needs new PS #link https://review.openstack.org/557433
08:52:23 <alexchadin> oups, missed
08:52:37 <alexchadin> Update "returns" to "return" who'd like to update this commit? #link https://review.openstack.org/#/c/549598/
08:53:20 <alexchadin> as adisky__ have said we need to replace returns with return across all project
08:53:32 <adisky__> alexchadin: I will update it
08:53:43 <alexchadin> adisky__: thanks a lot!
08:53:53 <alexchadin> #action adisky__ submit new PS https://review.openstack.org/#/c/549598/
08:54:08 <alexchadin> Added _get_model_list base method for all get_*_list methods needs new PS #link https://review.openstack.org/#/c/559481/
08:54:26 <erakli> alexchadin: unittests in work
08:54:30 <alexchadin> erakli: got it
08:54:42 <alexchadin> mox-removal should be reviewed #link https://review.openstack.org/#/q/topic:mox-removal+(status:open+OR+status:merged)+project:openstack/watcher-dashboard
08:55:05 <Yumeng> +1
08:55:23 <alexchadin> licanwei: I'll review the remaining ones
08:55:29 <alexchadin> Yumeng: got it!
08:55:42 <alexchadin> #action Yumeng alexchadin review https://review.openstack.org/#/q/topic:mox-removal+(status:open+OR+status:merged)+project:openstack/watcher-dashboard
08:55:46 <alexchadin> woah
08:55:47 <licanwei> alexchadin yumeng: thanks!
08:56:06 <alexchadin> just in time!
08:56:55 <alexchadin> oh, a little reminder: Rocky-1 milestone is scheduled on 16-20 April
08:57:28 <alexchadin> I will release all watcher repos by 19-20 April
08:58:28 <alexchadin> thank you for attending!
08:58:30 <alexchadin> bye
08:58:36 <erakli> bye
08:58:39 <Yumeng> got it . bye
08:58:39 <suzhengwei> bye
08:58:42 <licanwei> bye~
08:58:52 <hidekazu> bye
08:59:00 <alexchadin> #endmeeting