08:00:04 <alexchadin> #startmeeting watcher
08:00:04 <openstack> Meeting started Wed May  9 08:00:04 2018 UTC and is due to finish in 60 minutes.  The chair is alexchadin. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:08 <openstack> The meeting name has been set to 'watcher'
08:00:42 <alexchadin> Hi
08:00:42 <hidekazu> hello
08:01:03 <alexchadin> adisky__: will you join us?
08:01:40 <alexchadin> hidekazu: how are you?
08:01:54 <hidekazu> alexchadin: fine
08:02:25 <hidekazu> alexchadin: these days i do not seee yumeng and licanwei
08:02:42 <alexchadin> hidekazu: ZTE has suspended their contribution to OpenStack because of US sanctions.
08:03:15 <hidekazu> alexchadin: oh, will they join again?
08:03:30 <hidekazu> alexchadin: only god knows?
08:03:33 <alexchadin> hidekazu: a lot of our Chinese friends has suspended their contribution to OpenStack
08:03:43 <alexchadin> hidekazu: they should join us again
08:04:07 <alexchadin> hidekazu: ZTE makes a high rate on OpenStack
08:04:17 <hidekazu> alexchadin: we are small team
08:04:25 <alexchadin> hidekazu: unfortunately yes
08:04:43 <hidekazu> alexchadin: zte contributes oss other than openstack.
08:05:02 <alexchadin> hidekazu: OSS?
08:05:03 <hidekazu> alexchadin: anyway, lets meeting :)
08:05:20 <alexchadin> hidekazu: I'm looking for a ways to invite more people to the project
08:05:22 <hidekazu> alexchadin: yes, OSS,
08:06:05 <alexchadin> well, let's move on to announcements
08:06:13 <alexchadin> #topic Announcements
08:06:25 <alexchadin> SBCloud company has been registered. Alexchadin has been working for this company since April.
08:07:13 <hidekazu> alexchadin: SB means SoftBank??
08:07:16 <alexchadin> cloud part of my previous company has been bought by Sberbank and I work for SBCloud now
08:07:21 <alexchadin> hidekazu: SberBank
08:07:58 <alexchadin> hidekazu: the biggest bank in Russia
08:08:07 <hidekazu> alexchadin: yeah, i googled now.
08:08:31 <hidekazu> alexchadin: congrats,,, you will continue to contibute, will you?
08:08:40 <alexchadin> hidekazu: sure I will
08:08:55 <hidekazu> alexchadin: great.
08:09:22 <alexchadin> hidekazu: and I have to attract more investments to upstream development
08:09:42 <alexchadin> hidekazu: I've invited Egor to our project
08:09:54 <alexchadin> hidekazu: and hope to find more people soon
08:10:09 <hidekazu> alexchadin: is he also a member of your company?
08:10:14 <alexchadin> hidekazu: yes
08:10:26 <hidekazu> alexchadin: nice
08:10:48 <hidekazu> alexchadin: your upstream includes whole openstack?
08:11:43 <alexchadin> hidekazu: mostly Watcher for now. We have some downstream code in other project of OpenStack and we'd like to find a way to publish it
08:11:55 <alexchadin> other projects*
08:12:42 <hidekazu> alexchadin: real project has some kind of own code.
08:13:22 <hidekazu> alexchadin: do you have more plan?
08:14:01 <alexchadin> hidekazu: yeap, there are some features we'd like to get upstream support for.
08:15:23 <hidekazu> alexchadin: i will be busy for review :)
08:15:29 <alexchadin> well, the second announcements: ZTE has suspended their contribution to OpenStack because of US sanctions. #link https://www.pcmag.com/commentary/360451/new-trade-war-targets-china-zte-but-us-firms-caught-in-cros
08:16:37 <alexchadin> hidekazu: do you have any other announcements?
08:16:48 <hidekazu> alexchadin: no
08:17:23 <alexchadin> let's move on to Review Items
08:17:31 <alexchadin> #topic Review Action Items
08:17:34 <alexchadin> Watcher specs
08:17:42 <alexchadin> Watcher Planner Selector needs final core review #link https://review.openstack.org/558614
08:17:59 <alexchadin> hidekazu: I'd ask you to review it
08:18:17 <hidekazu> alexchadin: sure i will
08:18:26 <alexchadin> hidekazu: thank you :)
08:18:37 <alexchadin> #action hidekazu review https://review.openstack.org/558614
08:18:51 <alexchadin> Watcher api validation using json needs new PS #link https://review.openstack.org/560779
08:19:06 <alexchadin> most of this spec looks good
08:22:33 <alexchadin> Respect Nova Scheduler filters needs new PS #link https://review.openstack.org/561640
08:23:03 <alexchadin> hidekazu: thank you for your review
08:23:34 <hidekazu> alexchadin: welcom
08:23:37 <hidekazu> e
08:23:38 <alexchadin> hidekazu: does it look good?
08:24:14 <hidekazu> alexchadin: yes, actually i have been developed my own nova filter 3 years ago.
08:24:47 <hidekazu> alexchadin: if you will update, i can add +2
08:24:49 <alexchadin> hidekazu: look what I've found: https://blueprints.launchpad.net/nova/+spec/scheduler-rest-api-select-destinations
08:25:00 <alexchadin> hidekazu: yeah, I'll update soon
08:25:18 <alexchadin> hidekazu: this proposition has been registered two years ago
08:25:34 <alexchadin> hidekazu: and there is still no history
08:27:27 <hidekazu> alexchadin: may be busy for placement.
08:28:30 <alexchadin> hidekazu: BTW, our customers asks for nova scheduler respecting
08:30:04 <alexchadin> Watcher
08:30:14 <alexchadin> Enhance Watcher Applier Engine needs reviews #link https://review.openstack.org/554765
08:30:56 <alexchadin> hidekazu: let's review it together
08:31:28 <hidekazu> alexchadin: spec has not merged yet.
08:31:58 <hidekazu> alexchadin: but ok,
08:32:20 <hidekazu> alexchadin: code says spec.
08:33:22 <alexchadin> #action hidekazu alexchadin review https://review.openstack.org/554765
08:33:35 <alexchadin> Use jsonschema to validate efficacy indicators needs new PS #link https://review.openstack.org/#/c/561182/
08:34:44 <alexchadin> I'll read through the comments and talk to Yumeng. Maybe we'll update this commit
08:35:38 <alexchadin> Add API Reference for Watcher needs reviews #link https://review.openstack.org/#/c/558559/
08:35:44 <alexchadin> hidekazu: your turn ;)
08:36:03 <alexchadin> it's really big commit, but it's mostly about docs
08:37:03 <hidekazu> alexchadin: ok..
08:38:09 <alexchadin> #action hidekazu review https://review.openstack.org/#/c/558559/
08:38:21 <alexchadin> Watcher Planner Selector needs to fix Zuul jobs #link https://review.openstack.org/#/c/563477/
08:38:31 <alexchadin> I'll ask Egor to update this commit
08:39:16 <alexchadin> add strategy host_maintenance needs new PS #link https://review.openstack.org/#/c/479200/
08:39:32 <alexchadin> seems that suzhengwei has stopped her contribution to OpenStack
08:39:44 <alexchadin> I'll try to update this commit by myself
08:39:56 <alexchadin> hidekazu: or you'd like to take it?
08:41:09 <hidekazu> alexchadin: if you give me time, i will do
08:41:17 <alexchadin> hidekazu: sure
08:41:31 <alexchadin> #action hidekazu submit new PS https://review.openstack.org/#/c/479200/
08:41:39 <hidekazu> alexchadin: ok, i will do in this month.
08:41:55 <alexchadin> I haven't include ZTE's commits in Agenda
08:42:24 <alexchadin> because it requires to discuss them with Yumeng and Licanwei
08:43:00 <adisky__> hi all
08:43:07 <alexchadin> adisky__: hi
08:43:13 <alexchadin> adisky__: how are you?
08:43:18 <adisky__> sorry i forgot about today's meeting
08:43:28 <adisky__> alexchadin: i am good
08:43:31 <alexchadin> adisky__: We've almost done our discussion for today :)
08:43:36 <alexchadin> adisky__: no worries
08:43:45 <adisky__> alexchadin: i see, i will read logs :)
08:43:51 <alexchadin> adisky__: you may read through the IRC history
08:43:56 <alexchadin> adisky__: oh, fine!
08:44:39 <alexchadin> adisky__: I'd want to ask you to review some items
08:45:05 <alexchadin> adisky__: https://review.openstack.org/#/c/558614/ (Watcher Planner Selector)
08:46:06 <adisky__> alexchadin: sure, will review
08:46:13 <alexchadin> adisky__: Add API Reference for Watcher needs reviews (https://review.openstack.org/#/c/558559/)
08:46:19 <alexchadin> adisky__: thank you
08:46:32 <adisky__> alexchadin: yeah!! i am reviewing it
08:46:45 <alexchadin> adisky__: a pretty big, right? ;)
08:47:14 <adisky__> alexchadin: yes, and currently i am busy in small POC for my talk  at vanocuver
08:47:30 <alexchadin> adisky__: oh, you've got a visa?
08:47:31 <adisky__> so hopefully  i will get time after MAy
08:47:50 <adisky__> alexchadin: I did not get VISA, I reapplied, waiting now
08:48:17 <adisky__> but have to prepare presentation in case visa approved
08:48:28 <alexchadin> adisky__: let's cross fingers for your visa
08:48:33 <adisky__> alexchadin: thanks
08:49:16 <alexchadin> adisky__: if you need my help in preparations for presentation talk in Vancouver, send me an email with link to the one
08:49:58 <adisky__> alexchadin: here is the link
08:49:58 <alexchadin> adisky__: BTW, I've been working for SBCloud since April :)
08:49:59 <adisky__> https://www.openstack.org/summit/vancouver-2018/summit-schedule/events/21142/leveraging-kubernetes-and-tensorflow-for-iot-analytics-in-edge-computing-environment
08:50:19 <alexchadin> adisky__: so I'll use new email as commit author's email
08:50:33 <adisky__> alexchadin: yeah, i read the above logs, is it good news for you?
08:51:18 <alexchadin> adisky__: yeah, probably new investments to upstream development
08:51:29 <adisky__> alexchadin: great!! congrats :)
08:51:37 <alexchadin> adisky__: thanks :)
08:51:57 <alexchadin> adisky__: do you plan to prepare Watcher's PU
08:51:57 <alexchadin> ?
08:52:43 <adisky__> alexchadin: yes i will try to,  I hope to complete by current presentation work within 2-3 days
08:52:56 <adisky__> then i will prepare watcher PU
08:53:15 <alexchadin> adisky__: thanks, keep me in touch
08:54:01 <alexchadin> we have a victory day today
08:54:14 <alexchadin> so I wish you a good day and let's end up this meeting :)
08:55:18 <adisky__> alexchadin: bye
08:55:21 <hidekazu> alexchadin: bye
08:55:24 <adisky__> hidekazu: bye
08:55:25 <alexchadin> bye!
08:55:33 <hidekazu> adisky__: bye
08:55:33 <alexchadin> #endmeeting